































































  
           
    <!DOCTYPE html>
<html class="uk-root" lang="en">
<head>
<link rel="stylesheet" type="text/css" href="/fdn-system/assets/pub/styles/desktop.css?cb=0caa3d1ddaa28a74c2f9b9ad2eafdd35" />
<script src="/fdn-system/assets/pub/scripts/uikit.js"></script>
<script src="/fdn-system/assets/pub/scripts/uikit-icons-fdn.js"></script>
<script src="/foundation/fontawesome/js/brands.min.js" async></script>
<script src="/foundation/fontawesome/js/solid.min.js" async></script>
<script src="/foundation/fontawesome/js/regular.min.js" async></script>
<script src="/foundation/fontawesome/js/fontawesome.min.js" async></script>
<script src="/foundation/fontawesome/js/light.min.js" async></script>
<script src="/foundation/fontawesome/js/duotone.min.js" async></script>
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta charset="UTF-8">
<meta name="layout" content="Blog Post (Responsive, Air)" />
<meta name="oid" content="30865003" />
<script>
window.__FOUNDATION_RESPONSIVE__ = true
// 
window.__FBAPIv__ = 'v3.2'
// 
</script>
<!--[if lte IE 8]>
<script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
<![endif]-->
<script>
if (!window.Promise) document.write('<scr'+'ipt src="https://cdnjs.cloudflare.com/ajax/libs/native-promise-only/0.8.1/npo.src.js"></scr'+'ipt>')
</script>
<script src="/foundation/scripts/common.js?cb=1507ac6511b177f36dcbd566c264b360"></script>
<script src="/foundation/scripts/foundation-air.js?cb=1507ac6511b177f36dcbd566c264b360"></script>
<link rel="alternate" type="application/rss+xml" title="Tucson Weekly RSS: Whole Site" href="https://www.tucsonweekly.com/tucson/Rss.xml" />
<link rel="alternate" type="application/rss+xml" title="Tucson Weekly RSS: News &amp; Opinion Section" href="https://www.tucsonweekly.com/tucson/Rss.xml?oid=1063709" />
<link rel="alternate" type="application/rss+xml" title="Tucson Weekly RSS: The Range" href="https://www.tucsonweekly.com/tucson/Rss.xml?oid=1125619" />
<link rel="alternate" type="application/rss+xml" title="Tucson Weekly RSS: The Range: " href="https://www.tucsonweekly.com/tucson/Rss.xml?category=1125619&amp;topic=oid%3A4842648" />
<script>
// rrr - What is this? 
fixupProfileLinks("https:\/\/www.tucsonweekly.com\/tucson\/Profile", "https:\/\/posting.tucsonweekly.com\/tucson\/MyProfile");
</script>
<meta name="google-signin-client_id" content="345770844416-lrktslqgimjsduaogv54o86orkjohqm1.apps.googleusercontent.com">
<!-- include: admin -->
<!-- Google Fonts -->
<link href='https://fonts.googleapis.com/css?family=Anton|Open+Sans:300,400,700' rel='stylesheet' type='text/css'>
<!-- End Google Fonts -->
<!-- Custom GPT Config ref: 20 -->
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + '//securepubads.g.doubleclick.net/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
<script type='text/javascript'>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</script>
<meta name="google-site-verification" content="1shMVE6r6wpDwBgxHmNKSAVS9_A0RaoG53XlEOtHOJM" />
<script type='text/javascript' src='https://www.insidetucsonbusiness.com/shared-content/tncms-ad-manager/ads.js'></script>
<script type='text/javascript' src='https://www.insidetucsonbusiness.com/content/tncms/ads/tncms-ad-limits.js'></script>
<!-- include: layout -->
<!-- include: section -->
<!-- include: category -->
<!-- include: page -->
<!-- include: microsite -->
<!-- include: content -->
<link rel="shortcut icon" href="/favicon.ico" />
<meta name="title" content="The Daily Saguaro, Wednesday, 7/7/21 | The Range" />
<meta name="description" content="The Range: The Tucson Weekly&#39;s Daily Dispatch" />
<meta name="keywords" content="Outdoors, Snapshot" />
<title>The Daily Saguaro, Wednesday, 7/7/21 | The Range</title>
<meta name="date" content="2021-07-07 13:00:00" />
<meta name="author" content="Carl Hanni">
<meta name="news_keywords" content="outdoors, snapshot" />
<link rel="image_src" href="https://media2.fdncms.com/tucsonweekly/imager/u/slideshow/30865008/img_0131.jpeg" />
<meta name="thumbnail" content="https://media2.fdncms.com/tucsonweekly/imager/u/slideshow/30865008/img_0131.jpeg" />
<link rel="canonical" href="https://www.tucsonweekly.com/TheRange/archives/2021/07/07/the-daily-saguaro-wednesday-7-7-21" />
<link rel="amphtml" href="https://www.tucsonweekly.com/TheRange/archives/2021/07/07/the-daily-saguaro-wednesday-7-7-21?media=AMP+HTML" />
<meta property="og:url" content="https://www.tucsonweekly.com/TheRange/archives/2021/07/07/the-daily-saguaro-wednesday-7-7-21" />
<meta property="fb:app_id" content="187122448009492" />
<meta property="og:site_name" content="Tucson Weekly" />
<meta property="og:title" content="The Daily Saguaro, Wednesday, 7/7/21" />
<meta property="og:image" content="https://media2.fdncms.com/tucsonweekly/imager/u/slideshow/30865008/img_0131.jpeg" />
<meta property="og:image:width" content="680" />
<meta property="og:image:height" content="910" />
<meta property="og:description" content="The Range: The Tucson Weekly&#39;s Daily Dispatch" />
<meta property="og:type" content="article" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:image" content="https://media2.fdncms.com/tucsonweekly/imager/u/slideshow/30865008/img_0131.jpeg">
<meta name="twitter:site" content="@tucsonweekly">
<meta name="twitter:title" content="The Daily Saguaro, Wednesday, 7/7/21">
<meta name="twitter:description" content="The Range: The Tucson Weekly&#39;s Daily Dispatch">
<!--
<PageMap>
<DataObject type="foundation">
<Attribute name="oid">30865003</Attribute>
<Attribute name="class">Content</Attribute>
<Attribute name="lastmodified">20210707130012</Attribute>
<Attribute name="creationdate">20210615145156</Attribute>
</DataObject>
<DataObject type="document">
<Attribute name="releasedatetime">20210707130000</Attribute>
<Attribute name="releasedate">20210707</Attribute>
<Attribute name="releaseepoch">1625688000</Attribute>
<Attribute name="title">The Daily Saguaro, Wednesday, 7/7/21</Attribute>
<Attribute name="author">1064096</Attribute>
<Attribute name="authorname">Carl Hanni</Attribute>
<Attribute name="authorsortname">Hanni, Carl</Attribute>
</DataObject>
</PageMap>
-->
<script type="application/ld+json">
{
"mainEntityOfPage": {
"@type": "WebPage",
"@id":"https:\/\/www.tucsonweekly.com\/TheRange\/archives\/2021\/07\/07\/the-daily-saguaro-wednesday-7-7-21"
},
"headline": "The Daily Saguaro, Wednesday, 7\/7\/21",
"image": {
"url": "https:\/\/media2.fdncms.com\/tucsonweekly\/imager\/u\/original\/30865008\/img_0131.jpeg",
"width": 1936,
"height": 2592,
"@type": "ImageObject"
},
"datePublished": "2021-07-07T13:00:00",
"dateModified": "2021-07-07T13:00:12",
"author": {
"name": "Carl Hanni",
"@type": "Person"
},
"publisher": {
"name": "Tucson Weekly",
"logo": {
"url": "https:\/\/www.tucsonweekly.com\/imager\/b\/google-amp-logo\/808579\/93e9\/adminIcon_tw.jpg",
"width": 60,
"height": 60,
"@type": "ImageObject"
},
"@type": "Organization"
},
"@context": "https://schema.org",
"@type": "NewsArticle"
}
</script>
<script>window.twttr = (function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0],
t = window.twttr || {};
if (d.getElementById(id)) return t;
js = d.createElement(s);
js.id = id;
js.src = "https://platform.twitter.com/widgets.js";
fjs.parentNode.insertBefore(js, fjs);
t._e = [];
t.ready = function(f) {
t._e.push(f);
};
return t;
}(document, "script", "twitter-wjs"));</script>
</head>
<script src="/fdn-system/assets/pub/scripts/ResizeSensor.js"></script>
<script src="/fdn-system/assets/pub/scripts/ElementQueries.js"></script>
<script>
ElementQueries.listen();
</script>
<body id="Post" class="BlogPost newsopinion RespTwoCol1 TheRange">
<script>
ElementQueries.init();
</script>
<div id="fb-root"></div>
<script>
(function () {
var app = new Foundation.Facebook.Application();
app.receiveAuthNotifications();
app.receiveLikeNotifications();
})();
</script>
<script>
(function () {
var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
//if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
}.bind(this), function(){
if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
})
})()
</script>
    





<div id="BlogPost"  
     class="grid-resp-1 page layout-BlogPost">
  <div class="ev-grid-layout ev-clamp@m ev-clamp@l">

    <div class="ev-grid-zone ev-leader-zone">
      <div class="ev-grid-col uk-width-1-1" data-ev-zone="Leader">
        <div class="Leader BlogPost Ad uk-margin-remove uk-visible@m
               uk-flex uk-flex-row uk-flex-around uk-root fdn-margin-vert AirLVPLeaderboard1 comp-" data-component-id="AirLVPLeaderboard1">
  <div class="fdn-ad-container fdn-ad-container-margin-collapse-fix">
            <!-- /4961490/TW_leaderboard -->
            <div id="div-gpt-ad-tw_leaderboard-1"
                 class=" fdn-ad-container"
                 data-content-type="ad"
                 data-slot="/4961490/TW_leaderboard"
                 data-output="asynchronous"
                 data-width="970"
                 data-height="250">
                <script type='text/javascript'>
                  googletag.cmd.push(function() {
                    Foundation.Ad.displayAdResponsive('div-gpt-ad-tw_leaderboard-1')
                  });
                </script>
            </div>
          </div>
</div><div class="Leader BlogPost Ad uk-margin-remove uk-hidden@m
               uk-flex uk-flex-row uk-flex-around uk-root fdn-margin-vert AirSVPLeaderboard1 comp-" data-component-id="AirSVPLeaderboard1">
  <div class="fdn-ad-container fdn-ad-container-margin-collapse-fix">
            <!-- /4961490/TW_leaderboard -->
            <div id="div-gpt-ad-tw_leaderboard-5"
                 class=" fdn-ad-container"
                 data-content-type="ad"
                 data-slot="/4961490/TW_leaderboard"
                 data-output="asynchronous"
                 data-width="970"
                 data-height="250">
                <script type='text/javascript'>
                  googletag.cmd.push(function() {
                    Foundation.Ad.displayAdResponsive('div-gpt-ad-tw_leaderboard-5')
                  });
                </script>
            </div>
          </div>
</div>
      </div>
    </div>

    <div class="ev-grid-zone ev-header-zone">
      <div class="ev-grid-col uk-width-1-1" data-ev-zone="GlobalHeader">
        



  
    <!-- cache-outer: 9e8654c3e13b26c61507cd028c37af7e -->

    


      
      


      
      

        
          

        

      

        
          

        

      

        
          

        

      


      <div class="GlobalHeader BlogPost uk-margin-remove   uk-root fdn-margin-vert SiteHeaderGrid comp-shell-siteheader" data-component-id="SiteHeaderGrid">
        <div class="fdn-site-header-flex">

          
          <div class="fdn-site-header-nav-toggle">
            <a href="#offcanvas-slide-navigation" 
               class="fdn-nav-toggle uk-button" uk-toggle>
               <span uk-icon="icon: menu; ratio: 2"></span>
             </a>
          </div>

          

            
            
              <div class="fdn-site-header-logo">
                




  

  

  <div class="GlobalHeader SiteLogoresponsive  uk-root SiteLogo comp-shell-logo" data-component-id="SiteLogo">

    
      <div class="uk-margin-remove">
      <a class="uk-logo" href="https://www.tucsonweekly.com/" title="Tucson Weekly">
      <img src="https://www.tucsonweekly.com/images/logos/mainLogo.jpg"
           alt="Tucson Weekly">
    </a>
      </div>
    

  </div>



              </div>
            

            
            

            
            

            
            

            
            

          

            
            

            
            
              <div class="fdn-site-header-nav">
                






  


  

  

  

  

  

  

  

  

  


  

  


  

  

  

  

  

  

  

  


  

  

  


  

   
    
    
    <!-- cache-inner: 9e8654c3e13b26c61507cd028c37af7e -->
<div id="NavigationHorizontal" class="GlobalHeader NavigationHorizontalresponsive   uk-root fdn-margin-vert NavigationHorizontal comp-shell-navigationhorizontal" data-component-id="NavigationHorizontal" uk-sticky>
<nav class="fdn-nav-block uk-navbar-container uk-navbar-transparent
uk-responsive-width uk-visible@m" 
id="mainNav" uk-navbar>
<ul class="site-nav-source uk-navbar-nav uk-width-1-1">
<li class="fdn-nav-parent uk-parent " id="home">
<a href="https://www.tucsonweekly.com/" target="_self">
Home
</a>
<div class="fdn-nav-dropdown uk-navbar-dropdown" uk-dropdown="offset: 0;"> 
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent " id="newsopinion">
<a href="https://www.tucsonweekly.com/tucson/news-and-opinion/Section?oid=1063709" target="_self">
News &amp; Opinion
</a>
<div class="fdn-nav-dropdown uk-navbar-dropdown" uk-dropdown="offset: 0;"> 
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/news-and-opinion/Section?oid=1063709" target="_self"
title="">
News Main Page
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/cover-story/Content?special=1125844" target="_self"
title="">
Cover Story
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/Category?oid=1063734" target="_self"
title="">
Currents Features
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/editors-note/Content?category=1063766" target="_self"
title="">
Editor&#39;s Note
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/Category?oid=1063741" target="_self"
title="">
Danehy
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/cannabis/Category?oid=3147720" target="_self"
title="The Tucson Weekly's column on the local world of medical marijuana.">
Cannabis
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/the-skinny/Content?category=1063733" target="_self"
title="">
The Skinny
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/police-dispatch/Category?oid=1063770" target="_self"
title="">
Police Dispatch
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/guest-commentary/Category?oid=1063786" target="_self"
title="">
Guest Commentary
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/tucson-salvage/Category?oid=5928956" target="_self"
title="">
Tucson Salvage
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/blogs/TheRange/" target="_self"
title="">
The Range
</a>
</li>
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent " id="chow">
<a href="https://www.tucsonweekly.com/tucson/chow/Section?oid=1063714" target="_self">
Chow
</a>
<div class="fdn-nav-dropdown uk-navbar-dropdown" uk-dropdown="offset: 0;"> 
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/chow/Section?oid=1063714" target="_self"
title="">
Chow Main Page
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/Category?oid=1063740" target="_self"
title="">
Chow Features
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationSection=1113936&sortType=range" target="_self"
title="">
Restaurants
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationSection=1113936&feature=Menu" target="_self"
title="">
Restaurant Menus
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063714" target="_self"
title="">
Chow Archives
</a>
</li>
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent " id="Events10days">
<a href="https://www.tucsonweekly.com/tucson/city-week/Content?category=1063735" target="_self">
Events
</a>
<div class="fdn-nav-dropdown uk-navbar-dropdown" uk-dropdown="offset: 0;"> 
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/city-week/Content?category=1063735" target="_self"
title="">
City Week: Weekly Picks
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=Today" target="_self"
title="">
Events Today
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=This+Weekend&sortType=date&v=d" target="_self"
title="">
This Weekend
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/EventSearch?feature=Staff%20Pick&sortType=Date" target="_self"
title="">
Staff Pick Listings
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107349" target="_self"
title="">
Bulletin Board
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch" target="_self"
title="">
Location Guide
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/Events/AddEvent" target="_self"
title="">
Submit an Event
</a>
</li>
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent " id="cinema">
<a href="https://www.tucsonweekly.com/tucson/cinema/Section?oid=1063716" target="_self">
Cinema
</a>
<div class="fdn-nav-dropdown uk-navbar-dropdown" uk-dropdown="offset: 0;"> 
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/cinema/Section?oid=1063716" target="_self"
title="">
Cinema Main Page
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/MovieTimes" target="_self"
title="">
Movie Times
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/MovieTimes?show=theater" target="_self"
title="">
Movie Theaters
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063716" target="_self"
title="">
Cinema Archives
</a>
</li>
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent " id="music">
<a href="https://www.tucsonweekly.com/tucson/music/Section?oid=1063712" target="_self">
Music
</a>
<div class="fdn-nav-dropdown uk-navbar-dropdown" uk-dropdown="offset: 0;"> 
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/music/Section?oid=1063712" target="_self"
title="">
Music Main Page
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/Category?oid=1063737" target="_self"
title="">
Music Features
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107701&sortType=Date" target="_self"
title="">
Music Listings
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113914&sortType=range" target="_self"
title="">
Bars
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113974&sortType=name" target="_self"
title="">
Music Venues
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063712" target="_self"
title="">
Music Archives
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/Events/AddEvent" target="_self"
title="">
Submit an Event
</a>
</li>
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent " id="artsculture">
<a href="https://www.tucsonweekly.com/tucson/arts-and-culture/Section?oid=1063713" target="_self">
Arts &amp; Culture
</a>
<div class="fdn-nav-dropdown uk-navbar-dropdown" uk-dropdown="offset: 0;"> 
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/arts-and-culture/Section?oid=1063713" target="_self"
title="">
Arts Main Page
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/category?oid=1063742" target="_self"
title="">
Book Features
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107327&sortType=Date" target="_self"
title="">
Art Events
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113916" target="_self"
title="">
Galleries
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107325&sortType=Date" target="_self"
title="">
Museum Listings
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113923" target="_self"
title="">
Museums
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107320&sortType=Date" target="_self"
title="">
Performing Arts Events
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113917" target="_self"
title="">
Theaters
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107323&sortType=Date" target="_self"
title="">
Dance Events
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113925" target="_self"
title="">
Bookstores
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113933" target="_self"
title="">
Coffee Houses
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113924" target="_self"
title="">
Libraries
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107335&sortType=Date" target="_self"
title="">
Literature Events
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063713" target="_self"
title="">
Arts &amp; Culture Archives
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/Events/AddEvent" target="_self"
title="">
Submit an Event
</a>
</li>
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent " id="cannabis">
<a href="https://www.tucsonweekly.com/tucson/cannabis/Category?oid=3147720" target="_self">
Cannabis
</a>
<div class="fdn-nav-dropdown uk-navbar-dropdown" uk-dropdown="offset: 0;"> 
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/cannabis/Category?oid=3147720" target="_self"
title="">
Cannabis Main Page
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=30226589&sortType=range" target="_self"
title="">
Dispensaries
</a>
</li>
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent " id="bestoftucson">
<a href="https://www.tucsonweekly.com/tucson/BestOf" target="_self">
Best of Tucson&reg;
</a>
<div class="fdn-nav-dropdown uk-navbar-dropdown" uk-dropdown="offset: 0;"> 
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
<li class="fdn-nav-item ">
<a href="https://www.tucsonweekly.com/tucson/BestOf" target="_self"
title="">
Main Page
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/arts-and-culture/BestOf?category=1063746&year=2020" target="_self"
title="">
Arts &amp; Culture
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/city-life/BestOf?category=1063748&year=2020" target="_self"
title="">
City Life
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/BestOf?category=3153674&year=2020" target="_self"
title="">
Fashion + Style
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/outdoors/BestOf?category=1063750&year=2020" target="_self"
title="">
Outdoors
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/BestOf?category=1063749&year=2020" target="_self"
title="">
Kids&#39; Stuff
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/BestOf?category=1063781&year=2020" target="_self"
title="">
Media Mix
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/casual-dining/BestOf?category=3154064&year=2017&year=2020" target="_self"
title="">
Casual Dining
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/kids-stuff/BestOf?category=1063782&year=2020" target="_self"
title="">
Restaurants
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/BestOf?category=3153201&year=2020" target="_self"
title="">
&iexcl;Comida!
</a>
</li>
<li class="fdn-nav-item searchItem">
<a href="https://www.tucsonweekly.com/tucson/spirits/BestOf?category=1063752&year=2020" target="_self"
title="">
Spirits &amp; Nightlife
</a>
</li>
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent " id="DONATE">
<a href="https://secure.goemerchant.com/secure/custompayment/tucsonlocalmedia/13365/default.aspx" target="_self">
DONATE!
</a>
<div class="fdn-nav-dropdown uk-navbar-dropdown" uk-dropdown="offset: 0;"> 
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent fdn-nav-login-NavigationHorizontal
fdn-login-loggedout-container"
data-view="loggedout"
style="display:none">
<a href="#LogIn">
<i class="fas fa-user"></i>
</a>
</li>
<li class="fdn-nav-parent uk-parent fdn-nav-logout-NavigationHorizontal
fdn-login-loggedin-container"
data-view="loggedin"
style="display: none;">
<a href="#"><i class="fas fa-user"></i></a>
<div class="fdn-nav-dropdown"
uk-dropdown="pos:bottom-right;">
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
<li class="fdn-nav-item-header">
<span data-label="username">Username</span>
</li>
<li class="fdn-nav-item">
<a href="https://posting.tucsonweekly.com/tucson/MyProfile">
View Profile
</a>
</li>
<li class="fdn-nav-item">
<a href="https://posting.tucsonweekly.com/tucson/Profile/MySettings">
Edit Profile
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/Logout">
Log Out
</a>
</li>
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent">
<a><i class="far fa-search fa-flip-horizontal fa-sm"></i></a>
<div id="fdn-NavigationHorizontal-dropdown-hook"
uk-dropdown="mode:click,hover;offset:0;pos:bottom-right;"
class="GlobalHeader NavigationHorizontalresponsive  fdn-site-search-dropdown uk-root fdn-margin-vert NavigationHorizontal comp-shell-navigationhorizontal" data-component-id="NavigationHorizontal">
<form action="https://posting.tucsonweekly.com/tucson/Search" >
<div class="fdn-site-search-input-block ">
<div class="uk-search uk-search-default uk-width-1-1">
<span class="fdn-site-search-icon" uk-search-icon></span>
<input class="fdn-site-search-input ev-search-input uk-search-input" 
name="keywords"
placeholder="Enter Keywords..."
autocomplete="off" 
type="search" />
</div>
</div>
<div >
<ul class="fdn-site-search-list uk-nav uk-margin-remove">
<li>
<a class="fdn-site-search-item" href="https://www.tucsonweekly.com/tucson/ArticleArchives">
in Articles &amp; Posts
</a>
</li>
<li>
<a class="fdn-site-search-item" href="https://www.tucsonweekly.com/tucson/LocationSearch">
in Locations
</a>
</li>
<li>
<a class="fdn-site-search-item" href="https://www.tucsonweekly.com/tucson/EventSearch">
in Events
</a>
</li>
<li>
<a class="fdn-site-search-item" href="https://www.tucsonweekly.com/tucson/SlideshowArchives">
in Slideshows
</a>
</li>
<li>
<a class="fdn-site-search-item" href="https://posting.tucsonweekly.com/tucson/Search">
All
</a>
</li>
</ul>
</div>
<div class="fdn-site-search-submit-block ">
<button class="uk-button fdn-button-control fdn-site-search-submit">
GO
</button>
</div>
</form>
<script>
jQuery("#fdn-NavigationHorizontal-dropdown-hook")
.on("beforehide", function(){ return !jQuery(".fdn-site-search-input").is(":focus") })
</script>
<script>
(function(){
// 
var componentId = 'NavigationHorizontal'
var defaultSearchUrl = 'https://posting.tucsonweekly.com/tucson/Search'
var componentElement = jQuery('div[data-component-id='+componentId+']')
var searchForm = componentElement.find('form') 
var searchInput = searchForm.find('input')
var searchLinks = searchForm.find('a')
// 
searchForm.submit(function(e){
e.preventDefault()
window.location = defaultSearchUrl + '?keywords=' + searchInput.val() 
})
// 
searchLinks.on('click', function(e){
e.preventDefault()
window.location = jQuery(e.target).attr('href') + '?keywords=' + searchInput.val()
})
// 
jQuery("#fdn-NavigationHorizontal-dropdown-hook")
.on("beforehide", function(){
return !jQuery(this).find(".fdn-site-search-input").is(":focus")
})
})()
</script>
</div>
</li>
</ul>
</nav>
<nav class="fdn-nav-block-secondary uk-navbar-container uk-navbar-transparent
uk-responsive-width uk-visible@m" uk-navbar>
<ul class="site-nav-source uk-navbar-nav uk-width-1-1">
<li class="fdn-nav-parent uk-parent" id="secondary-FindaWeekly">
<a href="https://www.tucsonweekly.com/tucson/WhereCanIGetaTucsonWeekly/Page" target="_self">
Find a Weekly
</a>
</li>
<li class="fdn-nav-parent uk-parent" id="secondary-archives">
<a href="https://www.tucsonweekly.com/tucson/ArticleArchives" target="_self">
archives
</a>
</li>
<li class="fdn-nav-parent uk-parent" id="secondary-Issues">
<a href="https://www.tucsonweekly.com/tucson/IssueArchives" target="_self">
Issues
</a>
</li>
<li class="fdn-nav-parent uk-parent" id="secondary-NewsletterSignup">
<a href="https://www.tucsonweekly.com/tucson/Newsletter" target="_self">
Newsletter Signup
</a>
</li>
<li class="fdn-nav-parent uk-parent" id="secondary-jobs">
<a href="https://www.tucsonweekly.com/tucson/Jobs/Page" target="_self">
Jobs
</a>
</li>
</ul>
</nav>
<div id="offcanvas-slide-navigation" uk-offcanvas="overlay: true">
<div id="site-nav-target" class="fdn-nav-panel-block uk-offcanvas-bar">
<ul class="site-nav-source uk-width-1-1 uk-nav uk-nav-parent-icon" uk-nav="multiple: false;">
<li class="fdn-nav-parent " id="offcanvas-home">
<a href="https://www.tucsonweekly.com/" target="_self">
Home
</a>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-NewsOpinionMainPage">
<a href="https://www.tucsonweekly.com/tucson/news-and-opinion/Section?oid=1063709" target="_self">
News &amp; Opinion<span uk-icon='chevron-left'></span>
</a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/news-and-opinion/Section?oid=1063709" 
target="_self"
title="">
News Main Page
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/cover-story/Content?special=1125844" 
target="_self"
title="">
Cover Story
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/Category?oid=1063734" 
target="_self"
title="">
Currents Features
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/editors-note/Content?category=1063766" 
target="_self"
title="">
Editor&#39;s Note
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/Category?oid=1063741" 
target="_self"
title="">
Danehy
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/cannabis/Category?oid=3147720" 
target="_self"
title="The Tucson Weekly's column on the local world of medical marijuana.">
Cannabis
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/the-skinny/Content?category=1063733" 
target="_self"
title="">
The Skinny
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/police-dispatch/Category?oid=1063770" 
target="_self"
title="">
Police Dispatch
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/guest-commentary/Category?oid=1063786" 
target="_self"
title="">
Guest Commentary
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/tucson-salvage/Category?oid=5928956" 
target="_self"
title="">
Tucson Salvage
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/blogs/TheRange/" 
target="_self"
title="">
The Range
</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-ChowMainPage">
<a href="https://www.tucsonweekly.com/tucson/chow/Section?oid=1063714" target="_self">
Chow<span uk-icon='chevron-left'></span>
</a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/chow/Section?oid=1063714" 
target="_self"
title="">
Chow Main Page
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/Category?oid=1063740" 
target="_self"
title="">
Chow Features
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationSection=1113936&sortType=range" 
target="_self"
title="">
Restaurants
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationSection=1113936&feature=Menu" 
target="_self"
title="">
Restaurant Menus
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063714" 
target="_self"
title="">
Chow Archives
</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-CityWeekWeeklyPicks">
<a href="https://www.tucsonweekly.com/tucson/city-week/Content?category=1063735" target="_self">
Events<span uk-icon='chevron-left'></span>
</a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/city-week/Content?category=1063735" 
target="_self"
title="">
City Week: Weekly Picks
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=Today" 
target="_self"
title="">
Events Today
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=This+Weekend&sortType=date&v=d" 
target="_self"
title="">
This Weekend
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/EventSearch?feature=Staff%20Pick&sortType=Date" 
target="_self"
title="">
Staff Pick Listings
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107349" 
target="_self"
title="">
Bulletin Board
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch" 
target="_self"
title="">
Location Guide
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/Events/AddEvent" 
target="_self"
title="">
Submit an Event
</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-CinemaMainPage">
<a href="https://www.tucsonweekly.com/tucson/cinema/Section?oid=1063716" target="_self">
Cinema<span uk-icon='chevron-left'></span>
</a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/cinema/Section?oid=1063716" 
target="_self"
title="">
Cinema Main Page
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/MovieTimes" 
target="_self"
title="">
Movie Times
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/MovieTimes?show=theater" 
target="_self"
title="">
Movie Theaters
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063716" 
target="_self"
title="">
Cinema Archives
</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-MusicMainPage">
<a href="https://www.tucsonweekly.com/tucson/music/Section?oid=1063712" target="_self">
Music<span uk-icon='chevron-left'></span>
</a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/music/Section?oid=1063712" 
target="_self"
title="">
Music Main Page
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/Category?oid=1063737" 
target="_self"
title="">
Music Features
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107701&sortType=Date" 
target="_self"
title="">
Music Listings
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113914&sortType=range" 
target="_self"
title="">
Bars
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113974&sortType=name" 
target="_self"
title="">
Music Venues
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063712" 
target="_self"
title="">
Music Archives
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/Events/AddEvent" 
target="_self"
title="">
Submit an Event
</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-ArtsMainPage">
<a href="https://www.tucsonweekly.com/tucson/arts-and-culture/Section?oid=1063713" target="_self">
Arts &amp; Culture<span uk-icon='chevron-left'></span>
</a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/arts-and-culture/Section?oid=1063713" 
target="_self"
title="">
Arts Main Page
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/category?oid=1063742" 
target="_self"
title="">
Book Features
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107327&sortType=Date" 
target="_self"
title="">
Art Events
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113916" 
target="_self"
title="">
Galleries
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107325&sortType=Date" 
target="_self"
title="">
Museum Listings
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113923" 
target="_self"
title="">
Museums
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107320&sortType=Date" 
target="_self"
title="">
Performing Arts Events
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113917" 
target="_self"
title="">
Theaters
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107323&sortType=Date" 
target="_self"
title="">
Dance Events
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113925" 
target="_self"
title="">
Bookstores
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113933" 
target="_self"
title="">
Coffee Houses
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113924" 
target="_self"
title="">
Libraries
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107335&sortType=Date" 
target="_self"
title="">
Literature Events
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063713" 
target="_self"
title="">
Arts &amp; Culture Archives
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/Events/AddEvent" 
target="_self"
title="">
Submit an Event
</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-CannabisMainPage">
<a href="https://www.tucsonweekly.com/tucson/cannabis/Category?oid=3147720" target="_self">
Cannabis<span uk-icon='chevron-left'></span>
</a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/cannabis/Category?oid=3147720" 
target="_self"
title="">
Cannabis Main Page
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=30226589&sortType=range" 
target="_self"
title="">
Dispensaries
</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-BestofTucsonMainPage">
<a href="https://www.tucsonweekly.com/tucson/BestOf" target="_self">
Best of Tucson&reg;<span uk-icon='chevron-left'></span>
</a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/BestOf" 
target="_self"
title="">
Main Page
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/arts-and-culture/BestOf?category=1063746&year=2020" 
target="_self"
title="">
Arts &amp; Culture
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/city-life/BestOf?category=1063748&year=2020" 
target="_self"
title="">
City Life
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/BestOf?category=3153674&year=2020" 
target="_self"
title="">
Fashion + Style
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/outdoors/BestOf?category=1063750&year=2020" 
target="_self"
title="">
Outdoors
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/BestOf?category=1063749&year=2020" 
target="_self"
title="">
Kids&#39; Stuff
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/BestOf?category=1063781&year=2020" 
target="_self"
title="">
Media Mix
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/casual-dining/BestOf?category=3154064&year=2017&year=2020" 
target="_self"
title="">
Casual Dining
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/kids-stuff/BestOf?category=1063782&year=2020" 
target="_self"
title="">
Restaurants
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/BestOf?category=3153201&year=2020" 
target="_self"
title="">
&iexcl;Comida!
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/spirits/BestOf?category=1063752&year=2020" 
target="_self"
title="">
Spirits &amp; Nightlife
</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent " id="offcanvas-DONATE">
<a href="https://secure.goemerchant.com/secure/custompayment/tucsonlocalmedia/13365/default.aspx" target="_self">
DONATE!
</a>
</li>
<li class="fdn-nav-parent fdn-nav-login-NavigationHorizontal
fdn-login-loggedout-container"
data-view="loggedout"
style="display:none">
<a href="#LogIn">
<i class="fas fa-user"></i>&nbsp;Log&nbsp;in
</a>
</li>
<li class="fdn-nav-parent uk-parent fdn-nav-logout-NavigationHorizontal
fdn-login-loggedin-container"
data-view="loggedin"
style="display: none;">
<a href="#"> 
<span class="uk-text-left" data-label="username">Username</span>
<i class="fas fa-user"></i>
<span uk-icon='chevron-left'></span>
</a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://posting.tucsonweekly.com/tucson/MyProfile">
View Profile
</a>
</li>
<li class="fdn-nav-item">
<a href="https://posting.tucsonweekly.com/tucson/Profile/MySettings">
Edit Profile
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.tucsonweekly.com/tucson/Logout">
Log Out
</a>
</li>
</ul>
</li>
</ul>
<ul class="site-nav-source uk-width-1-1 uk-nav" uk-nav="multiple: false;">
<li class="fdn-nav-parent" id="offcanvas-secondary-FindaWeekly">
<a href="https://www.tucsonweekly.com/tucson/WhereCanIGetaTucsonWeekly/Page" target="_self">
Find a Weekly
</a>
</li>
<li class="fdn-nav-parent" id="offcanvas-secondary-archives">
<a href="https://www.tucsonweekly.com/tucson/ArticleArchives" target="_self">
archives
</a>
</li>
<li class="fdn-nav-parent" id="offcanvas-secondary-Issues">
<a href="https://www.tucsonweekly.com/tucson/IssueArchives" target="_self">
Issues
</a>
</li>
<li class="fdn-nav-parent" id="offcanvas-secondary-NewsletterSignup">
<a href="https://www.tucsonweekly.com/tucson/Newsletter" target="_self">
Newsletter Signup
</a>
</li>
<li class="fdn-nav-parent" id="offcanvas-secondary-jobs">
<a href="https://www.tucsonweekly.com/tucson/Jobs/Page" target="_self">
Jobs
</a>
</li>
</ul>
</div>
</div>
<script> new Foundation.LoginRequiredComponent('#NavigationHorizontal') </script>
</div>
  


              </div>
            

            
            

            
            

            
            

          

            
            

            
            

            
            
              <div class="fdn-site-header-search-toggle">
                <span class="fdn-nav-toggle uk-button" 
                      uk-toggle="target: #fdn-SiteSearchModalOnly-modal-hook">
                  <span uk-icon="icon:search;ratio:2;"></span>
                </span>
                
    
    
    
    






















  <div class="GlobalHeader SiteSearchModalOnlyresponsive   uk-root fdn-margin-vert SiteSearchModalOnly comp-shell-search" data-component-id="SiteSearchModalOnly">

    
    

      

      

      <div id="fdn-SiteSearchModalOnly-modal-hook" 
           class="fdn-site-search-modal"
           uk-modal="">
        <div class="uk-modal-dialog uk-modal-body">
          <h2 class="uk-modal-title">Search</h2>
          <button class="uk-modal-close uk-modal-close-default" 
                  type="button" 
                  uk-close></button>
          <form action="https://posting.tucsonweekly.com/tucson/Search" class="uk-flex uk-flex-wrap">
    <div class="fdn-site-search-modal-input-block uk-width-1-1 uk-flex-none">
      <div class="uk-search uk-search-default uk-width-1-1">
        <span class="fdn-site-search-modal-icon" uk-search-icon></span>
        <input class="fdn-site-search-modal-input ev-search-input uk-search-input" 
               name="keywords"
               placeholder="Enter Keywords..."
               autocomplete="off" 
               type="search" />
      </div>
    </div>

    <div class="uk-width-expand">
      <ul class="fdn-site-search-modal-list uk-nav uk-margin-remove">
        <li>
          <a class="fdn-site-search-modal-item" href="https://www.tucsonweekly.com/tucson/ArticleArchives">
              in Articles &amp; Posts
          </a>
        </li>
        <li>
          <a class="fdn-site-search-modal-item" href="https://www.tucsonweekly.com/tucson/LocationSearch">
            in Locations
          </a>
        </li>
        <li>
          <a class="fdn-site-search-modal-item" href="https://www.tucsonweekly.com/tucson/EventSearch">
            in Events
          </a>
        </li>

        
          <li>
            <a class="fdn-site-search-modal-item" href="https://www.tucsonweekly.com/tucson/SlideshowArchives">
              in Slideshows
            </a>
          </li>
        

        <li>
          <a class="fdn-site-search-modal-item" href="https://posting.tucsonweekly.com/tucson/Search">
            All
          </a>
        </li>
      </ul>
    </div>

    <div class="fdn-site-search-modal-submit-block uk-margin-auto-left uk-margin-auto-top uk-padding-xsmall-left">
      <button class="uk-button fdn-button-control fdn-site-search-modal-submit">
        GO
      </button>
    </div>
  </form>
        </div>
      </div>

    
    

    <script>
  (function(){
    // 
    var componentId = 'SiteSearchModalOnly'
    var defaultSearchUrl = 'https://posting.tucsonweekly.com/tucson/Search'
    var componentElement = jQuery('div[data-component-id='+componentId+']')
    var searchForm = componentElement.find('form') 
    var searchInput = searchForm.find('input')
    var searchLinks = searchForm.find('a')

    // 
    searchForm.submit(function(e){
      e.preventDefault()
      window.location = defaultSearchUrl + '?keywords=' + searchInput.val() 
    })

    // 
    searchLinks.on('click', function(e){
      e.preventDefault()
      window.location = jQuery(e.target).attr('href') + '?keywords=' + searchInput.val()
    })

    // 
    jQuery("#fdn-SiteSearchModalOnly-dropdown-hook")
      .on("beforehide", function(){
        return !jQuery(this).find(".fdn-site-search-input").is(":focus")
      })
  })()
  </script>

  </div>



              </div>
            

            
            

            
            

          

            
            

            
            

            
            

            
            

            
            

          

            
            

            
            

            
            

            
            

            
            

          

        </div>
      </div>
    

  

<div class="GlobalHeader BlogPost Ad uk-margin-remove-bottom uk-margin-small-top
               uk-visible@m
               uk-flex uk-flex-column uk-flex-around uk-root fdn-margin-vert AirLVPPencil comp-" data-component-id="AirLVPPencil">

  

  <div id="div-gpt-ad-tw_pencil_960x30" class=" fdn-ad-container">
      <!-- /4961490/TW_Pencil_960x30 -->
      <script type='text/javascript'>
        googletag.cmd.push(function() {
          googletag.display('div-gpt-ad-tw_pencil_960x30');
        });
      </script>
    </div>

  <div id="div-gpt-ad-sliding_billboard" class=" fdn-ad-container">
      <!-- /4961490/Sliding_Billboard -->
      <script type='text/javascript'>
        googletag.cmd.push(function() {
          googletag.display('div-gpt-ad-sliding_billboard');
        });
      </script>
    </div>
</div>
      </div>
    </div>

    <div class="ev-grid-zone ev-primary-zone">

      <div class="fdn-grid-main uk-flex-none fdn-primary">
        <div class="ev-grid-col" data-ev-zone="MainTop">
          


  <div class="ZoneA BlogPost   uk-root fdn-margin-vert BlogHeaderCategoryList comp-content-blogheader" data-component-id="BlogHeaderCategoryList">
    

    <h1 class="uk-flex uk-flex-center uk-flex-middle fdn-blog-header-block TheRange">
      <a class="fdn-blog-header-link" href="https://www.tucsonweekly.com/blogs/TheRange/">
        
          <img uk-img=""  
           data-src="/imager/b/magnum/1125619/a4db/the-range-header.gif"
           alt="The Range"
           width="680"
           height="174"
           class="" />
        
      </a>
    </h1>

    <div class="uk-flex uk-flex-wrap uk-flex-bottom fdn-blog-header-link-block">
      <div class="uk-flex uk-width-3-4@s fdn-blog-header-categories-block">
        
              <ul class="fdn-separated-list uk-list uk-flex uk-flex-wrap fdn-blog-header-category-list">
                <li><strong>Categories:</strong></li>
            

            

            
              <li><a href="https://www.tucsonweekly.com/TheRange/archives/politics/">Politics</a></li>
            

          

        

            

            
              <li><a href="https://www.tucsonweekly.com/TheRange/archives/news/">News</a></li>
            

          

        

            

            
              <li><a href="https://www.tucsonweekly.com/TheRange/archives/do-this/">Do This!</a></li>
            

          

        

            

            
              <li><a href="https://www.tucsonweekly.com/TheRange/archives/music/">Music</a></li>
            

          

        

            

            
              <li><a href="https://www.tucsonweekly.com/TheRange/archives/chow/">Chow</a></li>
            

          

        

            

            
              <li><a href="https://www.tucsonweekly.com/TheRange/archives/media/">Media</a></li>
            

          

        

            

            
              <li><a href="https://www.tucsonweekly.com/TheRange/archives/education/">Education</a></li>
            

          

        

            

            
              <li><a href="https://www.tucsonweekly.com/TheRange/archives/fun-in-general/">Fun in General</a></li>
            

          

        

            

            
              <li><a href="https://www.tucsonweekly.com/TheRange/archives/covid-19/">COVID-19</a></li>
            

          

        

            

            
              <li><a href="https://www.tucsonweekly.com/TheRange/archives/community-info/">Community Info</a></li>
            

          

        

            

            
              <li><a href="https://www.tucsonweekly.com/TheRange/archives/cinema/">Cinema</a></li>
            

          

        

            

            
              <li><a href="https://www.tucsonweekly.com/TheRange/archives/arts-and-culture/">Arts and Culture</a></li>
            

          

        
            <li><a href="https://www.tucsonweekly.com/tucson/TheRange/blogs/Archives">more categories &raquo;</a></li>
            </ul>
          
      
      </div>

      <div class="uk-flex uk-flex-wrap uk-width-1-4@s uk-flex-right fdn-blog-header-links">
        <a class="uk-display-inline-block uk-text-nowrap uk-text-bold uk-margin-small-right fdn-blog-header-link-archives" href="https://www.tucsonweekly.com/tucson/TheRange/blogs/Archives">
          <span class="fdn-bold-icon uk-margin-xsmall-right" uk-icon="icon:search;ratio:.68;"></span>Archives
        </a> 
        <a class="uk-display-inline-block uk-text-nowrap uk-text-bold fdn-blog-header-link-rss" href="/tucson/Rss.xml?category=1125619">
          <span class="fdn-bold-icon uk-margin-xsmall-right" uk-icon="icon:rss;ratio:.68;"></span>RSS
        </a>
      </div>

    </div>

  </div>









































  <div class="ZoneA BlogPost   uk-root fdn-margin-vert BlogsBlogPost comp-content-post" data-component-id="BlogsBlogPost">
    <div> 
      
      

      
          <p class="fdn-interface-subheader">
            Wednesday, July  7, 2021
          </p>

          
        

        

        
        <div class="pres-BlogPostFull">

    
    

    

    <div class="fdn-inline-split-list fdn-blog-tagline fdn-blog-tight">
      <a class="fdn-blog-tag" href="https://www.tucsonweekly.com/TheRange/archives/outdoors/">
        Outdoors
      </a>
       
    
      
      <a class="fdn-blog-tag" href="https://www.tucsonweekly.com/TheRange/archives/snapshot/">
        Snapshot
      </a>
    </div>
    
    
    

    
      <div class="uk-position-relative uk-visible-toggle uk-margin-xsmall-bottom"> 
        <div class="uk-hidden-hover uk-position-top-right uk-padding-xsmall uk-position-absolute">
          
        </div> 
        <h3 class="fdn-blog-headline">
          The Daily Saguaro, Wednesday, 7/7/21
        </h3>
    </div>
    

    

    
      <div class="MicroComponent BlogPostresponsive   uk-root fdn-margin-vert ShareToolsNexttotheAuthor comp-shell-sharetools" data-component-id="ShareToolsNexttotheAuthor" fdn-share-id="30865003">
    <div class="comp-ShellHorizontalBar " >

      <div class="uk-flex uk-margin-xsmall-left uk-grid-small" 
           uk-grid>

        
        <div class="uk-padding-remove-left" fdn-share-button-facebook>
          <a href="https://www.facebook.com/sharer/sharer.php?app_id=187122448009492&amp;redirect_uri=https%3A%2F%2Fwww.tucsonweekly.com%2FTheRange%2Farchives%2F2021%2F07%2F07%2Fthe-daily-saguaro-wednesday-7-7-21&amp;u=https%3A%2F%2Fwww.tucsonweekly.com%2FTheRange%2Farchives%2F2021%2F07%2F07%2Fthe-daily-saguaro-wednesday-7-7-21" 
             uk-tooltip="title: Share on Facebook"
             onClick="window.open('https://www.facebook.com/sharer/sharer.php?app_id=187122448009492&amp;redirect_uri=https%3A%2F%2Fwww.tucsonweekly.com%2FTheRange%2Farchives%2F2021%2F07%2F07%2Fthe-daily-saguaro-wednesday-7-7-21&amp;u=https%3A%2F%2Fwww.tucsonweekly.com%2FTheRange%2Farchives%2F2021%2F07%2F07%2Fthe-daily-saguaro-wednesday-7-7-21','_blank','resizable,height=700,width=600'); return false;"
             target="_blank">
            <span class="uk-icon-button fdn-icon-button-smaller fdn-share-icon-facebook"><i class="fab fa-facebook-f fa-sm"></i></span>
          </a>
        </div>

        
        <div fdn-share-button-twitter>
          <a href="https://twitter.com/intent/tweet?text=The%20Daily%20Saguaro%2C%20Wednesday%2C%207%2F7%2F21&amp;url=https%3A%2F%2Fwww.tucsonweekly.com%2FTheRange%2Farchives%2F2021%2F07%2F07%2Fthe-daily-saguaro-wednesday-7-7-21&amp;via=tucsonweekly" 
             uk-tooltip="title: Share on Twitter"
             onClick="window.open('https://twitter.com/intent/tweet?text=The%20Daily%20Saguaro%2C%20Wednesday%2C%207%2F7%2F21&amp;url=https%3A%2F%2Fwww.tucsonweekly.com%2FTheRange%2Farchives%2F2021%2F07%2F07%2Fthe-daily-saguaro-wednesday-7-7-21&amp;via=tucsonweekly','_blank','resizable,height=700,width=600'); return false;"
             target="_blank">
            <span class="uk-icon-button fdn-icon-button-smaller fdn-share-icon-twitter"><i class="fab fa-twitter fa-sm"></i></span>
          </a>
        </div>

        
        
          <div fdn-share-button-pinterest>
            <a href="https://pinterest.com/pin/create/link/?description=The%20Daily%20Saguaro%2C%20Wednesday%2C%207%2F7%2F21&amp;redirect_uri=https%3A%2F%2Fwww.tucsonweekly.com%2FTheRange%2Farchives%2F2021%2F07%2F07%2Fthe-daily-saguaro-wednesday-7-7-21&amp;url=https%3A%2F%2Fwww.tucsonweekly.com%2FTheRange%2Farchives%2F2021%2F07%2F07%2Fthe-daily-saguaro-wednesday-7-7-21" 
               uk-tooltip="title: Share on Pinterest"
               data-pin-do="buttonBookmark"
               data-pin-custom="true"
               data-pin-url="https://www.tucsonweekly.com/TheRange/archives/2021/07/07/the-daily-saguaro-wednesday-7-7-21"
               data-pin-description="The Daily Saguaro, Wednesday, 7/7/21"
               data-pin-error="true">
               <span class="uk-icon-button fdn-icon-button-smaller fdn-share-icon-pinterest"><i class="fab fa-pinterest-p fa-sm"></i></span>
            </a>
          </div>
        

        
        
          <div fdn-share-button-favorite>
            
            <div uk-tooltip="title: Mark as Favorite"
               data-toolsoid="30865003" 
               data-toolsajaxmacro="addObject">
               <span class="uk-icon-button fdn-icon-button-smaller 
                            fdn-icon-tool-core fdn-share-icon-favorite">
                          <i class="fas fa-heart fa-sm"></i></span>
            </div>

            
            <div uk-tooltip="title: Unmark as Favorite"
               data-toolsoid="30865003" 
               data-toolsajaxmacro="removeObject"
               hidden>
               <span class="uk-icon-button fdn-icon-button-smaller 
                            fdn-icon-tool-core fdn-tool-core-favorited fdn-share-icon-favorite">
                          <i class="fas fa-heart fa-sm"></i></span>
            </div>
            
          </div>
        

        
        <div fdn-share-button-email>
          <a href="mailto:?subject=Tucson%20Weekly%20shared%20URL%3A%20The%20Daily%20Saguaro%2C%20Wednesday%2C%207/7/21&body=%0A%0AThe%20Daily%20Saguaro%2C%20Wednesday%2C%207/7/21%0A%0A<https://www.tucsonweekly.com/TheRange/archives/2021/07/07/the-daily-saguaro-wednesday-7-7-21>%0A%0A%0A" uk-tooltip="title: Share via Email">
             <span class="uk-icon-button fdn-icon-button-smaller fdn-icon-tool-core fdn-share-icon-email"><i class="far fa-envelope fa-sm"></i></span>
          </a>
        </div>


        
        
          <div>
            

            <a href="#comments" uk-tooltip="title:Comments">
              
                <span class="uk-icon-button fdn-icon-button-smaller fdn-icon-tool-core fdn-share-icon-comment"><i class="far fa-comment-alt"></i></span>
              
            </a>
          </div>
        

      </div>
    </div>

    
    <div id="ShareToolsNexttotheAuthor-modal" uk-modal>
      <div class="uk-modal-dialog uk-modal-body">
        <h2 class="uk-modal-title"></h2>
        <button class="uk-modal-close uk-modal-close-default" type="button" uk-close></button>
        <div class="contents"></div>
      </div>
    </div>

    <script>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</script>

    
    
      <script type="text/javascript" async defer src="//assets.pinterest.com/js/pinit.js"></script>
    
  </div>
    

    <p class="fdn-blog-infoline">

  
    <span>
      Posted
    </span>
  

  
    

    <span class="byAttribute">By</span> 
    <a href="https://www.tucsonweekly.com/author/carl-hanni" rel="author">Carl Hanni</a>
  

  
    on <span class="postTime">Wed, Jul  7, 2021</span> at <span class="postTime"> 1:00 PM</span>
  
  </p>    
    <div class="fdn-blog-body">

      
          
      

      

      

        

        
        

         
        

          

          

          

          

          

          

          
          

          

          

          
        

      


      
      
       
      
      

      
      

      
      
        
        <div uk-lightbox class="uk-position-relative fdn-content-image-center contentImageCenter">                                                        <a href="https://media2.fdncms.com/tucsonweekly/imager/u/original/30865008/img_0131.jpeg"                   rel="contentImg_gal-30865003"                   title="Keeping watch - CARL HANNI"                   data-caption="<span>Keeping watch</span>&nbsp;&nbsp;            <em>Carl Hanni</em>"                   class="uk-display-block uk-position-relative uk-visible-toggle">                  <span class="fdn-button-enlarge uk-position-absolute                    uk-position-top-right uk-hidden-hover">        click to enlarge      </span>                  <img src="https://media2.fdncms.com/tucsonweekly/imager/u/blog/30865008/img_0131.jpeg?cb=1623946112"                        alt="Keeping watch - CARL HANNI"                        width="680"                       height="910" />                 </a>                                                                                            <div class="fdn-caption-block uk-margin-auto"                                       style="max-width: 680px"                                      >                    <div class="fdn-image-credit">                                                  Carl Hanni                                              </div>                                                                                                                    <div class="fdn-image-caption">                        Keeping watch                      </div>                  </div>                                                        </div>

              
            

            
            
              

              
                <div class="fdn-ads-inline-content-block">
                  <div class="ZoneA AirMedRectComboInlineContent1responsive Ad uk-margin-remove uk-root fdn-margin-vert AirMedRectComboInlineContent1 comp-" data-component-id="AirMedRectComboInlineContent1">
  
  <div class="uk-visible@m uk-flex uk-flex-row uk-flex-around uk-width-1-1">
    <div class="fdn-ad-container">
            <!-- TW_MediumRectangle-300x250 -->
            <div id="div-gpt-ad-tw_mediumrectangle_300x250-40"
                 class=" fdn-ad-container"
                 data-content-type="ad"
                 data-slot="TW_MediumRectangle-300x250"
                 data-output="asynchronous"
                 data-width="300"
                 data-height="250">
                <script type='text/javascript'>
                  googletag.cmd.push(function() {
                    Foundation.Ad.displayAdResponsive('div-gpt-ad-tw_mediumrectangle_300x250-40')
                  });
                </script>
            </div>
          </div>

    <div class="fdn-ad-container">
            <!-- TW_MediumRectangle-300x250 -->
            <div id="div-gpt-ad-tw_mediumrectangle_300x250-41"
                 class=" fdn-ad-container"
                 data-content-type="ad"
                 data-slot="TW_MediumRectangle-300x250"
                 data-output="asynchronous"
                 data-width="300"
                 data-height="250">
                <script type='text/javascript'>
                  googletag.cmd.push(function() {
                    Foundation.Ad.displayAdResponsive('div-gpt-ad-tw_mediumrectangle_300x250-41')
                  });
                </script>
            </div>
          </div>
  </div>
  
  <div class="uk-hidden@m">
    <div class="fdn-ad-container">
            <!-- TW_MediumRectangle-300x250 -->
            <div id="div-gpt-ad-tw_mediumrectangle_300x250-42"
                 class=" fdn-ad-container"
                 data-content-type="ad"
                 data-slot="TW_MediumRectangle-300x250"
                 data-output="asynchronous"
                 data-width="300"
                 data-height="250">
                <script type='text/javascript'>
                  googletag.cmd.push(function() {
                    Foundation.Ad.displayAdResponsive('div-gpt-ad-tw_mediumrectangle_300x250-42')
                  });
                </script>
            </div>
          </div>
  </div>
</div>
                </div>
              
            
              

              
                <div class="fdn-ads-inline-content-block">
                  <div class="componentGrid-TwoZones-Auto-Expand uk-root uk-width-1-1 uk-flex uk-flex-row uk-flex-wrap fdn-component-grid-row@m" uk-height-match data-component-grid-id="TopStoriesVideoPair">

  <div class="uk-width-1-1 uk-width-auto@m uk-flex uk-flex-column uk-inline fdn-component-grid-zone">
    



















<div class="ComponentZoneA TopStoriesVideoPairresponsive  trending-by-day uk-root fdn-margin-vert TrendingContentList comp-landing-trending" data-component-id="TrendingContentList">
  <div class="fdn-component-header-block uk-margin ">

      

      <h3 class="fdn-component-header-text uk-margin-remove ">
        
          Trending
        
      </h3>

      

      
    </div>

    
    
    

    
        <ul class="pres-ContentListHeadline uk-list uk-list-divider">
      
      

      <li class="fdn-pres-item">
    <a class="uk-flex uk-flex-top" href="https://www.tucsonweekly.com/TheRange/archives/2021/07/01/enduring-trauma-arizonas-indigenous-boarding-schools-will-be-investigated-interior-announces">
      <p class="fdn-teaser-headline">
        Enduring trauma: Arizona's Indigenous boarding schools will be investigated, Interior announces
      </p>
    </a>
  </li>

      
   
    
      

      <li class="fdn-pres-item">
    <a class="uk-flex uk-flex-top" href="https://www.tucsonweekly.com/tucson/the-skinny-gov-doug-ducey-achieves-his-dream-of-comforting-the-comfortable-and-afflicting-the-afflicted/Content?oid=30944729">
      <p class="fdn-teaser-headline">
        The Skinny: Gov. Doug Ducey achieves his dream of comforting the comfortable and afflicting the afflicted
      </p>
    </a>
  </li>

      
   
    
      

      <li class="fdn-pres-item">
    <a class="uk-flex uk-flex-top" href="https://www.tucsonweekly.com/tucson/danehy-the-anti-vax-crowd-sure-has-some-stupid-arguments/Content?oid=30904900">
      <p class="fdn-teaser-headline">
        Danehy: The Anti-Vax Crowd Sure Has Some  Stupid Arguments
      </p>
    </a>
  </li>

      
   
    
        </ul>
        <script>
    jQuery(function () {
      var setHeights = function () {
        for(var item of document.querySelectorAll('[data-component-id="TrendingContentList"].trending-by-day li a')) {
          item.style.height = null
          item.style.height = item.getHeight() + 'px'
        }
      }
      window.addEventListener('resize', setHeights)
      window.addEventListener('orientationchange', setHeights)
      setHeights()
    })
    </script>
      

  

</div>

    
  </div>

  <div class="uk-width-1-1 uk-width-expand@m uk-flex uk-flex-column uk-inline fdn-component-grid-zone">
    <!-- 
        fetched: 2021-07-07 14:00 2 
        mode: content
        requestSite: tucsonweekly
        requestPage: article
        xid: 21212411
        vid: 21212412
        vrd: null ()
        vri: 2 ()
        vrp: false ()
        pause: false
      -->

      

        

        

        
            <div class="ComponentZoneB TopStoriesVideoPairresponsive  no-foundation-imgeditor uk-root fdn-margin-vert TopStoriesVideo comp-content-topstoriesvideo" data-component-id="TopStoriesVideo">
    <div class="top-stories-video">
    <div class="uk-inline">
      <div class="carousel-items">
          
          

          

          

          <div class="item uk-overflow-hidden uk-animation-fade ">
            <a href="https://www.tucsonweekly.com/TheRange/archives/2021/07/07/claytoonz-billionaires-in-space" target="_top">
              <img class="uk-animation-kenburns uk-transform-origin-top-left"
                   src="https://media1.fdncms.com/tucsonweekly/imager/u/16x9-m/30971956/cjones07112021.jpg" alt="">
            </a>
            <div class="uk-hidden uk-animation-slide-left" data-headline>
              <a class="carousel-headline" href="https://www.tucsonweekly.com/TheRange/archives/2021/07/07/claytoonz-billionaires-in-space" target="_top"><strong>Claytoonz: Billionaires In Space</strong></a>
            </div>
          </div> 

          
        
          

          

          

          <div class="item uk-overflow-hidden uk-animation-fade uk-hidden">
            <a href="https://www.tucsonweekly.com/TheRange/archives/2021/07/07/az-goes-ev-rate-of-electric-car-ownership-relatively-high-in-arizona" target="_top">
              <img class="uk-animation-kenburns uk-transform-origin-top-center"
                   src="https://media1.fdncms.com/tucsonweekly/imager/u/16x9-m/30972138/05-ev-plug-full_volt_electric_car.jpg" alt="">
            </a>
            <div class="uk-hidden uk-animation-slide-left" data-headline>
              <a class="carousel-headline" href="https://www.tucsonweekly.com/TheRange/archives/2021/07/07/az-goes-ev-rate-of-electric-car-ownership-relatively-high-in-arizona" target="_top"><strong>AZ goes EV: Rate of electric car ownership relatively high in Arizona</strong></a>
            </div>
          </div> 

          
        
          

          

          

          <div class="item uk-overflow-hidden uk-animation-fade uk-hidden">
            <a href="https://www.tucsonweekly.com/TheRange/archives/2021/07/07/claytoonz-prisonburgh-for-weisselberg" target="_top">
              <img class="uk-animation-kenburns uk-transform-origin-center-left"
                   src="https://media1.fdncms.com/tucsonweekly/imager/u/16x9-m/30971948/cjones07082021.jpg" alt="">
            </a>
            <div class="uk-hidden uk-animation-slide-left" data-headline>
              <a class="carousel-headline" href="https://www.tucsonweekly.com/TheRange/archives/2021/07/07/claytoonz-prisonburgh-for-weisselberg" target="_top"><strong>Claytoonz: Prisonburgh For Weisselberg</strong></a>
            </div>
          </div> 

          
        
          

          

          

          <div class="item uk-overflow-hidden uk-animation-fade uk-hidden">
            <a href="https://www.tucsonweekly.com/TheRange/archives/2021/07/06/monsoon-2021-off-to-a-stronger-start-than-last-year" target="_top">
              <img class="uk-animation-kenburns uk-transform-origin-center-right"
                   src="https://media1.fdncms.com/tucsonweekly/imager/u/16x9-m/30972108/screen_shot_2021-07-06_at_11.18.39_am.png" alt="">
            </a>
            <div class="uk-hidden uk-animation-slide-left" data-headline>
              <a class="carousel-headline" href="https://www.tucsonweekly.com/TheRange/archives/2021/07/06/monsoon-2021-off-to-a-stronger-start-than-last-year" target="_top"><strong>Monsoon 2021 off to a Stronger Start Than Last Year</strong></a>
            </div>
          </div> 

          
        
          

          

          

          <div class="item uk-overflow-hidden uk-animation-fade uk-hidden">
            <a href="https://www.tucsonweekly.com/TheRange/archives/2021/07/06/the-daily-saguaro-tuesday-7-6-21" target="_top">
              <img class="uk-animation-kenburns uk-transform-origin-bottom-left"
                   src="https://media1.fdncms.com/tucsonweekly/imager/u/16x9-m/30865002/img_0081.jpeg" alt="">
            </a>
            <div class="uk-hidden uk-animation-slide-left" data-headline>
              <a class="carousel-headline" href="https://www.tucsonweekly.com/TheRange/archives/2021/07/06/the-daily-saguaro-tuesday-7-6-21" target="_top"><strong>The Daily Saguaro, Tuesday 7/6/21</strong></a>
            </div>
          </div> 

          
        
            </div>

      

      
      
        
        

        <div class="uk-position-top-left uk-position-small uk-flex uk-flex-row carousel-info-text">
          <div class="uk-width-auto uk-padding-small uk-text-bold">
            
              Top Stories
            
          </div>
        </div>
      

      
      
        <div class="uk-position-top-right uk-flex-top uk-position-small uk-width-1-6 carousel-info-icon uk-flex uk-flex-right">
          <img src="/apple-touch-icon-iphone.png" width="40">
        </div>
      

      
      <div class="uk-position-bottom-right uk-position-small uk-flex uk-flex-row">
        
        
          <div class="uk-flex-1 carousel-progress-block">
            
            
            <div class="carousel-progress-block-item"></div>
          </div> 
        
          <div class="uk-flex-1 carousel-progress-block">
            
            
            <div class="carousel-progress-block-item"></div>
          </div> 
        
          <div class="uk-flex-1 carousel-progress-block">
            
            
            <div class="carousel-progress-block-item"></div>
          </div> 
        
          <div class="uk-flex-1 carousel-progress-block">
            
            
            <div class="carousel-progress-block-item"></div>
          </div> 
        
          <div class="uk-flex-1 carousel-progress-block">
            
            
            <div class="carousel-progress-block-item"></div>
          </div> 
        
      </div>

      
      <div class="carousel-video-player uk-overlay-default uk-position-cover uk-hidden">
      </div>

      
      <div class="carousel-video-player-label video-player-label-mute-toggle uk-overlay-default uk-position-top-center carousel-button uk-padding-small uk-hidden">
        Advertisement:
        <span class="uk-margin-xsmall-right uk-hidden volume-icon" uk-icon="icon:fdn-volume;ratio:1.8"></span>
        <span class="uk-margin-xsmall-right uk-hidden volume-mute-icon" uk-icon="icon:fdn-volume-mute;ratio:1.8"></span>
      </div>

      
      <div class="carousel-video-player-countdown uk-position-bottom-right uk-hidden uk-flex uk-flex-middle uk-padding-small" style="color:white;font-weight:bold;text-shadow: 1px 1px #000000;">
      </div>

      
      <div class="carousel-prev carousel-button uk-position-center-left">
        <span uk-icon="icon: triangle-left; ratio: 2"></span>
      </div>

      
      <div class="carousel-pause carousel-button uk-position-center uk-hidden">
        <span uk-icon="icon: fdn-pause; ratio: 3.5"></span>
      </div>

      
      <div class="carousel-play carousel-button uk-position-center uk-hidden">
        <span uk-icon="icon: play; ratio: 3.5"></span>
      </div>

      
      <div class="carousel-next carousel-button uk-position-center-right">
        <span uk-icon="icon: triangle-right; ratio: 2"></span>
      </div>

      
      <div class="carousel-volume carousel-button uk-position-bottom-left uk-width-1-4 uk-hidden uk-flex uk-flex-middle uk-padding-xsmall">
        <div class="carousel-volume-mute-toggle">
          <span class="uk-margin-xsmall-right uk-hidden volume-icon" uk-icon="icon:fdn-volume;ratio:1.3"></span>
          <span class="uk-margin-xsmall-right uk-hidden volume-mute-icon" uk-icon="icon:fdn-volume-mute;ratio:1.3"></span>
        </div>
        <input class="uk-range" type="range" value="0.5" min="0" max="1" step="0.1" style="height: 40px;margin-top: -10px;margin-bottom: -10px;">
      </div>
    </div>

    <div class="uk-flex carousel-info-height-wrapper">
      <div class="carousel-info uk-overflow-hidden uk-width-1-1">
        
      </div>
    </div>

    

    <script src="https://imasdk.googleapis.com/js/sdkloader/ima3.js"></script>



    <script>
    // 
  var evVarDebuggingOutput = false
  // 

  function logToConsole () {
    if(typeof evVarDebuggingOutput !== 'undefined' && evVarDebuggingOutput === true) {
      var grayb = 'color:white;background:darkgray;padding:4px;border-radius:4px;'
      console.log('%cReely', grayb, ...arguments)
    }
  }
  function warnToConsole () {
    if(typeof evVarDebuggingOutput !== 'undefined' && evVarDebuggingOutput === true) {
      var orangeb = 'color:white;background:darkorange;padding:4px;border-radius:4px;'
      console.warn('%cReely', orangeb, ...arguments)
    }
  }
  function loggfdnpbjs () {
    if(typeof evVarDebuggingOutput !== 'undefined' && evVarDebuggingOutput === true) {
      var greenb = 'color:white;background:forestgreen;padding:4px;border-radius:4px;'
      console.log('%cfdnpbjs', greenb, ...arguments)
    }
  }
    </script>


    

    

    <script>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</script>

    




  </div>
  </div><!-- End .top-stories-video -->

    
  </div>

</div>
                </div>
      
      
      
      
    </div>

    

    

    

  </div>

        

      
          
        
    </div>
  </div>












  
  
  

















  


  

  

  


  

  

  
  
  

  


  

  

  
  
  
  

  <div class="ZoneA BlogPost   uk-root fdn-margin-vert ShareTools comp-shell-sharetools" data-component-id="ShareTools" fdn-share-id="30865003">
    <div class="comp-ShellHorizontalBar " >

      <div class="uk-flex uk-margin-xsmall-left uk-grid-small" 
           uk-grid>

        
        <div class="uk-padding-remove-left" fdn-share-button-facebook>
          <a href="https://www.facebook.com/sharer/sharer.php?app_id=187122448009492&amp;redirect_uri=https%3A%2F%2Fwww.tucsonweekly.com%2FTheRange%2Farchives%2F2021%2F07%2F07%2Fthe-daily-saguaro-wednesday-7-7-21&amp;u=https%3A%2F%2Fwww.tucsonweekly.com%2FTheRange%2Farchives%2F2021%2F07%2F07%2Fthe-daily-saguaro-wednesday-7-7-21" 
             uk-tooltip="title: Share on Facebook"
             onClick="window.open('https://www.facebook.com/sharer/sharer.php?app_id=187122448009492&amp;redirect_uri=https%3A%2F%2Fwww.tucsonweekly.com%2FTheRange%2Farchives%2F2021%2F07%2F07%2Fthe-daily-saguaro-wednesday-7-7-21&amp;u=https%3A%2F%2Fwww.tucsonweekly.com%2FTheRange%2Farchives%2F2021%2F07%2F07%2Fthe-daily-saguaro-wednesday-7-7-21','_blank','resizable,height=700,width=600'); return false;"
             target="_blank">
            <span class="uk-icon-button fdn-icon-button-smaller fdn-share-icon-facebook"><i class="fab fa-facebook-f fa-sm"></i></span>
          </a>
        </div>

        
        <div fdn-share-button-twitter>
          <a href="https://twitter.com/intent/tweet?text=The%20Daily%20Saguaro%2C%20Wednesday%2C%207%2F7%2F21&amp;url=https%3A%2F%2Fwww.tucsonweekly.com%2FTheRange%2Farchives%2F2021%2F07%2F07%2Fthe-daily-saguaro-wednesday-7-7-21&amp;via=tucsonweekly" 
             uk-tooltip="title: Share on Twitter"
             onClick="window.open('https://twitter.com/intent/tweet?text=The%20Daily%20Saguaro%2C%20Wednesday%2C%207%2F7%2F21&amp;url=https%3A%2F%2Fwww.tucsonweekly.com%2FTheRange%2Farchives%2F2021%2F07%2F07%2Fthe-daily-saguaro-wednesday-7-7-21&amp;via=tucsonweekly','_blank','resizable,height=700,width=600'); return false;"
             target="_blank">
            <span class="uk-icon-button fdn-icon-button-smaller fdn-share-icon-twitter"><i class="fab fa-twitter fa-sm"></i></span>
          </a>
        </div>

        
        
          <div fdn-share-button-pinterest>
            <a href="https://pinterest.com/pin/create/link/?description=The%20Daily%20Saguaro%2C%20Wednesday%2C%207%2F7%2F21&amp;redirect_uri=https%3A%2F%2Fwww.tucsonweekly.com%2FTheRange%2Farchives%2F2021%2F07%2F07%2Fthe-daily-saguaro-wednesday-7-7-21&amp;url=https%3A%2F%2Fwww.tucsonweekly.com%2FTheRange%2Farchives%2F2021%2F07%2F07%2Fthe-daily-saguaro-wednesday-7-7-21" 
               uk-tooltip="title: Share on Pinterest"
               data-pin-do="buttonBookmark"
               data-pin-custom="true"
               data-pin-url="https://www.tucsonweekly.com/TheRange/archives/2021/07/07/the-daily-saguaro-wednesday-7-7-21"
               data-pin-description="The Daily Saguaro, Wednesday, 7/7/21"
               data-pin-error="true">
               <span class="uk-icon-button fdn-icon-button-smaller fdn-share-icon-pinterest"><i class="fab fa-pinterest-p fa-sm"></i></span>
            </a>
          </div>
        

        
        
          <div fdn-share-button-favorite>
            
            <div uk-tooltip="title: Mark as Favorite"
               data-toolsoid="30865003" 
               data-toolsajaxmacro="addObject">
               <span class="uk-icon-button fdn-icon-button-smaller 
                            fdn-icon-tool-core fdn-share-icon-favorite">
                          <i class="fas fa-heart fa-sm"></i></span>
            </div>

            
            <div uk-tooltip="title: Unmark as Favorite"
               data-toolsoid="30865003" 
               data-toolsajaxmacro="removeObject"
               hidden>
               <span class="uk-icon-button fdn-icon-button-smaller 
                            fdn-icon-tool-core fdn-tool-core-favorited fdn-share-icon-favorite">
                          <i class="fas fa-heart fa-sm"></i></span>
            </div>
            
          </div>
        

        
        <div fdn-share-button-email>
          <a href="mailto:?subject=Tucson%20Weekly%20shared%20URL%3A%20The%20Daily%20Saguaro%2C%20Wednesday%2C%207/7/21&body=%0A%0AThe%20Daily%20Saguaro%2C%20Wednesday%2C%207/7/21%0A%0A<https://www.tucsonweekly.com/TheRange/archives/2021/07/07/the-daily-saguaro-wednesday-7-7-21>%0A%0A%0A" uk-tooltip="title: Share via Email">
             <span class="uk-icon-button fdn-icon-button-smaller fdn-icon-tool-core fdn-share-icon-email"><i class="far fa-envelope fa-sm"></i></span>
          </a>
        </div>


        
        
          <div>
            

            <a href="#comments" uk-tooltip="title:Comments">
              
                <span class="uk-icon-button fdn-icon-button-smaller fdn-icon-tool-core fdn-share-icon-comment"><i class="far fa-comment-alt"></i></span>
              
            </a>
          </div>
        

      </div>
    </div>

    
    <div id="ShareTools-modal" uk-modal>
      <div class="uk-modal-dialog uk-modal-body">
        <h2 class="uk-modal-title"></h2>
        <button class="uk-modal-close uk-modal-close-default" type="button" uk-close></button>
        <div class="contents"></div>
      </div>
    </div>

    <script>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</script>

    
    
      <script type="text/javascript" async defer src="//assets.pinterest.com/js/pinit.js"></script>
    
  </div>




































  <div class="ZoneA BlogPost fdn-margin-medium-vert  uk-clear-both uk-root fdn-margin-vert BlogsPreviousNext comp-content-previousnext" data-component-id="BlogsPreviousNext">

    <div class="uk-flex"> 
      
      

        


        <a class="fdn-prev-next-link uk-width-1-2 uk-padding-xsmall-right" 

           href="https://www.tucsonweekly.com/TheRange/archives/2021/07/07/claytoonz-billionaires-in-space" 
           uk-tooltip="title: <strong>Previous:</strong> Claytoonz: Billionaires In Space">

          <div class="fdn-prev-next-block uk-flex uk-flex-middle">
            
              <div style="max-width: 60px" 
                   class="uk-flex-none uk-width-small uk-margin-small-right">
                <img uk-img="" 
           data-src="https://media1.fdncms.com/tucsonweekly/imager/u/r-bigsquare/30971956/cjones07112021.jpg?cb=1625587932"
           alt="Claytoonz: Billionaires In Space"
           width="400"
           height="400"
           class="" />
              </div>
            

            <div style="overflow: hidden">
              <p class="uk-margin-remove">Previous Post</p>
              <h4 class="uk-margin-remove uk-text-truncate uk-visible@s">
                Claytoonz: Billionaires In Space
              </h4>
            </div>
          </div>
        </a>
      

      
      
    </div>
  </div>









        
        
        
        




























































  

  

  
    <div class="ZoneA BlogPost  fdn-component-related-items uk-root fdn-margin-vert MorebyThisAuthor comp-content-morebyauthor" data-component-id="MorebyThisAuthor">
      <div>
              <div class="fdn-component-header-block uk-margin ">

      

      <h3 class="fdn-component-header-text uk-margin-remove ">
        
          More by Carl Hanni
        
      </h3>

      

      
    </div>
              <div class="pres-ContentTileSquareBrief uk-grid uk-grid-small"
       uk-grid="true"
       data-ev-presentation="ContentTileSquareBrief"
       uk-height-match=".fdn-pres-image">
          
          

          <div class="uk-width-1-2 uk-width-1-4@es uk-width-1-5@el">

    <a class="uk-flex uk-flex-column fdn-decoration-remove" 
       href="https://www.tucsonweekly.com/TheRange/archives/2021/07/06/the-daily-saguaro-tuesday-7-6-21">

      <div>

        <p class="fdn-teaser-headline">
          The Daily Saguaro, Tuesday 7/6/21

          
        </p>
        
        <div class="fdn-teaser-infoline fdn-inline-split-list">
           
          
            <p>
              By Carl Hanni
            </p>
          

          <time>
            Jul  6, 2021
          </time>
        </div>

      </div>
      
      
        <div class="uk-margin-small-bottom uk-flex-first">
          <img uk-img="" 
           data-src="https://media1.fdncms.com/tucsonweekly/imager/u/r-bigsquare/30865002/img_0081.jpeg?cb=1623793903"
           alt="Framed"
           width="400"
           height="400"
           class="" />
        </div>
      
    </a>
  </div>

                    
        
          

          <div class="uk-width-1-2 uk-width-1-4@es uk-width-1-5@el">

    <a class="uk-flex uk-flex-column fdn-decoration-remove" 
       href="https://www.tucsonweekly.com/TheRange/archives/2021/07/05/the-daily-saguaro-monday-7-5-21">

      <div>

        <p class="fdn-teaser-headline">
          The Daily Saguaro, Monday 7/5/21

          
        </p>
        
        <div class="fdn-teaser-infoline fdn-inline-split-list">
           
          
            <p>
              By Carl Hanni
            </p>
          

          <time>
            Jul  5, 2021
          </time>
        </div>

      </div>
      
      
        <div class="uk-margin-small-bottom uk-flex-first">
          <img uk-img="" 
           data-src="https://media1.fdncms.com/tucsonweekly/imager/u/r-bigsquare/30864927/img_4607.jpeg?cb=1623793527"
           alt="Owl &amp; Lion, close-up"
           width="400"
           height="400"
           class="" />
        </div>
      
    </a>
  </div>

                    
        
          

          <div class="uk-width-1-2 uk-width-1-4@es uk-width-1-5@el">

    <a class="uk-flex uk-flex-column fdn-decoration-remove" 
       href="https://www.tucsonweekly.com/TheRange/archives/2021/07/04/the-daily-saguaro-sunday-7-4-21">

      <div>

        <p class="fdn-teaser-headline">
          The Daily Saguaro, Sunday 7/4/21

          
        </p>
        
        <div class="fdn-teaser-infoline fdn-inline-split-list">
           
          
            <p>
              By Carl Hanni
            </p>
          

          <time>
            Jul  4, 2021
          </time>
        </div>

      </div>
      
      
        <div class="uk-margin-small-bottom uk-flex-first">
          <img uk-img="" 
           data-src="https://media2.fdncms.com/tucsonweekly/imager/u/r-bigsquare/30864920/img_4606.jpeg?cb=1625500118"
           alt="Owl &amp; Lion"
           width="400"
           height="400"
           class="" />
        </div>
      
    </a>
  </div>

                    
        
          

          <div class="uk-width-1-2 uk-width-1-4@es uk-width-1-5@el">

    <a class="uk-flex uk-flex-column fdn-decoration-remove" 
       href="https://www.tucsonweekly.com/TheRange/archives/2021/07/03/the-daily-saguaro-saturday-7-3-21">

      <div>

        <p class="fdn-teaser-headline">
          The Daily Saguaro, Saturday, 7/3/21

          
        </p>
        
        <div class="fdn-teaser-infoline fdn-inline-split-list">
           
          
            <p>
              By Carl Hanni
            </p>
          

          <time>
            Jul  3, 2021
          </time>
        </div>

      </div>
      
      
        <div class="uk-margin-small-bottom uk-flex-first">
          <img uk-img="" 
           data-src="https://media2.fdncms.com/tucsonweekly/imager/u/r-bigsquare/30864903/img_3081.jpeg?cb=1623793223"
           alt="Another look at this face...because it&#39;s so great."
           width="400"
           height="400"
           class="" />
        </div>
      
    </a>
  </div>

                    
        
              </div>
              
              <div class="uk-margin-small uk-clearfix uk-text-right ">
      <a class="uk-align-right uk-margin-remove fdn-more-link uk-flex-inline uk-flex-middle" href="https://www.tucsonweekly.com/tucson/ArticleArchives?author=1064096">
        More &raquo;
      </a>
    </div>
            </div>
    </div>  
  












  

  




































































  

  
    

    

    

    

    

    

    

    

    

    

    

    

    

    

    

    

    

    
    

    

    

    

    

      

      

        

        <div id="Comments" class="ZoneA BlogPost  fdn-margin-vert uk-root fdn-margin-vert Comments comp-comment-comments" data-component-id="Comments">

          <div class="uk-flex uk-flex-column">

            

            

            

            

            <div class="uk-flex uk-flex-wrap uk-flex-middle uk-inline fdn-comments-header-block uk-hidden" id="readerComments">

              <div class="uk-position-center" uk-spinner></div>

              
              


              

              <div class="fdn-teaser-headline fdn-comments-header-title uk-margin-remove uk-width-expand@s uk-width-1-2@s">
                Comments
                (<span id="comments_total" class="commentsTotalUpdate">0</span>)
              </div>

              

              

              

              

            </div>
          

            

            

            

            <div id="Comments_commentContent" class="uk-flex-column uk-width-1-1 uk-inline commentContent">
              
            </div>

            

            
          
          

            

            <div class="uk-flex uk-flex-column">

              
                

                <form class="userCommentForm validateForm"
                      id="CommentsPostCommentForm"
                      method="post"
                      data-validate="login"
                      data-validate-login-options="{&quot;feelingShy&quot;:true}">

                  <input type="hidden" name="commentType" value="comment" />
                  <input type="hidden" name="oid" value="30865003" />
                  <input type="hidden" name="source" value="desktop">

                  
                  

                  
                  
                    <div class="fdn-component-header-block uk-margin fdn-comment-component-header-block">

      

      <h3 class="fdn-component-header-text uk-margin-remove fdn-comment-component-header-text">
        
          Add a comment
        
      </h3>

      

      
    </div>
                        <a name="readerComments" style="display: none;">Add a Comment</a>
                    </h4>
                  

                  
                  

                  <div class="errorDisplay uk-alert-warning" style="display:none" uk-alert>
                    <ol class="uk-text-danger fdn-text-medium"></ol>
                  </div>

                  

                  

                  <textarea id="comment"
                            class="expandableBox required uk-textarea uk-margin-small"
                            rows="8"
                            name="comment"
                            tabindex="1"
                            data-validate="required"></textarea>

                <div class="uk-flex uk-flex-middle uk-flex-between">            
                  <div class="uk-flex uk-flex-row uk-flex-middle">
                    <input class="uk-checkbox uk-margin-small-right"
                           type="checkbox"
                           name="subscribe"
                           id="Comments_commentSubscribe"
                           value="yes">
                    <label for="Comments_commentSubscribe">Subscribe to this thread</label>
                  </div>

                  

                  <div class="">
                    <input id="commentSubmit"
                           class="uk-input fdn-button-control uk-width-auto"
                           type="submit"
                           name="commentSubmit"
                           tabindex="2"
                           value="Post Comment">
                  </div>
                </div>
                </form>
              
            </div>
          </div>

          

          <script type="text/javascript">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</script>
        </div>
      
    
  























      
  

  
      <div class="ZoneA BlogPost  fdn-component-related-items uk-root fdn-margin-vert PreviouslyintheRange comp-content-latestincategory" data-component-id="PreviouslyintheRange">
        <div class="fdn-component-header-block uk-margin ">

      

      <h3 class="fdn-component-header-text uk-margin-remove ">
        
          Previously in the Range
        
      </h3>

      

      
    </div>
        <ul class="pres-ContentListRectangle uk-list uk-list-divider">
    
    

    <li class="fdn-pres-item ">
    <div class="uk-flex">
      <div class="uk-flex-1 uk-margin-remove">

        

        <a href="https://www.tucsonweekly.com/TheRange/archives/2021/07/06/monsoon-2021-off-to-a-stronger-start-than-last-year">
          <p class="fdn-teaser-headline">
            Monsoon 2021 off to a Stronger Start Than Last Year
          </p>
        </a>

        <div class="fdn-teaser-infoline fdn-inline-split-list">
          
            <p>
              By Jeff Gardner
            </p>
          

          <time>
            Jul  6, 2021
          </time>
        </div>

      </div>

      
        <div class="uk-margin-small-right uk-width-2-5 uk-flex-first">
          <a href="https://www.tucsonweekly.com/TheRange/archives/2021/07/06/monsoon-2021-off-to-a-stronger-start-than-last-year">
            <img uk-img="" 
           data-src="https://media1.fdncms.com/tucsonweekly/imager/u/r-big16x10/30972108/screen_shot_2021-07-06_at_11.18.39_am.png?cb=1625601558"
           alt="Monsoon 2021 off to a Stronger Start Than Last Year"
           width="660"
           height="370"
           class="" />
          </a>
        </div>
      
    </div>
  </li>

    
  
    

    <li class="fdn-pres-item ">
    <div class="uk-flex">
      <div class="uk-flex-1 uk-margin-remove">

        

        <a href="https://www.tucsonweekly.com/TheRange/archives/2021/07/06/the-daily-saguaro-tuesday-7-6-21">
          <p class="fdn-teaser-headline">
            The Daily Saguaro, Tuesday 7/6/21
          </p>
        </a>

        <div class="fdn-teaser-infoline fdn-inline-split-list">
          
            <p>
              By Carl Hanni
            </p>
          

          <time>
            Jul  6, 2021
          </time>
        </div>

      </div>

      
        <div class="uk-margin-small-right uk-width-2-5 uk-flex-first">
          <a href="https://www.tucsonweekly.com/TheRange/archives/2021/07/06/the-daily-saguaro-tuesday-7-6-21">
            <img uk-img="" 
           data-src="https://media1.fdncms.com/tucsonweekly/imager/u/r-big16x10/30865002/img_0081.jpeg?cb=1623793903"
           alt="Framed"
           width="660"
           height="370"
           class="" />
          </a>
        </div>
      
    </div>
  </li>

    
  
    

    <li class="fdn-pres-item ">
    <div class="uk-flex">
      <div class="uk-flex-1 uk-margin-remove">

        

        <a href="https://www.tucsonweekly.com/TheRange/archives/2021/07/05/the-daily-saguaro-monday-7-5-21">
          <p class="fdn-teaser-headline">
            The Daily Saguaro, Monday 7/5/21
          </p>
        </a>

        <div class="fdn-teaser-infoline fdn-inline-split-list">
          
            <p>
              By Carl Hanni
            </p>
          

          <time>
            Jul  5, 2021
          </time>
        </div>

      </div>

      
        <div class="uk-margin-small-right uk-width-2-5 uk-flex-first">
          <a href="https://www.tucsonweekly.com/TheRange/archives/2021/07/05/the-daily-saguaro-monday-7-5-21">
            <img uk-img="" 
           data-src="https://media1.fdncms.com/tucsonweekly/imager/u/r-big16x10/30864927/img_4607.jpeg?cb=1623793527"
           alt="Owl &amp; Lion, close-up"
           width="660"
           height="370"
           class="" />
          </a>
        </div>
      
    </div>
  </li>

    
  
    

    <li class="fdn-pres-item ">
    <div class="uk-flex">
      <div class="uk-flex-1 uk-margin-remove">

        

        <a href="https://www.tucsonweekly.com/TheRange/archives/2021/07/04/the-daily-saguaro-sunday-7-4-21">
          <p class="fdn-teaser-headline">
            The Daily Saguaro, Sunday 7/4/21
          </p>
        </a>

        <div class="fdn-teaser-infoline fdn-inline-split-list">
          
            <p>
              By Carl Hanni
            </p>
          

          <time>
            Jul  4, 2021
          </time>
        </div>

      </div>

      
        <div class="uk-margin-small-right uk-width-2-5 uk-flex-first">
          <a href="https://www.tucsonweekly.com/TheRange/archives/2021/07/04/the-daily-saguaro-sunday-7-4-21">
            <img uk-img="" 
           data-src="https://media2.fdncms.com/tucsonweekly/imager/u/r-big16x10/30864920/img_4606.jpeg?cb=1625500118"
           alt="Owl &amp; Lion"
           width="660"
           height="370"
           class="" />
          </a>
        </div>
      
    </div>
  </li>

    
  
    

    <li class="fdn-pres-item ">
    <div class="uk-flex">
      <div class="uk-flex-1 uk-margin-remove">

        

        <a href="https://www.tucsonweekly.com/TheRange/archives/2021/07/03/the-daily-saguaro-saturday-7-3-21">
          <p class="fdn-teaser-headline">
            The Daily Saguaro, Saturday, 7/3/21
          </p>
        </a>

        <div class="fdn-teaser-infoline fdn-inline-split-list">
          
            <p>
              By Carl Hanni
            </p>
          

          <time>
            Jul  3, 2021
          </time>
        </div>

      </div>

      
        <div class="uk-margin-small-right uk-width-2-5 uk-flex-first">
          <a href="https://www.tucsonweekly.com/TheRange/archives/2021/07/03/the-daily-saguaro-saturday-7-3-21">
            <img uk-img="" 
           data-src="https://media2.fdncms.com/tucsonweekly/imager/u/r-big16x10/30864903/img_3081.jpeg?cb=1623793223"
           alt="Another look at this face...because it&#39;s so great."
           width="660"
           height="370"
           class="" />
          </a>
        </div>
      
    </div>
  </li>

    
  
    

    <li class="fdn-pres-item ">
    <div class="uk-flex">
      <div class="uk-flex-1 uk-margin-remove">

        

        <a href="https://www.tucsonweekly.com/TheRange/archives/2021/07/02/the-daily-saguaro-friday-7-2-21">
          <p class="fdn-teaser-headline">
            The Daily Saguaro, Friday 7/2/21
          </p>
        </a>

        <div class="fdn-teaser-infoline fdn-inline-split-list">
          
            <p>
              By Carl Hanni
            </p>
          

          <time>
            Jul  2, 2021
          </time>
        </div>

      </div>

      
        <div class="uk-margin-small-right uk-width-2-5 uk-flex-first">
          <a href="https://www.tucsonweekly.com/TheRange/archives/2021/07/02/the-daily-saguaro-friday-7-2-21">
            <img uk-img="" 
           data-src="https://media1.fdncms.com/tucsonweekly/imager/u/r-big16x10/30864842/img_2968.jpeg?cb=1623793049"
           alt="Skin #6"
           width="660"
           height="370"
           class="" />
          </a>
        </div>
      
    </div>
  </li>

    
  
        </ul>
        <div class="uk-margin-small uk-clearfix uk-text-right ">
      <a class="uk-align-right uk-margin-remove fdn-more-link uk-flex-inline uk-flex-middle" href="https://www.tucsonweekly.com/tucson/ArticleArchives?category=1125619">
        More &raquo;
      </a>
    </div>
      </div>
    












        </div>

        <div class="ev-grid-col" data-ev-zone="ZoneB">
          
          
        </div>

        <div class="ev-grid-col" style="clear:both;" data-ev-zone="ZoneC">
          
        </div>
      </div>

      <div class="fdn-grid-sidebar">
        <div class="ev-grid-col" data-ev-zone="ZoneD">
          























<div class="ZoneD BlogPost  uk-text-center uk-root fdn-margin-vert Donate comp-" data-component-id="Donate">
  <a href="https://www.tucsonweekly.com/TheRange/archives/2020/03/25/we-need-you-support-the-tucson-weekly" target="_blank"><img src="/binary/697f/binary-viewer.jpeg" width="300" height="250" alt="" /></a>
</div><div class="ZoneD BlogPost Ad uk-margin-remove uk-root fdn-margin-vert AirMedRect1 comp-" data-component-id="AirMedRect1">
  <div class="fdn-ad-container fdn-ad-container-medium-margin">
            <!-- /4961490/TW_MediumRectangle-300x250 -->
            <div id="div-gpt-ad-tw_mediumrectangle_300x250-20"
                 class=" fdn-ad-container"
                 data-content-type="ad"
                 data-slot="/4961490/TW_MediumRectangle-300x250"
                 data-output="asynchronous"
                 data-width="300"
                 data-height="250">
                <script type='text/javascript'>
                  googletag.cmd.push(function() {
                    googletag.display('div-gpt-ad-tw_mediumrectangle_300x250-20');
                  });
                </script>
            </div>
          </div>
</div><div class="ZoneD BlogPost  uk-text-center uk-root fdn-margin-vert COVID19tocontent comp-" data-component-id="COVID19tocontent">
  <a href="https://www.tucsonweekly.com/TheRange/archives/covid-19/" target="_blank"><img src="/binary/f096/corona-button.jpeg" width="300" height="250" alt="" /></a>
</div><div class="ZoneD BlogPost Ad uk-margin-remove uk-root fdn-margin-vert AirMedRect2 comp-" data-component-id="AirMedRect2">
  <div class="fdn-ad-container fdn-ad-container-medium-margin">
            <!-- /4961490/TW_MediumRectangle-300x250 -->
            <div id="div-gpt-ad-tw_mediumrectangle_300x250-21"
                 class=" fdn-ad-container"
                 data-content-type="ad"
                 data-slot="/4961490/TW_MediumRectangle-300x250"
                 data-output="asynchronous"
                 data-width="300"
                 data-height="250">
                <script type='text/javascript'>
                  googletag.cmd.push(function() {
                    googletag.display('div-gpt-ad-tw_mediumrectangle_300x250-21');
                  });
                </script>
            </div>
          </div>
</div><div class="ZoneD BlogPost  uk-text-center uk-root fdn-margin-vert BestofTucson2021VotingAd comp-" data-component-id="BestofTucson2021VotingAd">
  <a href="https://posting.tucsonweekly.com/tucson/Survey?survey=30797651">
    <img src="/binary/6698/63C830FC357B48E18719066F2AE2262B.jpg" width="702" height="585" alt="" />
  </a>
</div><div class="ZoneD BlogPost Ad uk-margin-remove uk-root fdn-margin-vert AirHalfPage1 comp-" data-component-id="AirHalfPage1">
  <div class="fdn-ad-container fdn-ad-container-medium-margin">
            <!-- /4961490/TW_HalfPage_300x600 -->
            <div id="div-gpt-ad-tw_halfpage_300x600-20"
                 class=" fdn-ad-container"
                 data-content-type="ad"
                 data-slot="/4961490/TW_HalfPage_300x600"
                 data-output="asynchronous"
                 data-width="300"
                 data-height="600">
                <script type='text/javascript'>
                  googletag.cmd.push(function() {
                    googletag.display('div-gpt-ad-tw_halfpage_300x600-20');
                  });
                </script>
            </div>
          </div>
</div>




















    <div class="ZoneD BlogPost   uk-root fdn-margin-vert CurrentIssueOnly comp-landing-currentissueonly" data-component-id="CurrentIssueOnly">
      
        <div class="fdn-component-header-block uk-margin ">

      

      <h3 class="fdn-component-header-text uk-margin-remove ">
        
          <a class="fdn-component-header-link-text" 
             href="https://www.tucsonweekly.com/tucson/IssueArchives?issue=30906604"
             target="">
            Current Issue
          </a>
        
      </h3>

      

      
    </div>      
      
  
         
  

  <div class="uk-flex uk-flex-wrap fdn-current-issue-block"> 

    
    <div class="uk-width-1-2@s uk-width-1-3 uk-padding-xsmall uk-padding-remove-top uk-padding-remove-left uk-text-center fdn-current-issue-issue-cover">
      <a class="no-foundation-imgeditor" href="https://www.tucsonweekly.com/tucson/IssueArchives?issue=30906604">
        <img uk-img=""  
           data-src="/imager/b/r-cover/30906604/dab3/TucsonWeekly_July_1_page_01.jpg"
           alt=""
           width="440"
           height="441"
           class="" />
      </a>
    </div>

    <div class="uk-width-1-2@s uk-width-2-3 uk-padding-small uk-padding-remove-top uk-flex uk-flex-column fdn-current-issue-links">
      <div class="fdn-current-issue-link-dates">
        <p class="uk-margin-remove"></p>
        
          July 01-07
         
      </div>

      <ul class="uk-list fdn-list-square">      
        
          <li>
            <a href="https://issuu.com/timespub/docs/tucson_weekly_july_1_2021" target="_blank">Digital Edition</a>
          </li>
        

        <li>
          <a href="https://www.tucsonweekly.com/tucson/IssueArchives">Cover Gallery</a>
        </li>

        <li>
          <a href="https://www.tucsonweekly.com/tucson/ArticleArchives">Archives</a>
        </li>
      </ul>
    </div>

  </div>
  

    </div>
  




























    <div class="ZoneD BlogPost   uk-root fdn-margin-vert BestOfHighlight comp-landing-bestofissuehighlight" data-component-id="BestOfHighlight">
      <div class="fdn-component-header-block uk-margin  ">

      

      <h3 class="fdn-component-header-text uk-margin-remove ">
        
          <a class="fdn-component-header-link-text" 
             href="https://www.tucsonweekly.com/tucson/BestOf"
             target="">
            Best Of Tucson®
          </a>
        
      </h3>

      

      
    </div>

      <div class="uk-flex uk-flex-wrap"> 
  

  

  
  
    <div class="uk-width-1-2@s uk-width-1-3 uk-padding-xsmall uk-padding-remove-top uk-padding-remove-left uk-text-center">
      <a href="https://www.tucsonweekly.com/tucson/BestOf?year=2020">
        <img uk-img=""  
           data-src="/imager/b/r-cover/29732722/19ae/BOT_2020_Pg1.jpg"
           alt="Best Of Tucson&reg;"
           width="440"
           height="441"
           class="" />
      </a>
    </div>

    <div class="uk-width-1-2 uk-padding-small uk-padding-remove-top uk-flex uk-flex-wrap uk-flex-between">
      <div class="uk-padding-xsmall uk-padding-remove-top uk-padding-remove-right">
        <h4 class="uk-margin-remove custom-homepage-header-link">
          <a href="https://www.tucsonweekly.com/tucson/BestOf?year=2020">Current Year</a>
        </h4>

        <ul class="uk-list uk-margin-remove">
          <li class="uk-margin-remove">
            <a class="uk-text-small" href="https://www.tucsonweekly.com/tucson/BestOf?year=2020">
              2020
            </a>
          </li>
        </ul>
      </div>


  
  

  


  

  
  

    
      <div class="uk-padding-xsmall uk-padding-remove-top uk-padding-remove-right">
        <h4 class="uk-margin-remove custom-homepage-header-link">
          Recent Years
        </h4>
       
      <ul class="uk-list uk-margin-remove">
    

    
      <li class="uk-margin-remove">
        <a class="uk-text-small" href="https://www.tucsonweekly.com/tucson/BestOf?year=2019">
          2019
        </a>
      </li>
    

    

  

  


  

  
  

    

    
      <li class="uk-margin-remove">
        <a class="uk-text-small" href="https://www.tucsonweekly.com/tucson/BestOf?year=2018">
          2018
        </a>
      </li>
    

    

  

  


  

  
  

    

    
      <li class="uk-margin-remove">
        <a class="uk-text-small" href="https://www.tucsonweekly.com/tucson/BestOf?year=2017">
          2017
        </a>
      </li>
    

    

  

  


  

  
  

    

    
      <li class="uk-margin-remove">
        <a class="uk-text-small" href="https://www.tucsonweekly.com/tucson/BestOf?year=2016">
          2016
        </a>
      </li>
    

    
      </ul>
        </div>
      </div>
    

  

  

      </div>


       

      

    </div>
  

        </div>
      </div>
      
    </div>

    <div class="ev-grid-zone ev-footer-zone" data-ev-zone="GlobalFooter">
      <div class="ev-grid-col uk-width-1-1">
        <div class="GlobalFooter BlogPost Ad uk-margin-remove uk-visible@m
               uk-flex uk-flex-row uk-flex-around uk-root fdn-margin-vert AirLVPLeaderboard2 comp-" data-component-id="AirLVPLeaderboard2">
  <div class="fdn-ad-container fdn-ad-container-margin-collapse-fix">
            <!-- /4961490/TW_leaderboard -->
            <div id="div-gpt-ad-tw_leaderboard-2"
                 class=" fdn-ad-container"
                 data-content-type="ad"
                 data-slot="/4961490/TW_leaderboard"
                 data-output="asynchronous"
                 data-width="970"
                 data-height="250">
                <script type='text/javascript'>
                  googletag.cmd.push(function() {
                    Foundation.Ad.displayAdResponsive('div-gpt-ad-tw_leaderboard-2')
                  });
                </script>
            </div>
          </div>
</div><div class="GlobalFooter BlogPost Ad uk-margin-remove uk-hidden@m
               uk-flex uk-flex-row uk-flex-around uk-root fdn-margin-vert AirSVPLeaderboard2 comp-" data-component-id="AirSVPLeaderboard2">
  <div class="fdn-ad-container fdn-ad-container-margin-collapse-fix">
            <!-- /4961490/TW_leaderboard -->
            <div id="div-gpt-ad-tw_leaderboard-6"
                 class=" fdn-ad-container"
                 data-content-type="ad"
                 data-slot="/4961490/TW_leaderboard"
                 data-output="asynchronous"
                 data-width="970"
                 data-height="250">
                <script type='text/javascript'>
                  googletag.cmd.push(function() {
                    Foundation.Ad.displayAdResponsive('div-gpt-ad-tw_leaderboard-6')
                  });
                </script>
            </div>
          </div>
</div>

<div class="GlobalFooter BlogPost  uk-margin-remove uk-root fdn-margin-vert FooterCustom comp-shell-footer" data-component-id="FooterCustom">
  
  
  <div class="uk-flex uk-flex-wrap uk-flex-top fdn-custom-footer-block-content-wrap">

    <div class="fdn-custom-footer-block-content-column-left uk-flex uk-flex-wrap uk-width-1-3@m uk-width-1-1@s">
      <div class="uk-flex uk-flex-wrap uk-width-1-1 fdn-custom-footer-block-logo-social-block"> 

        
        <a class="uk-margin-medium-right fdn-custom-footer-block-logo" href="https://www.tucsonweekly.com/">
          Tucson Weekly
        </a>

        
        <div class="fdn-custom-footer-block-social-links uk-flex uk-flex-wrap uk-flex-top uk-flex-center uk-child-width-auto">
          
            <a id="fdn-footer-icon-facebook" 
               class="custom-footer-icon-link uk-flex uk-flex-middle uk-padding-remove" 
               href="https://www.facebook.com/tucsonweekly" target="_blank">

              <div class="uk-width-auto">
                <span class="custom-footer-icon uk-icon-button" 
                      uk-icon="ratio:.7;icon:facebook"></span>
              </div>

              <div class="uk-margin-xsmall-left fdn-line-height-1 uk-visible@m fdn-custom-footer-icon-link-text">
                Facebook
              </div>
            </a>
          
            <a id="fdn-footer-icon-twitter" 
               class="custom-footer-icon-link uk-flex uk-flex-middle uk-padding-remove" 
               href="https://twitter.com/TucsonWeekly" target="_self">

              <div class="uk-width-auto">
                <span class="custom-footer-icon uk-icon-button" 
                      uk-icon="ratio:.7;icon:twitter"></span>
              </div>

              <div class="uk-margin-xsmall-left fdn-line-height-1 uk-visible@m fdn-custom-footer-icon-link-text">
                Twitter
              </div>
            </a>
          
            <a id="fdn-footer-icon-Newsletters" 
               class="custom-footer-icon-link uk-flex uk-flex-middle uk-padding-remove" 
               href="/tucson/Newsletter" target="_self">

              <div class="uk-width-auto">
                <span class="custom-footer-icon uk-icon-button" 
                      uk-icon="ratio:.7;icon:mail"></span>
              </div>

              <div class="uk-margin-xsmall-left fdn-line-height-1 uk-visible@m fdn-custom-footer-icon-link-text">
                Newsletters
              </div>
            </a>
          
            <a id="fdn-footer-icon-RSS" 
               class="custom-footer-icon-link uk-flex uk-flex-middle uk-padding-remove" 
               href="/tucson/Syndication" target="_self">

              <div class="uk-width-auto">
                <span class="custom-footer-icon uk-icon-button" 
                      uk-icon="ratio:.7;icon:rss"></span>
              </div>

              <div class="uk-margin-xsmall-left fdn-line-height-1 uk-visible@m fdn-custom-footer-icon-link-text">
                RSS
              </div>
            </a>
          
        </div>
      </div> <!-- End fdn-custom-footer-block-logo-social-block -->

      
      <ul class="uk-list fdn-custom-footer-block-contact-info"
        
          <li><strong>Tucson Weekly</strong></li>
          <li>7225 N. Mona Lisa Rd</li>
          <li>Suite 125</li>
          <li>Tucson, AZ 85741</li>
          <li>(520) 797-4384</li>
        
      </ul>
    </div>


    
    <div class="uk-flex uk-flex-wrap uk-flex-1  uk-width-1-1 uk-width-3-5@s fdn-custom-footer-block-link-block">
      <div class="uk-flex uk-width-1-1 fdn-custom-footer-block-link-block-row">
        

          <div class="fdn-custom-footer-block-link-section-block">
            <h3 class="fdn-custom-footer-block-link-section-header uk-margin-xsmall-bottom uk-margin-remove-top">
              <a href="/tucson/news-and-opinion/Section?oid=1063709" target="_self">News & Opinion</a>
            </h3>

            
                
                <ul class="uk-list uk-margin-remove fdn-custom-footer-block-link-section-links uk-column-1-2">
              
              

              

              <li>
                <a href="/tucson/news-and-opinion/Section?oid=1063709" target="_self">News Main Page</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/cover-story/Content?special=1125844" target="_self">Cover Story</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/Category?oid=1063734" target="_self">Currents Features</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/editors-note/Content?category=1063766" target="_self">Editor's Note</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/Category?oid=1063741" target="_self">Danehy</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/cannabis/Category?oid=3147720" target="_self">Cannabis</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/the-skinny/Content?category=1063733" target="_self">The Skinny</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/police-dispatch/Category?oid=1063770" target="_self">Police Dispatch</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/guest-commentary/Category?oid=1063786" target="_self">Guest Commentary</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/tucson-salvage/Category?oid=5928956" target="_self">Tucson Salvage</a>
              </li>

              
            
              

              

              <li>
                <a href="/blogs/TheRange/" target="_self">The Range</a>
              </li>

              
            
                </ul>
              

          </div>

          
        

          <div class="fdn-custom-footer-block-link-section-block">
            <h3 class="fdn-custom-footer-block-link-section-header uk-margin-xsmall-bottom uk-margin-remove-top">
              <a href="/tucson/chow/Section?oid=1063714" target="_self">Chow</a>
            </h3>

            
                
                <ul class="uk-list uk-margin-remove fdn-custom-footer-block-link-section-links ">
              
              

              

              <li>
                <a href="/tucson/chow/Section?oid=1063714" target="_self">Chow Main Page</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/Category?oid=1063740" target="_self">Chow Features</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/LocationSearch?locationSection=1113936&sortType=range" target="_self">Restaurants</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/LocationSearch?locationSection=1113936&feature=Menu" target="_self">Restaurant Menus</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/ArticleArchives?section=1063714" target="_self">Chow Archives</a>
              </li>

              
            
                </ul>
              

          </div>

          
        

          <div class="fdn-custom-footer-block-link-section-block">
            <h3 class="fdn-custom-footer-block-link-section-header uk-margin-xsmall-bottom uk-margin-remove-top">
              <a href="/tucson/city-week/Content?category=1063735" target="_self">Events</a>
            </h3>

            
                
                <ul class="uk-list uk-margin-remove fdn-custom-footer-block-link-section-links uk-column-1-2">
              
              

              

              <li>
                <a href="/tucson/city-week/Content?category=1063735" target="_self">City Week: Weekly Picks</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/EventSearch?narrowByDate=Today" target="_self">Events Today</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/EventSearch?narrowByDate=This+Weekend&sortType=date&v=d" target="_self">This Weekend</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/EventSearch?feature=Staff%20Pick&sortType=Date" target="_self">Staff Pick Listings</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/EventSearch?eventCategory=1107349" target="_self">Bulletin Board</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/LocationSearch" target="_self">Location Guide</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/Events/AddEvent" target="_self">Submit an Event</a>
              </li>

              
            
                </ul>
              

          </div>

          
        

          <div class="fdn-custom-footer-block-link-section-block">
            <h3 class="fdn-custom-footer-block-link-section-header uk-margin-xsmall-bottom uk-margin-remove-top">
              <a href="/tucson/cinema/Section?oid=1063716" target="_self">Cinema</a>
            </h3>

            
                
                <ul class="uk-list uk-margin-remove fdn-custom-footer-block-link-section-links ">
              
              

              

              <li>
                <a href="/tucson/cinema/Section?oid=1063716" target="_self">Cinema Main Page</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/MovieTimes" target="_self">Movie Times</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/MovieTimes?show=theater" target="_self">Movie Theaters</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/ArticleArchives?section=1063716" target="_self">Cinema Archives</a>
              </li>

              
            
                </ul>
              

          </div>

          
            </div>
            <div class="uk-flex uk-width-1-1 fdn-custom-footer-block-link-block-row">
          
        

          <div class="fdn-custom-footer-block-link-section-block">
            <h3 class="fdn-custom-footer-block-link-section-header uk-margin-xsmall-bottom uk-margin-remove-top">
              <a href="/tucson/arts-and-culture/Section?oid=1063713" target="_self">Arts & Culture</a>
            </h3>

            
                
                <ul class="uk-list uk-margin-remove fdn-custom-footer-block-link-section-links uk-column-1-2">
              
              

              

              <li>
                <a href="/tucson/arts-and-culture/Section?oid=1063713" target="_self">Arts Main Page</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/category?oid=1063742" target="_self">Book Features</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/EventSearch?eventCategory=1107327&sortType=Date" target="_self">Art Events</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/LocationSearch?locationCategory=1113916" target="_self">Galleries</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/EventSearch?eventCategory=1107325&sortType=Date" target="_self">Museum Listings</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/LocationSearch?locationCategory=1113923" target="_self">Museums</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/EventSearch?eventCategory=1107320&sortType=Date" target="_self">Performing Arts Events</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/LocationSearch?locationCategory=1113917" target="_self">Theaters</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/EventSearch?eventCategory=1107323&sortType=Date" target="_self">Dance Events</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/LocationSearch?locationCategory=1113925" target="_self">Bookstores</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/LocationSearch?locationCategory=1113933" target="_self">Coffee Houses</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/LocationSearch?locationCategory=1113924" target="_self">Libraries</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/EventSearch?eventCategory=1107335&sortType=Date" target="_self">Literature Events</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/ArticleArchives?section=1063713" target="_self">Arts & Culture Archives</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/Events/AddEvent" target="_self">Submit an Event</a>
              </li>

              
            
                </ul>
              

          </div>

          
        

          <div class="fdn-custom-footer-block-link-section-block">
            <h3 class="fdn-custom-footer-block-link-section-header uk-margin-xsmall-bottom uk-margin-remove-top">
              <a href="/tucson/music/Section?oid=1063712" target="_self">Music</a>
            </h3>

            
                
                <ul class="uk-list uk-margin-remove fdn-custom-footer-block-link-section-links uk-column-1-2">
              
              

              

              <li>
                <a href="/tucson/music/Section?oid=1063712" target="_self">Music Main Page</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/Category?oid=1063737" target="_self">Music Features</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/EventSearch?eventCategory=1107701&sortType=Date" target="_self">Music Listings</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/LocationSearch?locationCategory=1113914&sortType=range" target="_self">Bars</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/LocationSearch?locationCategory=1113974&sortType=name" target="_self">Music Venues</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/ArticleArchives?section=1063712" target="_self">Music Archives</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/Events/AddEvent" target="_self">Submit an Event</a>
              </li>

              
            
                </ul>
              

          </div>

          
        

          <div class="fdn-custom-footer-block-link-section-block">
            <h3 class="fdn-custom-footer-block-link-section-header uk-margin-xsmall-bottom uk-margin-remove-top">
              <a href="/tucson/BestOf" target="_self">Best of Tucson®</a>
            </h3>

            
                
                <ul class="uk-list uk-margin-remove fdn-custom-footer-block-link-section-links uk-column-1-2">
              
              

              

              <li>
                <a href="/tucson/BestOf" target="_self">Main Page</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/arts-and-culture/BestOf?category=1063746&year=2020" target="_self">Arts & Culture</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/city-life/BestOf?category=1063748&year=2020" target="_self">City Life</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/BestOf?category=3153674&year=2020" target="_self">Fashion + Style</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/outdoors/BestOf?category=1063750&year=2020" target="_self">Outdoors</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/BestOf?category=1063749&year=2020" target="_self">Kids' Stuff</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/BestOf?category=1063781&year=2020" target="_self">Media Mix</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/casual-dining/BestOf?category=3154064&year=2017&year=2020" target="_self">Casual Dining</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/kids-stuff/BestOf?category=1063782&year=2020" target="_self">Restaurants</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/BestOf?category=3153201&year=2020" target="_self">¡Comida!</a>
              </li>

              
            
              

              

              <li>
                <a href="/tucson/spirits/BestOf?category=1063752&year=2020" target="_self">Spirits & Nightlife</a>
              </li>

              
            
                </ul>
              

          </div>

          
        
      </div>
    </div>


  </div>
</div>









    <div class="GlobalFooter BlogPost   uk-root fdn-margin-vert FooterNavigation comp-shell-footernavigation" data-component-id="FooterNavigation">
      <ul class="fdn-footer-navigation fdn-separated-list uk-list uk-flex uk-flex-center uk-flex-wrap uk-margin-top uk-padding-small uk-padding-remove-vertical">
  
  

  <li>
    
    <a href="https://www.tucsonweekly.com/tucson/ArticleArchives" target="_self">
      
        archives
      
    </a>
  </li> 

  

  

  <li>
    
    <a href="https://www.tucsonweekly.com/tucson/Advertising/Page" target="_self">
      
        advertising
      
    </a>
  </li> 

  

  

  <li>
    
    <a href="https://www.tucsonweekly.com/tucson/PrivacyPolicy/Page" target="_self">
      
        privacy policy
      
    </a>
  </li> 

  

  

  <li>
    
    <a href="https://www.tucsonweekly.com/tucson/Staff/Page" target="_self">
      
        Staff / Contact Us
      
    </a>
  </li> 

  

  

  <li>
    
    <a href="https://www.tucsonweekly.com/tucson/TermsConditions/Page" target="_self">
      
        terms & conditions
      
    </a>
  </li> 

  

  

  <li>
    
    <a href="https://www.tucsonweekly.com/tucson/CommentsPolicy/Page" target="_self">
      
        comments policy
      
    </a>
  </li> 

  

      </ul>
    </div>
  


<div class="GlobalFooter BlogPost   uk-root fdn-margin-vert FooterCopyright comp-shell-footercopyright" data-component-id="FooterCopyright">
  <div class="uk-text-center">
    <div class="fdn-copyright-text">
      &copy; 2021
      Tucson Weekly 
    </div>
    <div class="fdn-copyright-text uk-margin-small-top">
      <a class="fdn-copyright-link" href="https://publishwithfoundation.com/" target="_blank">
        <img width="110" alt="Powered By Foundation" src="/foundation/images/PoweredByFoundation.svg">
      </a>
    </div>
  </div>
</div>
<div class="GlobalFooter BlogPost Ad uk-hidden uk-margin-remove uk-root fdn-margin-vert AirLVPSiteSkin comp-" data-component-id="AirLVPSiteSkin">
  <div class="fdn-ad-container">
            <!-- /4961490/TW_Siteskin -->
            <div id="div-gpt-ad-tw_siteskin"
                 class=" fdn-ad-container"
                 data-content-type="ad"
                 data-slot="/4961490/TW_Siteskin"
                 data-output="asynchronous"
                 data-width="1"
                 data-height="1">
                <script type='text/javascript'>
                  googletag.cmd.push(function() {
                    googletag.display('div-gpt-ad-tw_siteskin');
                  });
                </script>
            </div>
          </div>
</div>


<!-- Start Google Analytics -->
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-3905397-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'stats.g.doubleclick.net/dc.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<!-- End Google Analytics -->


<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-6cJMtQ1dR3JBg"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-6cJMtQ1dR3JBg.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->
      </div>
    </div>

    <div class="ev-grid-zone ev-closer-zone" data-ev-zone="Closer">
      <div class="ev-grid-col uk-width-1-1">
        
      </div>
    </div>

  </div>

</div>




    </body>
</html>
  


