































































  
           
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "https://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="https://www.w3.org/1999/xhtml" xmlns:fb="https://www.facebook.com/2008/fbml" xml:lang="en" lang="en">

<head>
  
  <meta name="viewport" content="width=1000">

  
  <meta name="layout" content="The Range Blog Post" />
  
    <meta name="oid" content="25346224" />
  
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <meta http-equiv="imagetoolbar" content="no" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />

  
  
  
  <link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=7a7ce6ebc17bcb5b6add9122d12b0c2b" />

  
  
    <link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=7a7ce6ebc17bcb5b6add9122d12b0c2b" />
    <link rel="stylesheet" type="text/css" href="/styles/components.css?cb=7a7ce6ebc17bcb5b6add9122d12b0c2b" />
    <link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=7a7ce6ebc17bcb5b6add9122d12b0c2b" />
  

  <style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>

  
    <link rel="stylesheet" type="text/css" href="/foundation/grids/iapetus-10-zone.css" />
  

  <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
  <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
  <!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
  <!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->

  <link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />

  
  
    
    
      <link rel="alternate" type="application/rss+xml" title="Tucson Weekly RSS: Whole Site" href="https://www.tucsonweekly.com/tucson/Rss.xml" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Tucson Weekly RSS: News &amp; Opinion Section" href="https://www.tucsonweekly.com/tucson/Rss.xml?oid=1063709" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Tucson Weekly RSS: The Range: The Tucson Weekly&#39;s Daily Dispatch" href="https://www.tucsonweekly.com/tucson/Rss.xml?oid=1125619" />
      
        <link rel="alternate" type="application/rss+xml" title="Tucson Weekly RSS: The Range: The Tucson Weekly&#39;s Daily Dispatch: " href="https://www.tucsonweekly.com/tucson/Rss.xml?category=1125619&amp;topic=oid%3A1180193" />
      
    

    
    
      <link rel="alternate" type="application/rss+xml" title="Tucson Weekly RSS: Comments on XOXO: Where to Rock This Weekend, June 28 to 30" href="https://www.tucsonweekly.com/tucson/Rss.xml?id=comments&amp;oid=25346224" />
    
  

  
  
    <!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
      
      <script>
        if (!window.Promise) document.write('<scr'+'ipt src="https://cdnjs.cloudflare.com/ajax/libs/native-promise-only/0.8.1/npo.src.js"></scr'+'ipt>')
      </script>
    
    
    
    
    <script src="/foundation/scripts/common.js?cb=4a74b021a2a92586ddd056b2ccd26f21"></script>
  
    
    
    
    
    
    
    <script src="/foundation/scripts/desktop-bundle.js?cb=4a74b021a2a92586ddd056b2ccd26f21"></script>
  

  
  <link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
  <script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>

  
  
  

  
  <script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("https:\/\/www.tucsonweekly.com\/tucson\/Profile", "https:\/\/posting.tucsonweekly.com\/tucson\/MyProfile");
  </script>
  
  
  

  
  
    <meta name="google-signin-client_id" content="345770844416-lrktslqgimjsduaogv54o86orkjohqm1.apps.googleusercontent.com">
  

    
  

  
  
<meta name="viewport" content="width=1000" />
 
<!-- Google Fonts -->
<link href='https://fonts.googleapis.com/css?family=Anton|Open+Sans:300,400,700' rel='stylesheet' type='text/css'>
<link href='https://fonts.googleapis.com/css?family=Yanone+Kaffeesatz' rel='stylesheet' type='text/css'>
<!-- End Google Fonts -->





  
    <script type='text/javascript'>
            var googletag = googletag || {};
            googletag.cmd = googletag.cmd || [];
            (function() {
              var gads = document.createElement('script');
              gads.async = true;
              gads.type = 'text/javascript';
              var useSSL = 'https:' == document.location.protocol;
              gads.src = (useSSL ? 'https:' : 'http:') + '//securepubads.g.doubleclick.net/tag/js/gpt.js';
              var node = document.getElementsByTagName('script')[0];
              node.parentNode.insertBefore(gads, node);
            })();
          </script>
          <script type='text/javascript'>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</script>
  



   <meta name="google-site-verification" content="1shMVE6r6wpDwBgxHmNKSAVS9_A0RaoG53XlEOtHOJM" />





  



<!-- Global TNCMS Ad Manager javascript files -->

<script type='text/javascript' src='https://www.insidetucsonbusiness.com/shared-content/tncms-ad-manager/ads.js'></script>
<script type='text/javascript' src='https://www.insidetucsonbusiness.com/shared-content/flowplayer/flashembed.min.js'></script>
<script type='text/javascript' src='https://www.insidetucsonbusiness.com/shared-content/swfobject/swfobject.js'></script>
<script type='text/javascript' src='https://www.insidetucsonbusiness.com/content/tncms/ads/tncms-ad-limits.js'></script>






<script>

Foundation.documentReady.then(function(){ //initialize
jQuery(".pencil-content").hide(); 
  jQuery(".pencil-top").click(function(){
      jQuery(this).next(".pencil-content").slideToggle(500);
  });

   if (document.cookie.indexOf('visited=true') == -1) {
    			        var fifteenDays = 1000*60*10;
    			        var expires = new Date((new Date()).valueOf() + fifteenDays);
    			        document.cookie = "visited=true;expires=" + expires.toUTCString();

  jQuery(".pencil-content")
   .slideToggle( function() 
   {
      setTimeout( function()
      {
         jQuery(".pencil-content").slideToggle(500);
      }, 3000);
   });
}
 });


</script>
  
  
  
  
  


  
  
  


  
  <link rel="shortcut icon" href="/favicon.ico" />
  <meta name="title" content="XOXO: Where to Rock This Weekend, June 28 to 30 | The Range: The Tucson Weekly&#39;s Daily Dispatch" />
  <meta name="description" content="Friday, June 28 Like the nail-biting scene in Pulp Fiction when Vincent Vega revived an overdosing Mia Wallace, this Mexican singer-songwriter&#39;s career received an intracardiac..." />
  <meta name="keywords" content="music, live show, live shows, Tucson, weekend, live music, concerts, bands, performances, Music" />
  <title>XOXO: Where to Rock This Weekend, June 28 to 30 | The Range: The Tucson Weekly's Daily Dispatch</title>

  
  
    <meta name="date" content="2019-06-28 01:00:00" />
  

  
  
  
    <meta name="author" content="Ambur Wilkerson, Xavier Omar Otero">
  

  
  
  <meta name="news_keywords" content="music, live show, live shows, tucson, weekend, live music, concerts, bands, performances, music" />

  
  
    
  
  
    <link rel="image_src" href="https://media2.fdncms.com/tucsonweekly/imager/u/slideshow/25349856/christian_nodal.jpg" />
    <meta name="thumbnail" content="https://media2.fdncms.com/tucsonweekly/imager/u/slideshow/25349856/christian_nodal.jpg" />
  

  
    
      <link rel="canonical" href="https://www.tucsonweekly.com/TheRange/archives/2019/06/28/xoxo-where-to-rock-this-weekend-june-28-to-30" />
      <link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.tucsonweekly.com/TheRange/archives/2019/06/28/xoxo-where-to-rock-this-weekend-june-28-to-30" />
      
    

    
    
    
      
      
      <link rel="amphtml" href="https://www.tucsonweekly.com/TheRange/archives/2019/06/28/xoxo-where-to-rock-this-weekend-june-28-to-30?media=AMP+HTML" />
    
  

  
    
      <meta property="og:url" content="https://www.tucsonweekly.com/TheRange/archives/2019/06/28/xoxo-where-to-rock-this-weekend-june-28-to-30" />
    
  

  
    <meta property="fb:app_id" content="187122448009492" />
  

  
  <meta property="og:site_name" content="Tucson Weekly" />
  <meta property="og:title" content="XOXO: Where to Rock This Weekend, June 28 to 30" />
 
  
    

    
    

    
    

    <meta property="og:image" content="https://media2.fdncms.com/tucsonweekly/imager/u/slideshow/25349856/christian_nodal.jpg" />

    
      <meta property="og:image:width" content="625" />
      <meta property="og:image:height" content="351" />
    
  

  
  
    <meta property="og:description" content="Friday, June 28 : Like the nail-biting scene in Pulp Fiction when Vincent Vega revived an overdosing Mia Wallace, this Mexican singer-songwriter&#39;s career received an intracardiac injection of epinephrine with the release of Me D&eacute;je Llevar (Universal Latin, 2017), a major label debut that yielded four smash hits on both U.S. Latin and Mexican charts. As the title (translated to English) implies, &quot;I Got Carried Away&quot; is full of tales of drinking to excess, double-dealing and bearing the karmic weight of being the betrayer, as in &quot;Te Fall&eacute;.&quot; His vocal style has drawn comparisons to iconic Mexican crooner Luis Miguel and &quot;El Rey de la M&uacute;sica Ranchera&quot; Vicente Fern&aacute;ndez. At 20 years young, with guns ablaze, Christian Nodal ascends to the throne at Tucson Music Hall. : The New York Times raved that it&#39;s &quot;the gleeful profanities, righteous protest anthems and impeccable folk songwriting&quot; that have carried one of the finest folk duos of all time through a career spanning three decades. Two distinct voices and worldviews&mdash;that of Amy Ray and Emily Saliers&mdash;come together. Indigo Girls strive to create something transcendent at the Rialto Theatre. : Keep your antipsychotic meds close. Maximal insanity awaits. Hitman Entertainment celebrates 8 Years of Keeping It Heavy ALWAYS Anniversary Show with WitchAlley, 7eventh of Never, Psycho 78 and Legion. At House of Bards. : Transcending all musical barriers, Washington indie rockers Stereo Riots cause a ruckus. With Defeat the Band whose collective interests include &quot;weed, good times and nice people,&quot; and the mighty Sur Block. At Sky Bar. : This week&#39;s installment of Tucson Duels sees The Demons vs. The &Ouml;hmlauts in a samurai sword fight to win the honorary title of kensei (Japenese sword saint). At The Screening Room. : Marrying humor with infectious cumbia/salsa rhythms singer Stephani Candelaria delivers a powerful feminist message. La Mera Candelaria adds a piquant sabor caribe&ntilde;o to the recurrent dance party sin fronteras that is El Tamb&oacute;. With DJ Humblelianess. On the plaza at Hotel Congress. : Like the mythical and elusive Chupacabra, Bordertown Devils roam the desert wasteland by moonlight in search of prey. With The Endless Pursuit and PS9. At the Surly Wench Pub. : Texas death metalists Creeping Death caution against the &quot;Specter of War.&quot; With Fuming Mouth, Languish, AOM and Scowl. At Ward6. : Nitecall: Disco 2000 features performances by The H&auml;us of Polkadots. DJs Mijito and Plastic Disease preside over the nights events. At R Bar. : Darkly roasted strains of country noir will waft through the air when West Texas Intermediate play Exo Bar. Hans Hutchison performs an opening set. : Desert rockers The Craig Green Band celebrates the release of Flyboy Serenade. At Monterey Court. Big Grin and Mike Sadler lend a hand. : Doom and sludge your thing? Wallow in the mire. Sixes, Atala and Dayak get filthy dirty at House of Bards. : After a rollover bus accident, in 1999, that claimed the lives of two band members and their road manager, these Tejano/norte&ntilde;o stars have lived up to their name. Intocable are at AVA Amphitheater. With Banda Machos. : Exuberant. Raw. Innovative. Former Funky Techno Tribe, DJ/remixer Donald Glaude spins house at Zen Rock. It&#39;s going to be &quot;Off the Hook...&quot; The Jack and Public Enemy #1 pay homage to AC-DC and M&ouml;tley Cr&uuml;e. At The Rock. : Singer-songwriter Leila Lopez, accompanied by bassist Brian Green, perform at Sand-Reckoner. : The sons of U.S. Air Force personnel stationed in London, this trio formed in the 1970s. Shortly after graduating high school, their tight vocal harmonies propelled major transatlantic hits: &quot;A Horse with No Name,&quot; &quot;Sister Golden Hair&quot; and &quot;Ventura Highway.&quot; America, The Band are the Desert Diamond Casino - Sahuarita. : Saturday, June 29 : Rolling Stone Brazil named them &quot;one of the most interesting retro acts of the last decade.&quot; Riding in on a heat wave of &#39;70s roots rock revival from S&atilde;o Paulo, Ted Marengos&#39; Timeless Beat USA Summer Tour descends upon the Sky Bar. They share the bill with epically spaced-out rockers Silver Cloud Express and psychedelic/synth-poppers Tropical Beach. : What you got in your pocket? Cruize: A Queer AF Hanky Code Party. Unfamiliar with the code? Google it and educate yourself. An evening free of hate and shaming, for queers by queers. DJs Atlantis Moreupset, Papita, Robertitx, DADDY SLMBR PRTY and Sissy Peniston spin the jams into the dawn. : A major star in regional Mexican music, &quot;El Rey de Mil Coronas&quot; (The King of a Thousand Crowns), Lalo Mora brings his accordion-powered norte&ntilde;o to Club 4th Avenue. : A bare-knuckle brawl ensues at Che&#39;s Lounge when Dirt Friends and Asian Fred face off. : Somewhat cryptically, Hank Topless asserts, &quot;Come hear why hippie music is so much better than all that countryfied corn that went before.&quot; At The Dusty Monk Pub. : Shitkickin&#39; since 2003, Phoenix cowpunks The Earps share the stage with local punks The &Ouml;hmlauts and rock quartet Escape Goat. At Irene&#39;s Holy Donuts. : An evening of clever songwriting awaits. Lana Rebel &amp;amp; Kevin Mayfield&#39;s songs provide the perfect soundtrack for a late-night porch gathering in the still of a summer night. Can you hear the crickets chirping? John Mount is known for crooning next to kegs at backyard parties. And Grip Jensen writes tender country songs for adults. At Exo Bar. : Prepare to be &quot;Thunderstruck.&quot; The ultimate all-girl tribute to AC-DC will shake you all night long. Sugar Stains and Mean Streets add to the sheer chaos. At Encore (formerly Club XS). : The horn, percussion and electric guitar propelled Latino sound of Santa Pachita manifests at Monterey Court. : Here Comes the Music. Songstress Adara Rae performs blues/pop/rock in the tasting room at Sand-Reckoner. : Queer Bazaar is an evening of revelry, outreach, engagement and pride to benefit the Reveille Men&#39;s Chorus and THEM Youth Ensemble Choir. DJ Mijito spins. : Featuring two-time Grammy nominee pianist/composer Enrique &quot;Hank&quot; Feldman, Acerek&oacute; performs Afro-Cuban/jazz at Crooked Tooth Brewing Co. : Tap + Bottle - Downtown celebrate 6 years on 6th with food trucks, libation and the music of Mariachi Tesoro, Hey, Bucko and Tongs. : &quot;We&#39;ll leave the light on for you.&quot; Nite Lite: DJs Dominator, Terry Jasinto and Cactus spin EDM from late at night until early in the morning. At Solar Culture. : Sunday, June 30 : St. Andrew&#39;s Bach Society presents Bach Without Borders. Classical guitarist Bin Hu and guzhengist (Chinese zither) Jing Xia perform a diverse program of traditional Chinese and classical compositions. At Grace St. Paul&#39;s Episcopal Church. : Be tragic. Tunes From The Crypt finds DJs Nullus and SET spinning goth and industrial from the &#39;80s and &#39;90s to darkwave and witch house from today. Darkness knows no bounds. At the Surly Wench Pub. : Infusing samba rhythms with jazz and blues, The Eugene Boronow Trio spreads bossa nova&#39;s heart-warming sound. At Public Brewhouse. : Like your toast with jam? Mik &amp;amp; The Funky Brunch provide family-friendly funk. At La Cocina." />
  

  
  

  
  
    <meta property="og:type" content="article" />
  

  
  

    
    

    
    

    
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:image" content="https://media2.fdncms.com/tucsonweekly/imager/u/slideshow/25349856/christian_nodal.jpg">

    
    

    

    <meta name="twitter:site" content="@tucsonweekly">
    <meta name="twitter:title" content="XOXO: Where to Rock This Weekend, June 28 to 30">
    <meta name="twitter:description" content="Friday, June 28 Like the nail-biting scene in Pulp Fiction when Vincent Vega revived an overdosing Mia Wallace, this Mexican singer-songwriter&#39;s career received an intracardiac...">
  

  
  
  <!--
    <PageMap>
      <DataObject type="foundation">
        <Attribute name="oid">25346224</Attribute>
        <Attribute name="class">Content</Attribute>
        <Attribute name="lastmodified">20190628010034</Attribute>
        <Attribute name="creationdate">20190627144052</Attribute>
      </DataObject>

      
        
          <DataObject type="document">
            <Attribute name="releasedatetime">20190628010000</Attribute>
            <Attribute name="releasedate">20190628</Attribute>
            <Attribute name="releaseepoch">1561708800</Attribute>
            <Attribute name="title">XOXO: Where to Rock This Weekend, June 28 to 30</Attribute>
            <Attribute name="author">25080121</Attribute>
            <Attribute name="authorname">Ambur Wilkerson</Attribute>
            <Attribute name="authorsortname">Wilkerson, Ambur</Attribute>
          </DataObject>
        

        
      
    </PageMap>
  -->


  
  
  
  
    
    <script type="application/ld+json">
        {
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id":"https:\/\/www.tucsonweekly.com\/TheRange\/archives\/2019\/06\/28\/xoxo-where-to-rock-this-weekend-june-28-to-30"
          },
          "headline": "XOXO: Where to Rock This Weekend, June 28 to 30",
          
            "description": "Friday, June 28",
          
          
            "image": {
              "url": "https:\/\/media2.fdncms.com\/tucsonweekly\/imager\/u\/original\/25349856\/christian_nodal.jpg",
              "width": 205,
              "height": 115,
              "@type": "ImageObject"
            },
          
          "datePublished": "2019-06-28T01:00:00",
          "dateModified": "2019-06-28T01:00:34",
          
            "author": [
              
                {
                  "name": "Ambur Wilkerson",
                  "@type": "Person"
                },
              
                {
                  "name": "Xavier Omar Otero",
                  "@type": "Person"
                }
              
            ],
          
          "publisher": {
            "name": "Tucson Weekly",
            
              
              
              
              "logo": {
                "url": "https:\/\/www.tucsonweekly.com\/imager\/b\/google-amp-logo\/808579\/93e9\/adminIcon_tw.jpg",
                "width": 60,
                "height": 60,
                "@type": "ImageObject"
              },
            
            "@type": "Organization"
          },
          "@context": "https://schema.org",
          "@type": "NewsArticle"
        }
      </script>
  


</head>





  <body id="Post" class="BlogPost Iapetus10Zone newsopinion TheRange">



<div id="fb-root"></div>


  <script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>




  <script>
    (function () {
      var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
        //if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
      }.bind(this), function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
      })
    })()
  </script>
    

<!-- Leader -->
<div id="gridLeader">
  
</div><!-- end gridLeader -->

<div id="gridClamp">
  <!-- Header -->
  <div id="gridHeader">
    




  
  

  
  
  

  

    
      <div id="MobileDetect" class="GlobalHeader TheRangeBlogPost " style="display:none">
        
        
          Switch to the <a href="https://m.tucsonweekly.com/TheRange/archives/2019/06/28/xoxo-where-to-rock-this-weekend-june-28-to-30" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      
      function setRedirectHash() {
        if (location.hash) {
          jQuery("#MobileDetect a[media='handheld']").each(function() {
            var link = jQuery(this);
            link.attr('href', link.attr('href').split('#')[0] + location.hash);
          });
        }
      }
      setRedirectHash();

      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  

<div id="Leaderboard" class="GlobalHeader TheRangeBlogPost Leaderboard Ad">
  
    <!-- /4961490/TW_ROS_Top_728x90 -->
          <div id="div-gpt-ad-tw_ros_top_728x90" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_Top_728x90" data-output="asynchronous" data-width="728" data-height="90">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_top_728x90');
                });
              </script>
          </div>
  
</div>

  <div id="Logo" class="GlobalHeader TheRangeBlogPost Leaderboard">
      
      <div id="header-contain">

        <div id="headerLeft">
         <div class="earAdLeft" style="width:250px;height:60px;">
               <!-- potential ad here -->
          </div>          

           <div class="headerLogin">     

            
  
            
            
              
              <ul data-view="loggedin" style="display:none">
                <li><strong data-label="username">Username</strong> / </li>
                
                <li><a href="https://posting.tucsonweekly.com/tucson/Profile/MySettings">Edit Settings</a> / </li>
                <li><a href="https://www.tucsonweekly.com/tucson/Logout">Log Out</a></li>
              </ul>

              <ul data-view="loggedout" style="display:none">
                <li><a href="#LogIn">Log in</a> / </li>
                <li><a href="#CreateAccount">Create Account</a></li>
              </ul>
            

            
            
              <script>
                new Foundation.LoginRequiredComponent("Logo");
              </script>
            
          </div> <!-- end login --> 
        </div> <!-- end headerLeft -->

         
           <div id="header-logo"><a href="https://www.tucsonweekly.com/">Tucson Weekly</a></div>    
         

         <div id="headerRight">        
          <div class="earAdRight" style="width:250px;height:60px;">
               <!-- potential ad here -->
          </div>          

         <div class="search"> 
           

            

              
              
              <form class="prepTextForm" id="searchbox_017793458706336421686:xynrvxedw04" action="https://www.tucsonweekly.com/tucson/Search">
                  <input type="hidden" name="cx" value="017793458706336421686:xynrvxedw04" />
                  <input type="hidden" name="cof" value="FORID:9" />
                  <input type="text" name="q" size="25" />
                  <input type="submit" name="sa" value="Search" />
              </form>
            
            <ul class="socialIcons">
               <li><a title="Tucson Weekly on Facebook" href="https://www.facebook.com/tucsonweekly" class="socialFBIcon" target="_blank" rel="nofollow">Facebook</a></li>    
               <li><a title="Tucson Weekly on Twitter" href="https://twitter.com/tucsonweekly" class="socialTweetIcon" target="_blank" rel="nofollow">Twitter</a></li>
               <li><a title="Tucson Weekly on Instagram" href="https://www.instagram.com/tucsonweekly/" class="socialInstagramIcon" target="_blank" rel="nofollow">Instagram</a></li>        
             </ul>
          </div>   <!-- end search -->

         </div> <!-- end headerRight -->
 
     </div> <!-- end headerContain -->
    </div>  <!-- end header Component --> 

















  <div id="NavigationHorizontal" class="GlobalHeader TheRangeBlogPost  ">
    
      
      
          <ul id="mainNav">
        
        

        

        

        

        <li class="first" id="NavItem_home">
          <a href="https://www.tucsonweekly.com/"  >Home</a>
        </li>
        
      
        

        

        

        

        <li class="navCurrent" id="NavItem_newsopinion">
          <a href="https://www.tucsonweekly.com/tucson/news-and-opinion/Section?oid=1063709"  class="subnav_link" id="SNAVL_newsopinion">News &amp; Opinion</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_chow">
          <a href="https://www.tucsonweekly.com/tucson/chow/Section?oid=1063714"  class="subnav_link" id="SNAVL_chow">Chow</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Events10days">
          <a href="https://www.tucsonweekly.com/tucson/city-week/Content?category=1063735"  class="subnav_link" id="SNAVL_Events10days">Events</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_cinema">
          <a href="https://www.tucsonweekly.com/tucson/cinema/Section?oid=1063716"  class="subnav_link" id="SNAVL_cinema">Cinema</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_music">
          <a href="https://www.tucsonweekly.com/tucson/music/Section?oid=1063712"  class="subnav_link" id="SNAVL_music">Music</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_artsculture">
          <a href="https://www.tucsonweekly.com/tucson/arts-and-culture/Section?oid=1063713"  class="subnav_link" id="SNAVL_artsculture">Arts &amp; Culture</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Jobs">
          <a href="https://www.tucsonweekly.com/tucson/Jobs/Page"  >Jobs</a>
        </li>
        
      
        

        

        

        

        <li class="last" id="NavItem_bestoftucson">
          <a href="https://www.tucsonweekly.com/tucson/Survey?oid=25310693"  class="subnav_link" id="SNAVL_bestoftucson">Best of Tucson&reg;</a>
        </li>
        
      
          </ul>
        

      
        
        
          
            <h3 class="hidden">Browse </h3>
            <ul class="subnav_content" id="SNAV_" style="display:none;">
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/books/Section?oid=1063715"  title="">Books Main Page</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063715"  title="">Books Archives</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse News &amp; Opinion</h3>
            <ul class="subnav_content" id="SNAV_newsopinion" style="display:none;">
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/currents/Section?oid=1063709"  title="">News &amp; Opinion Main Page</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/cover-story/Content?special=1125844"  title="">Cover Story</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Category?oid=1063734"  title="">Currents Features</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/editors-note/Content?category=1063766"  title="">Editor&#39;s Note</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Category?oid=1063741"  title="">Danehy</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Category?oid=3147720"  title="The Tucson Weekly's column on the local world of medical marijuana.">Medical MJ</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/police-dispatch/Category?oid=1063770"  title="">Police Dispatch</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/the-skinny/Content?category=1063733"  title="">The Skinny</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/guest-commentary/Category?oid=1063786"  title="">Guest Commentary</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?category=5928956"  title="">Tucson Salvage</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/blogs/TheRange/"  title="">The Range</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Events</h3>
            <ul class="subnav_content" id="SNAV_Events10days" style="display:none;">
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=Today"  title="">Events Today</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?feature=Staff%20Pick&sortType=Date"  title="">Staff Pick Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107349"  title="">Bulletin Board</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch"  title="">Location Guide</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Events/AddEvent"  title="">Submit an Event Listing</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Cinema</h3>
            <ul class="subnav_content" id="SNAV_cinema" style="display:none;">
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/cinema/Section?oid=1063716"  title="">Cinema Main Page</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/now-showing-at-home/Category?oid=1063785"  title="">Now Showing at Home</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063716"  title="">Cinema Archives</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Music</h3>
            <ul class="subnav_content" id="SNAV_music" style="display:none;">
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/music/Section?oid=1063712"  title="">Music Main Page</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Category?oid=1063737"  title="">Music Features</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/soundbites/Content?category=1063738"  title="">Soundbites</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/live/Content?category=1063790"  title="">Live</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107701&sortType=Date"  title="">Live Music Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?oid=1113914&amp;locationCategory=1113914"  title="">Bars</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113974&sortType=name"  title="">Music Venues</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063712"  title="">Music Archives</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Events/AddEvent"  title="">Submit Club Listings</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Arts &amp; Culture</h3>
            <ul class="subnav_content" id="SNAV_artsculture" style="display:none;">
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/arts/Section?oid=1063713"  title="">Arts Main Page</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/category?oid=1063742"  title="">Book Features</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107327&sortType=Date"  title="">Art Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113916"  title="">Galleries</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107325&sortType=Date"  title="">Museum Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113923"  title="">Museums</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107320&sortType=Date"  title="">Theater Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113917"  title="">Theaters</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107323&sortType=Date"  title="">Dance Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113925"  title="">Bookstores</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113933"  title="">Coffee Houses</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113924"  title="">Libraries</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107335&sortType=Date"  title="">Literature Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063713"  title="">Arts Archives</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Events/AddEvent"  title="">Submit an Event Listing</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Chow</h3>
            <ul class="subnav_content" id="SNAV_chow" style="display:none;">
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/chow/Section?oid=1063714"  title="">Chow Main Page</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Category?oid=1063740"  title="">Chow Features</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationSection=1113936"  title="">Restaurants</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationSection=1113936&feature=Menu"  title="">Restaurant Menus</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/CommentArchives?feature=Locations&locationSection=1113936"  title="">Reader Reviews</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063714"  title="">Chow Archives</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?category=1063794"  title="">Yum! Archives</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Best of Tucson&reg;</h3>
            <ul class="subnav_content" id="SNAV_bestoftucson" style="display:none;">
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Survey?oid=25310693"  title="">Best of Tucson 2019 Ballot</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/BestOf"  title="">Best of Tucson&reg; Main Page</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/arts-and-culture/BestOf?category=1063746"  title="">Best of Tucson&reg;: Arts &amp; Culture</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/city-life/BestOf?category=1063748"  title="">Best of Tucson&reg;: City Life</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/casual-dining/BestOf?category=3154064&year=2017"  title="">Best of Tucson&reg;: Casual Dining</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/BestOf?category=3153201"  title="">Best of Tucson&reg;: &iexcl;Cultura!</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/BestOf?category=3153674&year=2011"  title="">Best of Tucson&reg;: Fashion + Style</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/BestOf?category=1063749"  title="">Best of Tucson&reg;: Kids&#39; Stuff</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/BestOf?category=1063781"  title="">Best of Tucson&reg;: Media Mix</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/outdoors/BestOf?category=1063750"  title="">Best of Tucson&reg;: Outdoors</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/kids-stuff/BestOf?category=1063782"  title="">Best of Tucson&reg;: Restaurants</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/spirits/BestOf?category=1063752"  title="">Best of Tucson&reg;: Spirits &amp; Nightlife</a>
          </li>
          
            </ul>
          
        

        

        
        
        
      
    
  </div>


  

  
  
  
    
    

      

      <script>
      "use strict";
      (function(){
        //
        if(navigator.userAgent.match(/\b(iPad|iPhone|iPod|Android|Pre|BlackBerry|Windows Phone)\b/i)){
          //
          //
            jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
          //
          //

        //
        }else{
          jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
        }
      })();
      </script>
    
  
  <!-- true == "true"
         && true == "devel" -->


<!-- End #NavigationHorizontal -->


    <div id="NavigationSubLinks" class="GlobalHeader TheRangeBlogPost ">
      <ul class="subnavlinks">
  
  
  
  

  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/IssueArchives" target="_self">Issues</a>
  </li>

  

  
  
  

  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/Newsletter" target="_self">Newsletter Signup</a>
  </li>

  

  
  
  

  <li class="">
    <a href="http://issuu.com/tucsonweekly/docs" target="_blank">Online Edition</a>
  </li>

  

  
  
  

  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/Events/AddEvent" target="_self">Submit A Listing</a>
  </li>

  

  
  
  

  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/ArticleArchives" target="_self">archives</a>
  </li>

  

  
  
  

  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/WhereCanIGetaTucsonWeekly/Page" target="_self">Find a Weekly</a>
  </li>

  

      </ul>
    </div>
  




  </div><!-- end gridHeader -->

  <div id="gridMain">

    <div id="gridFrame">

      <div id="gridSpanningFeature">
        



  <!-- UIkit CSS -->
  <link rel="stylesheet" type="text/css" href="/fdn-system/assets/pub/styles/desktop.css?cb=d81249f9be46914a60a277073221c47e" />

  <!-- UIkit JS -->
  <script src="/fdn-system/assets/pub/scripts/uikit.min.js?cb=d81249f9be46914a60a277073221c47e"></script>
  <script src="/fdn-system/assets/pub/scripts/uikit-icons-fdn.min.js?cb=d81249f9be46914a60a277073221c47e"></script>

  <style>
    #gridMainColumn .uk-width-1-2\@es {
      width: 50%;
    }

    #gridMainColumn .uk-child-width-auto\@exs > * {
      width: auto;
    }
    
    .uk-root, .uk-root * {
      font-family: "PT Sans", sans-serif;
      font-size: 14px;
    }
  </style>









      

  <div id="BlogHeaderCategoryList" class="SpanningFeature TheRangeBlogPost  topic_music">
    <h1 class="TheRange">
      
        <a href="https://www.tucsonweekly.com/blogs/TheRange/">The Range: The Tucson Weekly's Daily Dispatch</a>
      
    </h1>

    <p style="float:left;">
      <a href="https://www.tucsonweekly.com/tucson/TheRange/blogs/Archives">Archives</a> | 
      <a href="/tucson/Rss.xml?category=1125619">RSS</a>
    </p>

    <p style="padding-left:150px;text-align:right;">
      <strong>Blog Categories:</strong>
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/politics/">Politics</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/news/">News</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/do-this/">Do This!</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/music/">Music</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/chow/">Chow</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/media/">Media</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/fun-in-general/">Fun in General</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/education/">Education</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/cinema/">Cinema</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/arts-and-culture/">Arts and Culture</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/sports/">Sports</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/pets-and-beasts/">Pets and Beasts</a> |  
      
      <a href="https://www.tucsonweekly.com/tucson/TheRange/blogs/Archives">more&nbsp;categories&raquo;</a>
    </p>

  </div>





  
  

  <div id="BlogsPreviousNext" class="SpanningFeature TheRangeBlogPost ">
    <div class="prevNext">
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/2019/06/27/laughing-stock-take-the-kids-to-the-laughing-pool" class="prev" rel="prev">&laquo;&nbsp;Laughing Stock: Take the kids to th&hellip;</a>
        
    </div>
  </div>








  
  <link type="text/css" href="/foundation/scripts/jplayer/skin/jplayer.blue.monday.css" rel="stylesheet" />
  <script type="text/javascript" src="/foundation/scripts/jplayer/jquery.jplayer.min.js"></script>               
  
    <style>
    div.jp-audio,
    div.jp-video {
      /* Edit the font-size to counteract inherited font sizing.
       * Eg. 1.25em = 1 / 0.8em
       */
      font-size:1.25em;
    }      
    div.postBody div.inlineAudio,
    div#AudioPlayer div.inlineAudio {
      width: 400px;
      margin: auto;
      clear:both;
      }      
    </style>
  


  <div id="BlogsBlogPost" class="SpanningFeature TheRangeBlogPost  topicView topic_music">

    

    
































    

    
    

    
      
      
        <h2 class="blogDate">Friday, June 28, 2019</h2>
      

      
      <div class="blogPost therange topic-music">
    
    
      <div class="postCategories">
                
        <span class="postCategory CategoryTheRange">
          <a href="https://www.tucsonweekly.com/TheRange/archives/music/" class="topic-music">Music</a>
        </span>
      </div>
    
    <h3 class="postTitle" id="a25346224">
      
      
      
      
      
      
        XOXO: Where to Rock This Weekend, June 28 to 30
      

      
    </h3>

    

    
      <h4 class="postedBy">
        
        <span class="byAttribute">Posted</span>
        
          
          <span class="byAttribute">By</span> <a href="https://www.tucsonweekly.com/author/ambur-wilkerson" rel="author">Ambur Wilkerson</a> and <a href="https://www.tucsonweekly.com/author/xavier-omar-otero" rel="author">Xavier Omar Otero</a>
        
        
          
            on <span class="postTime">Fri, Jun 28, 2019</span> at <span class="postTime"> 1:00 AM</span>
          
        
           
      </h4>
    

   
    
    

    

    
    

    
    

    <div class="postBody">
      
          
      


      
     
       
      
      
      
      
       
      
      

      
      

      
      
        
        <span style="" id="docs-internal-guid-32ccf6be-7fff-8048-d9af-fbdec2f205f8"><p dir="ltr" style="font-weight: bold; text-align: center; line-height: 1.38; margin-top: 0pt; margin-bottom: 0pt;">
        Friday, June 28<br>
        <br>
          
</p>
   <div class="contentImageRight" style="overflow:hidden;">                                        <img src="https://media2.fdncms.com/tucsonweekly/imager/u/blog/25349856/christian_nodal.jpg?cb=1561674489" width="244" height="137" alt="christian_nodal.jpg" srcset="" />                                                                                                           <ul style="width:244px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>    
<p dir="ltr" style="font-weight: bold; line-height: 1.38; margin-top: 0pt; margin-bottom: 0pt;">
        <span style="font-weight: normal;">Like the nail-biting scene in <i>Pulp Fiction</i> when Vincent Vega revived an overdosing Mia Wallace, this Mexican singer-songwriter's career received an intracardiac injection of epinephrine with the release of <i>Me Déje Llevar </i>(Universal Latin, 2017), a major label debut that yielded four smash hits on both U.S. Latin and Mexican charts. As the title (translated to English) implies, "I Got Carried Away" is full of tales of drinking to excess, double-dealing and bearing the karmic weight of being the betrayer, as in "Te Fallé." His vocal style has drawn comparisons to iconic Mexican crooner Luis Miguel and "El Rey de la Música Ranchera" Vicente Fernández. At 20 years young, with guns ablaze, </span>Christian Nodal<span style="font-weight: normal;"> ascends to the throne at Tucson Music Hall.</span><br>
        <br>
        <span style="font-weight: normal;"> The <i>New York Times</i> raved that it's "the gleeful profanities, righteous protest anthems and impeccable folk songwriting" that have carried one of the finest folk duos of all time through a career spanning three decades. Two distinct voices and worldviews—that of Amy Ray and Emily Saliers—come together. </span>Indigo Girls <span style="font-weight: normal;">strive to create something transcendent at the Rialto Theatre.</span><br>
        <br>
        <span style="font-weight: normal;"> Keep your antipsychotic meds close. Maximal insanity awaits. Hitman Entertainment celebrates 8</span> Years of Keeping It Heavy ALWAYS Anniversary Show<span style="font-weight: normal;"> with </span>WitchAlley<span style="font-weight: normal;">, </span>7eventh of Never<span style="font-weight: normal;">,</span> Psycho 78<span style="font-weight: normal;"> and </span>Legion<span style="font-weight: normal;">. At House of Bards.</span><br>
        <br>
        <span style="font-weight: normal;"> Transcending all musical barriers, Washington indie rockers </span>Stereo Riots<span style="font-weight: normal;"> cause a ruckus. With </span>Defeat the Band <span style="font-weight: normal;">whose collective interests include "weed, good times and nice people," and the mighty </span>Sur Block<span style="font-weight: normal;">. At Sky Bar.</span><br>
        <br>
        <span style="font-weight: normal;"> This week's installment of</span> Tucson Duels<span style="font-weight: normal;"> sees </span>The Demons vs. The Öhmlauts<span style="font-weight: normal;"> in a samurai sword fight to win the honorary title of <i>kensei</i> (Japenese sword saint). At The Screening Room.</span><br>
        <br>
        <span style="font-weight: normal;"> Marrying humor with infectious cumbia/salsa rhythms singer Stephani Candelaria delivers a powerful feminist message. </span>La Mera Candelaria<span style="font-weight: normal;"> adds a piquant <i>sabor caribeño</i> to the recurrent dance party <i>sin fronteras</i> that is </span>El Tambó<span style="font-weight: normal;">. With DJ </span>Humblelianess<span style="font-weight: normal;">. On the plaza at Hotel Congress.</span><br>
        <br>
        <span style="font-weight: normal;"> Like the mythical and elusive Chupacabra, </span>Bordertown Devils<span style="font-weight: normal;"> roam the desert wasteland by moonlight in search of prey. With</span> The Endless Pursuit<span style="font-weight: normal;"> and </span>PS9<span style="font-weight: normal;">. At the Surly Wench Pub.</span><br>
        <br>
        <span style="font-weight: normal;"> Texas death metalists </span>Creeping Death<span style="font-weight: normal;"> caution against the "Specter of War." With </span>Fuming Mouth<span style="font-weight: normal;">, </span>Languish<span style="font-weight: normal;">, </span>AOM <span style="font-weight: normal;">and </span>Scowl<span style="font-weight: normal;">. At Ward6.</span><br>
        <br>
         Nitecall: Disco 2000<span style="font-weight: normal;"> features performances by The Häus of Polkadots. DJs </span>Mijito<span style="font-weight: normal;"> and </span>Plastic Disease<span style="font-weight: normal;"> preside over the nights events. At R Bar.</span><br>
        <br>
        <span style="font-weight: normal;"> Darkly roasted strains of country noir will waft through the air when </span>West Texas Intermediate<span style="font-weight: normal;"> play Exo Bar. </span>Hans Hutchison<span style="font-weight: normal;"> performs an opening set.</span><br>
        <br>
        <span style="font-weight: normal;"> Desert rockers </span>The Craig Green Band<span style="font-weight: normal;"> celebrates the release of <i>Flyboy Serenade</i>. At Monterey Court. </span>Big Grin<span style="font-weight: normal;"> and </span>Mike Sadler <span style="font-weight: normal;">lend a hand.</span><br>
        <br>
        <span style="font-weight: normal;"> Doom and sludge your thing? Wallow in the mire. </span>Sixes<span style="font-weight: normal;">, </span>Atala<span style="font-weight: normal;"> and </span>Dayak<span style="font-weight: normal;"> get filthy dirty at House of Bards.</span><br>
        <br>
        <span style="font-weight: normal;"> After a rollover bus accident, in 1999, that claimed the lives of two band members and their road manager, these Tejano/norteño stars have lived up to their name. </span>Intocable<span style="font-weight: normal;"> are at AVA Amphitheater. With </span>Banda Machos<span style="font-weight: normal;">.</span><br>
        <br>
        <span style="font-weight: normal;"> Exuberant. Raw. Innovative. Former Funky Techno Tribe, DJ/remixer </span>Donald Glaude<span style="font-weight: normal;"> spins house at Zen Rock. It's going to be "Off the Hook..." </span>The Jack<span style="font-weight: normal;"> an</span>d Public Enemy #1<span style="font-weight: normal;"> pay homage to AC-DC and Mötley Crüe. At The Rock.</span><br>
        <br>
        <span style="font-weight: normal;">Singer-songwriter</span> Leila Lopez<span style="font-weight: normal;">, accompanied by bassist </span>Brian Green<span style="font-weight: normal;">, perform at Sand-Reckoner.</span><br>
        <br>
        <span style="font-weight: normal;"> The sons of U.S. Air Force personnel stationed in London, this trio formed in the 1970s. Shortly after graduating high school, their tight vocal harmonies propelled major transatlantic hits: "A Horse with No Name," "Sister Golden Hair" and "Ventura Highway." </span>America, The Band<span style="font-weight: normal;"> are the Desert Diamond Casino - Sahuarita.</span>  
</p>
  <br>
    
<p dir="ltr" style="font-weight: bold; text-align: center; line-height: 1.38; margin-top: 0pt; margin-bottom: 0pt;">
        Saturday, June 29<br>
        <br>
          
</p>
   <div class="contentImageLeft" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/tucsonweekly/imager/u/original/25350170/sky_bar.jpg" class="zoomable" rel="contentImg_gal-25346224" title="">                  <img src="https://media1.fdncms.com/tucsonweekly/imager/u/blog/25350170/sky_bar.jpg?cb=1561708833" width="250" height="141" alt="sky_bar.jpg" srcset="" />                </a>                                                                                                           <ul style="width:250px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div><br>
      
<p dir="ltr" style="line-height: 1.38; margin-top: 0pt; margin-bottom: 0pt;">
        <span style="font-weight: normal;"><i>Rolling Stone Brazil</i> named them "one of the most interesting retro acts of the last decade." Riding in on a heat wave of '70s roots rock revival from São Paulo, </span><b>Ted Marengos'</b><span style="font-weight: normal;"> <i>Timeless Beat USA Summer Tour</i> descends upon the Sky Bar. They share the bill with epically spaced-out rockers </span><b>Silver Cloud Express</b><span style="font-weight: normal;"> and psychedelic/synth-poppers </span><b>Tropical Beach</b><span style="font-weight: normal;">.</span><br>
        <br>
        <span style="font-weight: normal;">What you got in your pocket? </span><b>Cruize: A Queer AF Hanky Code Party</b><span style="font-weight: normal;">. Unfamiliar with the code? Google it and educate yourself. An evening free of hate and shaming, for queers by queers. DJs </span><b>Atlantis Moreupset</b><span style="font-weight: normal;">, </span><b>Papita</b><span style="font-weight: normal;">, </span><b>Robertitx</b><span style="font-weight: normal;">, </span><b>DADDY SLMBR PRTY</b><span style="font-weight: normal;"> and </span><b>Sissy Peniston</b><span style="font-weight: normal;"> spin the jams into the dawn.</span><br>
        <br>
        <span style="font-weight: normal;"> A major star in regional Mexican music, "El Rey de Mil Coronas" (The King of a Thousand Crowns), </span><b>Lalo Mora</b><span style="font-weight: normal;"> brings his accordion-powered norteño to Club 4th Avenue.</span><br>
        <br>
        <span style="font-weight: normal;"> A bare-knuckle brawl ensues at Che's Lounge when </span><b>Dirt Friends</b><span style="font-weight: normal;"> and </span><b>Asian Fred</b><span style="font-weight: normal;"> face off.</span><br>
        <br>
        <span style="font-weight: normal;">Somewhat cryptically, </span><b>Hank Topless</b><span style="font-weight: normal;"> asserts, "Come hear why hippie music is so much better than all that countryfied corn that went before." At The Dusty Monk Pub.</span><br>
        <br>
        <span style="font-weight: normal;"> Shitkickin' since 2003, Phoenix cowpunks </span><b>The Earps</b><span style="font-weight: normal;"> share the stage with local punks </span><b>The Öhmlauts</b><span style="font-weight: normal;"> and rock quartet </span><b>Escape Goat</b><span style="font-weight: normal;">. At Irene's Holy Donuts.</span><br>
        <br>
        <span style="font-weight: normal;"> An evening of clever songwriting awaits. </span><b>Lana Rebel &amp; Kevin Mayfield's </b><span style="font-weight: normal;">songs provide the perfect soundtrack for a late-night porch gathering in the still of a summer night. Can you hear the crickets chirping? </span><b>John Mount</b><span style="font-weight: normal;"> is known for crooning next to kegs at backyard parties. And </span><b>Grip Jensen</b><span style="font-weight: normal;"> writes tender country songs for adults. At Exo Bar.</span><br>
        <br>
        <span style="font-weight: normal;"> Prepare to be "Thunderstruck." The ultimate all-girl tribute to </span><b>AC-DC</b><span style="font-weight: normal;"> will shake you all night long. </span><b>Sugar Stains</b><span style="font-weight: normal;"> and </span><b>Mean Streets</b><span style="font-weight: normal;"> add to the sheer chaos. At Encore (formerly Club XS).</span><br>
        <br>
        <span style="font-weight: normal;"> The horn, percussion and electric guitar propelled<i> Latino</i> sound of </span><b>Santa Pachita</b><span style="font-weight: normal;"> manifests at Monterey Court.</span><br>
        <br>
        <span style="font-weight: normal;"> Here Comes the Music. Songstress </span><b>Adara Rae</b><span style="font-weight: normal;"> performs blues/pop/rock in the tasting room at Sand-Reckoner.</span><br>
        <br>
        <b> Queer Bazaar</b><span style="font-weight: normal;"> is an evening of revelry, outreach, engagement and pride to benefit the </span><b>Reveille Men's Chorus</b><span style="font-weight: normal;"> and </span><b>THEM Youth Ensemble Choir</b><span style="font-weight: normal;">. </span><b>DJ Mijito</b><span style="font-weight: normal;"> spins.</span><br>
        <br>
        <span style="font-weight: normal;">Featuring two-time Grammy nominee pianist/composer Enrique "Hank" Feldman, </span><b>Acerekó </b><span style="font-weight: normal;">performs Afro-Cuban/jazz at Crooked Tooth Brewing Co.</span><br>
        <br>
        <span style="font-weight: normal;"> Tap + Bottle - Downtown celebrate </span><b>6 years on 6th</b><span style="font-weight: normal;"> with food trucks, libation and the music of </span><b>Mariachi Tesoro</b><span style="font-weight: normal;">, </span><b>Hey</b><span style="font-weight: normal;">, </span><b>Bucko</b><span style="font-weight: normal;"> and </span><b>Tongs</b><span style="font-weight: normal;">.</span><br>
        <br>
        <span style="font-weight: normal;"> "We'll leave the light on for you." </span><b>Nite Lite: </b>DJs<b> Dominator</b><span style="font-weight: normal;">, </span><b>Terry Jasinto</b><span style="font-weight: normal;"> and </span><b>Cactus</b><span style="font-weight: normal;"> spin EDM from late at night until early in the morning. At Solar Culture.</span>  
</p>
  <br>
    
<p dir="ltr" style="font-weight: bold; text-align: center; line-height: 1.38; margin-top: 0pt; margin-bottom: 0pt;">
        Sunday, June 30<br>
        <br>
          
</p>
   <div class="contentImageRight" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media2.fdncms.com/tucsonweekly/imager/u/original/25350656/bach.jpg" class="zoomable" rel="contentImg_gal-25346224" title="">                  <img src="https://media2.fdncms.com/tucsonweekly/imager/u/blog/25350656/bach.jpg?cb=1561708834" width="217" height="334" alt="bach.jpg" srcset="" />                </a>                                                                                                           <ul style="width:217px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div><span style="font-weight: normal;"><i>St. Andrew's Bach Society</i> presents </span><b>Bach Without Borders</b><span style="font-weight: normal;">. Classical guitarist </span><b>Bin Hu</b><span style="font-weight: normal;"> and guzhengist (Chinese zither) </span><b>Jing Xia</b><span style="font-weight: normal;"> perform a diverse program of traditional Chinese and classical compositions. At Grace St. Paul's Episcopal Church.<br>
  <br>
  Be tragic. </span><b>Tunes From The Crypt</b><span style="font-weight: normal;"> finds DJs </span><b>Nullus</b><span style="font-weight: normal;"> and </span><b>SET</b><span style="font-weight: normal;"> spinning goth and industrial from the '80s and '90s to darkwave and witch house from today. Darkness knows no bounds. At the Surly Wench Pub.<br>
  <br>
  Infusing samba rhythms with jazz and blues, </span><b>The Eugene Boronow</b><span style="font-weight: normal;"> </span><b>Trio</b><span style="font-weight: normal;"> spreads bossa nova's heart-warming sound. At Public Brewhouse.<br>
  <br>
  Like your toast with jam? </span><b>Mik &amp; The Funky Brunch</b><span style="font-weight: normal;"> provide family-friendly funk. At La Cocina.</span></span>
      
      
      <div class="clearfix"></div>
      
      
      
    </div>

    
    
    
      
    

    

    
      
      <p class="tags">
        Tags: <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=music" rel="tag">music</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=live%20show" rel="tag">live show</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=live%20shows" rel="tag">live shows</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Tucson" rel="tag">Tucson</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=weekend" rel="tag">weekend</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=live%20music" rel="tag">live music</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=concerts" rel="tag">concerts</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=bands" rel="tag">bands</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=performances" rel="tag">performances</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?contentFeature=3669452" rel="tag">Image</a>
      </p>
    

    

  </div> <!-- end blogPost -->
    
    <div class="clear"></div>
  </div>
















  
  















  
  
  

  
  
  

  
 
  



  
  
    
  
  
  <div id="TallBar" class="SpanningFeature TheRangeBlogPost ">
    <ul>
      <li class="l0 first" style="width:50%">
        <fb:like href="https://www.tucsonweekly.com/TheRange/archives/2019/06/28/xoxo-where-to-rock-this-weekend-june-28-to-30" 
         send="true" 
         width="285" 
         show_faces="false" 
         action="like" 
         font="tahoma" 
         colorscheme="light" 
         layout="standard"></fb:like></li> <li class="l0" style="width:16%;"><a href="https://twitter.com/share?url=https%3A//www.tucsonweekly.com/TheRange/archives/2019/06/28/xoxo-where-to-rock-this-weekend-june-28-to-30&text=XOXO%3A%20Where%20to%20Rock%20This%20Weekend%2C%20June%2028%20to%2030" class="twitter-share-button" data-count="vertical">Tweet</a>
<script>
  dnLoadScript("https://platform.twitter.com/widgets.js", true);
</script></li> <li class="l0 last" style="width:16%;">




  <div class="addthis_toolbox addthis_default_style"><a addthis:url="https://www.tucsonweekly.com/TheRange/archives/2019/06/28/xoxo-where-to-rock-this-weekend-june-28-to-30" addthis:title="XOXO: Where to Rock This Weekend, June 28 to 30" addthis:description="" class="addthis_counter"></a></div>
  <script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4ea84184281c09f8", true);
  </script>


      </li>
    </ul>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  




    
    
    
    





















  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  
  


  

  
    
      <style>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</style>
      <div id="BlogComments" class="SpanningFeature TheRangeBlogPost CommentsComponent ">
        
        
        <div class="commentsHeader hreview-aggregate clearfix" id="readerComments">

          
          
          
          <h3 class="clearfix">
            <div style="float:left;">
              Comments 
            </div>
            
          </h3>
        </div>
        
        
        <div id="BlogComments_commentContent" class="commentContent">
          
        </div>
        

        
          <div class="bottomOptionBar clearfix">
            
              <div style="float:left;">
      <div style="float:left;margin:4px 0; padding:4px 6px;">Subscribe to this thread:</div>
      <div style="position:relative;float:left">
      <div class="commentSubscribeLink">
        <a class="toggleActivator saveAction" id="doSubscribe" href="javascript://Subscribe">By Email</a>
      </div>
      <div class="togglePanel" data-toolsoid="25346224" data-toolsajaxmacro="commentSubscribe" style="display:none">
        <div class="toggleArrowBorder"></div>
        <div class="toggleArrow"></div>
        <a href="javascript://close" class="togglePanelClose"><img src="/foundation/images/icons/cross.png" width="14" height="14"></a>
        <div class="loading">Subscribing&hellip;</div>
        <div class="ajaxUpdater" style="display:none;"></div>
      </div>
      </div>
      <div class="commentRSSLink"><a href="/tucson/Rss.xml?id=comments&amp;oid=25346224" class="feedLink" title="Subscribe to this story's comments" target="_blank">With RSS</a></div>
      </div>
            
            
          </div>          
          
        <hr />

        

        
          

          <form id="BlogCommentsPostCommentForm" method="post" class="userCommentForm validateForm" data-validate="login" data-validate-login-options="{&quot;feelingShy&quot;:true}">
            <input type="hidden" name="commentType" value="comment" />
            <input type="hidden" name="oid" value="25346224" />
            <input type="hidden" name="source" value="desktop">

            
            

            <label for="comment" class="hidden">Comment</label>
            
              <h4 class="commentFormAddHeader"><a name="readerComments">Add a comment</a></h4>
            

            
            <div>(<a href="/tucson/CommentsPolicy/Page">comments policy</a>)</div>
            

            <div class="errorDisplay" style="display:none">
              <ol></ol>
            </div>
            <dl class="formElements clearfix">
            
              <dd><textarea name="comment" style="height:112px;overflow:hidden;" tabindex="1" class="expandableBox required" id="comment" data-validate="required"></textarea></dd>
            </dl>

            

            

            <input type="checkbox" name="subscribe" id="BlogComments_commentSubscribe" value="yes"> <label for="BlogComments_commentSubscribe" style="margin-right:24px;">Subscribe to this thread</label>
            
            

            <p class="commentFormSubmit">
              <input type="submit" name="commentSubmit" tabindex="2" value="Post Comment" id="commentSubmit" />
            </p>

          </form>
          <script>
            jQuery("textarea.expandableBox").autoBoxResize();
          </script>
        
      </div><!-- comments -->
      <script type="text/javascript">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</script>
    
  








      </div><!-- gridSpanningFeature -->
      
      <div id="gridSpanningFeature2">
        
      </div><!-- gridSpanningFeature2 -->

      <div id="gridColumnContainer" class="clearfix">

        <div id="gridMainColumn1">
          





  
      <div id="PreviouslyintheRange" class="MainColumn1 TheRangeBlogPost ">
        <h3>Previously in the Range</h3>
        <ul class="moduleList">
    
    

    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.tucsonweekly.com/TheRange/archives/2019/06/27/xoxo-where-to-rock-thursday-june-27">XOXO: Where to Rock Thursday, June 27</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Ambur Wilkerson and Xavier Omar Otero</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Jun 27, 2019</span>
        </li>
      
    </ul>
  </li>
      
    
  
    

    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.tucsonweekly.com/TheRange/archives/2019/06/26/xoxo-where-to-rock-wednesday-june-26">XOXO: Where to Rock Wednesday, June 26</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Ambur Wilkerson and Xavier Omar Otero</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Jun 26, 2019</span>
        </li>
      
    </ul>
  </li>
      
    
  
    

    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.tucsonweekly.com/TheRange/archives/2019/06/25/xoxo-where-to-rock-tuesday-june-25">XOXO: Where to Rock Tuesday, June 25</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Ambur Wilkerson</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Jun 25, 2019</span>
        </li>
      
    </ul>
  </li>
      
    
  
         <li class="l0 storyItem">
           <a href="https://www.tucsonweekly.com/blogs/TheRange/" class="more">More &raquo;</a>
         </li>
         </ul>
      </div>
    


        </div><!-- gridMainColumn1 -->
        
        <div id="gridMainColumn2">
          







  

  

  
    <div id="MorebyThisAuthorWrapper" class="MainColumn2 TheRangeBlogPost Wrapper">

    
      
      
          <div id="MorebyThisAuthor" class="MainColumn2 TheRangeBlogPost ">
            <h3><span class="headingText">More by Ambur Wilkerson</span></h3>
            <ul class="moduleList">
        
        
        
        <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.tucsonweekly.com/TheRange/archives/2019/06/27/xoxo-where-to-rock-thursday-june-27">XOXO: Where to Rock Thursday, June 27</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Ambur Wilkerson and Xavier Omar Otero</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Jun 27, 2019</span>
        </li>
      
    </ul>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.tucsonweekly.com/TheRange/archives/2019/06/26/xoxo-where-to-rock-wednesday-june-26">XOXO: Where to Rock Wednesday, June 26</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Ambur Wilkerson and Xavier Omar Otero</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Jun 26, 2019</span>
        </li>
      
    </ul>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.tucsonweekly.com/TheRange/archives/2019/06/25/xoxo-where-to-rock-tuesday-june-25">XOXO: Where to Rock Tuesday, June 25</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Ambur Wilkerson</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Jun 25, 2019</span>
        </li>
      
    </ul>
  </li>
        
        

      
             <li class="l0 storyItem more">
               <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?author=25080121" class="more">More &raquo;</a>
             </li>
             </ul>
          </div>
        
    
      
      
          <div id="MorebyThisAuthor" class="MainColumn2 TheRangeBlogPost ">
            <h3><span class="headingText">More by Xavier Omar Otero</span></h3>
            <ul class="moduleList">
        
        
        
        <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.tucsonweekly.com/TheRange/archives/2019/06/27/xoxo-where-to-rock-thursday-june-27">XOXO: Where to Rock Thursday, June 27</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Ambur Wilkerson and Xavier Omar Otero</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Jun 27, 2019</span>
        </li>
      
    </ul>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.tucsonweekly.com/tucson/xoxo/Content?oid=25340301">XOXO</a>
    </h4>
    
      <h5 class="subhead">
        Mark your calendars
      </h5>
    
    <ul>
      
        <li class="l1 byline">by Xavier Omar Otero</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Jun 27, 2019</span>
        </li>
      
    </ul>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.tucsonweekly.com/TheRange/archives/2019/06/26/xoxo-where-to-rock-wednesday-june-26">XOXO: Where to Rock Wednesday, June 26</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Ambur Wilkerson and Xavier Omar Otero</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Jun 26, 2019</span>
        </li>
      
    </ul>
  </li>
        
        

      
             <li class="l0 storyItem more">
               <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?author=7297906" class="more">More &raquo;</a>
             </li>
             </ul>
          </div>
        
    
   </div>  
   
  



        </div><!-- gridMainColumn2 -->

      </div><!-- end gridColumnContainer -->

    </div><!-- end gridFrame -->

    <div id="gridRightColumn">   
      <div id="gridSpanningIsland">
        

























<div id="EventPicksChooser" class="SpanningIsland TheRangeBlogPost ">

  <div class="headerBar">
    <h2><a href="https://www.tucsonweekly.com/tucson/EventSearch">Events</a> &amp; <a href="https://www.tucsonweekly.com/tucson/EventSearch?feature=Staff%20Pick">Staff Picks</a></h2></a>
  </div>

  
    

    <div class="calendarDays">
      <a class="calCurrent" href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=today">Today</a>
      
        | <a class="calDay" href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=2019-06-29%2004%3A00%3A00">Sat</a>
      
        | <a class="calDay" href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=2019-06-30%2004%3A00%3A00">Sun</a>
      
        | <a class="calDay" href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=2019-07-01%2004%3A00%3A00">Mon</a>
      
        | <a class="calDay" href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=2019-07-02%2004%3A00%3A00">Tue</a>
      
        | <a class="calDay" href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=2019-07-03%2004%3A00%3A00">Wed</a>
      
        | <a class="calDay last" href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=2019-07-04%2004%3A00%3A00">Thu</a>
      
    </div>

    
    
      <div class="storyItem">
    

    

    
      <a href="https://www.tucsonweekly.com/tucson/meditation-and-buddhist-study/Event?oid=5986433">
        <img src="https://media1.fdncms.com/tucsonweekly/imager/u/featurette/5986432/3dab04cd_image.jpeg" alt="Meditation and Buddhist study" title="Meditation and Buddhist study" width="124" height="99" />
      </a>
     
    <h4 class="headline"><a href="https://www.tucsonweekly.com/tucson/meditation-and-buddhist-study/Event?oid=5986433">Meditation and Buddhist study</a>  
      <span class="smaller">@ Sky Island Zen</span>
    </h4>
    <h5 class="subhead">Mondays, Saturdays</h5>
  </div>
      

  
 
  <p class="more"><a href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=today">All of today's events</a> | <a href="https://www.tucsonweekly.com/tucson/EventSearch?feature=Staff%20Pick">Staff Picks</a></p>

  

  <div id=""> <!-- Tabbed Box -->  
    <div class="tabs">  
      <div class="tabCurrent tabLeft"><a href="#">Events</a></div> 
      <div class="tabBack tabCenter"><a href="#">Music</a></div> 
      <div class="tabBack tabCenter"><a href="#">Movies</a></div> 
      <div class="tabBack tabRight"><a href="#">Dining</a></div>
      <div class="tabBack tabRight"><a href="#">Locations</a></div>
    </div>
    <div class="clear"></div>

    

    <div class="eventSearchBody" >
      <form name="eventSearchForm" method="get" action="https://www.tucsonweekly.com/tucson/EventSearch">
        <select name="narrowByDate">
    <option value="">-All Dates-</option>
    
    
      
      
        
        
          <option value="2019-06-28" selected="selected">Friday, June 28</option>
        
      
        
        
          <option value="2019-06-29">Saturday, June 29</option>
        
      
        
        
          <option value="2019-06-30">Sunday, June 30</option>
        
      
        
        
          <option value="2019-07-01">Monday, July  1</option>
        
      
        
        
          <option value="2019-07-02">Tuesday, July  2</option>
        
      
        
        
          <option value="2019-07-03">Wednesday, July  3</option>
        
      
        
        
          <option value="2019-07-04">Thursday, July  4</option>
        
      
        
        
          <option value="2019-07-05">Friday, July  5</option>
        
      
        
        
          <option value="2019-07-06">Saturday, July  6</option>
        
      
        
        
          <option value="2019-07-07">Sunday, July  7</option>
        
      
        
        
          <option value="2019-07-08">Monday, July  8</option>
        
      
        
        
          <option value="2019-07-09">Tuesday, July  9</option>
        
      
        
        
          <option value="2019-07-10">Wednesday, July 10</option>
        
      
        
        
          <option value="2019-07-11">Thursday, July 11</option>
        
      
        
        
          <option value="2019-07-12">Friday, July 12</option>
        
      
        
        
          <option value="2019-07-13">Saturday, July 13</option>
        
      
        
        
          <option value="2019-07-14">Sunday, July 14</option>
        
      
        
        
          <option value="2019-07-15">Monday, July 15</option>
        
      
        
        
          <option value="2019-07-16">Tuesday, July 16</option>
        
      
        
        
          <option value="2019-07-17">Wednesday, July 17</option>
        
      
        
        
          <option value="2019-07-18">Thursday, July 18</option>
        
      
        
        
          <option value="2019-07-19">Friday, July 19</option>
        
      
        
        
          <option value="2019-07-20">Saturday, July 20</option>
        
      
        
        
          <option value="2019-07-21">Sunday, July 21</option>
        
      
        
        
          <option value="2019-07-22">Monday, July 22</option>
        
      
        
        
          <option value="2019-07-23">Tuesday, July 23</option>
        
      
        
        
          <option value="2019-07-24">Wednesday, July 24</option>
        
      
        
        
          <option value="2019-07-25">Thursday, July 25</option>
        
      
        
        
          <option value="2019-07-26">Friday, July 26</option>
        
      
        
        
          <option value="2019-07-27">Saturday, July 27</option>
        
      
        
        
          <option value="2019-07-28">Sunday, July 28</option>
        
      
    
  </select>

        <select name="eventCategory">
          <option value="">-All Categories-</option>
          
            <option value="1107327" >&nbsp;&nbsp;Art</option>
          
            <option value="2026929" >&nbsp;&nbsp;Back to School</option>
          
            <option value="1107349" >&nbsp;&nbsp;Bulletin Board</option>
          
            <option value="2490677" >&nbsp;&nbsp;Business & Finance</option>
          
            <option value="1107323" >&nbsp;&nbsp;Dance</option>
          
            <option value="4103152" >&nbsp;&nbsp;Dining</option>
          
            <option value="3093926" >&nbsp;&nbsp;Fall Arts Preview</option>
          
            <option value="1107328" >&nbsp;&nbsp;Family Fun</option>
          
            <option value="1107395" >&nbsp;&nbsp;Film</option>
          
            <option value="3910368" >&nbsp;&nbsp;For Valentines</option>
          
            <option value="1107336" >&nbsp;&nbsp;Gardening</option>
          
            <option value="3555917" >&nbsp;&nbsp;Halloween and All Souls</option>
          
            <option value="2506799" >&nbsp;&nbsp;Health</option>
          
            <option value="1107472" >&nbsp;&nbsp;Lectures</option>
          
            <option value="1107335" >&nbsp;&nbsp;Literature</option>
          
            <option value="1107325" >&nbsp;&nbsp;Museums</option>
          
            <option value="1107343" >&nbsp;&nbsp;Music (Classical, Opera, Jazz, Folk)</option>
          
            <option value="2026930" >&nbsp;&nbsp;New Year's Eve</option>
          
            <option value="1107386" >&nbsp;&nbsp;Outdoors</option>
          
            <option value="1107320" >&nbsp;&nbsp;Performing Arts</option>
          
            <option value="4136083" >&nbsp;&nbsp;Pet-Friendly & Fundraisers</option>
          
            <option value="2026928" >&nbsp;&nbsp;Pride</option>
          
            <option value="1107371" >&nbsp;&nbsp;Special Events</option>
          
            <option value="2506800" >&nbsp;&nbsp;Spirituality</option>
          
            <option value="1130857" >&nbsp;&nbsp;Sports</option>
          
            <option value="2456766" >&nbsp;&nbsp;Spring Arts Preview</option>
          
            <option value="2751116" >&nbsp;&nbsp;Summer Survival Guide</option>
          
            <option value="4000687" >&nbsp;&nbsp;Support Groups</option>
          
            <option value="3904784" >&nbsp;&nbsp;Transgender Awareness Week</option>
          
            <option value="3862947" >&nbsp;&nbsp;Volunteer</option>
          
            <option value="1107321" >&nbsp;&nbsp;Well-Being</option>
          
            <option value="1107942" >&nbsp;&nbsp;Comedy & Storytellers</option>
          
            <option value="3656923" >&nbsp;&nbsp;Dancing, DJ, Karaoke and Open Mic</option>
          
            <option value="3707286" >&nbsp;&nbsp;Trivia Games</option>
          
        </select>

        <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        
          <option value="7424285" >TUCSON</option>
        
        <option value="3552209" >&nbsp;&nbsp;Downtown / 4th Ave / University</option>
      
        
        <option value="1094781" >&nbsp;&nbsp;Central</option>
      
        
        <option value="1094814" >&nbsp;&nbsp;South Tucson</option>
      
        
        <option value="3287529" >&nbsp;&nbsp;North/Foothills</option>
      
        
        <option value="1094791" >&nbsp;&nbsp;East side</option>
      
        
        <option value="1094969" >&nbsp;&nbsp;West side</option>
      
        
        <option value="3266147" >&nbsp;&nbsp;Southeast</option>
      
        
        <option value="3138323" >&nbsp;&nbsp;Southwest</option>
      
        
        <option value="1094793" >&nbsp;&nbsp;Northeast</option>
      
        
        <option value="1094785" >&nbsp;&nbsp;Northwest</option>
      
        
        <option value="7424290" >&nbsp;&nbsp;Tucson (general)</option>
      
        
          <option value="7424291" >NORTH OF TUCSON</option>
        
        <option value="3287479" >&nbsp;&nbsp;Catalina</option>
      
        
        <option value="3904764" >&nbsp;&nbsp;Florence</option>
      
        
        <option value="3287527" >&nbsp;&nbsp;Marana</option>
      
        
        <option value="3287528" >&nbsp;&nbsp;Oracle</option>
      
        
        <option value="3287533" >&nbsp;&nbsp;Oro Valley</option>
      
        
        <option value="3339208" >&nbsp;&nbsp;San Manuel</option>
      
        
        <option value="3212371" >&nbsp;&nbsp;Superior</option>
      
        
        <option value="7426378" >&nbsp;&nbsp;Globe</option>
      
        
        <option value="7426357" >&nbsp;&nbsp;Phoenix / Chandler / Glendale</option>
      
        
        <option value="7426433" >&nbsp;&nbsp;Casa Grande</option>
      
        
        <option value="7426380" >&nbsp;&nbsp;Payson</option>
      
        
        <option value="7426379" >&nbsp;&nbsp;Sedona / Flagstaff</option>
      
        
        <option value="7426319" >&nbsp;&nbsp;Scottsdale</option>
      
        
          <option value="7424292" >SOUTH OF TUCSON</option>
        
        <option value="3223056" >&nbsp;&nbsp;Ajo</option>
      
        
        <option value="3235744" >&nbsp;&nbsp;Amado / Carmen</option>
      
        
        <option value="3212928" >&nbsp;&nbsp;Arivaca</option>
      
        
        <option value="3509182" >&nbsp;&nbsp;Elgin</option>
      
        
        <option value="3229508" >&nbsp;&nbsp;Green Valley</option>
      
        
        <option value="3259115" >&nbsp;&nbsp;Huachuca City</option>
      
        
        <option value="3303004" >&nbsp;&nbsp;Nogales</option>
      
        
        <option value="3287530" >&nbsp;&nbsp;Patagonia</option>
      
        
        <option value="3274620" >&nbsp;&nbsp;Sahuarita</option>
      
        
        <option value="2700860" >&nbsp;&nbsp;Sonoita</option>
      
        
        <option value="3187460" >&nbsp;&nbsp;Tumacácori</option>
      
        
        <option value="7426317" >&nbsp;&nbsp;Sasabe</option>
      
        
        <option value="7426318" >&nbsp;&nbsp;Douglas</option>
      
        
        <option value="2573339" >&nbsp;&nbsp;Sierra Vista / Hereford</option>
      
        
        <option value="7424289" >&nbsp;&nbsp;Tubac</option>
      
        
          <option value="7424287" >EAST OF TUCSON</option>
        
        <option value="3093054" >&nbsp;&nbsp;Benson / Dragoon</option>
      
        
        <option value="2673664" >&nbsp;&nbsp;Bisbee / Warren</option>
      
        
        <option value="3011257" >&nbsp;&nbsp;Safford</option>
      
        
        <option value="7424288" >&nbsp;&nbsp;Silver City / Pinos Altos</option>
      
        
        <option value="2826341" >&nbsp;&nbsp;Tombstone</option>
      
        
        <option value="3268503" >&nbsp;&nbsp;Vail</option>
      
        
        <option value="3243183" >&nbsp;&nbsp;Willcox</option>
      
        
        <option value="1094842" >&nbsp;&nbsp;Beyond AZ</option>
      
        
          <option value="7424302" >WEST OF TUCSON</option>
        
        <option value="3287537" >&nbsp;&nbsp;Three Points</option>
      
    
  </select>

        <input type="text" name="keywords" title="Enter keyword" class="text" value="" />
        <input type="submit" value="go" />
      </form>
      <div class="clear"></div>
      <p class="submitLink"><a href="https://posting.tucsonweekly.com/tucson/Events/AddEvent">Submit an Event</a></p>
    </div>

    

    <div class="eventSearchBody" style="display: none;">
      <form name="musicEventSearchForm" method="get" action="https://www.tucsonweekly.com/tucson/EventSearch">
        <input type="hidden" name="eventCategory" value="1107701" />

        <select name="narrowByDate">
    <option value="">-All Dates-</option>
    
    
      
      
        
        
          <option value="2019-06-28" selected="selected">Friday, June 28</option>
        
      
        
        
          <option value="2019-06-29">Saturday, June 29</option>
        
      
        
        
          <option value="2019-06-30">Sunday, June 30</option>
        
      
        
        
          <option value="2019-07-01">Monday, July  1</option>
        
      
        
        
          <option value="2019-07-02">Tuesday, July  2</option>
        
      
        
        
          <option value="2019-07-03">Wednesday, July  3</option>
        
      
        
        
          <option value="2019-07-04">Thursday, July  4</option>
        
      
        
        
          <option value="2019-07-05">Friday, July  5</option>
        
      
        
        
          <option value="2019-07-06">Saturday, July  6</option>
        
      
        
        
          <option value="2019-07-07">Sunday, July  7</option>
        
      
        
        
          <option value="2019-07-08">Monday, July  8</option>
        
      
        
        
          <option value="2019-07-09">Tuesday, July  9</option>
        
      
        
        
          <option value="2019-07-10">Wednesday, July 10</option>
        
      
        
        
          <option value="2019-07-11">Thursday, July 11</option>
        
      
        
        
          <option value="2019-07-12">Friday, July 12</option>
        
      
        
        
          <option value="2019-07-13">Saturday, July 13</option>
        
      
        
        
          <option value="2019-07-14">Sunday, July 14</option>
        
      
        
        
          <option value="2019-07-15">Monday, July 15</option>
        
      
        
        
          <option value="2019-07-16">Tuesday, July 16</option>
        
      
        
        
          <option value="2019-07-17">Wednesday, July 17</option>
        
      
        
        
          <option value="2019-07-18">Thursday, July 18</option>
        
      
        
        
          <option value="2019-07-19">Friday, July 19</option>
        
      
        
        
          <option value="2019-07-20">Saturday, July 20</option>
        
      
        
        
          <option value="2019-07-21">Sunday, July 21</option>
        
      
        
        
          <option value="2019-07-22">Monday, July 22</option>
        
      
        
        
          <option value="2019-07-23">Tuesday, July 23</option>
        
      
        
        
          <option value="2019-07-24">Wednesday, July 24</option>
        
      
        
        
          <option value="2019-07-25">Thursday, July 25</option>
        
      
        
        
          <option value="2019-07-26">Friday, July 26</option>
        
      
        
        
          <option value="2019-07-27">Saturday, July 27</option>
        
      
        
        
          <option value="2019-07-28">Sunday, July 28</option>
        
      
    
  </select>
        <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        
          <option value="7424285" >TUCSON</option>
        
        <option value="3552209" >&nbsp;&nbsp;Downtown / 4th Ave / University</option>
      
        
        <option value="1094781" >&nbsp;&nbsp;Central</option>
      
        
        <option value="1094814" >&nbsp;&nbsp;South Tucson</option>
      
        
        <option value="3287529" >&nbsp;&nbsp;North/Foothills</option>
      
        
        <option value="1094791" >&nbsp;&nbsp;East side</option>
      
        
        <option value="1094969" >&nbsp;&nbsp;West side</option>
      
        
        <option value="3266147" >&nbsp;&nbsp;Southeast</option>
      
        
        <option value="3138323" >&nbsp;&nbsp;Southwest</option>
      
        
        <option value="1094793" >&nbsp;&nbsp;Northeast</option>
      
        
        <option value="1094785" >&nbsp;&nbsp;Northwest</option>
      
        
        <option value="7424290" >&nbsp;&nbsp;Tucson (general)</option>
      
        
          <option value="7424291" >NORTH OF TUCSON</option>
        
        <option value="3287479" >&nbsp;&nbsp;Catalina</option>
      
        
        <option value="3904764" >&nbsp;&nbsp;Florence</option>
      
        
        <option value="3287527" >&nbsp;&nbsp;Marana</option>
      
        
        <option value="3287528" >&nbsp;&nbsp;Oracle</option>
      
        
        <option value="3287533" >&nbsp;&nbsp;Oro Valley</option>
      
        
        <option value="3339208" >&nbsp;&nbsp;San Manuel</option>
      
        
        <option value="3212371" >&nbsp;&nbsp;Superior</option>
      
        
        <option value="7426378" >&nbsp;&nbsp;Globe</option>
      
        
        <option value="7426357" >&nbsp;&nbsp;Phoenix / Chandler / Glendale</option>
      
        
        <option value="7426433" >&nbsp;&nbsp;Casa Grande</option>
      
        
        <option value="7426380" >&nbsp;&nbsp;Payson</option>
      
        
        <option value="7426379" >&nbsp;&nbsp;Sedona / Flagstaff</option>
      
        
        <option value="7426319" >&nbsp;&nbsp;Scottsdale</option>
      
        
          <option value="7424292" >SOUTH OF TUCSON</option>
        
        <option value="3223056" >&nbsp;&nbsp;Ajo</option>
      
        
        <option value="3235744" >&nbsp;&nbsp;Amado / Carmen</option>
      
        
        <option value="3212928" >&nbsp;&nbsp;Arivaca</option>
      
        
        <option value="3509182" >&nbsp;&nbsp;Elgin</option>
      
        
        <option value="3229508" >&nbsp;&nbsp;Green Valley</option>
      
        
        <option value="3259115" >&nbsp;&nbsp;Huachuca City</option>
      
        
        <option value="3303004" >&nbsp;&nbsp;Nogales</option>
      
        
        <option value="3287530" >&nbsp;&nbsp;Patagonia</option>
      
        
        <option value="3274620" >&nbsp;&nbsp;Sahuarita</option>
      
        
        <option value="2700860" >&nbsp;&nbsp;Sonoita</option>
      
        
        <option value="3187460" >&nbsp;&nbsp;Tumacácori</option>
      
        
        <option value="7426317" >&nbsp;&nbsp;Sasabe</option>
      
        
        <option value="7426318" >&nbsp;&nbsp;Douglas</option>
      
        
        <option value="2573339" >&nbsp;&nbsp;Sierra Vista / Hereford</option>
      
        
        <option value="7424289" >&nbsp;&nbsp;Tubac</option>
      
        
          <option value="7424287" >EAST OF TUCSON</option>
        
        <option value="3093054" >&nbsp;&nbsp;Benson / Dragoon</option>
      
        
        <option value="2673664" >&nbsp;&nbsp;Bisbee / Warren</option>
      
        
        <option value="3011257" >&nbsp;&nbsp;Safford</option>
      
        
        <option value="7424288" >&nbsp;&nbsp;Silver City / Pinos Altos</option>
      
        
        <option value="2826341" >&nbsp;&nbsp;Tombstone</option>
      
        
        <option value="3268503" >&nbsp;&nbsp;Vail</option>
      
        
        <option value="3243183" >&nbsp;&nbsp;Willcox</option>
      
        
        <option value="1094842" >&nbsp;&nbsp;Beyond AZ</option>
      
        
          <option value="7424302" >WEST OF TUCSON</option>
        
        <option value="3287537" >&nbsp;&nbsp;Three Points</option>
      
    
  </select>

        <input type="text" name="keywords" title="Enter keyword" class="text" value="" />
        <input type="submit" value="go" />
      </form>
      <div class="clear"></div>
      <p class="submitLink"><a href="https://posting.tucsonweekly.com/tucson/Events/AddEvent">Submit an Event</a></p>
    </div>

    

    <div class="eventSearchBody" style="display: none;">
      <form name="movietimesSearchForm" method="get" action="https://www.tucsonweekly.com/tucson/MovieTimes">
        <select name="film" onchange="submit();">
          <option value="">Select a movie</option>
          
        </select>
        <noscript>
          <br />
          <input type="submit" value="go" />
        </noscript>
      </form>

      <p>or</p>

      <form name="movietimesSearchForm" method="get" action="https://www.tucsonweekly.com/tucson/MovieTimes">
        <select name="location" onchange="submit();">
          <option value="">Select a location</option>
          
        </select>
        <noscript>
           <br />
           <input type="submit" value="go" />
        </noscript>
      </form>
    </div>

    

    <div class="eventSearchBody" style="display: none;">
      <form name="diningSearchForm" method="get" action="https://www.tucsonweekly.com/tucson/LocationSearch">
        <input type="hidden" name="locationSection" value="1113936" />

        <select name="locationCategory">
          <option value="">-All Categories-</option>
          
            <option value="1113954">Americana</option>
          
            <option value="3966316">Australian</option>
          
            <option value="1113955">Barbecue</option>
          
            <option value="1113956">Brew Pubs</option>
          
            <option value="3691897">Buffet</option>
          
            <option value="3966308">Burgers & Dogs</option>
          
            <option value="1113961">Cafes and Bistros</option>
          
            <option value="1113965">Cajun</option>
          
            <option value="3966320">Caribbean</option>
          
            <option value="1113959">Chinese</option>
          
            <option value="1113957">Coffee Houses</option>
          
            <option value="1113958">Cuban</option>
          
            <option value="2593488">Deli</option>
          
            <option value="1294952">Eastern European</option>
          
            <option value="1113953">Ethiopian</option>
          
            <option value="1113966">Filipino</option>
          
            <option value="1113937">French</option>
          
            <option value="1113945">Greek</option>
          
            <option value="3950579">Guatemalan</option>
          
            <option value="3179449">Hawaiian</option>
          
            <option value="1113947">Indian</option>
          
            <option value="1113950">Italian</option>
          
            <option value="2321964">Jamaican</option>
          
            <option value="1113962">Korean</option>
          
            <option value="1113951">Latin American</option>
          
            <option value="1113967">Malaysian</option>
          
            <option value="2593490">Market</option>
          
            <option value="1113952">Mexican</option>
          
            <option value="1113938">Middle Eastern</option>
          
            <option value="1113940">Pan-Asian</option>
          
            <option value="1113942">Pizza</option>
          
            <option value="3951464">Russian</option>
          
            <option value="1113943">Sandwiches</option>
          
            <option value="2583225">Seafood</option>
          
            <option value="1113944">Southwest</option>
          
            <option value="1113964">Spanish</option>
          
            <option value="2593489">Sports Bar</option>
          
            <option value="2583227">Steakhouse</option>
          
            <option value="1113946">Surf and Turf</option>
          
            <option value="1113948">Sushi and Japanese</option>
          
            <option value="1113941">Thai</option>
          
            <option value="1113949">Upper Crust</option>
          
            <option value="1113939">Vegetarian Friendly</option>
          
            <option value="1113963">Vietnamese</option>
          
            <option value="1113960">Wine Bars</option>
          
        </select>

        <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        
          <option value="7424285" >TUCSON</option>
        
        <option value="3552209" >&nbsp;&nbsp;Downtown / 4th Ave / University</option>
      
        
        <option value="1094781" >&nbsp;&nbsp;Central</option>
      
        
        <option value="1094814" >&nbsp;&nbsp;South Tucson</option>
      
        
        <option value="3287529" >&nbsp;&nbsp;North/Foothills</option>
      
        
        <option value="1094791" >&nbsp;&nbsp;East side</option>
      
        
        <option value="1094969" >&nbsp;&nbsp;West side</option>
      
        
        <option value="3266147" >&nbsp;&nbsp;Southeast</option>
      
        
        <option value="3138323" >&nbsp;&nbsp;Southwest</option>
      
        
        <option value="1094793" >&nbsp;&nbsp;Northeast</option>
      
        
        <option value="1094785" >&nbsp;&nbsp;Northwest</option>
      
        
        <option value="7424290" >&nbsp;&nbsp;Tucson (general)</option>
      
        
          <option value="7424291" >NORTH OF TUCSON</option>
        
        <option value="3287479" >&nbsp;&nbsp;Catalina</option>
      
        
        <option value="3904764" >&nbsp;&nbsp;Florence</option>
      
        
        <option value="3287527" >&nbsp;&nbsp;Marana</option>
      
        
        <option value="3287528" >&nbsp;&nbsp;Oracle</option>
      
        
        <option value="3287533" >&nbsp;&nbsp;Oro Valley</option>
      
        
        <option value="3339208" >&nbsp;&nbsp;San Manuel</option>
      
        
        <option value="3212371" >&nbsp;&nbsp;Superior</option>
      
        
        <option value="7426378" >&nbsp;&nbsp;Globe</option>
      
        
        <option value="7426357" >&nbsp;&nbsp;Phoenix / Chandler / Glendale</option>
      
        
        <option value="7426433" >&nbsp;&nbsp;Casa Grande</option>
      
        
        <option value="7426380" >&nbsp;&nbsp;Payson</option>
      
        
        <option value="7426379" >&nbsp;&nbsp;Sedona / Flagstaff</option>
      
        
        <option value="7426319" >&nbsp;&nbsp;Scottsdale</option>
      
        
          <option value="7424292" >SOUTH OF TUCSON</option>
        
        <option value="3223056" >&nbsp;&nbsp;Ajo</option>
      
        
        <option value="3235744" >&nbsp;&nbsp;Amado / Carmen</option>
      
        
        <option value="3212928" >&nbsp;&nbsp;Arivaca</option>
      
        
        <option value="3509182" >&nbsp;&nbsp;Elgin</option>
      
        
        <option value="3229508" >&nbsp;&nbsp;Green Valley</option>
      
        
        <option value="3259115" >&nbsp;&nbsp;Huachuca City</option>
      
        
        <option value="3303004" >&nbsp;&nbsp;Nogales</option>
      
        
        <option value="3287530" >&nbsp;&nbsp;Patagonia</option>
      
        
        <option value="3274620" >&nbsp;&nbsp;Sahuarita</option>
      
        
        <option value="2700860" >&nbsp;&nbsp;Sonoita</option>
      
        
        <option value="3187460" >&nbsp;&nbsp;Tumacácori</option>
      
        
        <option value="7426317" >&nbsp;&nbsp;Sasabe</option>
      
        
        <option value="7426318" >&nbsp;&nbsp;Douglas</option>
      
        
        <option value="2573339" >&nbsp;&nbsp;Sierra Vista / Hereford</option>
      
        
        <option value="7424289" >&nbsp;&nbsp;Tubac</option>
      
        
          <option value="7424287" >EAST OF TUCSON</option>
        
        <option value="3093054" >&nbsp;&nbsp;Benson / Dragoon</option>
      
        
        <option value="2673664" >&nbsp;&nbsp;Bisbee / Warren</option>
      
        
        <option value="3011257" >&nbsp;&nbsp;Safford</option>
      
        
        <option value="7424288" >&nbsp;&nbsp;Silver City / Pinos Altos</option>
      
        
        <option value="2826341" >&nbsp;&nbsp;Tombstone</option>
      
        
        <option value="3268503" >&nbsp;&nbsp;Vail</option>
      
        
        <option value="3243183" >&nbsp;&nbsp;Willcox</option>
      
        
        <option value="1094842" >&nbsp;&nbsp;Beyond AZ</option>
      
        
          <option value="7424302" >WEST OF TUCSON</option>
        
        <option value="3287537" >&nbsp;&nbsp;Three Points</option>
      
    
  </select>

        <input type="text" name="keywords" title="Enter keyword" class="text" value="" />
        <input type="submit" value="go" />
      </form>
    </div>

    

    <div class="eventSearchBody" style="display: none;">
      <form name="locationSearchForm" method="get" action="https://www.tucsonweekly.com/tucson/LocationSearch">
        <select name="locationCategory">
          <option value="">-All Categories-</option>
          
            
              <option value="2215006" >CULTURE & ENTERTAINMENT</option>
            
            <option value="1113914" >&nbsp;&nbsp;Bar</option>
          
            
            <option value="1113933" >&nbsp;&nbsp;Coffee House</option>
          
            
            <option value="1256739" >&nbsp;&nbsp;Concert Hall</option>
          
            
            <option value="1146952" >&nbsp;&nbsp;Dance Club</option>
          
            
            <option value="1113916" >&nbsp;&nbsp;Galleries</option>
          
            
            <option value="4002307" >&nbsp;&nbsp;Hookah Bar</option>
          
            
            <option value="1113923" >&nbsp;&nbsp;Museums</option>
          
            
            <option value="1113974" >&nbsp;&nbsp;Music Venues</option>
          
            
            <option value="1113928" >&nbsp;&nbsp;Theaters (film)</option>
          
            
            <option value="1113917" >&nbsp;&nbsp;Theaters (live)</option>
          
            
            <option value="1252196" >&nbsp;&nbsp;Winery</option>
          
            
              <option value="1113913" >COMMUNITY, SHOPS & SERVICES</option>
            
            <option value="1252195" >&nbsp;&nbsp;Banquet Hall</option>
          
            
            <option value="1113925" >&nbsp;&nbsp;Bookstore</option>
          
            
            <option value="1253417" >&nbsp;&nbsp;Business</option>
          
            
            <option value="1252187" >&nbsp;&nbsp;Caterer</option>
          
            
            <option value="1113919" >&nbsp;&nbsp;Community Center</option>
          
            
            <option value="1113926" >&nbsp;&nbsp;Country Club</option>
          
            
            <option value="1113934" >&nbsp;&nbsp;Dance Studios/Companies</option>
          
            
            <option value="1113922" >&nbsp;&nbsp;Education</option>
          
            
            <option value="1113935" >&nbsp;&nbsp;Government</option>
          
            
            <option value="1113929" >&nbsp;&nbsp;Health</option>
          
            
            <option value="1113932" >&nbsp;&nbsp;Hotel</option>
          
            
            <option value="1113924" >&nbsp;&nbsp;Library</option>
          
            
            <option value="1113921" >&nbsp;&nbsp;Outdoors</option>
          
            
            <option value="1113920" >&nbsp;&nbsp;Park</option>
          
            
            <option value="1113918" >&nbsp;&nbsp;Religious</option>
          
            
            <option value="1113931" >&nbsp;&nbsp;Residential</option>
          
            
            <option value="1113930" >&nbsp;&nbsp;Sports or Recreation</option>
          
            
            <option value="1113927" >&nbsp;&nbsp;Store or Market</option>
          
        </select>

        <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        
          <option value="7424285" >TUCSON</option>
        
        <option value="3552209" >&nbsp;&nbsp;Downtown / 4th Ave / University</option>
      
        
        <option value="1094781" >&nbsp;&nbsp;Central</option>
      
        
        <option value="1094814" >&nbsp;&nbsp;South Tucson</option>
      
        
        <option value="3287529" >&nbsp;&nbsp;North/Foothills</option>
      
        
        <option value="1094791" >&nbsp;&nbsp;East side</option>
      
        
        <option value="1094969" >&nbsp;&nbsp;West side</option>
      
        
        <option value="3266147" >&nbsp;&nbsp;Southeast</option>
      
        
        <option value="3138323" >&nbsp;&nbsp;Southwest</option>
      
        
        <option value="1094793" >&nbsp;&nbsp;Northeast</option>
      
        
        <option value="1094785" >&nbsp;&nbsp;Northwest</option>
      
        
        <option value="7424290" >&nbsp;&nbsp;Tucson (general)</option>
      
        
          <option value="7424291" >NORTH OF TUCSON</option>
        
        <option value="3287479" >&nbsp;&nbsp;Catalina</option>
      
        
        <option value="3904764" >&nbsp;&nbsp;Florence</option>
      
        
        <option value="3287527" >&nbsp;&nbsp;Marana</option>
      
        
        <option value="3287528" >&nbsp;&nbsp;Oracle</option>
      
        
        <option value="3287533" >&nbsp;&nbsp;Oro Valley</option>
      
        
        <option value="3339208" >&nbsp;&nbsp;San Manuel</option>
      
        
        <option value="3212371" >&nbsp;&nbsp;Superior</option>
      
        
        <option value="7426378" >&nbsp;&nbsp;Globe</option>
      
        
        <option value="7426357" >&nbsp;&nbsp;Phoenix / Chandler / Glendale</option>
      
        
        <option value="7426433" >&nbsp;&nbsp;Casa Grande</option>
      
        
        <option value="7426380" >&nbsp;&nbsp;Payson</option>
      
        
        <option value="7426379" >&nbsp;&nbsp;Sedona / Flagstaff</option>
      
        
        <option value="7426319" >&nbsp;&nbsp;Scottsdale</option>
      
        
          <option value="7424292" >SOUTH OF TUCSON</option>
        
        <option value="3223056" >&nbsp;&nbsp;Ajo</option>
      
        
        <option value="3235744" >&nbsp;&nbsp;Amado / Carmen</option>
      
        
        <option value="3212928" >&nbsp;&nbsp;Arivaca</option>
      
        
        <option value="3509182" >&nbsp;&nbsp;Elgin</option>
      
        
        <option value="3229508" >&nbsp;&nbsp;Green Valley</option>
      
        
        <option value="3259115" >&nbsp;&nbsp;Huachuca City</option>
      
        
        <option value="3303004" >&nbsp;&nbsp;Nogales</option>
      
        
        <option value="3287530" >&nbsp;&nbsp;Patagonia</option>
      
        
        <option value="3274620" >&nbsp;&nbsp;Sahuarita</option>
      
        
        <option value="2700860" >&nbsp;&nbsp;Sonoita</option>
      
        
        <option value="3187460" >&nbsp;&nbsp;Tumacácori</option>
      
        
        <option value="7426317" >&nbsp;&nbsp;Sasabe</option>
      
        
        <option value="7426318" >&nbsp;&nbsp;Douglas</option>
      
        
        <option value="2573339" >&nbsp;&nbsp;Sierra Vista / Hereford</option>
      
        
        <option value="7424289" >&nbsp;&nbsp;Tubac</option>
      
        
          <option value="7424287" >EAST OF TUCSON</option>
        
        <option value="3093054" >&nbsp;&nbsp;Benson / Dragoon</option>
      
        
        <option value="2673664" >&nbsp;&nbsp;Bisbee / Warren</option>
      
        
        <option value="3011257" >&nbsp;&nbsp;Safford</option>
      
        
        <option value="7424288" >&nbsp;&nbsp;Silver City / Pinos Altos</option>
      
        
        <option value="2826341" >&nbsp;&nbsp;Tombstone</option>
      
        
        <option value="3268503" >&nbsp;&nbsp;Vail</option>
      
        
        <option value="3243183" >&nbsp;&nbsp;Willcox</option>
      
        
        <option value="1094842" >&nbsp;&nbsp;Beyond AZ</option>
      
        
          <option value="7424302" >WEST OF TUCSON</option>
        
        <option value="3287537" >&nbsp;&nbsp;Three Points</option>
      
    
  </select>

        <input type="text" name="keywords" title="Enter keyword" class="text" value="" />
        <input type="submit" value="go" />
      </form>
    </div>
  </div><!-- End of Tabbed Box -->

</div>





<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function() {
  // Main tabs.
  dnSetupTabGroup(
      $$("#EventPicksChooser div.tabs>div"),
      $$("#EventPicksChooser div.eventSearchBody"),
      "tabCurrent", "tabBack", 0
  );

  // Remove default tab behavior.
  $$("#EventPicksChooser div.tabs>div a").each(function (a, index) {
      a.onclick = function() {
        return false;
      };
  });
});
//-->
</script>
<!-- End #EventPicksChooser -->
<div id="Rectangle1" class="SpanningIsland TheRangeBlogPost MediumRectangle Ad">
  
  <!-- /4961490/TW_ROS_right_300x250 -->
          <div id="div-gpt-ad-tw_ros_right_300x250" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_300x250" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_300x250');
                });
              </script>
          </div>
  
</div><style>
.storyItem.EotD img {margin:0 0 10px;width:280px;}
</style>


  

  <div id="EventoftheDay" class="SpanningIsland TheRangeBlogPost PickOfTheDay ">
    <div class="headerBar">
      <h1 class="sectionHeader">Staff Pick</h1>
    </div>

    <div class="storyItem EotD">
      
        <a href="https://www.tucsonweekly.com/tucson/the-three-sisters-culinary-series/Event?oid=25157366"> 
          <img src="https://media2.fdncms.com/tucsonweekly/imager/u/eventoftheday/25157358/three_sisters_logo.jpg" alt="" class="storyImg" />
          
        </a>
      

      <h4 class="headline"><a href="https://www.tucsonweekly.com/tucson/the-three-sisters-culinary-series/Event?oid=25157366">The Three Sisters Culinary Series</a></h4>
 
      
        <p>Join the Southern Arizona Arts & Cultural Alliance and Native Seeds/SEARCH at Westward Look for a progressive,&hellip;
        <a href="https://www.tucsonweekly.com/tucson/the-three-sisters-culinary-series/Event?oid=25157366">More</a></p>
      
    </div>

    <div class="storyItem eventInfo">
      
        @ Westward Look Wyndham Grand Resort & Spa
      
      Sat., June 29, 6-8:30 p.m.
      
        245 E. Ina Road.
      
    </div>

    <p class="submitListing"><a href="https://www.tucsonweekly.com/tucson/EventSearch?feature=Staff%20Pick">&raquo; More Picks</a></p>
    <p class="submitListing"><a href="https://posting.tucsonweekly.com/tucson/SubmitEvent/Page">Submit an Event Listing</a></p>
  </div>


<div id="Rectangle3" class="SpanningIsland TheRangeBlogPost MediumRectangle Ad">
  
  <!-- /4961490/TW_WeGotCactus_300x250_1 -->
          <div id="div-gpt-ad-tw_wegotcactus_300x250_1" style="" data-content-type="ad" data-slot="/4961490/TW_WeGotCactus_300x250_1" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_wegotcactus_300x250_1');
                });
              </script>
          </div>
  
</div>

<div id="TabbedMost" class="SpanningIsland TheRangeBlogPost ">












  <!-- Cached: 2019-06-28 01:00 -->

  <h2>Popular Content</h2>

    <div class="tabs">
      <a href="#" class="mostread tabCurrent">Most Read</a>
      
      <a href="#" class="mostdiscussed tabBack">Most Discussed</a>
    </div>

    <div class="clear"><!-- clear --></div>

    
    <div class="commentsBody" style="">
      
      

      
        
            <ol>
          
          
          <li><a href="https://www.tucsonweekly.com/TheRange/archives/2019/06/27/its-here-vote-now-in-the-final-round-of-best-of-tucson">It's Here! Vote Now in the Final Round of Best of Tucson</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
          
        
          
          <li><a href="https://www.tucsonweekly.com/TheRange/archives/2019/06/27/three-great-things-to-do-in-tucson-today-thursday-june-27">Three Great Things to Do in Tucson Today: Thursday, June 27</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
          
        
          
          <li><a href="https://www.tucsonweekly.com/TheRange/archives/2019/06/27/claytoon-of-the-day-soc-it-to-him">Claytoon of the Day: Soc It To Him</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
          
        
          
          <li><a href="https://www.tucsonweekly.com/TheRange/archives/2019/06/26/did-i-underestimate-the-impact-of-open-enrollment-in-my-last-post">Did I Underestimate the Impact Of Open Enrollment In My Last Post?</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
          
        
          
          <li><a href="https://www.tucsonweekly.com/TheRange/archives/2019/06/27/laughing-stock-take-the-kids-to-the-laughing-pool">Laughing Stock: Take the kids to the laughing pool!</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
          
        
            </ol>
          
      
      <div class="clear"><!-- clear --></div>
    </div>

  

    
    <div class="commentsBody" style="display:none">
      
          <ol>
        
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2019/06/13/ding-dong-sarah-huckabee-sanders-is-gone">Ding Dong, Sarah Huckabee Sanders is Gone</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2019/06/18/claytoon-of-the-day-fat-head-rolls-with-the-polls">Claytoon of the Day: Fat Head Rolls With The Polls</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2019/06/19/claytoon-of-the-day-coughing-up-classified">Claytoon of the Day: Coughing Up Classified</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2019/06/24/claytoon-of-the-day-operation-desert-stormy">Claytoon of the Day: Operation Desert Stormy</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2019/06/20/a-multi-factored-look-at-tusds-enrollment-decline">A Multi-Factored Look At TUSD's Enrollment Decline</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
          </ol>
        
      <div class="clear"><!-- clear --></div>
    </div>


  

    

    <script type="text/javascript">
    <!--
      Event.observe(document, "dom:loaded", function() {
        dnSetupTabGroup(
            $$("#TabbedMost div.tabs a"),
            $$("#TabbedMost div.commentsBody"),
            "tabCurrent", "tabBack", 0
        );
      });
    //-->
    </script>
  </div>
  


<div id="BigSkyscraper300x600" class="SpanningIsland TheRangeBlogPost HalfPage Ad">
  
  <!-- /4961490/TW_ROS_right_300x600 -->
          <div id="div-gpt-ad-tw_ros_right_300x600" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_300x600" data-output="asynchronous" data-width="300" data-height="600">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_300x600');
                });
              </script>
          </div>
  
</div><div id="Rectangle2" class="SpanningIsland TheRangeBlogPost Ad MediumRectangle">
  <!-- /4961490/TW_ROS_right_300x250_2 -->
          <div id="div-gpt-ad-tw_ros_right_300x250_2" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_300x250_2" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_300x250_2');
                });
              </script>
          </div>
</div><div id="Rectangle4" class="SpanningIsland TheRangeBlogPost Ad MediumRectangle">
  
  <!-- /4961490/TW_WeGotCactus_300x250_2 -->
          <div id="div-gpt-ad-tw_wegotcactus_300x250_2" style="" data-content-type="ad" data-slot="/4961490/TW_WeGotCactus_300x250_2" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_wegotcactus_300x250_2');
                });
              </script>
          </div>
  
</div><div id="Rectangle5" class="SpanningIsland TheRangeBlogPost Ad MediumRectangle">
  
  <!-- /4961490/TW_WeGotCactus_300x250_3 -->
          <div id="div-gpt-ad-tw_wegotcactus_300x250_3" style="" data-content-type="ad" data-slot="/4961490/TW_WeGotCactus_300x250_3" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_wegotcactus_300x250_3');
                });
              </script>
          </div>
  
</div>
      </div><!-- end gridSpanningIsland -->  
     
      <div id="gridMainSidebar">
        <div id="Skyscraper1" class="MainSidebar TheRangeBlogPost Ad Skyscraper">
  
  <!-- /4961490/TW_ROS_right_160x600 -->
          <div id="div-gpt-ad-tw_ros_right_160x600" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_160x600" data-output="asynchronous" data-width="160" data-height="600">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_160x600');
                });
              </script>
          </div>
  
</div>
      </div><!-- end gridMainSidebar -->

      <div id="gridAdSidebar">
        <div id="Skyscraper2" class="AdSidebar TheRangeBlogPost Ad Skyscraper">
  
  <!-- /4961490/TW_ROS_right_160x600_2 -->
          <div id="div-gpt-ad-tw_ros_right_160x600_2" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_160x600_2" data-output="asynchronous" data-width="160" data-height="600">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_160x600_2');
                });
              </script>
          </div>
  
</div>
      </div><!-- end gridAdSidebar -->
      
      <div id="gridBottomSidebar">
        <div id="BigSkyscraper300x600Ad2" class="MainSidebar TheRangeBlogPost Ad HalfPage">
  <!-- /4961490/TW_ROS_right_300x600_2 -->
          <div id="div-gpt-ad-tw_ros_right_300x600_2" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_300x600_2" data-output="asynchronous" data-width="300" data-height="600">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_300x600_2');
                });
              </script>
          </div>
</div><div id="BigSkyscraper300x6003" class="MainSidebar TheRangeBlogPost Ad HalfPage">
  <!-- /4961490/TW_ROS_right_300x600_3 -->
          <div id="div-gpt-ad-tw_ros_right_300x600_3" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_300x600_3" data-output="asynchronous" data-width="300" data-height="600">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_300x600_3');
                });
              </script>
          </div>
</div><div id="BigSkyscraper300x6004" class="MainSidebar TheRangeBlogPost Ad HalfPage">
  <!-- /4961490/TW_ROS_right_300x600_4 -->
          <div id="div-gpt-ad-tw_ros_right_300x600_4" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_300x600_4" data-output="asynchronous" data-width="300" data-height="600">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_300x600_4');
                });
              </script>
          </div>
</div><div id="BigSkyscraper300x6005" class="MainSidebar TheRangeBlogPost Ad HalfPage">
  <!-- /4961490/TW_ROS_right_300x600_5 -->
          <div id="div-gpt-ad-tw_ros_right_300x600_5" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_300x600_5" data-output="asynchronous" data-width="300" data-height="600">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_300x600_5');
                });
              </script>
          </div>
</div>
      </div>
    </div><!-- end gridRightColumn -->
    
    <!-- Footer -->
    <div id="gridFooter">
      


    <div id="FooterNavigation" class="GlobalFooter TheRangeBlogPost ">
      <ul>
  
  
  <li class="">
    <a href="https://www.tucsonweekly.com/" target="_self">
      
        home
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/opinion/Section?oid=1063711" target="_self">
      
        opinion
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/currents/Section?oid=1063709" target="_self">
      
        currents
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/cityweek/Section?oid=1063710" target="_self">
      
        city week
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/cinema/Section?oid=1063716" target="_self">
      
        cinema
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/arts/Section?oid=1063713" target="_self">
      
        arts
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/books/Section?oid=1063715" target="_self">
      
        books
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/chow/Section?oid=1063714" target="_self">
      
        chow
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/BestOf" target="_self">
      
        best of tucson®
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.facebook.com/tucsonweekly" target="_blank">
      
        Facebook
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/ArticleArchives" target="_self">
      
        archives
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/Advertising/Page" target="_self">
      
        advertising
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/PrivacyPolicy/Page" target="_self">
      
        privacy policy
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/Staff/Page" target="_self">
      
        Staff / Contact Us
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="rss-icon">
    <a href="https://www.tucsonweekly.com/tucson/Syndication/Page" target="_self">
      
        rss
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.flickr.com/photos/tucsonweekly/" target="_blank">
      
        Flickr
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.twitter.com/TucsonWeekly" target="_blank">
      
        Twitter
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/TermsConditions/Page" target="_self">
      
        terms & conditions
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://displayads.tucsonweekly.com/" target="_self">
      
        print ads
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/CommentsPolicy/Page" target="_self">
      
        comments policy
      
    </a>
    
    
  </li> 
  

      </ul>
    </div>
  





<div id="footerCopyright">
  <p>
   &copy; 2019
   Tucson Weekly |
   7225 Mona Lisa Rd. Ste. 125, Tucson AZ 85741 |
   
  (520) 797-4384 |
   Powered by <a href="http://foundation.gyrobase.com/" target="_blank">Foundation</a>
  </p>
</div><!-- start compete.com tag -->
<script type="text/javascript">
    __compete_code = '312a684a250efb96916726877042f53b';
    (function () {
        var s = document.createElement('script'),
            d = document.getElementsByTagName('head')[0] ||
                document.getElementsByTagName('body')[0],
            t = 'https:' == document.location.protocol ? 
                'https://c.compete.com/bootstrap/' : 
                'http://c.compete.com/bootstrap/';
        s.src = t + __compete_code + '/bootstrap.js';
        s.type = 'text/javascript';
        s.async = 'async'; 
        if (d) { d.appendChild(s); }
    }());
</script>
<!-- end compete.com tag --> </div>


<!-- Start Google Analytics -->
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-3905397-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'stats.g.doubleclick.net/dc.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<!-- End Google Analytics -->


<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-6cJMtQ1dR3JBg"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-6cJMtQ1dR3JBg.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->


  <img src="/foundation/images/icons/pixel.gif?oid=25346224" alt="" />


    </div><!-- end gridFooter -->

  </div><!-- end gridMain -->

</div><!-- end gridClamp -->

<!-- Closer -->
<div id="gridCloser">
  <div id="FullBackgroundAd" class="Closer TheRangeBlogPost ">
  <!-- /4961490/BackgroundAd1950x930 -->
          <div id="div-gpt-ad-backgroundad1950x930" style="" data-content-type="ad" data-slot="/4961490/BackgroundAd1950x930" data-output="asynchronous" data-width="1950" data-height="930">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-backgroundad1950x930');
                });
              </script>
          </div>
</div>
</div><!-- end gridCloser -->
    </body>
</html>
  


