































































  
           
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "https://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="https://www.w3.org/1999/xhtml" xmlns:fb="https://www.facebook.com/2008/fbml" xml:lang="en" lang="en">

<head>
  
  <meta name="viewport" content="width=1000">

  
  <meta name="layout" content="The Range Blog Post" />
  
    <meta name="oid" content="16969914" />
  
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <meta http-equiv="imagetoolbar" content="no" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />

  
  
  
  <link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=8160c33c03364a089bd94e6ac855e1e1" />

  
  
    <link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=8160c33c03364a089bd94e6ac855e1e1" />
    <link rel="stylesheet" type="text/css" href="/styles/components.css?cb=8160c33c03364a089bd94e6ac855e1e1" />
    <link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=8160c33c03364a089bd94e6ac855e1e1" />
  

  <style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>

  
    <link rel="stylesheet" type="text/css" href="/foundation/grids/iapetus-10-zone.css" />
  

  <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
  <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
  <!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
  <!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->

  <link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />

  
  
    
    
      <link rel="alternate" type="application/rss+xml" title="Tucson Weekly RSS: Whole Site" href="https://www.tucsonweekly.com/tucson/Rss.xml" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Tucson Weekly RSS: News &amp; Opinion Section" href="https://www.tucsonweekly.com/tucson/Rss.xml?oid=1063709" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Tucson Weekly RSS: The Range: The Tucson Weekly&#39;s Daily Dispatch" href="https://www.tucsonweekly.com/tucson/Rss.xml?oid=1125619" />
      
        <link rel="alternate" type="application/rss+xml" title="Tucson Weekly RSS: The Range: The Tucson Weekly&#39;s Daily Dispatch: " href="https://www.tucsonweekly.com/tucson/Rss.xml?category=1125619&amp;topic=oid%3A1169456" />
      
    

    
    
      <link rel="alternate" type="application/rss+xml" title="Tucson Weekly RSS: Comments on The Weekly List: 23 Things To Do In Tucson This Week" href="https://www.tucsonweekly.com/tucson/Rss.xml?id=comments&amp;oid=16969914" />
    
  

  
  
    <!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
      
      <script>
        if (!window.Promise) document.write('<scr'+'ipt src="https://cdnjs.cloudflare.com/ajax/libs/native-promise-only/0.8.1/npo.src.js"></scr'+'ipt>')
      </script>
    
    
    
    
    <script src="/foundation/scripts/common.js?cb=7d560144a9ca53e9f991933210f7a5d4"></script>
  
    
    
    
    
    
    
    <script src="/foundation/scripts/desktop-bundle.js?cb=7d560144a9ca53e9f991933210f7a5d4"></script>
  

  
  <link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
  <script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>

  
  <script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("https:\/\/www.tucsonweekly.com\/tucson\/Profile", "https:\/\/posting.tucsonweekly.com\/tucson\/MyProfile");
  </script>
  
  
  

  
  
    <meta name="google-signin-client_id" content="345770844416-lrktslqgimjsduaogv54o86orkjohqm1.apps.googleusercontent.com">
  

    
  

  
  
<meta name="viewport" content="width=1000" />
 
<!-- Google Fonts -->
<link href='https://fonts.googleapis.com/css?family=Anton|Open+Sans:300,400,700' rel='stylesheet' type='text/css'>
<link href='https://fonts.googleapis.com/css?family=Yanone+Kaffeesatz' rel='stylesheet' type='text/css'>
<!-- End Google Fonts -->





  
    <script type='text/javascript'>
              var googletag = googletag || {};
              googletag.cmd = googletag.cmd || [];
              (function() {
                var gads = document.createElement('script');
                gads.async = true;
                gads.type = 'text/javascript';
                var useSSL = 'https:' == document.location.protocol;
                gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(gads, node);
              })();
          </script>
          <script type='text/javascript'>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</script>
  



   <meta name="google-site-verification" content="1shMVE6r6wpDwBgxHmNKSAVS9_A0RaoG53XlEOtHOJM" />





  



<!-- Global TNCMS Ad Manager javascript files -->

<script type='text/javascript' src='https://www.insidetucsonbusiness.com/shared-content/tncms-ad-manager/ads.js'></script>
<script type='text/javascript' src='https://www.insidetucsonbusiness.com/shared-content/flowplayer/flashembed.min.js'></script>
<script type='text/javascript' src='https://www.insidetucsonbusiness.com/shared-content/swfobject/swfobject.js'></script>
<script type='text/javascript' src='https://www.insidetucsonbusiness.com/content/tncms/ads/tncms-ad-limits.js'></script>






<script>

Foundation.documentReady.then(function(){ //initialize
jQuery(".pencil-content").hide(); 
  jQuery(".pencil-top").click(function(){
      jQuery(this).next(".pencil-content").slideToggle(500);
  });

   if (document.cookie.indexOf('visited=true') == -1) {
    			        var fifteenDays = 1000*60*10;
    			        var expires = new Date((new Date()).valueOf() + fifteenDays);
    			        document.cookie = "visited=true;expires=" + expires.toUTCString();

  jQuery(".pencil-content")
   .slideToggle( function() 
   {
      setTimeout( function()
      {
         jQuery(".pencil-content").slideToggle(500);
      }, 3000);
   });
}
 });


</script>
  
  
  
  
  


  
  
  


  
  <link rel="shortcut icon" href="/favicon.ico" />
  <meta name="title" content="The Weekly List: 23 Things To Do In Tucson This Week | The Range: The Tucson Weekly&#39;s Daily Dispatch" />
  <meta name="description" content="Your Weekly guide to keeping busy in the Old Pueblo. Music Celebrating the Spectrum 2018. Desert Voices, Tucson&rsquo;s premier gay, lesbian, bisexual, transgender and ally..." />
  <meta name="keywords" content="art, music, food, summer, entertainment, celebration, second saturday, second sunday, first thursday, Arts and Culture, Do This!, The Weekly List" />
  <title>The Weekly List: 23 Things To Do In Tucson This Week | The Range: The Tucson Weekly's Daily Dispatch</title>

  
  
    <meta name="date" content="2018-06-07 12:42:00" />
  

  
  
  
    <meta name="author" content="Weekly Staff and Contributors">
  

  
  
  <meta name="news_keywords" content="art, music, food, summer, entertainment, celebration, second saturday, second sunday, first thursday, arts and culture" />

  
  
    
  
  
    <link rel="image_src" href="https://media1.fdncms.com/tucsonweekly/imager/u/slideshow/16970246/33118862_10155884805511622_3149267250620399616_o.jpg" />
    <meta name="thumbnail" content="https://media1.fdncms.com/tucsonweekly/imager/u/slideshow/16970246/33118862_10155884805511622_3149267250620399616_o.jpg" />
  

  
    
      <link rel="canonical" href="https://www.tucsonweekly.com/TheRange/archives/2018/06/07/the-weekly-list-23-things-to-do-in-tucson-this-week" />
      <link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.tucsonweekly.com/TheRange/archives/2018/06/07/the-weekly-list-23-things-to-do-in-tucson-this-week" />
      
    

    
    
    
  

  
    
      <meta property="og:url" content="https://www.tucsonweekly.com/TheRange/archives/2018/06/07/the-weekly-list-23-things-to-do-in-tucson-this-week" />
    
  

  
    <meta property="fb:app_id" content="187122448009492" />
  

  
  <meta property="og:site_name" content="Tucson Weekly" />
  <meta property="og:title" content="The Weekly List: 23 Things To Do In Tucson This Week" />
 
  
    

    
    

    
    

    <meta property="og:image" content="https://media1.fdncms.com/tucsonweekly/imager/u/slideshow/16970246/33118862_10155884805511622_3149267250620399616_o.jpg" />

    
      <meta property="og:image:width" content="625" />
      <meta property="og:image:height" content="352" />
    
  

  
  
    <meta property="og:description" content="Your Weekly guide to keeping busy in the Old Pueblo. : Music : Celebrating the Spectrum 2018. Desert Voices, Tucson&rsquo;s premier gay, lesbian, bisexual, transgender and ally chorus, is all about the idea that anyone can sing. And not just anyone on the LGBTQ+ spectrum. Anyone, regardless of creed, age, background, age, race or pizza topping preference. (Even anchovy lovers are welcome here.) For this event, Desert Voices is hosting GALA choruses from throughout Southern Arizona and Southern California to celebrate equality, diversity and the unity found in love of music. 3 to 5 p.m. Sunday, June 10. Arizona Theatre Company, Temple of Music and Art, 330 S. Scott Ave. $25 door, $20 advance, $15 student. : Summer Sizzlers&ndash;Cool Hot Jazz for the Summer. Here come the Dixie Cats, the swinging jazz group that&rsquo;s known for playing the tunes of old NOLA. Their show &ldquo;A Brief History of Jazz&rdquo; will play tunes all the way from late 19th-century ragtime to late 20th-century big band swing and trad-jazz. This is the first in the St. Philip&rsquo;s in the Hills Friends of Music summer concert series, so if you enjoy this, you can look forward to Grupo Riken, the Puerto Rican/Latin Jazz group, playing in July. 2 p.m. Sunday, June 10. St. Philip&rsquo;s in the Hills Episcopal Church, 4440 N. Campbell Ave. Suggested admission is $15. Students with ID admitted at no charge. : 1812 Overture by the Tucson Pops Orchestra. June is upon us, so it&rsquo;s only natural that, thanks to the Tucson Pops Orchestra, tunes are upon us as well. At this evening event in the park, you&rsquo;ll hear music from Miss Saigon, a Tchaikovsky piece, &ldquo;America the Beautiful,&rdquo; and, in the young conductors&rsquo; portion, even &ldquo;La Bamba.&rdquo; Grab your blanket or folding chair&mdash;heck, bring a picnic if you want&mdash;and settle in for an evening of music. 7 p.m. Sunday, June 10. DeMeester Outdoor Performance Center at Reid Park, 900 S. Randolph Way. Free. : Art : Etherton Gallery&rsquo;s Summer Exhibitions. No matter what kind of art you like, you&rsquo;ll want to make it a point to head to Etherton this summer. Their photography exhibition, &ldquo;From the Archive: Masters of 20th Century Photography,&rdquo; showcases work by American modernist photographers like Ansel Adams, Robert Frank, Annie Leibovitz and Eugene Smith. Hand-colored bird and flower photography by Tucson artist Kate Breakey will be on display in the pop-up gallery. And they&rsquo;ve also partnered with The Skateroom to display editioned artwork on skateboards (designed to be hung on the wall, but could be used for skating as well) by artists such as Andy Warhol, Shepard Fairey and Ai Wei Wei. A portion of gallery sales of the skateboards will go into a fund for Cushing Street Skate Park, a needed covered skate park for Tucson youth. On display through the end of August. Opening reception 7 to 10 p.m. Saturday, June 9. Etherton Gallery, 135 S. Sixth Ave. Free. : [jump] : Our Stories: High School Artists. Teenagers, long considered more like children or adults depending on what&rsquo;s convenient for adults in the moment, are (to borrow a phrase from teenagers) having a moment right now. This exhibit at the UA&rsquo;s Museum of Art showcases work from by artists from five high schools all over the Tucson area. Whether it&rsquo;s inspired by a prompt, a social issue, literature or even in video games, these students are making statements and making art. Art teachers from each school selected art for submission to the museum, and the museum is showing off the technical skill, creativity and ingenuity of Tucson&rsquo;s high schoolers. Exhibit is showing through Sunday, Aug. 26. Museum hours usually from 9 a.m. to 4 p.m. University of Arizona Museum of Art &amp;amp; Archive of Visual Arts, 1031 N. Olive Road. : Great Summer Art Auction. Well, the title of this event pretty much just says it all, doesn&rsquo;t it? The Madaras Gallery is having a summer art auction, and there&rsquo;s no mediocre art to be found here. The whole silent auction is two weeks long, so you have plenty of excuses to keep going back to look at the art, and to try to distract your art nemeses from outbidding you. The bidding kicks off at the gallery&rsquo;s first Thursday party from 5:30 to 7:30 p.m. on Thursday, June 7. There&rsquo;ll be wine, cheese, Diana Madaras herself and a special surprise. Silent auction ends Thursday, June 21. Gallery hours are 9 a.m. to 5 p.m. Monday through Saturday and 11 a.m. to 5 p.m. on Sundays. Madaras Gallery, 3035 N. Swan Road. : Folkert de Jong: Last Nation. Folkert de Jong, who lives and works in Amsterdam at the moment, uses his work to explore imperialism, violence, and the way we all become desensitized to atrocities over time. He doesn&rsquo;t shy away from making big statements in his sculpture and painting works, like in &ldquo;Totemism,&rdquo; where he portrays Sukarno, George Washington and Hernan Cortes. His focus is primarily on power balances, politics, war and ecology in the Netherlands, but using themes and methods that are easily understood in a U.S. context as well. In his own words, &ldquo;If we do not see ourselves as one in a vulnerable world, we will be the generation that is responsible for initiating the end of humanity.&rdquo; Mic drop. Hightail it over to MOCA to see this exhibition. Wednesday through Sunday, noon to 5 p.m. Museum of Contemporary Art, 265 S. Church Ave. $5 GA, $3 seniors, military, students. : The New Art Show: &ldquo;Paradigm Shift.&rdquo; Solar Culture Gallery is hosting a chance for you to show your art&mdash;yes, you! If you bring your art in by the evening of Thursday, June 7, they&rsquo;ll show it at this exhibition, free of charge, free of jury and free of worry. But full of fun and opportunities! In keeping with the DIY spirit, the art show&rsquo;s opening reception is a pot luck! Free of worry and jury, but full of curry? Opening reception 6 to 9 p.m. on Saturday, June 9. Solar Culture Gallery, 31 E. Toole Ave. Free. : Monthly Events : Second Saturdays at Steam Pump Ranch. Just like the rest of the year, the Oro Valley Farmer&rsquo;s Market will be at Steam Pump Ranch every Saturday from 8 a.m. to noon throughout the summer. But to make the heat a little more bearable, they&rsquo;re offering a little extra. This Saturday, there will be Fathers&rsquo; Day gift craft for kids (and hey, it can&rsquo;t hurt to pop by the craft booth to gain a little inspiration if you&rsquo;re an adult who hasn&rsquo;t picked up a gift for dad yet). The first 20 people who walk or bike on the shared-use path to the market can stop by the parks and rec booth for a $1 off coupon. Just make sure you drink plenty of water! 8 a.m. to noon. Saturday, June 9. Steam Pump Ranch, 10901 N. Oracle Road. Free entry. : Second Saturdays Downtown. You know the drill: It&rsquo;s always happenin&rsquo; downtown on a Saturday night (and it&rsquo;s usually happenin&rsquo; downtown on all the other nights). But on second Saturdays, there are drink specials too! Stop by Charro Steak (188 E. Broadway) from 4 to 6 p.m. and 9 p.m. to close, Downtown Kitchen and Cocktails (135 S. Sixth Ave) from 4 to 6 p.m., Maynards (400 N. Toole) at 10 p.m. for reverse happy hour, and Penca (50 E. Broadway) from 3 to 5 p.m. for happy hour. There are so many happy hours that you might only have to pay for a couple drinks between 6 and 9. But even then, you&rsquo;ll be downtown on a Saturday night, and what&rsquo;s not happy about that? : Second SundAZE Family Day @ TMA. Mosey on over to the Tucson Museum of Art for FREE at this event presented by the Stonewall Foundation. As if free admission to the museum&rsquo;s regular exhibits weren&rsquo;t enough, there&rsquo;s also opportunities to learn more about its Latin American Folk Art collection by making your own collage molas and tin ornaments. There&rsquo;s also storytime in the galleries at 1 p.m. and a performance by Mariachi Sonidos De Mexico at 3 p.m. Let&rsquo;s get it art-ed! 10 a.m. to 5 p.m. Sunday, June 10. Tucson Museum of Art and Historic Block, 140 N. Main Ave. Free. : Art after Dark. The Tucson Children&rsquo;s Museum is partnering with Artabilityaz this month to bring art, literature, accessibility and fun to the masses. Artabilityaz uses the arts to help young kids&mdash;including those with disabilities, to explore commonly taught themes. At the museum, they&rsquo;ll be reading a sensory-based version of the old standby, &ldquo;The Very Hungry Caterpillar,&rdquo; and leading a craft to make stick puppets of the caterpillar and the (spoiler alert) butterfly. The first 400 people who attend Art After Dark get a pass for one free visit to the museum! 5:30 to 8 p.m. Saturday, June 9. Children&rsquo;s Museum Tucson, 200 S. Sixth Ave. Free. Kids must be accompanied by adults, and vice versa. : Free First Thursday at the Tucson Museum of Art. Thursday is practically Friday, and Friday is practically the weekend, so let&rsquo;s party over at TMA! Mariachi Sonido de Mexico and Ballet Foklorico Tapatio are performing, and patrons can enjoy a temporary Mayo textiles exhibit, buy drinks, make art at several stations and stop by the Museum Store for a reception for June&rsquo;s featured artist, Heather Frietas. Frietas is an eco-art activist who creates her works using recycled materials. 5 to 8 p.m. Thursday, June 6. Tucson Museum of Art and Historic Block, 140 N. Main Ave. Free. : Especially for Summer : Cool Summer Nights. Try to ignore the fact that technically, summer hasn&rsquo;t even started yet, by learning about cooler climes at the Arizona Sonora Desert Museum. This week&rsquo;s theme is World Oceans Night, and they&rsquo;re going all out! Fini&rsquo;s Landing, Primo, Maynards, Hotel Congress and the museum&rsquo;s own Craft Culinary Concepts will be offering up free sustainable seafood tastings to get you started, and then you can spend the night exploring all sorts of activities. From Shaun Pipes, &ldquo;The Shark Guy,&rdquo; to a session on how you can help protect the world&rsquo;s oceans to a book signing by Marilyn Malone and Betty Hupp to live flute music, you&rsquo;ll be waving from the shore as you watch your troubles drift out to sea. 6 to 9 p.m. Saturday, June 9. Arizona-Sonora Desert Museum, 2021 N. Kinney Road. $22 GA, $20 seniors 65 and up, $9 kids 2 to 12, $18 military, $17 Arizona/Sonora resident. : Summer Safari Nights. Summer Safari Nights are supposed to be a nice reprieve from the dry heat of Tucson in the summer. And they are. But this week, the event comes with a little dose of irony as we celebrate World Ocean Day and the importance of water conservation. But don&rsquo;t worry&mdash;your thirst for cuteness will certainly be quenched by animals like otters, armadillos, flamingos and tapir, and your thirst for knowledge on where to find sustainable seafood will be quenched as well when you learn about programs like Seafood Watch. Plus, can&rsquo;t-miss entertainment by Shrimp Chaperone. 6 to 8 p.m. Friday, June 8. Reid Park Zoo, 3400 Zoo Court. $10.50 adults, $8.50 seniors, $6.50 kids 2 to 14. Half off for zoo members! : FC Tucson Women vs. Phoenix Del Sol. The women&rsquo;s division of Tucson&rsquo;s own semi-professional soccer club is facing off against Phoenix Del Sol, our northern neighbor&rsquo;s team, for their fourth game of the 2018 season. Whether you&rsquo;re invested in the age-old rivalry between the two cities, or whether you don&rsquo;t even understand how there could be a rivalry, when Tucson is so far superior, you won&rsquo;t want to miss these women playing their hearts out. 5:30 p.m. Friday, June 8. Kino North Stadium in the Kino Sports Complex, 2500 E. Ajo Way. See fctucson.com for more info. : Fun in General : The Pima County Home &amp;amp; Garden Show. It&rsquo;s an HGTV enthusiast&rsquo;s dream come true: free seminars on everything from how to hire the right contractor to how to save money on home maintenance, a chance to win one of three $2,500 luxury vacations, and plenty of opportunities to see the latest and greatest options for landscaping and remodeling. Spouses and partners of HGTV enthusiasts, never fear! There&rsquo;s also free food! Barbecue from Barnfire Mesquite Grill, Gelato from Blue Ice Gelato, cold brew from Yellow Brick coffee, Hawaiian barbecue from Mama&rsquo;s, ice cream from Isabella&rsquo;s and Chef Barry Infuso and made-to-order omelets from Chef Michael Briceno, the actual king of omelets. First 200 attendees each day get a free plant! And the last one there&rsquo;s a rotten egg! 10 a.m. to 6 p.m. Friday, June 8 and Saturday, June 9. 10 a.m. to 4 p.m. Sunday, June 10. Tucson Convention Center, 260 S. Church Ave. $8 GA, free for active military and kids 16 and under. Free for seniors 55+ on Friday only. There&rsquo;s a $2 off coupon on their website! : Putt-ing Kids First. Get ready to putt some golf balls on the mini-green, but not until you&rsquo;ve putted some children first. Obviously, you&rsquo;re not really going to be whacking kids at this event. In fact, you&rsquo;ll be a part of the Blair Charity Group&rsquo;s weeklong Arizona Basketball Academy camp for kids. Campers get unlimited access to games and attractions at Golf N&rsquo; Stuff (including laaaaaser taaaag), and the ticket prices include unlimited golf, bumper boats, laser tag, batting cages, arcade games, face painting, a photo booth and food. And more! Get to the green! 6 to 10 p.m. Friday, June 8. Golf N&rsquo; Stuff, 6503 E. Tanque Verde Road. $25 adults, $20 kids, $100 family pack (two adults and three kids). : Tucson Roller Derby Harry Potter Wizards Cup! Students at Hogwarts have plenty of chances to show off their skills with a broomstick, but how often do you get to see the best roller skaters in the school duke it out? The Tucson Roller Derby is hosting this event of four mini bouts (20 minutes each) to determine which house will win this year. (Last year, it was Hufflepuff!) Here&rsquo;s where it really gets fun: Audience members can pay to cast spells on the court, which range from a $5 Confundus charm to make everyone skate in the opposite direction around the court to a $10 Patronus charm to give one team an extra player to that most Unforgivable (and $100) of curses, Avada Kedavra, where you can make a skater of your choice sit in box for an entire game. All proceeds go to the nonprofit Tucson Roller Derby, and The Unday provides live entertainment. Doors open at 6 p.m. Saturday, June 9. Tucson Indoor Sports Center, 1065 W. Grant Road. $15 at door, presale tickets $10 adults, $5 kids 11 to 17. Kids 10 and under free with the purchase of an adult ticket. : District Photo Studio Grand Opening. Tucson has a new photo studio, so whether you need family photos, an engagement shoot, a boudoir session, corporate portraits, someone to photograph you wedding, or one of those fake maternity shoots where the couple is tenderly holding a giant burrito, owners Birdie and Justin will have you covered. At the grand opening, there&rsquo;ll be a food truck, a DJ, and a chance to check out the studio and learn about gear rental, studio rentals and membership options. Come a little earlier if you&rsquo;re more into the tour aspect, and a little later if you just want to party. 6 to 10 p.m. Friday, June 8. District Photo Studio, 657 W. St. Mary&rsquo;s Road, Studio C10. Free. : Nightcrawler : Fish Karma. Terry Owen and his irreverent blend of punk, wit and folk have made him&mdash;and his emotional sidekick Fish Karma&mdash;a kind of Old Pueblo Godhead. Like Zappa, Owens owns his humor, and uses it to make razor-sharp truths palatable, all in the idiom of sweet songcraft, even jangly rock &rsquo;n&rsquo; roll. That ain&rsquo;t easy to do. Most never got it. Remember when punk-rock hero Jello Biafra said that Owens writes some of the &ldquo;meanest put-downs of American consumer culture&rdquo; he&rsquo;s ever heard? We do. Biafra nailed it. Owen&rsquo;s newest work of musical performance art debuts this week with the Rock Opera launch of his new album, Time To Say Goodbye. Owens says it &ldquo;celebrates the destruction that human beings have wrought on the planetary ecosystem&rdquo; and will be released online shortly as a digital download. Hard copies are only available at the launch party, and include Owen&rsquo;s fetching, hand-painted cover art. The show will be emcee&rsquo;d by local cartoonist David Fitzsimmons. Like great theater, Time To Say Goodbye will be prickly, offensive and mad, mad, mad fun. Saturday, June 9. Club Congress, 311 E. Congress. 7 p.m. Free. &mdash;B.S. Eliot : The Sword. Armed with broad swords and a field full of plaited maidens riding white mares into the sunset, Austin&rsquo;s stoner metalers The Sword fight their way&mdash;riff-and-sorcery style&mdash;into the listener&rsquo;s cranium, and then lops it the hell off. Lugging nu-metal riffs uphold soaring Sabbath-y vocal melodies that successfully honors hard-rock history while forging suckerpunch metal to soundtrack the present and future. First discovered by Lamb of God in the early aughts, the quartet evolved from its wholly-Medieval themes into a band discovering tension in the toxic waste-dump environment that is our &ldquo;used future.&rdquo; Artfully crafted ditties like &ldquo;Sea of Green&rdquo; sidestep didacticism and simply state, &ldquo;What was your home is now a wasteland.&rdquo; Hard enough to be cathartic, but smart enough to be thought-provoking, each tune is a well-wrought, double-edged, um, sword. With The Atomic Bitchwax. Friday, June 8 at 191 Toole. Doors at 8 p.m. 21+. $20. &mdash;B.S. Eliot : Wrekonize. London-born Wrekonize is a well-spoken blend of his English mother and Capetown dad. His lyrics too are a blend&mdash;of straight-ahead confessional (&ldquo;My mom was a dancer&mdash;the exotic kind&rdquo;) and science fiction (&ldquo;I&rsquo;m surrounded by clones.&rdquo;) Wrek&rsquo;s flow betrays no British accent, instead revealing a true (manic) street preacher passion; like Brother Ali, he inhales and exhales rhymes without ever being out of breath. Wrek&rsquo;s astute and conceptual, extrapolating regional truths from London streets and broadening them to greater street life truths worldwide. And his production is killer. Currently signed to the mighty TechN9ne&rsquo;s Strange Music label, Wrek&rsquo;s spit is met with swirling synths and heartbeat bass. Every cut on a Wrekonize album, even a normally throwaway opening skit, has a reason to be there. And if he&rsquo;s &ldquo;packing heat,&rdquo; it is with the pen, not the sword&mdash;this is a refreshingly intelligent and open-eyed rapper worth many ear bends. With D. Lynch, 1TON, Double You, Tommy Will, Juan P. Simplistic and OGXO on Tuesday, June 12. Solar Culture Gallery, 31 East Toole. Doors at 7 p.m. $12-$15. All ages. &mdash;B.S. Eliot" />
  

  
  

  
  
    <meta property="og:type" content="article" />
  

  
  

    
    

    
    

    
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:image" content="https://media1.fdncms.com/tucsonweekly/imager/u/slideshow/16970246/33118862_10155884805511622_3149267250620399616_o.jpg">

    
    

    

    <meta name="twitter:site" content="@tucsonweekly">
    <meta name="twitter:title" content="The Weekly List: 23 Things To Do In Tucson This Week">
    <meta name="twitter:description" content="Your Weekly guide to keeping busy in the Old Pueblo. Music Celebrating the Spectrum 2018. Desert Voices, Tucson&rsquo;s premier gay, lesbian, bisexual, transgender and ally...">
  

  
  
  <!--
    <PageMap>
      <DataObject type="foundation">
        <Attribute name="oid">16969914</Attribute>
        <Attribute name="class">Content</Attribute>
        <Attribute name="lastmodified">20180607125122</Attribute>
        <Attribute name="creationdate">20180606083717</Attribute>
      </DataObject>

      
        
          <DataObject type="document">
            <Attribute name="releasedatetime">20180607124200</Attribute>
            <Attribute name="releasedate">20180607</Attribute>
            <Attribute name="releaseepoch">1528400520</Attribute>
            <Attribute name="title">The Weekly List: 23 Things To Do In Tucson This Week</Attribute>
            <Attribute name="author">1064055</Attribute>
            <Attribute name="authorname">Weekly Staff and Contributors</Attribute>
            <Attribute name="authorsortname">Weekly Staff and Contributors</Attribute>
          </DataObject>
        

        
      
    </PageMap>
  -->


  
  
  
  
    
    <script type="application/ld+json">
        {
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id":"https:\/\/www.tucsonweekly.com\/TheRange\/archives\/2018\/06\/07\/the-weekly-list-23-things-to-do-in-tucson-this-week"
          },
          "headline": "The Weekly List: 23 Things To Do In Tucson This Week",
          
            "description": "Your Weekly guide to keeping busy in the Old Pueblo. Music\n    Celebrating the Spectrum 2018.",
          
          
            "image": {
              "url": "https:\/\/media1.fdncms.com\/tucsonweekly\/imager\/u\/original\/16970246\/33118862_10155884805511622_3149267250620399616_o.jpg",
              "width": 2048,
              "height": 1152,
              "@type": "ImageObject"
            },
          
          "datePublished": "2018-06-07T12:42:00",
          "dateModified": "2018-06-07T12:51:22",
          
            "author": {
              "name": "Weekly Staff and Contributors",
              "@type": "Person"
            },
          
          "publisher": {
            "name": "Tucson Weekly",
            
              
              
              
              "logo": {
                "url": "https:\/\/www.tucsonweekly.com\/imager\/b\/google-amp-logo\/808579\/93e9\/adminIcon_tw.jpg",
                "width": 60,
                "height": 60,
                "@type": "ImageObject"
              },
            
            "@type": "Organization"
          },
          "@context": "https://schema.org",
          "@type": "NewsArticle"
        }
      </script>
  


</head>





  <body id="Post" class="BlogPost Iapetus10Zone newsopinion TheRange">



<div id="fb-root"></div>


  <script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>




  <script>
    (function () {
      var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
        //if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
      }.bind(this), function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
      })
    })()
  </script>
    

<!-- Leader -->
<div id="gridLeader">
  
</div><!-- end gridLeader -->

<div id="gridClamp">
  <!-- Header -->
  <div id="gridHeader">
    




  
  

  
  
  

  

    
      <div id="MobileDetect" class="GlobalHeader TheRangeBlogPost " style="display:none">
        
        
          Switch to the <a href="https://m.tucsonweekly.com/TheRange/archives/2018/06/07/the-weekly-list-23-things-to-do-in-tucson-this-week" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  

<div id="Leaderboard" class="GlobalHeader TheRangeBlogPost Leaderboard Ad">
  
    <!-- /4961490/TW_ROS_Top_728x90 -->
          <div id="div-gpt-ad-tw_ros_top_728x90" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_Top_728x90" data-output="asynchronous" data-width="728" data-height="90">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_top_728x90');
                  });
              </script>
          </div>
  
</div>

  <div id="Logo" class="GlobalHeader TheRangeBlogPost Leaderboard">
      
      <div id="header-contain">

        <div id="headerLeft">
         <div class="earAdLeft" style="width:250px;height:60px;">
               <!-- potential ad here -->
          </div>          

           <div class="headerLogin">     

            
  
            
            
              
              <ul data-view="loggedin" style="display:none">
                <li><strong data-label="username">Username</strong> / </li>
                
                <li><a href="https://posting.tucsonweekly.com/tucson/Profile/MySettings">Edit Settings</a> / </li>
                <li><a href="https://www.tucsonweekly.com/tucson/Logout">Log Out</a></li>
              </ul>

              <ul data-view="loggedout" style="display:none">
                <li><a href="#LogIn">Log in</a> / </li>
                <li><a href="#CreateAccount">Create Account</a></li>
              </ul>
            

            
            
              <script>
                new Foundation.LoginRequiredComponent("Logo");
              </script>
            
          </div> <!-- end login --> 
        </div> <!-- end headerLeft -->

         
           <div id="header-logo"><a href="https://www.tucsonweekly.com/">Tucson Weekly</a></div>    
         

         <div id="headerRight">        
          <div class="earAdRight" style="width:250px;height:60px;">
               <!-- potential ad here -->
          </div>          

         <div class="search"> 
           

            

              
              
              <form class="prepTextForm" id="searchbox_017793458706336421686:xynrvxedw04" action="https://www.tucsonweekly.com/tucson/Search">
                  <input type="hidden" name="cx" value="017793458706336421686:xynrvxedw04" />
                  <input type="hidden" name="cof" value="FORID:9" />
                  <input type="text" name="q" size="25" />
                  <input type="submit" name="sa" value="Search" />
              </form>
            
            <ul class="socialIcons">
               <li><a href="https://www.facebook.com/tucsonweekly" class="socialFBIcon">Facebook</a></li>    
               <li><a href="https://twitter.com/tucsonweekly" class="socialTweetIcon">Twitter</a></li>    
             </ul>
          </div>   <!-- end search -->

         </div> <!-- end headerRight -->
 
     </div> <!-- end headerContain -->
    </div>  <!-- end header Component --> 


















  <div id="NavigationHorizontal" class="GlobalHeader TheRangeBlogPost  ">
    
      
      
          <ul id="mainNav">
        
        

        

        

        

        <li class="first" id="NavItem_home">
          <a href="https://www.tucsonweekly.com/"  >Home</a>
        </li>
        
      
        

        

        

        

        <li class="navCurrent" id="NavItem_newsopinion">
          <a href="https://www.tucsonweekly.com/tucson/news-and-opinion/Section?oid=1063709"  class="subnav_link" id="SNAVL_newsopinion">News &amp; Opinion</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_chow">
          <a href="https://www.tucsonweekly.com/tucson/chow/Section?oid=1063714"  class="subnav_link" id="SNAVL_chow">Chow</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Events10days">
          <a href="https://www.tucsonweekly.com/tucson/Content?topic=7302251"  class="subnav_link" id="SNAVL_Events10days">Events</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_cinema">
          <a href="https://www.tucsonweekly.com/tucson/cinema/Section?oid=1063716"  class="subnav_link" id="SNAVL_cinema">Cinema</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_music">
          <a href="https://www.tucsonweekly.com/tucson/music/Section?oid=1063712"  class="subnav_link" id="SNAVL_music">Music</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_artsculture">
          <a href="https://www.tucsonweekly.com/tucson/arts-and-culture/Section?oid=1063713"  class="subnav_link" id="SNAVL_artsculture">Arts &amp; Culture</a>
        </li>
        
      
        

        

        

        

        <li class="last" id="NavItem_bestoftucson">
          <a href="https://www.tucsonweekly.com/tucson/BestOf"  class="subnav_link" id="SNAVL_bestoftucson">Best of Tucson&reg;</a>
        </li>
        
      
          </ul>
        

      
        
        
          
            <h3 class="hidden">Browse </h3>
            <ul class="subnav_content" id="SNAV_" style="display:none;">
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/books/Section?oid=1063715"  title="">Books Main Page</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063715"  title="">Books Archives</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse News &amp; Opinion</h3>
            <ul class="subnav_content" id="SNAV_newsopinion" style="display:none;">
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/currents/Section?oid=1063709"  title="">News &amp; Opinion Main Page</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/cover-story/Content?special=1125844"  title="">Cover Story</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Category?oid=1063734"  title="">Currents Features</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/editors-note/Content?category=1063766"  title="">Editor&#39;s Note</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Category?oid=1063741"  title="">Danehy</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Category?oid=3147720"  title="The Tucson Weekly's column on the local world of medical marijuana.">Medical MJ</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/ask-a-mexican/Content?category=1063806"  title="">Ask a Mexican!</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/the-skinny/Content?category=1063733"  title="">The Skinny</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/police-dispatch/Category?oid=1063770"  title="">Police Dispatch</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/media-watch/Category?oid=1063784"  title="">Media Watch</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/guest-commentary/Category?oid=1063786"  title="">Guest Commentary</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/dust-devils/Category?oid=4921545"  title="Please send letters to Tucson Weekly, 7225 N. Mona Lisa Road, Suite 125, Tucson, AZ 85741 or email to mari@tucsonlocalmedia.com. Dust Devil, 70-word short stories, are due Friday, Noon. Get busy, Tucson.">Dust Devils</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?category=5928956"  title="">Tucson Salvage</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/letters-to-the-editor/Category?oid=4921578"  title="">Letters to the Editor</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/blogs/TheRange/"  title="">The Range</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Events</h3>
            <ul class="subnav_content" id="SNAV_Events10days" style="display:none;">
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=Today"  title="">Events Today</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?feature=Staff%20Pick&sortType=Date"  title="">Staff Pick Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107349"  title="">Bulletin Board</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch"  title="">Location Guide</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Events/AddEvent"  title="">Submit an Event Listing</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Cinema</h3>
            <ul class="subnav_content" id="SNAV_cinema" style="display:none;">
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/cinema/Section?oid=1063716"  title="">Cinema Main Page</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/now-showing-at-home/Category?oid=1063785"  title="">Now Showing at Home</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063716"  title="">Cinema Archives</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Music</h3>
            <ul class="subnav_content" id="SNAV_music" style="display:none;">
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/music/Section?oid=1063712"  title="">Music Main Page</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Category?oid=1063737"  title="">Music Features</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/soundbites/Content?category=1063738"  title="">Soundbites</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/live/Content?category=1063790"  title="">Live</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107701&sortType=Date"  title="">Live Music Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?oid=1113914&amp;locationCategory=1113914"  title="">Bars</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113974&sortType=name"  title="">Music Venues</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063712"  title="">Music Archives</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Events/AddEvent"  title="">Submit Club Listings</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Arts &amp; Culture</h3>
            <ul class="subnav_content" id="SNAV_artsculture" style="display:none;">
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/arts/Section?oid=1063713"  title="">Arts Main Page</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/category?oid=1063742"  title="">Book Features</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107327&sortType=Date"  title="">Art Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113916"  title="">Galleries</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107325&sortType=Date"  title="">Museum Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113923"  title="">Museums</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107320&sortType=Date"  title="">Theater Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113917"  title="">Theaters</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107323&sortType=Date"  title="">Dance Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113925"  title="">Bookstores</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113933"  title="">Coffee Houses</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113924"  title="">Libraries</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107335&sortType=Date"  title="">Literature Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063713"  title="">Arts Archives</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Events/AddEvent"  title="">Submit an Event Listing</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Chow</h3>
            <ul class="subnav_content" id="SNAV_chow" style="display:none;">
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/chow/Section?oid=1063714"  title="">Chow Main Page</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Category?oid=1063740"  title="">Chow Features</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationSection=1113936"  title="">Restaurants</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationSection=1113936&feature=Menu"  title="">Restaurant Menus</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/CommentArchives?feature=Locations&locationSection=1113936"  title="">Reader Reviews</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063714"  title="">Chow Archives</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?category=1063794"  title="">Yum! Archives</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Best of Tucson&reg;</h3>
            <ul class="subnav_content" id="SNAV_bestoftucson" style="display:none;">
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Survey?survey=16173761"  title="">Best of Tucson 2018 Ballot</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/BestOf"  title="">Best of Tucson&reg; Main Page</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/arts-and-culture/BestOf?category=1063746"  title="">Best of Tucson&reg;: Arts &amp; Culture</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/city-life/BestOf?category=1063748"  title="">Best of Tucson&reg;: City Life</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/BestOf?category=1063749&year=2011"  title="">Best of Tucson&reg;: Casual Dining</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/BestOf?category=3153201"  title="">Best of Tucson&reg;: &iexcl;Cultura!</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/BestOf?category=3153674&year=2011"  title="">Best of Tucson&reg;: Fashion + Style</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/BestOf?category=1063749"  title="">Best of Tucson&reg;: Kids&#39; Stuff</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/BestOf?category=1063781"  title="">Best of Tucson&reg;: Media Mix</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/outdoors/BestOf?category=1063750"  title="">Best of Tucson&reg;: Outdoors</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/kids-stuff/BestOf?category=1063782"  title="">Best of Tucson&reg;: Restaurants</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/spirits/BestOf?category=1063752"  title="">Best of Tucson&reg;: Spirits &amp; Nightlife</a>
          </li>
          
            </ul>
          
        

        

        
        
        
      
    
  </div>


  

  
  
  
    
    

      

      <script>
      "use strict";
      (function(){
        //
        if(navigator.userAgent.match(/\b(iPad|iPhone|iPod|Android|Pre|BlackBerry|Windows Phone)\b/i)){
          //
          //
            jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
          //
          //

        //
        }else{
          jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
        }
      })();
      </script>
    
  
  <!-- true == "true"
         && true == "devel" -->


<!-- End #NavigationHorizontal -->


    <div id="NavigationSubLinks" class="GlobalHeader TheRangeBlogPost ">
      <ul class="subnavlinks">
  
  
  
  

  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/IssueArchives" target="_self">Issues</a>
  </li>

  

  
  
  

  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/Newsletter" target="_self">Newsletter Signup</a>
  </li>

  

  
  
  

  <li class="">
    <a href="http://issuu.com/tucsonweekly/docs" target="_blank">Online Edition</a>
  </li>

  

  
  
  

  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/Events/AddEvent" target="_self">Submit A Listing</a>
  </li>

  

  
  
  

  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/ArticleArchives" target="_self">archives</a>
  </li>

  

  
  
  

  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/dust-devils/Content?category=4921545" target="_self">Dust Devils</a>
  </li>

  

  
  
  

  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/WhereCanIGetaTucsonWeekly/Page" target="_self">Find a Weekly</a>
  </li>

  

      </ul>
    </div>
  




  </div><!-- end gridHeader -->

  <div id="gridMain">

    <div id="gridFrame">

      <div id="gridSpanningFeature">
        


      

  <div id="BlogHeaderCategoryList" class="SpanningFeature TheRangeBlogPost  topic_arts-and-culture">
    <h1 class="TheRange">
      
        <a href="https://www.tucsonweekly.com/blogs/TheRange/">The Range: The Tucson Weekly's Daily Dispatch</a>
      
    </h1>

    <p style="float:left;">
      <a href="https://www.tucsonweekly.com/tucson/TheRange/blogs/Archives">Archives</a> | 
      <a href="/tucson/Rss.xml?category=1125619">RSS</a>
    </p>

    <p style="padding-left:150px;text-align:right;">
      <strong>Blog Categories:</strong>
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/politics/">Politics</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/news/">News</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/music/">Music</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/do-this/">Do This!</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/chow/">Chow</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/media/">Media</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/cinema/">Cinema</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/education/">Education</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/arts-and-culture/">Arts and Culture</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/fun-in-general/">Fun in General</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/sports/">Sports</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/tv/">TV</a> |  
      
      <a href="https://www.tucsonweekly.com/tucson/TheRange/blogs/Archives">more&nbsp;categories&raquo;</a>
    </p>

  </div>





  
  

  <div id="BlogsPreviousNext" class="SpanningFeature TheRangeBlogPost ">
    <div class="prevNext">
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/31/know-your-product-the-sword" class="prev" rel="prev">&laquo;&nbsp;Know Your Product - The Sword</a>
        
    </div>
  </div>








  
  <link type="text/css" href="/foundation/scripts/jplayer/skin/jplayer.blue.monday.css" rel="stylesheet" />
  <script type="text/javascript" src="/foundation/scripts/jplayer/jquery.jplayer.min.js"></script>               
  
    <style>
    div.jp-audio,
    div.jp-video {
      /* Edit the font-size to counteract inherited font sizing.
       * Eg. 1.25em = 1 / 0.8em
       */
      font-size:1.25em;
    }      
    div.postBody div.inlineAudio,
    div#AudioPlayer div.inlineAudio {
      width: 400px;
      margin: auto;
      clear:both;
      }      
    </style>
  

  <div id="BlogsBlogPost" class="SpanningFeature TheRangeBlogPost  topicView topic_arts-and-culture">

    

    













    
    
    
    
  
    
      
      
        <h2 class="blogDate">Thursday, June  7, 2018</h2>
      
    
      
      <div class="blogPost therange topic-arts-and-culture topic-do-this topic-the-weekly-list">
    
    
      <div class="postCategories">
                
        <span class="postCategory CategoryTheRange">
          <a href="https://www.tucsonweekly.com/TheRange/archives/arts-and-culture/" class="topic-arts-and-culture">Arts and Culture</a> / <a href="https://www.tucsonweekly.com/TheRange/archives/do-this/" class="topic-do-this">Do This!</a> / <a href="https://www.tucsonweekly.com/TheRange/archives/the-weekly-list/" class="topic-the-weekly-list">The Weekly List</a>
        </span>
      </div>
    
    <h3 class="postTitle" id="a16969914">
      
      
      
      
      
      
        The Weekly List: 23 Things To Do In Tucson This Week
      

      
    </h3>

    

    
      <h4 class="postedBy">
        
        <span class="byAttribute">Posted</span>
        
          
          <span class="byAttribute">By</span> <a href="https://www.tucsonweekly.com/author/weekly-staff-and-contributors" rel="author">Weekly Staff and Contributors</a>
        
        
          
            on <span class="postTime">Thu, Jun  7, 2018</span> at <span class="postTime">12:42 PM</span>
          
        
           
      </h4>
    

   
    
    

    

    
    

    
    

    <div class="postBody">
      
          
      


      
     
       
      
      
      
      
       
      
      

      
      

      
      
        
        Your <i>Weekly</i> guide to keeping busy in the Old Pueblo.<br>
  
<h2 class="content_h2">Music</h2>
  <div class="contentImageCenter" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media2.fdncms.com/tucsonweekly/imager/u/original/16970249/celebrating_the_spectrum.jpg" class="zoomable" rel="contentImg_gal-16969914" title="">                  <img src="https://media2.fdncms.com/tucsonweekly/imager/u/blog/16970249/celebrating_the_spectrum.jpg?cb=1528304890" width="625" height="326" alt="celebrating_the_spectrum.jpg" />                </a>                                                                                                           <ul style="width:625px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <a href="http://www.desertvoices.org/content.aspx?page_id=0&amp;club_id=406098" target="_blank">Celebrating the Spectrum 2018</a>. Desert Voices, Tucson’s premier gay, lesbian, bisexual, transgender and ally chorus, is all about the idea that anyone can sing. And not just anyone on the LGBTQ+ spectrum. Anyone, regardless of creed, age, background, age, race or pizza topping preference. (Even anchovy lovers are welcome here.) For this event, Desert Voices is hosting GALA choruses from throughout Southern Arizona and Southern California to celebrate equality, diversity and the unity found in love of music. 3 to 5 p.m. Sunday, June 10. Arizona Theatre Company, Temple of Music and Art, 330 S. Scott Ave. $25 door, $20 advance, $15 student.<br>
 <br>
 <!——StartFragment——><a href="https://www.facebook.com/friendsofmusictucson/" target="_blank" style="color: rgb(204, 0, 0); text-decoration: none; font-weight: bold; font-family: &quot;Lucida Grande&quot;, &quot;Lucida Sans Unicode&quot;, Arial, Helvetica, sans-serif; font-size: 13px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px;">Summer Sizzlers–Cool Hot Jazz for the Summer</a>. Here come the Dixie Cats, the swinging jazz group that’s known for playing the tunes of old NOLA. Their show “A Brief History of Jazz” will play tunes all the way from late 19th-century ragtime to late 20th-century big band swing and trad-jazz. This is the first in the St. Philip’s in the Hills Friends of Music summer concert series, so if you enjoy this, you can look forward to Grupo Riken, the Puerto Rican/Latin Jazz group, playing in July. 2 p.m. Sunday, June 10. St. Philip’s in the Hills Episcopal Church, 4440 N. Campbell Ave. Suggested admission is $15. Students with ID admitted at no charge.<br style="color: rgb(34, 34, 34); font-family: &quot;Lucida Grande&quot;, &quot;Lucida Sans Unicode&quot;, Arial, Helvetica, sans-serif; font-size: 13px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; text-decoration-style: initial; text-decoration-color: initial;">
 <br style="color: rgb(34, 34, 34); font-family: &quot;Lucida Grande&quot;, &quot;Lucida Sans Unicode&quot;, Arial, Helvetica, sans-serif; font-size: 13px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; text-decoration-style: initial; text-decoration-color: initial;">
 <a href="https://www.tucsonpops.org/june-10-mdash-1812-overture.html" target="_blank" style="color: rgb(204, 0, 0); text-decoration: none; font-weight: bold; font-family: &quot;Lucida Grande&quot;, &quot;Lucida Sans Unicode&quot;, Arial, Helvetica, sans-serif; font-size: 13px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px;">1812 Overture by the Tucson Pops Orchestra</a>. June is upon us, so it’s only natural that, thanks to the Tucson Pops Orchestra, tunes are upon us as well. At this evening event in the park, you’ll hear music from Miss Saigon, a Tchaikovsky piece, “America the Beautiful,” and, in the young conductors’ portion, even “La Bamba.” Grab your blanket or folding chair—heck, bring a picnic if you want—and settle in for an evening of music. 7 p.m. Sunday, June 10. DeMeester Outdoor Performance Center at Reid Park, 900 S. Randolph Way. Free.<br>
  
<h2 class="content_h2">Art</h2>
  <div class="contentImageCenter" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media2.fdncms.com/tucsonweekly/imager/u/original/16970243/etherton_gallery.gif" class="zoomable" rel="contentImg_gal-16969914" title="">                  <img src="https://media2.fdncms.com/tucsonweekly/imager/u/blog/16970243/etherton_gallery.gif?cb=1528304890" width="625" height="333" alt="etherton_gallery.gif" />                </a>                                                                                                           <ul style="width:625px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <a href="http://www.ethertongallery.com/" target="_blank">Etherton Gallery’s Summer Exhibitions</a>. No matter what kind of art you like, you’ll want to make it a point to head to Etherton this summer. Their photography exhibition, “From the Archive: Masters of 20th Century Photography,” showcases work by American modernist photographers like Ansel Adams, Robert Frank, Annie Leibovitz and Eugene Smith. Hand-colored bird and flower photography by Tucson artist Kate Breakey will be on display in the pop-up gallery. And they’ve also partnered with The Skateroom to display editioned artwork on skateboards (designed to be hung on the wall, but could be used for skating as well) by artists such as Andy Warhol, Shepard Fairey and Ai Wei Wei. A portion of gallery sales of the skateboards will go into a fund for Cushing Street Skate Park, a needed covered skate park for Tucson youth. On display through the end of August. Opening reception 7 to 10 p.m. Saturday, June 9. Etherton Gallery, 135 S. Sixth Ave. Free.<br>
 <br>
  
<a name="more"></a>

  <a href="http://artmuseum.arizona.edu/events/event/stories-high-school-artists#" target="_blank">Our Stories: High School Artists</a>. Teenagers, long considered more like children or adults depending on what’s convenient for adults in the moment, are (to borrow a phrase from teenagers) having a moment right now. This exhibit at the UA’s Museum of Art showcases work from by artists from five high schools all over the Tucson area. Whether it’s inspired by a prompt, a social issue, literature or even in video games, these students are making statements and making art. Art teachers from each school selected art for submission to the museum, and the museum is showing off the technical skill, creativity and ingenuity of Tucson’s high schoolers. Exhibit is showing through Sunday, Aug. 26. Museum hours usually from 9 a.m. to 4 p.m. University of Arizona Museum of Art &amp; Archive of Visual Arts, 1031 N. Olive Road.<br>
 <br>
 <a href="https://www.madaras.com/gallery-events" target="_blank">Great Summer Art Auction</a>. Well, the title of this event pretty much just says it all, doesn’t it? The Madaras Gallery is having a summer art auction, and there’s no mediocre art to be found here. The whole silent auction is two weeks long, so you have plenty of excuses to keep going back to look at the art, and to try to distract your art nemeses from outbidding you. The bidding kicks off at the gallery’s first Thursday party from 5:30 to 7:30 p.m. on Thursday, June 7. There’ll be wine, cheese, Diana Madaras herself and a special surprise. Silent auction ends Thursday, June 21. Gallery hours are 9 a.m. to 5 p.m. Monday through Saturday and 11 a.m. to 5 p.m. on Sundays. Madaras Gallery, 3035 N. Swan Road.<br>
 <br>
  <div class="contentImageRight" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media2.fdncms.com/tucsonweekly/imager/u/original/16970742/10257863_10153173483935982_8877125137504377578_o.jpg" class="zoomable" rel="contentImg_gal-16969914" title="">                  <img src="https://media2.fdncms.com/tucsonweekly/imager/u/blog/16970742/10257863_10153173483935982_8877125137504377578_o.jpg?cb=1528305706" width="250" height="188" alt="10257863_10153173483935982_8877125137504377578_o.jpg" />                </a>                                                                                                           <ul style="width:250px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <a href="https://moca-tucson.org/exhibition/folkert-de-jong/" target="_blank">Folkert de Jong: Last Nation</a>. Folkert de Jong, who lives and works in Amsterdam at the moment, uses his work to explore imperialism, violence, and the way we all become desensitized to atrocities over time. He doesn’t shy away from making big statements in his sculpture and painting works, like in “Totemism,” where he portrays Sukarno, George Washington and Hernan Cortes. His focus is primarily on power balances, politics, war and ecology in the Netherlands, but using themes and methods that are easily understood in a U.S. context as well. In his own words, “If we do not see ourselves as one in a vulnerable world, we will be the generation that is responsible for initiating the end of humanity.” Mic drop. Hightail it over to MOCA to see this exhibition. Wednesday through Sunday, noon to 5 p.m. Museum of Contemporary Art, 265 S. Church Ave. $5 GA, $3 seniors, military, students.<br>
 <br>
 <a href="https://www.facebook.com/events/2084254335230648/?active_tab=about" target="_blank">The New Art Show: “Paradigm Shift.”</a> Solar Culture Gallery is hosting a chance for you to show your art—yes, you! If you bring your art in by the evening of Thursday, June 7, they’ll show it at this exhibition, free of charge, free of jury and free of worry. But full of fun and opportunities! In keeping with the DIY spirit, the art show’s opening reception is a pot luck! Free of worry and jury, but full of curry? Opening reception 6 to 9 p.m. on Saturday, June 9. Solar Culture Gallery, 31 E. Toole Ave. Free.<br>
 <br>
  
<h2 class="content_h2">Monthly Events</h2>
  <div class="contentImageRight" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media2.fdncms.com/tucsonweekly/imager/u/original/16970244/2nd_saturdays_steam_pump_ranch.jpg" class="zoomable" rel="contentImg_gal-16969914" title="">                  <img src="https://media2.fdncms.com/tucsonweekly/imager/u/blog/16970244/2nd_saturdays_steam_pump_ranch.jpg?cb=1528304890" width="250" height="156" alt="2nd_saturdays_steam_pump_ranch.jpg" />                </a>                                                                                                           <ul style="width:250px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <a href="https://www.orovalleyaz.gov/parksandrec/calendar/second-saturdays-steam-pump-ranch" target="_blank">Second Saturdays at Steam Pump Ranch</a>. Just like the rest of the year, the Oro Valley Farmer’s Market will be at Steam Pump Ranch every Saturday from 8 a.m. to noon throughout the summer. But to make the heat a little more bearable, they’re offering a little extra. This Saturday, there will be Fathers’ Day gift craft for kids (and hey, it can’t hurt to pop by the craft booth to gain a little inspiration if you’re an adult who hasn’t picked up a gift for dad yet). The first 20 people who walk or bike on the shared-use path to the market can stop by the parks and rec booth for a $1 off coupon. Just make sure you drink plenty of water! 8 a.m. to noon. Saturday, June 9. Steam Pump Ranch, 10901 N. Oracle Road. Free entry.<br>
 <br>
 <!——StartFragment——><a href="http://www.2ndsaturdaysdowntown.com/" target="_blank" style="color: rgb(204, 0, 0); text-decoration: none; font-weight: bold; font-family: &quot;Lucida Grande&quot;, &quot;Lucida Sans Unicode&quot;, Arial, Helvetica, sans-serif; font-size: 13px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px;">Second Saturdays Downtown</a>. You know the drill: It’s always happenin’ downtown on a Saturday night (and it’s usually happenin’ downtown on all the other nights). But on second Saturdays, there are drink specials too! Stop by Charro Steak (188 E. Broadway) from 4 to 6 p.m. and 9 p.m. to close, Downtown Kitchen and Cocktails (135 S. Sixth Ave) from 4 to 6 p.m., Maynards (400 N. Toole) at 10 p.m. for reverse happy hour, and Penca (50 E. Broadway) from 3 to 5 p.m. for happy hour. There are so many happy hours that you might only have to pay for a couple drinks between 6 and 9. But even then, you’ll be downtown on a Saturday night, and what’s not happy about that?<!——EndFragment——><br>
 <br>
 <br>
  <div class="contentImageCenter" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/tucsonweekly/imager/u/original/16970246/33118862_10155884805511622_3149267250620399616_o.jpg" class="zoomable" rel="contentImg_gal-16969914" title="">                  <img src="https://media1.fdncms.com/tucsonweekly/imager/u/blog/16970246/33118862_10155884805511622_3149267250620399616_o.jpg?cb=1528304890" width="625" height="352" alt="33118862_10155884805511622_3149267250620399616_o.jpg" />                </a>                                                                                                           <ul style="width:625px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <a href="https://www.facebook.com/events/624534914547808/" target="_blank">Second SundAZE Family Day @ TMA</a>. Mosey on over to the Tucson Museum of Art for FREE at this event presented by the Stonewall Foundation. As if free admission to the museum’s regular exhibits weren’t enough, there’s also opportunities to learn more about its Latin American Folk Art collection by making your own collage molas and tin ornaments. There’s also storytime in the galleries at 1 p.m. and a performance by Mariachi Sonidos De Mexico at 3 p.m. Let’s get it art-ed! 10 a.m. to 5 p.m. Sunday, June 10. Tucson Museum of Art and Historic Block, 140 N. Main Ave. Free.<br>
 <br>
 <!——StartFragment——> <div class="contentImageCenter" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/tucsonweekly/imager/u/original/16970248/33965463_1915938115107375_7269461422424195072_o.jpg" class="zoomable" rel="contentImg_gal-16969914" title="">                  <img src="https://media1.fdncms.com/tucsonweekly/imager/u/blog/16970248/33965463_1915938115107375_7269461422424195072_o.jpg?cb=1528304890" width="625" height="352" alt="33965463_1915938115107375_7269461422424195072_o.jpg" />                </a>                                                                                                           <ul style="width:625px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <a href="https://www.facebook.com/events/1976624122667240/" target="_blank" style="color: rgb(204, 0, 0); text-decoration: none; font-weight: bold; font-family: &quot;Lucida Grande&quot;, &quot;Lucida Sans Unicode&quot;, Arial, Helvetica, sans-serif; font-size: 13px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px;">Art after Dark</a>. The Tucson Children’s Museum is partnering with Artabilityaz this month to bring art, literature, accessibility and fun to the masses. Artabilityaz uses the arts to help young kids—including those with disabilities, to explore commonly taught themes. At the museum, they’ll be reading a sensory-based version of the old standby, “The Very Hungry Caterpillar,” and leading a craft to make stick puppets of the caterpillar and the (spoiler alert) butterfly. The first 400 people who attend Art After Dark get a pass for one free visit to the museum! 5:30 to 8 p.m. Saturday, June 9. Children’s Museum Tucson, 200 S. Sixth Ave. Free. Kids must be accompanied by adults, and vice versa.<!——EndFragment——><br>
 <br>
  <div class="contentImageRight" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/tucsonweekly/imager/u/original/16970245/32202971_10155859641186622_3906859688762802176_o.jpg" class="zoomable" rel="contentImg_gal-16969914" title="">                  <img src="https://media1.fdncms.com/tucsonweekly/imager/u/blog/16970245/32202971_10155859641186622_3906859688762802176_o.jpg?cb=1528304890" width="250" height="141" alt="32202971_10155859641186622_3906859688762802176_o.jpg" />                </a>                                                                                                           <ul style="width:250px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <a href="https://www.facebook.com/events/238897170192572/" target="_blank">Free First Thursday at the Tucson Museum of Art</a>. Thursday is practically Friday, and Friday is practically the weekend, so let’s party over at TMA! Mariachi Sonido de Mexico and Ballet Foklorico Tapatio are performing, and patrons can enjoy a temporary Mayo textiles exhibit, buy drinks, make art at several stations and stop by the Museum Store for a reception for June’s featured artist, Heather Frietas. Frietas is an eco-art activist who creates her works using recycled materials. 5 to 8 p.m. Thursday, June 6. Tucson Museum of Art and Historic Block, 140 N. Main Ave. Free.<br>
 <br>
  
<h2 class="content_h2">Especially for Summer</h2>
  <div class="contentImageCenter" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/tucsonweekly/imager/u/original/16970250/cool_summer_nights.jpg" class="zoomable" rel="contentImg_gal-16969914" title="">                  <img src="https://media1.fdncms.com/tucsonweekly/imager/u/blog/16970250/cool_summer_nights.jpg?cb=1528304890" width="625" height="156" alt="cool_summer_nights.jpg" />                </a>                                                                                                           <ul style="width:625px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <a href="http://www.desertmuseum.org/visit/events_saturday.php?ref=hp" target="_blank">Cool Summer Nights</a>. Try to ignore the fact that technically, summer hasn’t even started yet, by learning about cooler climes at the Arizona Sonora Desert Museum. This week’s theme is World Oceans Night, and they’re going all out! Fini’s Landing, Primo, Maynards, Hotel Congress and the museum’s own Craft Culinary Concepts will be offering up free sustainable seafood tastings to get you started, and then you can spend the night exploring all sorts of activities. From Shaun Pipes, “The Shark Guy,” to a session on how you can help protect the world’s oceans to a book signing by Marilyn Malone and Betty Hupp to live flute music, you’ll be waving from the shore as you watch your troubles drift out to sea. 6 to 9 p.m. Saturday, June 9. Arizona-Sonora Desert Museum, 2021 N. Kinney Road. $22 GA, $20 seniors 65 and up, $9 kids 2 to 12, $18 military, $17 Arizona/Sonora resident.<br>
 <br>
 <a href="https://reidparkzoo.org/event/summer-safari-friday-nights-2018/" target="_blank">Summer Safari Nights</a>. Summer Safari Nights are supposed to be a nice reprieve from the dry heat of Tucson in the summer. And they are. But this week, the event comes with a little dose of irony as we celebrate World Ocean Day and the importance of water conservation. But don’t worry—your thirst for cuteness will certainly be quenched by animals like otters, armadillos, flamingos and tapir, and your thirst for knowledge on where to find sustainable seafood will be quenched as well when you learn about programs like Seafood Watch. Plus, can’t-miss entertainment by Shrimp Chaperone. 6 to 8 p.m. Friday, June 8. Reid Park Zoo, 3400 Zoo Court. $10.50 adults, $8.50 seniors, $6.50 kids 2 to 14. Half off for zoo members!<br>
 <br>
 <a href="https://www.fctucson.com/2018fctwschedule" target="_blank">FC Tucson Women vs. Phoenix Del Sol</a>. The women’s division of Tucson’s own semi-professional soccer club is facing off against Phoenix Del Sol, our northern neighbor’s team, for their fourth game of the 2018 season. Whether you’re invested in the age-old rivalry between the two cities, or whether you don’t even understand how there could be a rivalry, when Tucson is so far superior, you won’t want to miss these women playing their hearts out. 5:30 p.m. Friday, June 8. Kino North Stadium in the Kino Sports Complex, 2500 E. Ajo Way. See fctucson.com for more info.<br>
 <br>
  
<h2 class="content_h2">Fun in General</h2>
  <div class="contentImageCenter" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media2.fdncms.com/tucsonweekly/imager/u/original/16970251/33422529_1877505438968616_2401180292363583488_o.jpg" class="zoomable" rel="contentImg_gal-16969914" title="">                  <img src="https://media2.fdncms.com/tucsonweekly/imager/u/blog/16970251/33422529_1877505438968616_2401180292363583488_o.jpg?cb=1528304890" width="625" height="287" alt="33422529_1877505438968616_2401180292363583488_o.jpg" />                </a>                                                                                                           <ul style="width:625px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <a href="https://www.asihomeshows.com/pima" target="_blank">The Pima County Home &amp; Garden Show</a>. It’s an HGTV enthusiast’s dream come true: free seminars on everything from how to hire the right contractor to how to save money on home maintenance, a chance to win one of three $2,500 luxury vacations, and plenty of opportunities to see the latest and greatest options for landscaping and remodeling. Spouses and partners of HGTV enthusiasts, never fear! There’s also free food! Barbecue from Barnfire Mesquite Grill, Gelato from Blue Ice Gelato, cold brew from Yellow Brick coffee, Hawaiian barbecue from Mama’s, ice cream from Isabella’s and Chef Barry Infuso and made-to-order omelets from Chef Michael Briceno, the actual king of omelets. First 200 attendees each day get a free plant! And the last one there’s a rotten egg! 10 a.m. to 6 p.m. Friday, June 8 and Saturday, June 9. 10 a.m. to 4 p.m. Sunday, June 10. Tucson Convention Center, 260 S. Church Ave. $8 GA, free for active military and kids 16 and under. Free for seniors 55+ on Friday only. There’s a $2 off coupon on their website!<br>
 <br>
 <a href="http://blaircharitygroup.org/putting-kids-first/" target="_blank">Putt-ing Kids First</a>. Get ready to putt some golf balls on the mini-green, but not until you’ve putted some children first. Obviously, you’re not really going to be whacking kids at this event. In fact, you’ll be a part of the Blair Charity Group’s weeklong Arizona Basketball Academy camp for kids. Campers get unlimited access to games and attractions at Golf N’ Stuff (including laaaaaser taaaag), and the ticket prices include unlimited golf, bumper boats, laser tag, batting cages, arcade games, face painting, a photo booth and food. And more! Get to the green! 6 to 10 p.m. Friday, June 8. Golf N’ Stuff, 6503 E. Tanque Verde Road. $25 adults, $20 kids, $100 family pack (two adults and three kids).<br>
 <br>
  <div class="contentImageCenter" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media2.fdncms.com/tucsonweekly/imager/u/original/16970247/33403286_10155163513940044_2179385509728485376_o.jpg" class="zoomable" rel="contentImg_gal-16969914" title="">                  <img src="https://media2.fdncms.com/tucsonweekly/imager/u/blog/16970247/33403286_10155163513940044_2179385509728485376_o.jpg?cb=1528304890" width="625" height="351" alt="33403286_10155163513940044_2179385509728485376_o.jpg" />                </a>                                                                                                           <ul style="width:625px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <a href="https://www.facebook.com/events/362777364129278/" target="_blank">Tucson Roller Derby Harry Potter Wizards Cup!</a> Students at Hogwarts have plenty of chances to show off their skills with a broomstick, but how often do you get to see the best roller skaters in the school duke it out? The Tucson Roller Derby is hosting this event of four mini bouts (20 minutes each) to determine which house will win this year. (Last year, it was Hufflepuff!) Here’s where it really gets fun: Audience members can pay to cast spells on the court, which range from a $5 Confundus charm to make everyone skate in the opposite direction around the court to a $10 Patronus charm to give one team an extra player to that most Unforgivable (and $100) of curses, Avada Kedavra, where you can make a skater of your choice sit in box for an entire game. All proceeds go to the nonprofit Tucson Roller Derby, and The Unday provides live entertainment. Doors open at 6 p.m. Saturday, June 9. Tucson Indoor Sports Center, 1065 W. Grant Road. $15 at door, presale tickets $10 adults, $5 kids 11 to 17. Kids 10 and under free with the purchase of an adult ticket.<br>
 <br>
 <a href="https://www.facebook.com/events/2169955106572288/" target="_blank">District Photo Studio Grand Opening</a>. Tucson has a new photo studio, so whether you need family photos, an engagement shoot, a boudoir session, corporate portraits, someone to photograph you wedding, or one of those fake maternity shoots where the couple is tenderly holding a giant burrito, owners Birdie and Justin will have you covered. At the grand opening, there’ll be a food truck, a DJ, and a chance to check out the studio and learn about gear rental, studio rentals and membership options. Come a little earlier if you’re more into the tour aspect, and a little later if you just want to party. 6 to 10 p.m. Friday, June 8. District Photo Studio, 657 W. St. Mary’s Road, Studio C10. Free.<br>
 <br>
  
<h2 class="content_h2">Nightcrawler</h2>
  <div class="contentImageCenter" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/tucsonweekly/imager/u/original/16970638/fish_karma.jpg" class="zoomable" rel="contentImg_gal-16969914" title="">                  <img src="https://media1.fdncms.com/tucsonweekly/imager/u/blog/16970638/fish_karma.jpg?cb=1528305001" width="625" height="415" alt="fish_karma.jpg" />                </a>                                                                                                           <ul style="width:625px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <a href="http://hotelcongress.com/music/fish-karma-record-release-rock-opera/" target="_blank">Fish Karma</a>. Terry Owen and his irreverent blend of punk, wit and folk have made him—and his emotional sidekick Fish Karma—a kind of Old Pueblo Godhead. Like Zappa, Owens owns his humor, and uses it to make razor-sharp truths palatable, all in the idiom of sweet songcraft, even jangly rock ’n’ roll. That ain’t easy to do. Most never got it. Remember when punk-rock hero Jello Biafra said that Owens writes some of the “meanest put-downs of American consumer culture” he’s ever heard? We do. Biafra nailed it. Owen’s newest work of musical performance art debuts this week with the Rock Opera launch of his new album, <i>Time To Say Goodbye</i>. Owens says it “celebrates the destruction that human beings have wrought on the planetary ecosystem” and will be released online shortly as a digital download. Hard copies are only available at the launch party, and include Owen’s fetching, hand-painted cover art. The show will be emcee’d by local cartoonist David Fitzsimmons. Like great theater, <i>Time To Say Goodbye</i> will be prickly, offensive and mad, mad, mad fun. Saturday, June 9. Club Congress, 311 E. Congress. 7 p.m. Free. —B.S. Eliot<br>
 <br>
  <div class="contentImageRight" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media2.fdncms.com/tucsonweekly/imager/u/original/16970642/the_sword.jpg" class="zoomable" rel="contentImg_gal-16969914" title="">                  <img src="https://media2.fdncms.com/tucsonweekly/imager/u/blog/16970642/the_sword.jpg?cb=1528305194" width="250" height="167" alt="the_sword.jpg" />                </a>                                                                                                           <ul style="width:250px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <a href="https://www.ticketfly.com/purchase/event/1667337" target="_blank">The Sword</a>. Armed with broad swords and a field full of plaited maidens riding white mares into the sunset, Austin’s stoner metalers The Sword fight their way—riff-and-sorcery style—into the listener’s cranium, and then lops it the hell off. Lugging nu-metal riffs uphold soaring Sabbath-y vocal melodies that successfully honors hard-rock history while forging suckerpunch metal to soundtrack the present and future. First discovered by Lamb of God in the early aughts, the quartet evolved from its wholly-Medieval themes into a band discovering tension in the toxic waste-dump environment that is our “used future.” Artfully crafted ditties like “Sea of Green” sidestep didacticism and simply state, “What was your home is now a wasteland.” Hard enough to be cathartic, but smart enough to be thought-provoking, each tune is a well-wrought, double-edged, um, sword. With The Atomic Bitchwax. Friday, June 8 at 191 Toole. Doors at 8 p.m. 21+. $20. —B.S. Eliot<br>
 <br>
  <div class="contentImageCenter" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/tucsonweekly/imager/u/original/16970739/wreckonize.jpg" class="zoomable" rel="contentImg_gal-16969914" title="">                  <img src="https://media1.fdncms.com/tucsonweekly/imager/u/blog/16970739/wreckonize.jpg?cb=1528305384" width="625" height="625" alt="wreckonize.jpg" />                </a>                                                                                                           <ul style="width:625px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <a href="https://www.songkick.com/concerts/34046609-wrekonize-at-solar-culture-gallery-and-performance-space?utm_medium=organic&amp;utm_source=microformat" target="_blank">Wrekonize</a>. London-born Wrekonize is a well-spoken blend of his English mother and Capetown dad. His lyrics too are a blend—of straight-ahead confessional (“My mom was a dancer—the exotic kind”) and science fiction (“I’m surrounded by clones.”) Wrek’s flow betrays no British accent, instead revealing a true (manic) street preacher passion; like Brother Ali, he inhales and exhales rhymes without ever being out of breath. Wrek’s astute and conceptual, extrapolating regional truths from London streets and broadening them to greater street life truths worldwide. And his production is killer. Currently signed to the mighty TechN9ne’s Strange Music label, Wrek’s spit is met with swirling synths and heartbeat bass. Every cut on a Wrekonize album, even a normally throwaway opening skit, has a reason to be there. And if he’s “packing heat,” it is with the pen, not the sword—this is a refreshingly intelligent and open-eyed rapper worth many ear bends. With D. Lynch, 1TON, Double You, Tommy Will, Juan P. Simplistic and OGXO on Tuesday, June 12. Solar Culture Gallery, 31 East Toole. Doors at 7 p.m. $12-$15. All ages. —B.S. Eliot
      
      
      <div class="clearfix"></div>
      
      
      
    </div>

    
    
    
      
    

    

    
      
      <p class="tags">
        Tags: <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=art" rel="tag">art</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=music" rel="tag">music</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=food" rel="tag">food</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=summer" rel="tag">summer</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=entertainment" rel="tag">entertainment</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=celebration" rel="tag">celebration</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=second%20saturday" rel="tag">second saturday</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=second%20sunday" rel="tag">second sunday</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=first%20thursday" rel="tag">first thursday</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?contentFeature=3669452" rel="tag">Image</a>
      </p>
    

    

  </div> <!-- end blogPost -->
    
    <div class="clear"></div>
  </div>

















  
  















  
  
  

  
  
  

  
  
  <!-- 
    xxx
    admin: 808579
    serverURl: https://www.tucsonweekly.com
    var.publicDesktopServer = https://www.tucsonweekly.com
    var.shareUrl = https://www.tucsonweekly.com/TheRange/archives/2018/06/07/the-weekly-list-23-things-to-do-in-tucson-this-week
    s/https\:\/\/www\.tucsonweekly\.com/https\:\/\/www\.tucsonweekly\.com/
    var.shareUrl = https://www.tucsonweekly.com/TheRange/archives/2018/06/07/the-weekly-list-23-things-to-do-in-tucson-this-week
  -->



  
  
    
  
  
  <div id="TallBar" class="SpanningFeature TheRangeBlogPost ">
    <ul>
      <li class="l0 first" style="width:50%">
        <fb:like href="https://www.tucsonweekly.com/TheRange/archives/2018/06/07/the-weekly-list-23-things-to-do-in-tucson-this-week" 
         send="true" 
         width="285" 
         show_faces="false" 
         action="like" 
         font="tahoma" 
         colorscheme="light" 
         layout="standard"></fb:like></li> <li class="l0" style="width:12%;"><a href="https://twitter.com/share?url=https%3A//www.tucsonweekly.com/TheRange/archives/2018/06/07/the-weekly-list-23-things-to-do-in-tucson-this-week&text=The%20Weekly%20List%3A%2023%20Things%20To%20Do%20In%20Tucson%20This%20Week" class="twitter-share-button" data-count="vertical">Tweet</a>
<script>
  dnLoadScript("https://platform.twitter.com/widgets.js", true);
</script></li> <li class="l0" style="width:12%;"><script>
  dnLoadScript("https://apis.google.com/js/plusone.js", true);
</script>
<g:plusone href="https://www.tucsonweekly.com/TheRange/archives/2018/06/07/the-weekly-list-23-things-to-do-in-tucson-this-week" size="tall" count="true"></g:plusone></li> <li class="l0 last" style="width:12%;">




  <div class="addthis_toolbox addthis_default_style"><a addthis:url="https://www.tucsonweekly.com/TheRange/archives/2018/06/07/the-weekly-list-23-things-to-do-in-tucson-this-week" addthis:title="The Weekly List: 23 Things To Do In Tucson This Week" addthis:description="" class="addthis_counter"></a></div>
  <script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4ea84184281c09f8", true);
  </script>


      </li>
    </ul>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  




    
    
    
    













  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  
  


  

  
    
      <style>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</style>
      <div id="BlogComments" class="SpanningFeature TheRangeBlogPost CommentsComponent ">
        
        
        <div class="commentsHeader hreview-aggregate clearfix" id="readerComments">

          
          
          
          <h3 class="clearfix">
            <div style="float:left;">
              Comments 
            </div>
            
          </h3>
        </div>
        
        
        <div id="BlogComments_commentContent" class="commentContent">
          
        </div>
        

        
          <div class="bottomOptionBar clearfix">
            
              <div style="float:left;">
      <div style="float:left;margin:4px 0; padding:4px 6px;">Subscribe to this thread:</div>
      <div style="position:relative;float:left">
      <div class="commentSubscribeLink">
        <a class="toggleActivator saveAction" id="doSubscribe" href="javascript://Subscribe">By Email</a>
      </div>
      <div class="togglePanel" data-toolsoid="16969914" data-toolsajaxmacro="commentSubscribe" style="display:none">
        <div class="toggleArrowBorder"></div>
        <div class="toggleArrow"></div>
        <a href="javascript://close" class="togglePanelClose"><img src="/foundation/images/icons/cross.png" width="14" height="14"></a>
        <div class="loading">Subscribing&hellip;</div>
        <div class="ajaxUpdater" style="display:none;"></div>
      </div>
      </div>
      <div class="commentRSSLink"><a href="/tucson/Rss.xml?id=comments&amp;oid=16969914" class="feedLink" title="Subscribe to this story's comments" target="_blank">With RSS</a></div>
      </div>
            
            
          </div>          
          
        <hr />

        

        
          

          <form id="BlogCommentsPostCommentForm" method="post" class="userCommentForm validateForm" data-validate="login" data-validate-login-options="{&quot;feelingShy&quot;:true}">
            <input type="hidden" name="commentType" value="comment" />
            <input type="hidden" name="oid" value="16969914" />
            <input type="hidden" name="source" value="desktop">

            
            

            <label for="comment" class="hidden">Comment</label>
            
              <h4 class="commentFormAddHeader"><a name="readerComments">Add a comment</a></h4>
            

            
            <div>(<a href="/tucson/CommentsPolicy/Page">comments policy</a>)</div>
            

            <div class="errorDisplay" style="display:none">
              <ol></ol>
            </div>
            <dl class="formElements clearfix">
            
              <dd><textarea name="comment" style="height:112px;overflow:hidden;" tabindex="1" class="expandableBox required" id="comment" data-validate="required"></textarea></dd>
            </dl>

            

            

            <input type="checkbox" name="subscribe" id="BlogComments_commentSubscribe" value="yes"> <label for="BlogComments_commentSubscribe" style="margin-right:24px;">Subscribe to this thread</label>
            
            

            <p class="commentFormSubmit">
              <input type="submit" name="commentSubmit" tabindex="2" value="Post Comment" id="commentSubmit" />
            </p>

          </form>
          <script>
            jQuery("textarea.expandableBox").autoBoxResize();
          </script>
        
      </div><!-- comments -->
      <script type="text/javascript">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</script>
    
  


      </div><!-- gridSpanningFeature -->
      
      <div id="gridSpanningFeature2">
        
      </div><!-- gridSpanningFeature2 -->

      <div id="gridColumnContainer" class="clearfix">

        <div id="gridMainColumn1">
          





  
      <div id="PreviouslyintheRange" class="MainColumn1 TheRangeBlogPost ">
        <h3>Previously in the Range</h3>
        <ul class="moduleList">
    
    

    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.tucsonweekly.com/TheRange/archives/2018/06/01/the-library-is-here-for-everyone-lgbtq-programming-a-top-priority">The Library is Here for Everyone: LGBTQ+ Programming a Top Priority</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Pima County Public Library</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Jun  1, 2018</span>
        </li>
      
    </ul>
  </li>
      
    
  
    

    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/31/the-weekly-list-23-things-to-do-in-tucson-this-week">The Weekly List: 23 Things To Do In Tucson This Week</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Weekly Staff and Contributors</li>
      
      
        <li class="l1 longOnly">
          <span class="date">May 31, 2018</span>
        </li>
      
    </ul>
  </li>
      
    
  
    

    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/24/the-weekly-list-29-things-to-do-in-tucson-this-week">The Weekly List: 19 Things To Do In Tucson This Week</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Weekly Staff and Contributors</li>
      
      
        <li class="l1 longOnly">
          <span class="date">May 24, 2018</span>
        </li>
      
    </ul>
  </li>
      
    
  
         <li class="l0 storyItem">
           <a href="https://www.tucsonweekly.com/blogs/TheRange/" class="more">More &raquo;</a>
         </li>
         </ul>
      </div>
    


        </div><!-- gridMainColumn1 -->
        
        <div id="gridMainColumn2">
          







  

  

  
    <div id="MorebyThisAuthorWrapper" class="MainColumn2 TheRangeBlogPost Wrapper">

    
      
      
          <div id="MorebyThisAuthor" class="MainColumn2 TheRangeBlogPost ">
            <h3><span class="headingText">More by Weekly Staff and Contributors</span></h3>
            <ul class="moduleList">
        
        
        
        <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/31/the-weekly-list-23-things-to-do-in-tucson-this-week">The Weekly List: 23 Things To Do In Tucson This Week</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Weekly Staff and Contributors</li>
      
      
        <li class="l1 longOnly">
          <span class="date">May 31, 2018</span>
        </li>
      
    </ul>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/24/the-weekly-list-29-things-to-do-in-tucson-this-week">The Weekly List: 19 Things To Do In Tucson This Week</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Weekly Staff and Contributors</li>
      
      
        <li class="l1 longOnly">
          <span class="date">May 24, 2018</span>
        </li>
      
    </ul>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/17/the-weekly-list-23-things-to-do-in-tucson-this-week">The Weekly List: 23 Things To Do In Tucson This Week</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Weekly Staff and Contributors</li>
      
      
        <li class="l1 longOnly">
          <span class="date">May 17, 2018</span>
        </li>
      
    </ul>
  </li>
        
        

      
             <li class="l0 storyItem more">
               <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?author=1064055" class="more">More &raquo;</a>
             </li>
             </ul>
          </div>
        
    
   </div>  
   
  



        </div><!-- gridMainColumn2 -->

      </div><!-- end gridColumnContainer -->

    </div><!-- end gridFrame -->

    <div id="gridRightColumn">   
      <div id="gridSpanningIsland">
        

























<div id="EventPicksChooser" class="SpanningIsland TheRangeBlogPost ">

  <div class="headerBar">
    <h2><a href="https://www.tucsonweekly.com/tucson/EventSearch">Events</a> &amp; <a href="https://www.tucsonweekly.com/tucson/EventSearch?feature=Staff%20Pick">Staff Picks</a></h2></a>
  </div>

  
    

    <div class="calendarDays">
      <a class="calCurrent" href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=today">Today</a>
      
        | <a class="calDay" href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=2018-06-08%2004%3A00%3A00">Fri</a>
      
        | <a class="calDay" href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=2018-06-09%2004%3A00%3A00">Sat</a>
      
        | <a class="calDay" href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=2018-06-10%2004%3A00%3A00">Sun</a>
      
        | <a class="calDay" href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=2018-06-11%2004%3A00%3A00">Mon</a>
      
        | <a class="calDay" href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=2018-06-12%2004%3A00%3A00">Tue</a>
      
        | <a class="calDay last" href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=2018-06-13%2004%3A00%3A00">Wed</a>
      
    </div>

    
    
      <div class="storyItem">
    

    

    
      <a href="https://www.tucsonweekly.com/tucson/dueling-pianos-a-sing-along-party/Event?oid=15942807">
        <img src="https://media2.fdncms.com/tucsonweekly/imager/u/featurette/15942806/8887619f_banner.jpg" alt="Dueling Pianos: A Sing-Along Party!" title="Dueling Pianos: A Sing-Along Party!" width="124" height="99" />
      </a>
     
    <h4 class="headline"><a href="https://www.tucsonweekly.com/tucson/dueling-pianos-a-sing-along-party/Event?oid=15942807">Dueling Pianos: A Sing-Along Party!</a>  
      <span class="smaller">@ The Gaslight Music Hall</span>
    </h4>
    <h5 class="subhead">Thu., June 7, 6-8 p.m.</h5>
  </div>
      

  
 
  <p class="more"><a href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=today">All of today's events</a> | <a href="https://www.tucsonweekly.com/tucson/EventSearch?feature=Staff%20Pick">Staff Picks</a></p>

  

  <div id=""> <!-- Tabbed Box -->  
    <div class="tabs">  
      <div class="tabCurrent tabLeft"><a href="#">Events</a></div> 
      <div class="tabBack tabCenter"><a href="#">Music</a></div> 
      <div class="tabBack tabCenter"><a href="#">Movies</a></div> 
      <div class="tabBack tabRight"><a href="#">Dining</a></div>
      <div class="tabBack tabRight"><a href="#">Locations</a></div>
    </div>
    <div class="clear"></div>

    

    <div class="eventSearchBody" >
      <form name="eventSearchForm" method="get" action="https://www.tucsonweekly.com/tucson/EventSearch">
        <select name="narrowByDate">
    <option value="">-All Dates-</option>
    
    
      
      
        
        
          <option value="2018-06-07" selected="selected">Thursday, June  7</option>
        
      
        
        
          <option value="2018-06-08">Friday, June  8</option>
        
      
        
        
          <option value="2018-06-09">Saturday, June  9</option>
        
      
        
        
          <option value="2018-06-10">Sunday, June 10</option>
        
      
        
        
          <option value="2018-06-11">Monday, June 11</option>
        
      
        
        
          <option value="2018-06-12">Tuesday, June 12</option>
        
      
        
        
          <option value="2018-06-13">Wednesday, June 13</option>
        
      
        
        
          <option value="2018-06-14">Thursday, June 14</option>
        
      
        
        
          <option value="2018-06-15">Friday, June 15</option>
        
      
        
        
          <option value="2018-06-16">Saturday, June 16</option>
        
      
        
        
          <option value="2018-06-17">Sunday, June 17</option>
        
      
        
        
          <option value="2018-06-18">Monday, June 18</option>
        
      
        
        
          <option value="2018-06-19">Tuesday, June 19</option>
        
      
        
        
          <option value="2018-06-20">Wednesday, June 20</option>
        
      
        
        
          <option value="2018-06-21">Thursday, June 21</option>
        
      
        
        
          <option value="2018-06-22">Friday, June 22</option>
        
      
        
        
          <option value="2018-06-23">Saturday, June 23</option>
        
      
        
        
          <option value="2018-06-24">Sunday, June 24</option>
        
      
        
        
          <option value="2018-06-25">Monday, June 25</option>
        
      
        
        
          <option value="2018-06-26">Tuesday, June 26</option>
        
      
        
        
          <option value="2018-06-27">Wednesday, June 27</option>
        
      
        
        
          <option value="2018-06-28">Thursday, June 28</option>
        
      
        
        
          <option value="2018-06-29">Friday, June 29</option>
        
      
        
        
          <option value="2018-06-30">Saturday, June 30</option>
        
      
        
        
          <option value="2018-07-01">Sunday, July  1</option>
        
      
        
        
          <option value="2018-07-02">Monday, July  2</option>
        
      
        
        
          <option value="2018-07-03">Tuesday, July  3</option>
        
      
        
        
          <option value="2018-07-04">Wednesday, July  4</option>
        
      
        
        
          <option value="2018-07-05">Thursday, July  5</option>
        
      
        
        
          <option value="2018-07-06">Friday, July  6</option>
        
      
        
        
          <option value="2018-07-07">Saturday, July  7</option>
        
      
    
  </select>

        <select name="eventCategory">
          <option value="">-All Categories-</option>
          
            <option value="1107327" >&nbsp;&nbsp;Art</option>
          
            <option value="2026929" >&nbsp;&nbsp;Back to School</option>
          
            <option value="1107349" >&nbsp;&nbsp;Bulletin Board</option>
          
            <option value="2490677" >&nbsp;&nbsp;Business & Finance</option>
          
            <option value="1107323" >&nbsp;&nbsp;Dance</option>
          
            <option value="4103152" >&nbsp;&nbsp;Dining</option>
          
            <option value="3093926" >&nbsp;&nbsp;Fall Arts Preview</option>
          
            <option value="1107328" >&nbsp;&nbsp;Family Fun</option>
          
            <option value="1107395" >&nbsp;&nbsp;Film</option>
          
            <option value="3910368" >&nbsp;&nbsp;For Valentines</option>
          
            <option value="1107336" >&nbsp;&nbsp;Gardening</option>
          
            <option value="3555917" >&nbsp;&nbsp;Halloween and All Souls</option>
          
            <option value="2506799" >&nbsp;&nbsp;Health</option>
          
            <option value="1107472" >&nbsp;&nbsp;Lectures</option>
          
            <option value="1107335" >&nbsp;&nbsp;Literature</option>
          
            <option value="1107325" >&nbsp;&nbsp;Museums</option>
          
            <option value="1107343" >&nbsp;&nbsp;Music (Classical, Opera, Jazz, Folk)</option>
          
            <option value="2026930" >&nbsp;&nbsp;New Year's Eve</option>
          
            <option value="1107386" >&nbsp;&nbsp;Outdoors</option>
          
            <option value="1107320" >&nbsp;&nbsp;Performing Arts</option>
          
            <option value="4136083" >&nbsp;&nbsp;Pet-Friendly & Fundraisers</option>
          
            <option value="2026928" >&nbsp;&nbsp;Pride</option>
          
            <option value="1107371" >&nbsp;&nbsp;Special Events</option>
          
            <option value="2506800" >&nbsp;&nbsp;Spirituality</option>
          
            <option value="1130857" >&nbsp;&nbsp;Sports</option>
          
            <option value="2456766" >&nbsp;&nbsp;Spring Arts Preview</option>
          
            <option value="2751116" >&nbsp;&nbsp;Summer Survival Guide</option>
          
            <option value="4000687" >&nbsp;&nbsp;Support Groups</option>
          
            <option value="3904784" >&nbsp;&nbsp;Transgender Awareness Week</option>
          
            <option value="3862947" >&nbsp;&nbsp;Volunteer</option>
          
            <option value="1107321" >&nbsp;&nbsp;Well-Being</option>
          
            <option value="1107942" >&nbsp;&nbsp;Comedy & Storytellers</option>
          
            <option value="3656923" >&nbsp;&nbsp;Dancing, DJ, Karaoke and Open Mic</option>
          
            <option value="3707286" >&nbsp;&nbsp;Trivia Games</option>
          
        </select>

        <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        
          <option value="7424285" >TUCSON</option>
        
        <option value="3552209" >&nbsp;&nbsp;Downtown / 4th Ave / University</option>
      
        
        <option value="1094781" >&nbsp;&nbsp;Central</option>
      
        
        <option value="1094814" >&nbsp;&nbsp;South Tucson</option>
      
        
        <option value="3287529" >&nbsp;&nbsp;North/Foothills</option>
      
        
        <option value="1094791" >&nbsp;&nbsp;East side</option>
      
        
        <option value="1094969" >&nbsp;&nbsp;West side</option>
      
        
        <option value="3266147" >&nbsp;&nbsp;Southeast</option>
      
        
        <option value="3138323" >&nbsp;&nbsp;Southwest</option>
      
        
        <option value="1094793" >&nbsp;&nbsp;Northeast</option>
      
        
        <option value="1094785" >&nbsp;&nbsp;Northwest</option>
      
        
        <option value="7424290" >&nbsp;&nbsp;Tucson (general)</option>
      
        
          <option value="7424291" >NORTH OF TUCSON</option>
        
        <option value="3287479" >&nbsp;&nbsp;Catalina</option>
      
        
        <option value="3904764" >&nbsp;&nbsp;Florence</option>
      
        
        <option value="3287527" >&nbsp;&nbsp;Marana</option>
      
        
        <option value="3287528" >&nbsp;&nbsp;Oracle</option>
      
        
        <option value="3287533" >&nbsp;&nbsp;Oro Valley</option>
      
        
        <option value="3339208" >&nbsp;&nbsp;San Manuel</option>
      
        
        <option value="3212371" >&nbsp;&nbsp;Superior</option>
      
        
        <option value="7426378" >&nbsp;&nbsp;Globe</option>
      
        
        <option value="7426357" >&nbsp;&nbsp;Phoenix / Chandler / Glendale</option>
      
        
        <option value="7426433" >&nbsp;&nbsp;Casa Grande</option>
      
        
        <option value="7426380" >&nbsp;&nbsp;Payson</option>
      
        
        <option value="7426379" >&nbsp;&nbsp;Sedona / Flagstaff</option>
      
        
        <option value="7426319" >&nbsp;&nbsp;Scottsdale</option>
      
        
          <option value="7424292" >SOUTH OF TUCSON</option>
        
        <option value="3223056" >&nbsp;&nbsp;Ajo</option>
      
        
        <option value="3235744" >&nbsp;&nbsp;Amado / Carmen</option>
      
        
        <option value="3212928" >&nbsp;&nbsp;Arivaca</option>
      
        
        <option value="3509182" >&nbsp;&nbsp;Elgin</option>
      
        
        <option value="3229508" >&nbsp;&nbsp;Green Valley</option>
      
        
        <option value="3259115" >&nbsp;&nbsp;Huachuca City</option>
      
        
        <option value="3303004" >&nbsp;&nbsp;Nogales</option>
      
        
        <option value="3287530" >&nbsp;&nbsp;Patagonia</option>
      
        
        <option value="3274620" >&nbsp;&nbsp;Sahuarita</option>
      
        
        <option value="2700860" >&nbsp;&nbsp;Sonoita</option>
      
        
        <option value="3187460" >&nbsp;&nbsp;Tumacácori</option>
      
        
        <option value="7426317" >&nbsp;&nbsp;Sasabe</option>
      
        
        <option value="7426318" >&nbsp;&nbsp;Douglas</option>
      
        
        <option value="2573339" >&nbsp;&nbsp;Sierra Vista / Hereford</option>
      
        
        <option value="7424289" >&nbsp;&nbsp;Tubac</option>
      
        
          <option value="7424287" >EAST OF TUCSON</option>
        
        <option value="3093054" >&nbsp;&nbsp;Benson / Dragoon</option>
      
        
        <option value="2673664" >&nbsp;&nbsp;Bisbee / Warren</option>
      
        
        <option value="3011257" >&nbsp;&nbsp;Safford</option>
      
        
        <option value="7424288" >&nbsp;&nbsp;Silver City / Pinos Altos</option>
      
        
        <option value="2826341" >&nbsp;&nbsp;Tombstone</option>
      
        
        <option value="3268503" >&nbsp;&nbsp;Vail</option>
      
        
        <option value="3243183" >&nbsp;&nbsp;Willcox</option>
      
        
        <option value="1094842" >&nbsp;&nbsp;Beyond AZ</option>
      
        
          <option value="7424302" >WEST OF TUCSON</option>
        
        <option value="3287537" >&nbsp;&nbsp;Three Points</option>
      
    
  </select>

        <input type="text" name="keywords" title="Enter keyword" class="text" value="" />
        <input type="submit" value="go" />
      </form>
      <div class="clear"></div>
      <p class="submitLink"><a href="https://posting.tucsonweekly.com/tucson/Events/AddEvent">Submit an Event</a></p>
    </div>

    

    <div class="eventSearchBody" style="display: none;">
      <form name="musicEventSearchForm" method="get" action="https://www.tucsonweekly.com/tucson/EventSearch">
        <input type="hidden" name="eventCategory" value="1107701" />

        <select name="narrowByDate">
    <option value="">-All Dates-</option>
    
    
      
      
        
        
          <option value="2018-06-07" selected="selected">Thursday, June  7</option>
        
      
        
        
          <option value="2018-06-08">Friday, June  8</option>
        
      
        
        
          <option value="2018-06-09">Saturday, June  9</option>
        
      
        
        
          <option value="2018-06-10">Sunday, June 10</option>
        
      
        
        
          <option value="2018-06-11">Monday, June 11</option>
        
      
        
        
          <option value="2018-06-12">Tuesday, June 12</option>
        
      
        
        
          <option value="2018-06-13">Wednesday, June 13</option>
        
      
        
        
          <option value="2018-06-14">Thursday, June 14</option>
        
      
        
        
          <option value="2018-06-15">Friday, June 15</option>
        
      
        
        
          <option value="2018-06-16">Saturday, June 16</option>
        
      
        
        
          <option value="2018-06-17">Sunday, June 17</option>
        
      
        
        
          <option value="2018-06-18">Monday, June 18</option>
        
      
        
        
          <option value="2018-06-19">Tuesday, June 19</option>
        
      
        
        
          <option value="2018-06-20">Wednesday, June 20</option>
        
      
        
        
          <option value="2018-06-21">Thursday, June 21</option>
        
      
        
        
          <option value="2018-06-22">Friday, June 22</option>
        
      
        
        
          <option value="2018-06-23">Saturday, June 23</option>
        
      
        
        
          <option value="2018-06-24">Sunday, June 24</option>
        
      
        
        
          <option value="2018-06-25">Monday, June 25</option>
        
      
        
        
          <option value="2018-06-26">Tuesday, June 26</option>
        
      
        
        
          <option value="2018-06-27">Wednesday, June 27</option>
        
      
        
        
          <option value="2018-06-28">Thursday, June 28</option>
        
      
        
        
          <option value="2018-06-29">Friday, June 29</option>
        
      
        
        
          <option value="2018-06-30">Saturday, June 30</option>
        
      
        
        
          <option value="2018-07-01">Sunday, July  1</option>
        
      
        
        
          <option value="2018-07-02">Monday, July  2</option>
        
      
        
        
          <option value="2018-07-03">Tuesday, July  3</option>
        
      
        
        
          <option value="2018-07-04">Wednesday, July  4</option>
        
      
        
        
          <option value="2018-07-05">Thursday, July  5</option>
        
      
        
        
          <option value="2018-07-06">Friday, July  6</option>
        
      
        
        
          <option value="2018-07-07">Saturday, July  7</option>
        
      
    
  </select>
        <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        
          <option value="7424285" >TUCSON</option>
        
        <option value="3552209" >&nbsp;&nbsp;Downtown / 4th Ave / University</option>
      
        
        <option value="1094781" >&nbsp;&nbsp;Central</option>
      
        
        <option value="1094814" >&nbsp;&nbsp;South Tucson</option>
      
        
        <option value="3287529" >&nbsp;&nbsp;North/Foothills</option>
      
        
        <option value="1094791" >&nbsp;&nbsp;East side</option>
      
        
        <option value="1094969" >&nbsp;&nbsp;West side</option>
      
        
        <option value="3266147" >&nbsp;&nbsp;Southeast</option>
      
        
        <option value="3138323" >&nbsp;&nbsp;Southwest</option>
      
        
        <option value="1094793" >&nbsp;&nbsp;Northeast</option>
      
        
        <option value="1094785" >&nbsp;&nbsp;Northwest</option>
      
        
        <option value="7424290" >&nbsp;&nbsp;Tucson (general)</option>
      
        
          <option value="7424291" >NORTH OF TUCSON</option>
        
        <option value="3287479" >&nbsp;&nbsp;Catalina</option>
      
        
        <option value="3904764" >&nbsp;&nbsp;Florence</option>
      
        
        <option value="3287527" >&nbsp;&nbsp;Marana</option>
      
        
        <option value="3287528" >&nbsp;&nbsp;Oracle</option>
      
        
        <option value="3287533" >&nbsp;&nbsp;Oro Valley</option>
      
        
        <option value="3339208" >&nbsp;&nbsp;San Manuel</option>
      
        
        <option value="3212371" >&nbsp;&nbsp;Superior</option>
      
        
        <option value="7426378" >&nbsp;&nbsp;Globe</option>
      
        
        <option value="7426357" >&nbsp;&nbsp;Phoenix / Chandler / Glendale</option>
      
        
        <option value="7426433" >&nbsp;&nbsp;Casa Grande</option>
      
        
        <option value="7426380" >&nbsp;&nbsp;Payson</option>
      
        
        <option value="7426379" >&nbsp;&nbsp;Sedona / Flagstaff</option>
      
        
        <option value="7426319" >&nbsp;&nbsp;Scottsdale</option>
      
        
          <option value="7424292" >SOUTH OF TUCSON</option>
        
        <option value="3223056" >&nbsp;&nbsp;Ajo</option>
      
        
        <option value="3235744" >&nbsp;&nbsp;Amado / Carmen</option>
      
        
        <option value="3212928" >&nbsp;&nbsp;Arivaca</option>
      
        
        <option value="3509182" >&nbsp;&nbsp;Elgin</option>
      
        
        <option value="3229508" >&nbsp;&nbsp;Green Valley</option>
      
        
        <option value="3259115" >&nbsp;&nbsp;Huachuca City</option>
      
        
        <option value="3303004" >&nbsp;&nbsp;Nogales</option>
      
        
        <option value="3287530" >&nbsp;&nbsp;Patagonia</option>
      
        
        <option value="3274620" >&nbsp;&nbsp;Sahuarita</option>
      
        
        <option value="2700860" >&nbsp;&nbsp;Sonoita</option>
      
        
        <option value="3187460" >&nbsp;&nbsp;Tumacácori</option>
      
        
        <option value="7426317" >&nbsp;&nbsp;Sasabe</option>
      
        
        <option value="7426318" >&nbsp;&nbsp;Douglas</option>
      
        
        <option value="2573339" >&nbsp;&nbsp;Sierra Vista / Hereford</option>
      
        
        <option value="7424289" >&nbsp;&nbsp;Tubac</option>
      
        
          <option value="7424287" >EAST OF TUCSON</option>
        
        <option value="3093054" >&nbsp;&nbsp;Benson / Dragoon</option>
      
        
        <option value="2673664" >&nbsp;&nbsp;Bisbee / Warren</option>
      
        
        <option value="3011257" >&nbsp;&nbsp;Safford</option>
      
        
        <option value="7424288" >&nbsp;&nbsp;Silver City / Pinos Altos</option>
      
        
        <option value="2826341" >&nbsp;&nbsp;Tombstone</option>
      
        
        <option value="3268503" >&nbsp;&nbsp;Vail</option>
      
        
        <option value="3243183" >&nbsp;&nbsp;Willcox</option>
      
        
        <option value="1094842" >&nbsp;&nbsp;Beyond AZ</option>
      
        
          <option value="7424302" >WEST OF TUCSON</option>
        
        <option value="3287537" >&nbsp;&nbsp;Three Points</option>
      
    
  </select>

        <input type="text" name="keywords" title="Enter keyword" class="text" value="" />
        <input type="submit" value="go" />
      </form>
      <div class="clear"></div>
      <p class="submitLink"><a href="https://posting.tucsonweekly.com/tucson/Events/AddEvent">Submit an Event</a></p>
    </div>

    

    <div class="eventSearchBody" style="display: none;">
      <form name="movietimesSearchForm" method="get" action="https://www.tucsonweekly.com/tucson/MovieTimes">
        <select name="film" onchange="submit();">
          <option value="">Select a movie</option>
          
        </select>
        <noscript>
          <br />
          <input type="submit" value="go" />
        </noscript>
      </form>

      <p>or</p>

      <form name="movietimesSearchForm" method="get" action="https://www.tucsonweekly.com/tucson/MovieTimes">
        <select name="location" onchange="submit();">
          <option value="">Select a location</option>
          
        </select>
        <noscript>
           <br />
           <input type="submit" value="go" />
        </noscript>
      </form>
    </div>

    

    <div class="eventSearchBody" style="display: none;">
      <form name="diningSearchForm" method="get" action="https://www.tucsonweekly.com/tucson/LocationSearch">
        <input type="hidden" name="locationSection" value="1113936" />

        <select name="locationCategory">
          <option value="">-All Categories-</option>
          
            <option value="1113954">Americana</option>
          
            <option value="3966316">Australian</option>
          
            <option value="1113955">Barbecue</option>
          
            <option value="1113956">Brew Pubs</option>
          
            <option value="3691897">Buffet</option>
          
            <option value="3966308">Burgers & Dogs</option>
          
            <option value="1113961">Cafes and Bistros</option>
          
            <option value="1113965">Cajun</option>
          
            <option value="3966320">Caribbean</option>
          
            <option value="1113959">Chinese</option>
          
            <option value="1113957">Coffee Houses</option>
          
            <option value="1113958">Cuban</option>
          
            <option value="2593488">Deli</option>
          
            <option value="1294952">Eastern European</option>
          
            <option value="1113953">Ethiopian</option>
          
            <option value="1113966">Filipino</option>
          
            <option value="1113937">French</option>
          
            <option value="1113945">Greek</option>
          
            <option value="3950579">Guatemalan</option>
          
            <option value="3179449">Hawaiian</option>
          
            <option value="1113947">Indian</option>
          
            <option value="1113950">Italian</option>
          
            <option value="2321964">Jamaican</option>
          
            <option value="1113962">Korean</option>
          
            <option value="1113951">Latin American</option>
          
            <option value="1113967">Malaysian</option>
          
            <option value="2593490">Market</option>
          
            <option value="1113952">Mexican</option>
          
            <option value="1113938">Middle Eastern</option>
          
            <option value="1113940">Pan-Asian</option>
          
            <option value="1113942">Pizza</option>
          
            <option value="3951464">Russian</option>
          
            <option value="1113943">Sandwiches</option>
          
            <option value="2583225">Seafood</option>
          
            <option value="1113944">Southwest</option>
          
            <option value="1113964">Spanish</option>
          
            <option value="2593489">Sports Bar</option>
          
            <option value="2583227">Steakhouse</option>
          
            <option value="1113946">Surf and Turf</option>
          
            <option value="1113948">Sushi and Japanese</option>
          
            <option value="1113941">Thai</option>
          
            <option value="1113949">Upper Crust</option>
          
            <option value="1113939">Vegetarian Friendly</option>
          
            <option value="1113963">Vietnamese</option>
          
            <option value="1113960">Wine Bars</option>
          
        </select>

        <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        
          <option value="7424285" >TUCSON</option>
        
        <option value="3552209" >&nbsp;&nbsp;Downtown / 4th Ave / University</option>
      
        
        <option value="1094781" >&nbsp;&nbsp;Central</option>
      
        
        <option value="1094814" >&nbsp;&nbsp;South Tucson</option>
      
        
        <option value="3287529" >&nbsp;&nbsp;North/Foothills</option>
      
        
        <option value="1094791" >&nbsp;&nbsp;East side</option>
      
        
        <option value="1094969" >&nbsp;&nbsp;West side</option>
      
        
        <option value="3266147" >&nbsp;&nbsp;Southeast</option>
      
        
        <option value="3138323" >&nbsp;&nbsp;Southwest</option>
      
        
        <option value="1094793" >&nbsp;&nbsp;Northeast</option>
      
        
        <option value="1094785" >&nbsp;&nbsp;Northwest</option>
      
        
        <option value="7424290" >&nbsp;&nbsp;Tucson (general)</option>
      
        
          <option value="7424291" >NORTH OF TUCSON</option>
        
        <option value="3287479" >&nbsp;&nbsp;Catalina</option>
      
        
        <option value="3904764" >&nbsp;&nbsp;Florence</option>
      
        
        <option value="3287527" >&nbsp;&nbsp;Marana</option>
      
        
        <option value="3287528" >&nbsp;&nbsp;Oracle</option>
      
        
        <option value="3287533" >&nbsp;&nbsp;Oro Valley</option>
      
        
        <option value="3339208" >&nbsp;&nbsp;San Manuel</option>
      
        
        <option value="3212371" >&nbsp;&nbsp;Superior</option>
      
        
        <option value="7426378" >&nbsp;&nbsp;Globe</option>
      
        
        <option value="7426357" >&nbsp;&nbsp;Phoenix / Chandler / Glendale</option>
      
        
        <option value="7426433" >&nbsp;&nbsp;Casa Grande</option>
      
        
        <option value="7426380" >&nbsp;&nbsp;Payson</option>
      
        
        <option value="7426379" >&nbsp;&nbsp;Sedona / Flagstaff</option>
      
        
        <option value="7426319" >&nbsp;&nbsp;Scottsdale</option>
      
        
          <option value="7424292" >SOUTH OF TUCSON</option>
        
        <option value="3223056" >&nbsp;&nbsp;Ajo</option>
      
        
        <option value="3235744" >&nbsp;&nbsp;Amado / Carmen</option>
      
        
        <option value="3212928" >&nbsp;&nbsp;Arivaca</option>
      
        
        <option value="3509182" >&nbsp;&nbsp;Elgin</option>
      
        
        <option value="3229508" >&nbsp;&nbsp;Green Valley</option>
      
        
        <option value="3259115" >&nbsp;&nbsp;Huachuca City</option>
      
        
        <option value="3303004" >&nbsp;&nbsp;Nogales</option>
      
        
        <option value="3287530" >&nbsp;&nbsp;Patagonia</option>
      
        
        <option value="3274620" >&nbsp;&nbsp;Sahuarita</option>
      
        
        <option value="2700860" >&nbsp;&nbsp;Sonoita</option>
      
        
        <option value="3187460" >&nbsp;&nbsp;Tumacácori</option>
      
        
        <option value="7426317" >&nbsp;&nbsp;Sasabe</option>
      
        
        <option value="7426318" >&nbsp;&nbsp;Douglas</option>
      
        
        <option value="2573339" >&nbsp;&nbsp;Sierra Vista / Hereford</option>
      
        
        <option value="7424289" >&nbsp;&nbsp;Tubac</option>
      
        
          <option value="7424287" >EAST OF TUCSON</option>
        
        <option value="3093054" >&nbsp;&nbsp;Benson / Dragoon</option>
      
        
        <option value="2673664" >&nbsp;&nbsp;Bisbee / Warren</option>
      
        
        <option value="3011257" >&nbsp;&nbsp;Safford</option>
      
        
        <option value="7424288" >&nbsp;&nbsp;Silver City / Pinos Altos</option>
      
        
        <option value="2826341" >&nbsp;&nbsp;Tombstone</option>
      
        
        <option value="3268503" >&nbsp;&nbsp;Vail</option>
      
        
        <option value="3243183" >&nbsp;&nbsp;Willcox</option>
      
        
        <option value="1094842" >&nbsp;&nbsp;Beyond AZ</option>
      
        
          <option value="7424302" >WEST OF TUCSON</option>
        
        <option value="3287537" >&nbsp;&nbsp;Three Points</option>
      
    
  </select>

        <input type="text" name="keywords" title="Enter keyword" class="text" value="" />
        <input type="submit" value="go" />
      </form>
    </div>

    

    <div class="eventSearchBody" style="display: none;">
      <form name="locationSearchForm" method="get" action="https://www.tucsonweekly.com/tucson/LocationSearch">
        <select name="locationCategory">
          <option value="">-All Categories-</option>
          
            
              <option value="2215006" >CULTURE & ENTERTAINMENT</option>
            
            <option value="1113914" >&nbsp;&nbsp;Bar</option>
          
            
            <option value="1113933" >&nbsp;&nbsp;Coffee House</option>
          
            
            <option value="1256739" >&nbsp;&nbsp;Concert Hall</option>
          
            
            <option value="1146952" >&nbsp;&nbsp;Dance Club</option>
          
            
            <option value="1113916" >&nbsp;&nbsp;Galleries</option>
          
            
            <option value="4002307" >&nbsp;&nbsp;Hookah Bar</option>
          
            
            <option value="1113923" >&nbsp;&nbsp;Museums</option>
          
            
            <option value="1113974" >&nbsp;&nbsp;Music Venues</option>
          
            
            <option value="1113928" >&nbsp;&nbsp;Theaters (film)</option>
          
            
            <option value="1113917" >&nbsp;&nbsp;Theaters (live)</option>
          
            
            <option value="1252196" >&nbsp;&nbsp;Winery</option>
          
            
              <option value="1113913" >COMMUNITY, SHOPS & SERVICES</option>
            
            <option value="1252195" >&nbsp;&nbsp;Banquet Hall</option>
          
            
            <option value="1113925" >&nbsp;&nbsp;Bookstore</option>
          
            
            <option value="1253417" >&nbsp;&nbsp;Business</option>
          
            
            <option value="1252187" >&nbsp;&nbsp;Caterer</option>
          
            
            <option value="1113919" >&nbsp;&nbsp;Community Center</option>
          
            
            <option value="1113926" >&nbsp;&nbsp;Country Club</option>
          
            
            <option value="1113934" >&nbsp;&nbsp;Dance Studios/Companies</option>
          
            
            <option value="1113922" >&nbsp;&nbsp;Education</option>
          
            
            <option value="1113935" >&nbsp;&nbsp;Government</option>
          
            
            <option value="1113929" >&nbsp;&nbsp;Health</option>
          
            
            <option value="1113932" >&nbsp;&nbsp;Hotel</option>
          
            
            <option value="1113924" >&nbsp;&nbsp;Library</option>
          
            
            <option value="1113921" >&nbsp;&nbsp;Outdoors</option>
          
            
            <option value="1113920" >&nbsp;&nbsp;Park</option>
          
            
            <option value="1113918" >&nbsp;&nbsp;Religious</option>
          
            
            <option value="1113931" >&nbsp;&nbsp;Residential</option>
          
            
            <option value="1113930" >&nbsp;&nbsp;Sports or Recreation</option>
          
            
            <option value="1113927" >&nbsp;&nbsp;Store or Market</option>
          
        </select>

        <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        
          <option value="7424285" >TUCSON</option>
        
        <option value="3552209" >&nbsp;&nbsp;Downtown / 4th Ave / University</option>
      
        
        <option value="1094781" >&nbsp;&nbsp;Central</option>
      
        
        <option value="1094814" >&nbsp;&nbsp;South Tucson</option>
      
        
        <option value="3287529" >&nbsp;&nbsp;North/Foothills</option>
      
        
        <option value="1094791" >&nbsp;&nbsp;East side</option>
      
        
        <option value="1094969" >&nbsp;&nbsp;West side</option>
      
        
        <option value="3266147" >&nbsp;&nbsp;Southeast</option>
      
        
        <option value="3138323" >&nbsp;&nbsp;Southwest</option>
      
        
        <option value="1094793" >&nbsp;&nbsp;Northeast</option>
      
        
        <option value="1094785" >&nbsp;&nbsp;Northwest</option>
      
        
        <option value="7424290" >&nbsp;&nbsp;Tucson (general)</option>
      
        
          <option value="7424291" >NORTH OF TUCSON</option>
        
        <option value="3287479" >&nbsp;&nbsp;Catalina</option>
      
        
        <option value="3904764" >&nbsp;&nbsp;Florence</option>
      
        
        <option value="3287527" >&nbsp;&nbsp;Marana</option>
      
        
        <option value="3287528" >&nbsp;&nbsp;Oracle</option>
      
        
        <option value="3287533" >&nbsp;&nbsp;Oro Valley</option>
      
        
        <option value="3339208" >&nbsp;&nbsp;San Manuel</option>
      
        
        <option value="3212371" >&nbsp;&nbsp;Superior</option>
      
        
        <option value="7426378" >&nbsp;&nbsp;Globe</option>
      
        
        <option value="7426357" >&nbsp;&nbsp;Phoenix / Chandler / Glendale</option>
      
        
        <option value="7426433" >&nbsp;&nbsp;Casa Grande</option>
      
        
        <option value="7426380" >&nbsp;&nbsp;Payson</option>
      
        
        <option value="7426379" >&nbsp;&nbsp;Sedona / Flagstaff</option>
      
        
        <option value="7426319" >&nbsp;&nbsp;Scottsdale</option>
      
        
          <option value="7424292" >SOUTH OF TUCSON</option>
        
        <option value="3223056" >&nbsp;&nbsp;Ajo</option>
      
        
        <option value="3235744" >&nbsp;&nbsp;Amado / Carmen</option>
      
        
        <option value="3212928" >&nbsp;&nbsp;Arivaca</option>
      
        
        <option value="3509182" >&nbsp;&nbsp;Elgin</option>
      
        
        <option value="3229508" >&nbsp;&nbsp;Green Valley</option>
      
        
        <option value="3259115" >&nbsp;&nbsp;Huachuca City</option>
      
        
        <option value="3303004" >&nbsp;&nbsp;Nogales</option>
      
        
        <option value="3287530" >&nbsp;&nbsp;Patagonia</option>
      
        
        <option value="3274620" >&nbsp;&nbsp;Sahuarita</option>
      
        
        <option value="2700860" >&nbsp;&nbsp;Sonoita</option>
      
        
        <option value="3187460" >&nbsp;&nbsp;Tumacácori</option>
      
        
        <option value="7426317" >&nbsp;&nbsp;Sasabe</option>
      
        
        <option value="7426318" >&nbsp;&nbsp;Douglas</option>
      
        
        <option value="2573339" >&nbsp;&nbsp;Sierra Vista / Hereford</option>
      
        
        <option value="7424289" >&nbsp;&nbsp;Tubac</option>
      
        
          <option value="7424287" >EAST OF TUCSON</option>
        
        <option value="3093054" >&nbsp;&nbsp;Benson / Dragoon</option>
      
        
        <option value="2673664" >&nbsp;&nbsp;Bisbee / Warren</option>
      
        
        <option value="3011257" >&nbsp;&nbsp;Safford</option>
      
        
        <option value="7424288" >&nbsp;&nbsp;Silver City / Pinos Altos</option>
      
        
        <option value="2826341" >&nbsp;&nbsp;Tombstone</option>
      
        
        <option value="3268503" >&nbsp;&nbsp;Vail</option>
      
        
        <option value="3243183" >&nbsp;&nbsp;Willcox</option>
      
        
        <option value="1094842" >&nbsp;&nbsp;Beyond AZ</option>
      
        
          <option value="7424302" >WEST OF TUCSON</option>
        
        <option value="3287537" >&nbsp;&nbsp;Three Points</option>
      
    
  </select>

        <input type="text" name="keywords" title="Enter keyword" class="text" value="" />
        <input type="submit" value="go" />
      </form>
    </div>
  </div><!-- End of Tabbed Box -->

</div>





<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function() {
  // Main tabs.
  dnSetupTabGroup(
      $$("#EventPicksChooser div.tabs>div"),
      $$("#EventPicksChooser div.eventSearchBody"),
      "tabCurrent", "tabBack", 0
  );

  // Remove default tab behavior.
  $$("#EventPicksChooser div.tabs>div a").each(function (a, index) {
      a.onclick = function() {
        return false;
      };
  });
});
//-->
</script>
<!-- End #EventPicksChooser -->
<div id="Rectangle1" class="SpanningIsland TheRangeBlogPost MediumRectangle Ad">
  
  <!-- /4961490/TW_ROS_right_300x250 -->
          <div id="div-gpt-ad-tw_ros_right_300x250" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_300x250" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_300x250');
                  });
              </script>
          </div>
  
</div><style>
.storyItem.EotD img {margin:0 0 10px;width:280px;}
</style>


  

  <div id="EventoftheDay" class="SpanningIsland TheRangeBlogPost PickOfTheDay ">
    <div class="headerBar">
      <h1 class="sectionHeader">Staff Pick</h1>
    </div>

    <div class="storyItem EotD">
      
        <a href="https://www.tucsonweekly.com/tucson/summer-safari-nights/Event?oid=15941877"> 
          <img src="https://media1.fdncms.com/tucsonweekly/imager/u/eventoftheday/15941876/d912b9a0_1376_2018_summer_safari_web_1200x628px_.jpg" alt="" class="storyImg" />
          
        </a>
      

      <h4 class="headline"><a href="https://www.tucsonweekly.com/tucson/summer-safari-nights/Event?oid=15941877">Summer Safari Nights</a></h4>
 
      
        <p>Summer Safari Friday Nights 2018 Date: Every Friday until August 3, 2018 6:00 pm — 8:00 pm&hellip;
        <a href="https://www.tucsonweekly.com/tucson/summer-safari-nights/Event?oid=15941877">More</a></p>
      
    </div>

    <div class="storyItem eventInfo">
      
        @ Reid Park Zoo
      
      Fri., May 18, 6-8 p.m., Fri., May 25, 6-8 p.m., Fri., June 1, 6-8 p.m., Fri., June 8, 6-8 p.m., Fri., June 15, 6-8 p.m., Fri., June 22, 6-8 p.m., Fri., June 29, 6-8 p.m., Fri., July 6, 6-8 p.m., Fri., July 13, 6-8 p.m., Fri., July 20, 6-8 p.m., Fri., July 27, 6-8 p.m. and Fri., Aug. 3, 6-8 p.m.
      
        3400 E Zoo Court
      
    </div>

    <p class="submitListing"><a href="https://www.tucsonweekly.com/tucson/EventSearch?feature=Staff%20Pick">&raquo; More Picks</a></p>
    <p class="submitListing"><a href="https://posting.tucsonweekly.com/tucson/SubmitEvent/Page">Submit an Event Listing</a></p>
  </div>


<div id="Rectangle3" class="SpanningIsland TheRangeBlogPost MediumRectangle Ad">
  
  <!-- /4961490/TW_WeGotCactus_300x250_1 -->
          <div id="div-gpt-ad-tw_wegotcactus_300x250_1" style="" data-content-type="ad" data-slot="/4961490/TW_WeGotCactus_300x250_1" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_wegotcactus_300x250_1');
                  });
              </script>
          </div>
  
</div>

<div id="TabbedMost" class="SpanningIsland TheRangeBlogPost ">












  <!-- Cached: 2018-06-07 12:00 -->

  <h2>Popular Content</h2>

    <div class="tabs">
      <a href="#" class="mostread tabCurrent">Most Read</a>
      
      <a href="#" class="mostdiscussed tabBack">Most Discussed</a>
    </div>

    <div class="clear"><!-- clear --></div>

    
    <div class="commentsBody" style="">
      
          <ol>
        
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/31/the-weekly-list-23-things-to-do-in-tucson-this-week">The Weekly List: 23 Things To Do In Tucson This Week</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2018/06/01/threat-watch-protrumpians-unbound">T.H.R.E.A.T. Watch: ProTrumpians Unbound</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/17/the-weekly-list-23-things-to-do-in-tucson-this-week">The Weekly List: 23 Things To Do In Tucson This Week</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/24/the-weekly-list-29-things-to-do-in-tucson-this-week">The Weekly List: 19 Things To Do In Tucson This Week</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/15/the-dangers-of-forming-political-coalitions-while-black-north-carolina-1898">The Dangers of Forming Political Coalitions While Black: North Carolina, 1898</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
          </ol>
        
      <div class="clear"><!-- clear --></div>
    </div>

  

    
    <div class="commentsBody" style="display:none">
      
          <ol>
        
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/11/the-games-basis-plays">The Games BASIS Plays</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2018/06/01/threat-watch-protrumpians-unbound">T.H.R.E.A.T. Watch: ProTrumpians Unbound</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/25/threat-watch-its-getting-real">T.H.R.E.A.T. Watch: It's Getting Real</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/08/the-new-republican-outlaw">The New Republican Outlaw</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/23/the-evolution-and-devolution-of-diane-douglas">The Evolution and Devolution of Diane Douglas</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
          </ol>
        
      <div class="clear"><!-- clear --></div>
    </div>


  

    

    <script type="text/javascript">
    <!--
      Event.observe(document, "dom:loaded", function() {
        dnSetupTabGroup(
            $$("#TabbedMost div.tabs a"),
            $$("#TabbedMost div.commentsBody"),
            "tabCurrent", "tabBack", 0
        );
      });
    //-->
    </script>
  </div>
  


<div id="BigSkyscraper300x600" class="SpanningIsland TheRangeBlogPost HalfPage Ad">
  
  <!-- /4961490/TW_ROS_right_300x600 -->
          <div id="div-gpt-ad-tw_ros_right_300x600" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_300x600" data-output="asynchronous" data-width="300" data-height="600">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_300x600');
                  });
              </script>
          </div>
  
</div><div id="Rectangle2" class="SpanningIsland TheRangeBlogPost Ad MediumRectangle">
  <!-- /4961490/TW_ROS_right_300x250_2 -->
          <div id="div-gpt-ad-tw_ros_right_300x250_2" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_300x250_2" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_300x250_2');
                  });
              </script>
          </div>
</div><div id="Rectangle4" class="SpanningIsland TheRangeBlogPost Ad MediumRectangle">
  
  <!-- /4961490/TW_WeGotCactus_300x250_2 -->
          <div id="div-gpt-ad-tw_wegotcactus_300x250_2" style="" data-content-type="ad" data-slot="/4961490/TW_WeGotCactus_300x250_2" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_wegotcactus_300x250_2');
                  });
              </script>
          </div>
  
</div><div id="Rectangle5" class="SpanningIsland TheRangeBlogPost Ad MediumRectangle">
  
  <!-- /4961490/TW_WeGotCactus_300x250_3 -->
          <div id="div-gpt-ad-tw_wegotcactus_300x250_3" style="" data-content-type="ad" data-slot="/4961490/TW_WeGotCactus_300x250_3" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_wegotcactus_300x250_3');
                  });
              </script>
          </div>
  
</div>
      </div><!-- end gridSpanningIsland -->  
     
      <div id="gridMainSidebar">
        <div id="Skyscraper1" class="MainSidebar TheRangeBlogPost Ad Skyscraper">
  
  <!-- /4961490/TW_ROS_right_160x600 -->
          <div id="div-gpt-ad-tw_ros_right_160x600" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_160x600" data-output="asynchronous" data-width="160" data-height="600">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_160x600');
                  });
              </script>
          </div>
  
</div>
      </div><!-- end gridMainSidebar -->

      <div id="gridAdSidebar">
        <div id="Skyscraper2" class="AdSidebar TheRangeBlogPost Ad Skyscraper">
  
  <!-- /4961490/TW_ROS_right_160x600_2 -->
          <div id="div-gpt-ad-tw_ros_right_160x600_2" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_160x600_2" data-output="asynchronous" data-width="160" data-height="600">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_160x600_2');
                  });
              </script>
          </div>
  
</div>
      </div><!-- end gridAdSidebar -->
      
      <div id="gridBottomSidebar">
        <div id="BigSkyscraper300x600Ad2" class="MainSidebar TheRangeBlogPost Ad HalfPage">
  <!-- /4961490/TW_ROS_right_300x600_2 -->
          <div id="div-gpt-ad-tw_ros_right_300x600_2" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_300x600_2" data-output="asynchronous" data-width="300" data-height="600">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_300x600_2');
                  });
              </script>
          </div>
</div><div id="BigSkyscraper300x6003" class="MainSidebar TheRangeBlogPost Ad HalfPage">
  <!-- /4961490/TW_ROS_right_300x600_3 -->
          <div id="div-gpt-ad-tw_ros_right_300x600_3" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_300x600_3" data-output="asynchronous" data-width="300" data-height="600">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_300x600_3');
                  });
              </script>
          </div>
</div><div id="BigSkyscraper300x6004" class="MainSidebar TheRangeBlogPost Ad HalfPage">
  <!-- /4961490/TW_ROS_right_300x600_4 -->
          <div id="div-gpt-ad-tw_ros_right_300x600_4" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_300x600_4" data-output="asynchronous" data-width="300" data-height="600">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_300x600_4');
                  });
              </script>
          </div>
</div><div id="BigSkyscraper300x6005" class="MainSidebar TheRangeBlogPost Ad HalfPage">
  <!-- /4961490/TW_ROS_right_300x600_5 -->
          <div id="div-gpt-ad-tw_ros_right_300x600_5" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_300x600_5" data-output="asynchronous" data-width="300" data-height="600">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_300x600_5');
                  });
              </script>
          </div>
</div>
      </div>
    </div><!-- end gridRightColumn -->
    
    <!-- Footer -->
    <div id="gridFooter">
      


    <div id="FooterNavigation" class="GlobalFooter TheRangeBlogPost ">
      <ul>
  
  
  <li class="">
    <a href="https://www.tucsonweekly.com/" target="_self">
      
        home
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/opinion/Section?oid=1063711" target="_self">
      
        opinion
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/currents/Section?oid=1063709" target="_self">
      
        currents
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/cityweek/Section?oid=1063710" target="_self">
      
        city week
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/cinema/Section?oid=1063716" target="_self">
      
        cinema
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/arts/Section?oid=1063713" target="_self">
      
        arts
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/books/Section?oid=1063715" target="_self">
      
        books
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/chow/Section?oid=1063714" target="_self">
      
        chow
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/BestOf" target="_self">
      
        best of tucson®
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.facebook.com/tucsonweekly" target="_blank">
      
        Facebook
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/ArticleArchives" target="_self">
      
        archives
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/Advertising/Page" target="_self">
      
        advertising
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/PrivacyPolicy/Page" target="_self">
      
        privacy policy
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/Staff/Page" target="_self">
      
        Staff / Contact Us
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="rss-icon">
    <a href="https://www.tucsonweekly.com/tucson/Syndication/Page" target="_self">
      
        rss
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.flickr.com/photos/tucsonweekly/" target="_blank">
      
        Flickr
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.twitter.com/TucsonWeekly" target="_blank">
      
        Twitter
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/TermsConditions/Page" target="_self">
      
        terms & conditions
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://displayads.tucsonweekly.com/" target="_self">
      
        print ads
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/CommentsPolicy/Page" target="_self">
      
        comments policy
      
    </a>
    
    
  </li> 
  

      </ul>
    </div>
  



<div id="footerCopyright">
  <p>
   &copy; 2018
   Tucson Weekly |
   7225 Mona Lisa Rd. Ste. 125, Tucson AZ 85741 |
   
  (520) 797-4384 |
   Powered by <a href="http://foundation.gyrobase.com/" target="_blank">Foundation</a>
  </p>
</div><!-- start compete.com tag -->
<script type="text/javascript">
    __compete_code = '312a684a250efb96916726877042f53b';
    (function () {
        var s = document.createElement('script'),
            d = document.getElementsByTagName('head')[0] ||
                document.getElementsByTagName('body')[0],
            t = 'https:' == document.location.protocol ? 
                'https://c.compete.com/bootstrap/' : 
                'http://c.compete.com/bootstrap/';
        s.src = t + __compete_code + '/bootstrap.js';
        s.type = 'text/javascript';
        s.async = 'async'; 
        if (d) { d.appendChild(s); }
    }());
</script>
<!-- end compete.com tag --> </div>


<!-- Start Google Analytics -->
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-3905397-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'stats.g.doubleclick.net/dc.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<!-- End Google Analytics -->


<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-6cJMtQ1dR3JBg"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-6cJMtQ1dR3JBg.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->


  <img src="/foundation/images/icons/pixel.gif?oid=16969914" alt="" />


    </div><!-- end gridFooter -->

  </div><!-- end gridMain -->

</div><!-- end gridClamp -->

<!-- Closer -->
<div id="gridCloser">
  <div id="FullBackgroundAd" class="Closer TheRangeBlogPost ">
  <!-- /4961490/BackgroundAd1950x930 -->
          <div id="div-gpt-ad-backgroundad1950x930" style="" data-content-type="ad" data-slot="/4961490/BackgroundAd1950x930" data-output="asynchronous" data-width="1950" data-height="930">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-backgroundad1950x930');
                  });
              </script>
          </div>
</div>
</div><!-- end gridCloser -->
    </body>
</html>
  


