





























































  
           
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "https://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="https://www.w3.org/1999/xhtml" xmlns:fb="https://www.facebook.com/2008/fbml" xml:lang="en" lang="en">

<head>
  
  <meta name="viewport" content="width=1000">

  
  <meta name="layout" content="The Range Blog Post" />
  
    <meta name="oid" content="16066002" />
  
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <meta http-equiv="imagetoolbar" content="no" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />

  
  
  
  <link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=c76589a9b8179c4fc56eb20f17fd28b7" />

  
  
    <link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=c76589a9b8179c4fc56eb20f17fd28b7" />
    <link rel="stylesheet" type="text/css" href="/styles/components.css?cb=c76589a9b8179c4fc56eb20f17fd28b7" />
    <link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=c76589a9b8179c4fc56eb20f17fd28b7" />
  

  <style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>

  
    <link rel="stylesheet" type="text/css" href="/foundation/grids/iapetus-10-zone.css" />
  

  <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
  <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
  <!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
  <!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->

  <link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />

  
  
    
    
      <link rel="alternate" type="application/rss+xml" title="Tucson Weekly RSS: Whole Site" href="https://www.tucsonweekly.com/tucson/Rss.xml" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Tucson Weekly RSS: News &amp; Opinion Section" href="https://www.tucsonweekly.com/tucson/Rss.xml?oid=1063709" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Tucson Weekly RSS: The Range: The Tucson Weekly&#39;s Daily Dispatch" href="https://www.tucsonweekly.com/tucson/Rss.xml?oid=1125619" />
      
    

    
    
      <link rel="alternate" type="application/rss+xml" title="Tucson Weekly RSS: Comments on Laughing Stock: Overstock! So. Much. Comedy." href="https://www.tucsonweekly.com/tucson/Rss.xml?id=comments&amp;oid=16066002" />
    
  

  
  
    <!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
      
      <script>
        if (!window.Promise) document.write('<scr'+'ipt src="https://cdnjs.cloudflare.com/ajax/libs/native-promise-only/0.8.1/npo.src.js"></scr'+'ipt>')
      </script>
    
    
    
    
    <script src="/foundation/scripts/common.js?cb=5d2f164a93c73fc3962b7ea019afabe8"></script>
  
    
    
    
    
    
    
    <script src="/foundation/scripts/desktop-bundle.js?cb=5d2f164a93c73fc3962b7ea019afabe8"></script>
  

  
  <link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
  <script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>

  
  <script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("https:\/\/www.tucsonweekly.com\/tucson\/Profile", "https:\/\/posting.tucsonweekly.com\/tucson\/MyProfile");
  </script>
  
  
  

  
  
    <meta name="google-signin-client_id" content="345770844416-lrktslqgimjsduaogv54o86orkjohqm1.apps.googleusercontent.com">
  

    
  

  
  
<meta name="viewport" content="width=1000" />
 
<!-- Google Fonts -->
<link href='https://fonts.googleapis.com/css?family=Anton|Open+Sans:300,400,700' rel='stylesheet' type='text/css'>
<link href='https://fonts.googleapis.com/css?family=Yanone+Kaffeesatz' rel='stylesheet' type='text/css'>
<!-- End Google Fonts -->





  
    <script type='text/javascript'>
              var googletag = googletag || {};
              googletag.cmd = googletag.cmd || [];
              (function() {
                var gads = document.createElement('script');
                gads.async = true;
                gads.type = 'text/javascript';
                var useSSL = 'https:' == document.location.protocol;
                gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(gads, node);
              })();
          </script>
          <script type='text/javascript'>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</script>
  



   <meta name="google-site-verification" content="1shMVE6r6wpDwBgxHmNKSAVS9_A0RaoG53XlEOtHOJM" />





  



<!-- Global TNCMS Ad Manager javascript files -->

<script type='text/javascript' src='https://www.insidetucsonbusiness.com/shared-content/tncms-ad-manager/ads.js'></script>
<script type='text/javascript' src='https://www.insidetucsonbusiness.com/shared-content/flowplayer/flashembed.min.js'></script>
<script type='text/javascript' src='https://www.insidetucsonbusiness.com/shared-content/swfobject/swfobject.js'></script>
<script type='text/javascript' src='https://www.insidetucsonbusiness.com/content/tncms/ads/tncms-ad-limits.js'></script>






<script>

Foundation.documentReady.then(function(){ //initialize
jQuery(".pencil-content").hide(); 
  jQuery(".pencil-top").click(function(){
      jQuery(this).next(".pencil-content").slideToggle(500);
  });

   if (document.cookie.indexOf('visited=true') == -1) {
    			        var fifteenDays = 1000*60*10;
    			        var expires = new Date((new Date()).valueOf() + fifteenDays);
    			        document.cookie = "visited=true;expires=" + expires.toUTCString();

  jQuery(".pencil-content")
   .slideToggle( function() 
   {
      setTimeout( function()
      {
         jQuery(".pencil-content").slideToggle(500);
      }, 3000);
   });
}
 });


</script>
  
  
  
  
  


  
  
  


  
  <link rel="shortcut icon" href="/favicon.ico" />
  <meta name="title" content="Laughing Stock: Overstock! So. Much. Comedy. | The Range: The Tucson Weekly&#39;s Daily Dispatch" />
  <meta name="description" content="Club Congress is Comedy Central Los Angeles comedians Dave Ross and Chris Charpentier mix it up with the locals at Club Congress at 8 PM,..." />
  <meta name="keywords" content="Dave Ross, Chris Charpentier, Club Congress, Chris Thayer, Kristine Levine, Pauly Casillas, Rockabilly Raceway, The Gaslight Theatre, Beatles hits, olio, Weird Al Yankelovich, The Hamilton Polka, Fox Tucson Theatre, Creative Tucson Studios, Matt Ziemak, Rich Aguirre, Airing It Out Live, Josiah Osego, Amber Frame, Randall Scott, Meredith Armstrong, Tucson Mojo, Carlos Arzati, Katie Haverly, Jillian Besset." />
  <title>Laughing Stock: Overstock! So. Much. Comedy. | The Range: The Tucson Weekly's Daily Dispatch</title>

  
  
  
    <meta name="author" content="Linda Ray">
  

  
  
  <meta name="news_keywords" content="dave ross, chris charpentier, club congress, chris thayer, kristine levine, pauly casillas, rockabilly raceway, the gaslight theatre, beatles hits, olio" />

  
  
    
  
  
    <link rel="image_src" href="https://media1.fdncms.com/tucsonweekly/imager/u/slideshow/16145063/kristine_levine.jpg" />
    <meta name="thumbnail" content="https://media1.fdncms.com/tucsonweekly/imager/u/slideshow/16145063/kristine_levine.jpg" />
  

  
    
      <link rel="canonical" href="https://www.tucsonweekly.com/TheRange/archives/2018/05/03/laughing-stock-overstock-so-much-comedy" />
      <link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.tucsonweekly.com/TheRange/archives/2018/05/03/laughing-stock-overstock-so-much-comedy" />
      
    

    
    
    
      
      
      <link rel="amphtml" href="https://www.tucsonweekly.com/TheRange/archives/2018/05/03/laughing-stock-overstock-so-much-comedy?media=AMP+HTML" />
    
  

  
    
      <meta property="og:url" content="https://www.tucsonweekly.com/TheRange/archives/2018/05/03/laughing-stock-overstock-so-much-comedy" />
    
  

  
    <meta property="fb:app_id" content="187122448009492" />
  

  
  <meta property="og:site_name" content="Tucson Weekly" />
  <meta property="og:title" content="Laughing Stock: Overstock! So. Much. Comedy." />
 
  
    

    
    

    
    

    <meta property="og:image" content="https://media1.fdncms.com/tucsonweekly/imager/u/slideshow/16145063/kristine_levine.jpg" />

    
      <meta property="og:image:width" content="625" />
      <meta property="og:image:height" content="417" />
    
  

  
  
    <meta property="og:description" content="Club Congress is Comedy Central : Los Angeles comedians Dave Ross and Chris Charpentier mix it up with the locals at Club Congress at 8 PM, Sunday, May 6. It&rsquo;s a 21-and-over show; tickets are $10. : Ross is best known for his role as Trademarq in the Comedy Central series, Corporate. Fans also remember his bits in This is Not Happening, Drunk History and WTF with Marc Maron. : Per his bio, Ross loves to yell and laugh, tell cum jokes and make the audience feel like family. : Ross also has played sketch comedy at the SF Sketchfest, and he&rsquo;s a storyteller with a Moth Grand Slam title. The Moth Radio Hour and podcast are much admired in Tucson&rsquo;s sizeable storytelling circles nurtured by FST and Odyssey Storytelling. : At Congress, Ross will concentrate on standup, as will touring companion, Charpentier, who has a West Coast improv background but made his national debut as a standup artist less than a year ago on the Jimmy Kimmel show. : The May 6 show opens with Tucson&rsquo;s top talent, Chris Thayer, a frequent cast member in Comedy Central series&rsquo; and numerous comedy podcasts, and a writer for Funny Or Die, among others. Kristine Levine of The Frank Show and Portlandia, and Tucson&rsquo;s comedy OG Pauly Casillas round out the bill. Casillas runs comedy shows in both Tucson and Phoenix. : Kristine Levine: More to Love : On May 5, Levine releases her first CD, Hey, Sailor, at the grand opening of Tucson Mojo, 228 N.4th Avenue. The 60-minute disc spans her career, including motherhood and retail work in a porn shop. &ldquo;My story is always moving,&rdquo; She says. &ldquo;My comedy is always evolving. What&#39;s that saying?  A poem is never finished, its abandoned? That&#39;s it. But more fun than poems.&rdquo; : Musical entertainment begins at 6 p.m. and includes Carlos Arzate, Katie Haverly and Jillian Besset. The comedy begins at 8 p.m. : You could be on TV! : Rich Aguirre and Matt Ziemak continue their live-broadcast standup comedy series, Airing It Out Live, at 8 pm., Friday, May 4. Featured are sets by Josiah Osego, Amber Frame, Randall Scott and Meredith Armstrong. : The show takes place at Creative Tucson Studios, 1100 S. 6th Ave. Admission is free. It&#39;s also broadcast live on channel 20, and videos will be available after the show at creativetucson.org/watch/live-20. : The Hamilton Polka. : Weird Al Yankelovich comes to the Fox Theatre at 8 p.m. May 5. We&rsquo;re excited about whatever  he&rsquo;ll sing about Cinco de Mayo. His song-subversions have been hilarious for decades, but his relevance to contemporary audiences is secured with the astonishing The Hamilton Polka, available now wherever you download. Tickets are $37 to $239 via foxtucsontheatre.ticketforce.com. : Race to Rockabilly Raceway : Rockabilly Raceway continues through June 3 at The Gaslight Theater, thegaslighttheatre.com. It&rsquo;s another family-friendly, see-through plot with silly song matches and crowd interactions. These are songs the whole family knows and loves, including the Edsels, Elvis and Etta James. The olio is a parade of Beatles hits." />
  

  
  

  
  
    <meta property="og:type" content="article" />
  

  
  

    
    

    
    

    
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:image" content="https://media1.fdncms.com/tucsonweekly/imager/u/slideshow/16145063/kristine_levine.jpg">

    
    

    

    <meta name="twitter:site" content="@tucsonweekly">
    <meta name="twitter:title" content="Laughing Stock: Overstock! So. Much. Comedy.">
    <meta name="twitter:description" content="Club Congress is Comedy Central Los Angeles comedians Dave Ross and Chris Charpentier mix it up with the locals at Club Congress at 8 PM,...">
  

  
  
  <!--
    <PageMap>
      <DataObject type="foundation">
        <Attribute name="oid">16066002</Attribute>
        <Attribute name="class">Content</Attribute>
        <Attribute name="lastmodified">20180503190040</Attribute>
        <Attribute name="creationdate">20180425184005</Attribute>
      </DataObject>

      
        
          <DataObject type="document">
            <Attribute name="releasedatetime">20180503185600</Attribute>
            <Attribute name="releasedate">20180503</Attribute>
            <Attribute name="releaseepoch">1525398960</Attribute>
            <Attribute name="title">Laughing Stock: Overstock! So. Much. Comedy.</Attribute>
            <Attribute name="author">1063875</Attribute>
            <Attribute name="authorname">Linda Ray</Attribute>
            <Attribute name="authorsortname">Ray, Linda</Attribute>
          </DataObject>
        

        
      
    </PageMap>
  -->


  
  
  
  
    
    <script type="application/ld+json">
        {
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id":"https:\/\/www.tucsonweekly.com\/TheRange\/archives\/2018\/05\/03\/laughing-stock-overstock-so-much-comedy"
          },
          "headline": "Laughing Stock: Overstock! So. Much. Comedy.",
          
            "description": "Club Congress is Comedy Central\n Los Angeles comedians Dave Ross and Chris Charpentier mix it up with the locals at Club Congress at 8 PM, Sunday, May 6. It’s a 21-and-over show; tickets are $10.",
          
          
            "image": {
              "url": "https:\/\/media1.fdncms.com\/tucsonweekly\/imager\/u\/original\/16145063\/kristine_levine.jpg",
              "width": 1852,
              "height": 1235,
              "@type": "ImageObject"
            },
          
          "datePublished": "2018-05-03T18:56:00",
          "dateModified": "2018-05-03T19:00:40",
          
            "author": {
              "name": "Linda Ray",
              "@type": "Person"
            },
          
          "publisher": {
            "name": "Tucson Weekly",
            
              
              
              
              "logo": {
                "url": "https:\/\/www.tucsonweekly.com\/imager\/b\/google-amp-logo\/808579\/93e9\/adminIcon_tw.jpg",
                "width": 60,
                "height": 60,
                "@type": "ImageObject"
              },
            
            "@type": "Organization"
          },
          "@context": "https://schema.org",
          "@type": "NewsArticle"
        }
      </script>
  


</head>





  <body id="Post" class="BlogPost Iapetus10Zone newsopinion TheRange">



<div id="fb-root"></div>


  <script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>




  <script>
    (function () {
      var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
        //if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
      }.bind(this), function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
      })
    })()
  </script>
    

<!-- Leader -->
<div id="gridLeader">
  
</div><!-- end gridLeader -->

<div id="gridClamp">
  <!-- Header -->
  <div id="gridHeader">
    




  
  

  
  
  

  

    
      <div id="MobileDetect" class="GlobalHeader TheRangeBlogPost " style="display:none">
        
        
          Switch to the <a href="https://m.tucsonweekly.com/TheRange/archives/2018/05/03/laughing-stock-overstock-so-much-comedy" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  

<div id="Leaderboard" class="GlobalHeader TheRangeBlogPost Leaderboard Ad">
  
    <!-- /4961490/TW_ROS_Top_728x90 -->
          <div id="div-gpt-ad-tw_ros_top_728x90" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_Top_728x90" data-output="asynchronous" data-width="728" data-height="90">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_top_728x90');
                  });
              </script>
          </div>
  
</div>

  <div id="Logo" class="GlobalHeader TheRangeBlogPost Leaderboard">
      
      <div id="header-contain">

        <div id="headerLeft">
         <div class="earAdLeft" style="width:250px;height:60px;">
               <!-- potential ad here -->
          </div>          

           <div class="headerLogin">     

            
  
            
            
              
              <ul data-view="loggedin" style="display:none">
                <li><strong data-label="username">Username</strong> / </li>
                
                <li><a href="https://posting.tucsonweekly.com/tucson/Profile/MySettings">Edit Settings</a> / </li>
                <li><a href="https://www.tucsonweekly.com/tucson/Logout">Log Out</a></li>
              </ul>

              <ul data-view="loggedout" style="display:none">
                <li><a href="#LogIn">Log in</a> / </li>
                <li><a href="#CreateAccount">Create Account</a></li>
              </ul>
            

            
            
              <script>
                new Foundation.LoginRequiredComponent("Logo");
              </script>
            
          </div> <!-- end login --> 
        </div> <!-- end headerLeft -->

         
           <div id="header-logo"><a href="https://www.tucsonweekly.com/">Tucson Weekly</a></div>    
         

         <div id="headerRight">        
          <div class="earAdRight" style="width:250px;height:60px;">
               <!-- potential ad here -->
          </div>          

         <div class="search"> 
           

            

              
              
              <form class="prepTextForm" id="searchbox_017793458706336421686:xynrvxedw04" action="https://www.tucsonweekly.com/tucson/Search">
                  <input type="hidden" name="cx" value="017793458706336421686:xynrvxedw04" />
                  <input type="hidden" name="cof" value="FORID:9" />
                  <input type="text" name="q" size="25" />
                  <input type="submit" name="sa" value="Search" />
              </form>
            
            <ul class="socialIcons">
               <li><a href="https://www.facebook.com/tucsonweekly" class="socialFBIcon">Facebook</a></li>    
               <li><a href="https://twitter.com/tucsonweekly" class="socialTweetIcon">Twitter</a></li>    
             </ul>
          </div>   <!-- end search -->

         </div> <!-- end headerRight -->
 
     </div> <!-- end headerContain -->
    </div>  <!-- end header Component --> 


















  <div id="NavigationHorizontal" class="GlobalHeader TheRangeBlogPost  ">
    
      
      
          <ul id="mainNav">
        
        

        

        

        

        <li class="first" id="NavItem_home">
          <a href="https://www.tucsonweekly.com/"  >Home</a>
        </li>
        
      
        

        

        

        

        <li class="navCurrent" id="NavItem_newsopinion">
          <a href="https://www.tucsonweekly.com/tucson/news-and-opinion/Section?oid=1063709"  class="subnav_link" id="SNAVL_newsopinion">News &amp; Opinion</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_chow">
          <a href="https://www.tucsonweekly.com/tucson/chow/Section?oid=1063714"  class="subnav_link" id="SNAVL_chow">Chow</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Events10days">
          <a href="https://www.tucsonweekly.com/tucson/Content?topic=7302251"  class="subnav_link" id="SNAVL_Events10days">Events</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_cinema">
          <a href="https://www.tucsonweekly.com/tucson/cinema/Section?oid=1063716"  class="subnav_link" id="SNAVL_cinema">Cinema</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_music">
          <a href="https://www.tucsonweekly.com/tucson/music/Section?oid=1063712"  class="subnav_link" id="SNAVL_music">Music</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_artsculture">
          <a href="https://www.tucsonweekly.com/tucson/arts-and-culture/Section?oid=1063713"  class="subnav_link" id="SNAVL_artsculture">Arts &amp; Culture</a>
        </li>
        
      
        

        

        

        

        <li class="last" id="NavItem_bestoftucson">
          <a href="https://www.tucsonweekly.com/tucson/BestOf"  class="subnav_link" id="SNAVL_bestoftucson">Best of Tucson&reg;</a>
        </li>
        
      
          </ul>
        

      
        
        
          
            <h3 class="hidden">Browse </h3>
            <ul class="subnav_content" id="SNAV_" style="display:none;">
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/books/Section?oid=1063715"  title="">Books Main Page</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063715"  title="">Books Archives</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse News &amp; Opinion</h3>
            <ul class="subnav_content" id="SNAV_newsopinion" style="display:none;">
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/currents/Section?oid=1063709"  title="">News &amp; Opinion Main Page</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/cover-story/Content?special=1125844"  title="">Cover Story</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Category?oid=1063734"  title="">Currents Features</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/editors-note/Content?category=1063766"  title="">Editor&#39;s Note</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Category?oid=1063741"  title="">Danehy</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Category?oid=3147720"  title="The Tucson Weekly's column on the local world of medical marijuana.">Medical MJ</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/ask-a-mexican/Content?category=1063806"  title="">Ask a Mexican!</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/the-skinny/Content?category=1063733"  title="">The Skinny</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/police-dispatch/Category?oid=1063770"  title="">Police Dispatch</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/media-watch/Category?oid=1063784"  title="">Media Watch</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/guest-commentary/Category?oid=1063786"  title="">Guest Commentary</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/dust-devils/Category?oid=4921545"  title="Please send letters to Tucson Weekly, 7225 N. Mona Lisa Road, Suite 125, Tucson, AZ 85741 or email to mari@tucsonlocalmedia.com. Dust Devil, 70-word short stories, are due Friday, Noon. Get busy, Tucson.">Dust Devils</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?category=5928956"  title="">Tucson Salvage</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/letters-to-the-editor/Category?oid=4921578"  title="">Letters to the Editor</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/blogs/TheRange/"  title="">The Range</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Events</h3>
            <ul class="subnav_content" id="SNAV_Events10days" style="display:none;">
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=Today"  title="">Events Today</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?feature=Staff%20Pick"  title="">Staff Pick Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107349"  title="">Bulletin Board</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch"  title="">Location Guide</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Events/AddEvent"  title="">Submit an Event Listing</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Cinema</h3>
            <ul class="subnav_content" id="SNAV_cinema" style="display:none;">
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/cinema/Section?oid=1063716"  title="">Cinema Main Page</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/now-showing-at-home/Category?oid=1063785"  title="">Now Showing at Home</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063716"  title="">Cinema Archives</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Music</h3>
            <ul class="subnav_content" id="SNAV_music" style="display:none;">
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/music/Section?oid=1063712"  title="">Music Main Page</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Category?oid=1063737"  title="">Music Features</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/soundbites/Content?category=1063738"  title="">Soundbites</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/live/Content?category=1063790"  title="">Live</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?eventSection=1107700&eventCategory=1107701"  title="">Live Music Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?oid=1113914&amp;locationCategory=1113914"  title="">Bars</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113974&sortType=name"  title="">Music Venues</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063712"  title="">Music Archives</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Events/AddEvent"  title="">Submit Club Listings</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Arts &amp; Culture</h3>
            <ul class="subnav_content" id="SNAV_artsculture" style="display:none;">
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/arts/Section?oid=1063713"  title="">Arts Main Page</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/category?oid=1063742"  title="">Book Features</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107327"  title="">Art Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113916"  title="">Galleries</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107325"  title="">Museum Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113923"  title="">Museums</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107320"  title="">Theater Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113917"  title="">Theaters</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107323"  title="">Dance Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113925"  title="">Bookstores</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113933"  title="">Coffee Houses</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationCategory=1113924"  title="">Libraries</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/EventSearch?eventCategory=1107335"  title="">Literature Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063713"  title="">Arts Archives</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Events/AddEvent"  title="">Submit an Event Listing</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Chow</h3>
            <ul class="subnav_content" id="SNAV_chow" style="display:none;">
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/chow/Section?oid=1063714"  title="">Chow Main Page</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Category?oid=1063740"  title="">Chow Features</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationSection=1113936"  title="">Restaurants</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/LocationSearch?locationSection=1113936&feature=Menu"  title="">Restaurant Menus</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/CommentArchives?feature=Locations&locationSection=1113936"  title="">Reader Reviews</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?section=1063714"  title="">Chow Archives</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?category=1063794"  title="">Yum! Archives</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Best of Tucson&reg;</h3>
            <ul class="subnav_content" id="SNAV_bestoftucson" style="display:none;">
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/Survey?survey=16173761"  title="">Best of Tucson 2018 Ballot</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.tucsonweekly.com/tucson/BestOf"  title="">Best of Tucson&reg; Main Page</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/arts-and-culture/BestOf?category=1063746"  title="">Best of Tucson&reg;: Arts &amp; Culture</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/city-life/BestOf?category=1063748"  title="">Best of Tucson&reg;: City Life</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/BestOf?category=1063749&year=2011"  title="">Best of Tucson&reg;: Casual Dining</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/BestOf?category=3153201"  title="">Best of Tucson&reg;: &iexcl;Cultura!</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/BestOf?category=3153674&year=2011"  title="">Best of Tucson&reg;: Fashion + Style</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/BestOf?category=1063749"  title="">Best of Tucson&reg;: Kids&#39; Stuff</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/BestOf?category=1063781"  title="">Best of Tucson&reg;: Media Mix</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/outdoors/BestOf?category=1063750"  title="">Best of Tucson&reg;: Outdoors</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/kids-stuff/BestOf?category=1063782"  title="">Best of Tucson&reg;: Restaurants</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.tucsonweekly.com/tucson/spirits/BestOf?category=1063752"  title="">Best of Tucson&reg;: Spirits &amp; Nightlife</a>
          </li>
          
            </ul>
          
        

        

        
        
        
      
    
  </div>


  

  
  
  
    
    

      

      <script>
      "use strict";
      (function(){
        //
        if(navigator.userAgent.match(/\b(iPad|iPhone|iPod|Android|Pre|BlackBerry|Windows Phone)\b/i)){
          //
          //
            jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
          //
          //

        //
        }else{
          jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
        }
      })();
      </script>
    
  
  <!-- true == "true"
         && true == "devel" -->


<!-- End #NavigationHorizontal -->


    <div id="NavigationSubLinks" class="GlobalHeader TheRangeBlogPost ">
      <ul class="subnavlinks">
  
  
  
  

  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/IssueArchives" target="_self">Issues</a>
  </li>

  

  
  
  

  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/Newsletter" target="_self">Newsletter Signup</a>
  </li>

  

  
  
  

  <li class="">
    <a href="http://issuu.com/tucsonweekly/docs" target="_blank">Online Edition</a>
  </li>

  

  
  
  

  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/Events/AddEvent" target="_self">Submit A Listing</a>
  </li>

  

  
  
  

  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/ArticleArchives" target="_self">archives</a>
  </li>

  

  
  
  

  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/dust-devils/Content?category=4921545" target="_self">Dust Devils</a>
  </li>

  

  
  
  

  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/WhereCanIGetaTucsonWeekly/Page" target="_self">Find a Weekly</a>
  </li>

  

      </ul>
    </div>
  




  </div><!-- end gridHeader -->

  <div id="gridMain">

    <div id="gridFrame">

      <div id="gridSpanningFeature">
        


      

  <div id="BlogHeaderCategoryList" class="SpanningFeature TheRangeBlogPost  ">
    <h1 class="TheRange">
      
        <a href="https://www.tucsonweekly.com/blogs/TheRange/">The Range: The Tucson Weekly's Daily Dispatch</a>
      
    </h1>

    <p style="float:left;">
      <a href="https://www.tucsonweekly.com/tucson/TheRange/blogs/Archives">Archives</a> | 
      <a href="/tucson/Rss.xml?category=1125619">RSS</a>
    </p>

    <p style="padding-left:150px;text-align:right;">
      <strong>Blog Categories:</strong>
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/politics/">Politics</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/news/">News</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/music/">Music</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/do-this/">Do This!</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/chow/">Chow</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/media/">Media</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/cinema/">Cinema</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/education/">Education</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/arts-and-culture/">Arts and Culture</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/fun-in-general/">Fun in General</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/sports/">Sports</a> |  
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/tv/">TV</a> |  
      
      <a href="https://www.tucsonweekly.com/tucson/TheRange/blogs/Archives">more&nbsp;categories&raquo;</a>
    </p>

  </div>





  
  

  <div id="BlogsPreviousNext" class="SpanningFeature TheRangeBlogPost ">
    <div class="prevNext">
      
        <a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/03/its-best-of-tucson-time" class="prev" rel="prev">&laquo;&nbsp;It's Best of Tucson Time</a>
        
    </div>
  </div>








  
  <link type="text/css" href="/foundation/scripts/jplayer/skin/jplayer.blue.monday.css" rel="stylesheet" />
  <script type="text/javascript" src="/foundation/scripts/jplayer/jquery.jplayer.min.js"></script>               
  
    <style>
    div.jp-audio,
    div.jp-video {
      /* Edit the font-size to counteract inherited font sizing.
       * Eg. 1.25em = 1 / 0.8em
       */
      font-size:1.25em;
    }      
    div.postBody div.inlineAudio,
    div#AudioPlayer div.inlineAudio {
      width: 400px;
      margin: auto;
      clear:both;
      }      
    </style>
  

  <div id="BlogsBlogPost" class="SpanningFeature TheRangeBlogPost   ">

    

    













    
    
    
    
  
    
      
      
        <h2 class="blogDate">Thursday, May  3, 2018</h2>
      
    
      
      <div class="blogPost therange ">
    
    
        
    
    <h3 class="postTitle" id="a16066002">
      
      
      
      
      
      
        Laughing Stock: Overstock! So. Much. Comedy.
      

      
    </h3>

    

    
      <h4 class="postedBy">
        
        <span class="byAttribute">Posted</span>
        
          
          <span class="byAttribute">By</span> <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?author=1063875" rel="author">Linda Ray</a>
        
        
          
            on <span class="postTime">Thu, May  3, 2018</span> at <span class="postTime"> 6:56 PM</span>
          
        
           
      </h4>
    

   
    
    

    

    
    

    
    

    <div class="postBody">
      
          
      


      
     
       
      
      
      
      
       
      
      

      
      

      
      
        
        <div class="contentImageRight" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/tucsonweekly/imager/u/original/16145063/kristine_levine.jpg" class="zoomable" rel="contentImg_gal-16066002" title="Kristine Levine releases her first CD at the grand opening of Mojo Tucson on May 5.">                  <img src="https://media1.fdncms.com/tucsonweekly/imager/u/blog/16145063/kristine_levine.jpg?cb=1525035584" width="250" height="167" alt="Kristine Levine releases her first CD at the grand opening of Mojo Tucson on May 5." />                </a>                                                                                                           <ul style="width:250px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                <li class="imageCaption">                      Kristine Levine releases her first CD at the grand opening of Mojo Tucson on May 5.                    </li>                                                                                                </ul>                                                       </div>     
<h2 class="content_h2"><b>Club Congress is Comedy Central</b><br></h2>
 Los Angeles comedians Dave Ross and Chris Charpentier mix it up with the locals at Club Congress at 8 PM, Sunday, May 6. It’s a 21-and-over show; tickets are $10.<br>
  Ross is best known for his role as Trademarq in the Comedy Central series, <i>Corporate</i>. Fans also remember his bits in <i>This is Not Happening, Drunk History</i> and WTF with Marc Maron. <br>
  <br>
  Per his bio, Ross loves to yell and laugh, tell cum jokes and make the audience feel like family. <br>
  <br>
  Ross also has played sketch comedy at the SF Sketchfest, and he’s a storyteller with a Moth Grand Slam title. The Moth Radio Hour and podcast are much admired in Tucson’s sizeable storytelling circles nurtured by FST and Odyssey Storytelling. <br>
  <br>
  At Congress, Ross will concentrate on standup, as will touring companion, Charpentier, who has a West Coast improv background but made his national debut as a standup artist less than a year ago on the Jimmy Kimmel show.<br>
  <br>
  The May 6 show opens with Tucson’s top talent, Chris Thayer, a frequent cast member in Comedy Central series’ and numerous comedy podcasts, and a writer for Funny Or Die, among others. Kristine Levine of The Frank Show and Portlandia, and Tucson’s comedy OG Pauly Casillas round out the bill. Casillas runs comedy shows in both Tucson and Phoenix.<br>
  <br>
  
<h2 class="content_h2"><b>Kristine Levine: More to Love</b><br></h2>
 On May 5, Levine releases her first CD, Hey, Sailor, at the grand opening of Tucson Mojo, 228 N.4th Avenue. The 60-minute disc spans her career, including motherhood and retail work in a porn shop. “My story is always moving,” She says. “My comedy is always evolving. What's that saying?  A poem is never finished, its abandoned? That's it. But more fun than poems.”<br>
  Musical entertainment begins at 6 p.m. and includes Carlos Arzate, Katie Haverly and Jillian Besset. The comedy begins at 8 p.m.<br>
  
<h2 class="content_h2"><b>You could be on TV!</b><br></h2>
 Rich Aguirre and Matt Ziemak continue their live-broadcast standup comedy series, Airing It Out Live, at 8 pm., Friday, May 4. Featured are sets by Josiah Osego, Amber Frame, Randall Scott and Meredith Armstrong.<br>
  <br>
  The show takes place at Creative Tucson Studios, 1100 S. 6th Ave. Admission is free. It's also broadcast live on channel 20, and videos will be available after the show at creativetucson.org/watch/live-20.<br>
  <br>
  
<h2 class="content_h2"><b>The Hamilton Polka</b>.<br></h2>
 Weird Al Yankelovich comes to the Fox Theatre at 8 p.m. May 5. We’re excited about whatever  he’ll sing about Cinco de Mayo. His song-subversions have been hilarious for decades, but his relevance to contemporary audiences is secured with the astonishing The Hamilton Polka, available now wherever you download. Tickets are $37 to $239 via foxtucsontheatre.ticketforce.com.<br>
  <br>
  
<h2 class="content_h2"><b>Race to Rockabilly Raceway </b><br></h2>
 Rockabilly Raceway continues through June 3 at The Gaslight Theater, thegaslighttheatre.com. It’s another family-friendly, see-through plot with silly song matches and crowd interactions. These are songs the whole family knows and loves, including the Edsels, Elvis and Etta James. The olio is a parade of Beatles hits. <br>
 <br>
      
      
      <div class="clearfix"></div>
      
      
      
    </div>

    
    
    
      
    

    

    
      
      <p class="tags">
        Tags: <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Dave%20Ross" rel="tag">Dave Ross</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Chris%20Charpentier" rel="tag">Chris Charpentier</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Club%20Congress" rel="tag">Club Congress</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Chris%20Thayer" rel="tag">Chris Thayer</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Kristine%20Levine" rel="tag">Kristine Levine</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Pauly%20Casillas" rel="tag">Pauly Casillas</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Rockabilly%20Raceway" rel="tag">Rockabilly Raceway</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=The%20Gaslight%20Theatre" rel="tag">The Gaslight Theatre</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Beatles%20hits" rel="tag">Beatles hits</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=olio" rel="tag">olio</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Weird%20Al%20Yankelovich" rel="tag">Weird Al Yankelovich</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=The%20Hamilton%20Polka" rel="tag">The Hamilton Polka</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Fox%20Tucson%20Theatre" rel="tag">Fox Tucson Theatre</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Creative%20Tucson%20Studios" rel="tag">Creative Tucson Studios</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Matt%20Ziemak" rel="tag">Matt Ziemak</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Rich%20Aguirre" rel="tag">Rich Aguirre</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Airing%20It%20Out%20Live" rel="tag">Airing It Out Live</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Josiah%20Osego" rel="tag">Josiah Osego</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Amber%20Frame" rel="tag">Amber Frame</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Randall%20Scott" rel="tag">Randall Scott</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Meredith%20Armstrong" rel="tag">Meredith Armstrong</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Tucson%20Mojo" rel="tag">Tucson Mojo</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Carlos%20Arzati" rel="tag">Carlos Arzati</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Katie%20Haverly" rel="tag">Katie Haverly</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?tag=Jillian%20Besset." rel="tag">Jillian Besset.</a>, <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?contentFeature=3669452" rel="tag">Image</a>
      </p>
    

    

  </div> <!-- end blogPost -->
    
    <div class="clear"></div>
  </div>

















  
  















  
  
  

  
  
  

  
  
  <!-- 
    xxx
    admin: 808579
    serverURl: https://www.tucsonweekly.com
    var.publicDesktopServer = https://www.tucsonweekly.com
    var.shareUrl = https://www.tucsonweekly.com/TheRange/archives/2018/05/03/laughing-stock-overstock-so-much-comedy
    s/https\:\/\/www\.tucsonweekly\.com/https\:\/\/www\.tucsonweekly\.com/
    var.shareUrl = https://www.tucsonweekly.com/TheRange/archives/2018/05/03/laughing-stock-overstock-so-much-comedy
  -->



  
  
    
  
  
  <div id="TallBar" class="SpanningFeature TheRangeBlogPost ">
    <ul>
      <li class="l0 first" style="width:50%">
        <fb:like href="https://www.tucsonweekly.com/TheRange/archives/2018/05/03/laughing-stock-overstock-so-much-comedy" 
         send="true" 
         width="285" 
         show_faces="false" 
         action="like" 
         font="tahoma" 
         colorscheme="light" 
         layout="standard"></fb:like></li> <li class="l0" style="width:12%;"><a href="https://twitter.com/share?url=https%3A//www.tucsonweekly.com/TheRange/archives/2018/05/03/laughing-stock-overstock-so-much-comedy&text=Laughing%20Stock%3A%20Overstock%21%20So.%20Much.%20Comedy." class="twitter-share-button" data-count="vertical">Tweet</a>
<script>
  dnLoadScript("https://platform.twitter.com/widgets.js", true);
</script></li> <li class="l0" style="width:12%;"><script>
  dnLoadScript("https://apis.google.com/js/plusone.js", true);
</script>
<g:plusone href="https://www.tucsonweekly.com/TheRange/archives/2018/05/03/laughing-stock-overstock-so-much-comedy" size="tall" count="true"></g:plusone></li> <li class="l0 last" style="width:12%;">




  <div class="addthis_toolbox addthis_default_style"><a addthis:url="https://www.tucsonweekly.com/TheRange/archives/2018/05/03/laughing-stock-overstock-so-much-comedy" addthis:title="Laughing Stock: Overstock! So. Much. Comedy." addthis:description="" class="addthis_counter"></a></div>
  <script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4ea84184281c09f8", true);
  </script>


      </li>
    </ul>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  




    
    
    
    













  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  
  


  

  
    
      <style>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</style>
      <div id="BlogComments" class="SpanningFeature TheRangeBlogPost CommentsComponent ">
        
        
        <div class="commentsHeader hreview-aggregate clearfix" id="readerComments">

          
          
          
          <h3 class="clearfix">
            <div style="float:left;">
              Comments 
            </div>
            
          </h3>
        </div>
        
        
        <div id="BlogComments_commentContent" class="commentContent">
          
        </div>
        

        
          <div class="bottomOptionBar clearfix">
            
              <div style="float:left;">
      <div style="float:left;margin:4px 0; padding:4px 6px;">Subscribe to this thread:</div>
      <div style="position:relative;float:left">
      <div class="commentSubscribeLink">
        <a class="toggleActivator saveAction" id="doSubscribe" href="javascript://Subscribe">By Email</a>
      </div>
      <div class="togglePanel" data-toolsoid="16066002" data-toolsajaxmacro="commentSubscribe" style="display:none">
        <div class="toggleArrowBorder"></div>
        <div class="toggleArrow"></div>
        <a href="javascript://close" class="togglePanelClose"><img src="/foundation/images/icons/cross.png" width="14" height="14"></a>
        <div class="loading">Subscribing&hellip;</div>
        <div class="ajaxUpdater" style="display:none;"></div>
      </div>
      </div>
      <div class="commentRSSLink"><a href="/tucson/Rss.xml?id=comments&amp;oid=16066002" class="feedLink" title="Subscribe to this story's comments" target="_blank">With RSS</a></div>
      </div>
            
            
          </div>          
          
        <hr />

        

        
          

          <form id="BlogCommentsPostCommentForm" method="post" class="userCommentForm validateForm" data-validate="login" data-validate-login-options="{&quot;feelingShy&quot;:true}">
            <input type="hidden" name="commentType" value="comment" />
            <input type="hidden" name="oid" value="16066002" />
            <input type="hidden" name="source" value="desktop">

            
            

            <label for="comment" class="hidden">Comment</label>
            
              <h4 class="commentFormAddHeader"><a name="readerComments">Add a comment</a></h4>
            

            
            <div>(<a href="/tucson/CommentsPolicy/Page">comments policy</a>)</div>
            

            <div class="errorDisplay" style="display:none">
              <ol></ol>
            </div>
            <dl class="formElements clearfix">
            
              <dd><textarea name="comment" style="height:112px;overflow:hidden;" tabindex="1" class="expandableBox required" id="comment" data-validate="required"></textarea></dd>
            </dl>

            

            

            <input type="checkbox" name="subscribe" id="BlogComments_commentSubscribe" value="yes"> <label for="BlogComments_commentSubscribe" style="margin-right:24px;">Subscribe to this thread</label>
            
            

            <p class="commentFormSubmit">
              <input type="submit" name="commentSubmit" tabindex="2" value="Post Comment" id="commentSubmit" />
            </p>

          </form>
          <script>
            jQuery("textarea.expandableBox").autoBoxResize();
          </script>
        
      </div><!-- comments -->
      <script type="text/javascript">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</script>
    
  


      </div><!-- gridSpanningFeature -->
      
      <div id="gridSpanningFeature2">
        
      </div><!-- gridSpanningFeature2 -->

      <div id="gridColumnContainer" class="clearfix">

        <div id="gridMainColumn1">
          





  
      <div id="PreviouslyintheRange" class="MainColumn1 TheRangeBlogPost ">
        <h3>Previously in the Range</h3>
        <ul class="moduleList">
    
    

    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/03/its-best-of-tucson-time">It's Best of Tucson Time</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Tucson Weekly Staff</li>
      
      
        <li class="l1 longOnly">
          <span class="date">May  3, 2018</span>
        </li>
      
    </ul>
  </li>
      
    
  
    

    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/03/the-weekly-list-23-things-to-do-in-tucson-this-week">The Weekly List: 23 Things To Do In Tucson This Week</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Weekly Staff and Contributors</li>
      
      
        <li class="l1 longOnly">
          <span class="date">May  3, 2018</span>
        </li>
      
    </ul>
  </li>
      
    
  
    

    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/02/some-schools-announce-reopening-as-lawmakers-debate-proposal-on-education-funding">Some Schools Announce Reopening as Lawmakers Debate Proposal on Education Funding</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Danyelle Khmara</li>
      
      
        <li class="l1 longOnly">
          <span class="date">May  2, 2018</span>
        </li>
      
    </ul>
  </li>
      
    
  
         <li class="l0 storyItem">
           <a href="https://www.tucsonweekly.com/blogs/TheRange/" class="more">More &raquo;</a>
         </li>
         </ul>
      </div>
    


        </div><!-- gridMainColumn1 -->
        
        <div id="gridMainColumn2">
          







  

  

  
    <div id="MorebyThisAuthorWrapper" class="MainColumn2 TheRangeBlogPost Wrapper">

    
      
      
          <div id="MorebyThisAuthor" class="MainColumn2 TheRangeBlogPost ">
            <h3><span class="headingText">More by Linda Ray</span></h3>
            <ul class="moduleList">
        
        
        
        <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.tucsonweekly.com/TheRange/archives/2018/04/26/laughing-stock-what-now">Laughing Stock: What, Now?</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Linda Ray</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Apr 26, 2018</span>
        </li>
      
    </ul>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.tucsonweekly.com/TheRange/archives/2018/04/18/laughing-stock-comedy-for-charity-brings-the-love">Laughing Stock: Comedy for Charity Brings the Love</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Linda Ray</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Apr 18, 2018</span>
        </li>
      
    </ul>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.tucsonweekly.com/TheRange/archives/2018/04/12/laughing-stock-architecture-historic-and-human">Laughing Stock: Architecture, Historic and Human</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Linda Ray</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Apr  6, 2018</span>
        </li>
      
    </ul>
  </li>
        
        

      
             <li class="l0 storyItem more">
               <a href="https://www.tucsonweekly.com/tucson/ArticleArchives?author=1063875" class="more">More &raquo;</a>
             </li>
             </ul>
          </div>
        
    
   </div>  
   
  



        </div><!-- gridMainColumn2 -->

      </div><!-- end gridColumnContainer -->

    </div><!-- end gridFrame -->

    <div id="gridRightColumn">   
      <div id="gridSpanningIsland">
        

























<div id="EventPicksChooser" class="SpanningIsland TheRangeBlogPost ">

  <div class="headerBar">
    <h2><a href="https://www.tucsonweekly.com/tucson/EventSearch">Events</a> &amp; <a href="https://www.tucsonweekly.com/tucson/EventSearch?feature=Staff%20Pick">Staff Picks</a></h2></a>
  </div>

  
    

    <div class="calendarDays">
      <a class="calCurrent" href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=today">Today</a>
      
        | <a class="calDay" href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=2018-05-04%2004%3A00%3A00">Fri</a>
      
        | <a class="calDay" href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=2018-05-05%2004%3A00%3A00">Sat</a>
      
        | <a class="calDay" href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=2018-05-06%2004%3A00%3A00">Sun</a>
      
        | <a class="calDay" href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=2018-05-07%2004%3A00%3A00">Mon</a>
      
        | <a class="calDay" href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=2018-05-08%2004%3A00%3A00">Tue</a>
      
        | <a class="calDay last" href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=2018-05-09%2004%3A00%3A00">Wed</a>
      
    </div>

    
    
      <div class="storyItem">
    

    

    
      <a href="https://www.tucsonweekly.com/tucson/ken-jeong/Event?oid=15769589">
        <img src="https://media1.fdncms.com/tucsonweekly/imager/u/featurette/15769588/a888f212_kenjeong_boximage.png" alt="Ken Jeong" title="Ken Jeong" width="124" height="99" />
      </a>
     
    <h4 class="headline"><a href="https://www.tucsonweekly.com/tucson/ken-jeong/Event?oid=15769589">Ken Jeong</a>  
      <span class="smaller">@ Fox Tucson Theatre</span>
    </h4>
    <h5 class="subhead">Thu., May 3, 7:30-9:30 p.m.</h5>
  </div>
      

  
 
  <p class="more"><a href="https://www.tucsonweekly.com/tucson/EventSearch?narrowByDate=today">All of today's events</a> | <a href="https://www.tucsonweekly.com/tucson/EventSearch?feature=Staff%20Pick">Staff Picks</a></p>

  

  <div id=""> <!-- Tabbed Box -->  
    <div class="tabs">  
      <div class="tabCurrent tabLeft"><a href="#">Events</a></div> 
      <div class="tabBack tabCenter"><a href="#">Music</a></div> 
      <div class="tabBack tabCenter"><a href="#">Movies</a></div> 
      <div class="tabBack tabRight"><a href="#">Dining</a></div>
      <div class="tabBack tabRight"><a href="#">Locations</a></div>
    </div>
    <div class="clear"></div>

    

    <div class="eventSearchBody" >
      <form name="eventSearchForm" method="get" action="https://www.tucsonweekly.com/tucson/EventSearch">
        <select name="narrowByDate">
    <option value="">-All Dates-</option>
    
    
      
      
        
        
          <option value="2018-05-03" selected="selected">Thursday, May  3</option>
        
      
        
        
          <option value="2018-05-04">Friday, May  4</option>
        
      
        
        
          <option value="2018-05-05">Saturday, May  5</option>
        
      
        
        
          <option value="2018-05-06">Sunday, May  6</option>
        
      
        
        
          <option value="2018-05-07">Monday, May  7</option>
        
      
        
        
          <option value="2018-05-08">Tuesday, May  8</option>
        
      
        
        
          <option value="2018-05-09">Wednesday, May  9</option>
        
      
        
        
          <option value="2018-05-10">Thursday, May 10</option>
        
      
        
        
          <option value="2018-05-11">Friday, May 11</option>
        
      
        
        
          <option value="2018-05-12">Saturday, May 12</option>
        
      
        
        
          <option value="2018-05-13">Sunday, May 13</option>
        
      
        
        
          <option value="2018-05-14">Monday, May 14</option>
        
      
        
        
          <option value="2018-05-15">Tuesday, May 15</option>
        
      
        
        
          <option value="2018-05-16">Wednesday, May 16</option>
        
      
        
        
          <option value="2018-05-17">Thursday, May 17</option>
        
      
        
        
          <option value="2018-05-18">Friday, May 18</option>
        
      
        
        
          <option value="2018-05-19">Saturday, May 19</option>
        
      
        
        
          <option value="2018-05-20">Sunday, May 20</option>
        
      
        
        
          <option value="2018-05-21">Monday, May 21</option>
        
      
        
        
          <option value="2018-05-22">Tuesday, May 22</option>
        
      
        
        
          <option value="2018-05-23">Wednesday, May 23</option>
        
      
        
        
          <option value="2018-05-24">Thursday, May 24</option>
        
      
        
        
          <option value="2018-05-25">Friday, May 25</option>
        
      
        
        
          <option value="2018-05-26">Saturday, May 26</option>
        
      
        
        
          <option value="2018-05-27">Sunday, May 27</option>
        
      
        
        
          <option value="2018-05-28">Monday, May 28</option>
        
      
        
        
          <option value="2018-05-29">Tuesday, May 29</option>
        
      
        
        
          <option value="2018-05-30">Wednesday, May 30</option>
        
      
        
        
          <option value="2018-05-31">Thursday, May 31</option>
        
      
        
        
          <option value="2018-06-01">Friday, June  1</option>
        
      
        
        
          <option value="2018-06-02">Saturday, June  2</option>
        
      
    
  </select>

        <select name="eventCategory">
          <option value="">-All Categories-</option>
          
            <option value="1107327" >&nbsp;&nbsp;Art</option>
          
            <option value="2026929" >&nbsp;&nbsp;Back to School</option>
          
            <option value="1107349" >&nbsp;&nbsp;Bulletin Board</option>
          
            <option value="2490677" >&nbsp;&nbsp;Business & Finance</option>
          
            <option value="1107323" >&nbsp;&nbsp;Dance</option>
          
            <option value="4103152" >&nbsp;&nbsp;Dining</option>
          
            <option value="3093926" >&nbsp;&nbsp;Fall Arts Preview</option>
          
            <option value="1107328" >&nbsp;&nbsp;Family Fun</option>
          
            <option value="1107395" >&nbsp;&nbsp;Film</option>
          
            <option value="3910368" >&nbsp;&nbsp;For Valentines</option>
          
            <option value="1107336" >&nbsp;&nbsp;Gardening</option>
          
            <option value="3555917" >&nbsp;&nbsp;Halloween and All Souls</option>
          
            <option value="2506799" >&nbsp;&nbsp;Health</option>
          
            <option value="1107472" >&nbsp;&nbsp;Lectures</option>
          
            <option value="1107335" >&nbsp;&nbsp;Literature</option>
          
            <option value="1107325" >&nbsp;&nbsp;Museums</option>
          
            <option value="1107343" >&nbsp;&nbsp;Music (Classical, Opera, Jazz, Folk)</option>
          
            <option value="2026930" >&nbsp;&nbsp;New Year's Eve</option>
          
            <option value="1107386" >&nbsp;&nbsp;Outdoors</option>
          
            <option value="1107320" >&nbsp;&nbsp;Performing Arts</option>
          
            <option value="4136083" >&nbsp;&nbsp;Pet-Friendly & Fundraisers</option>
          
            <option value="2026928" >&nbsp;&nbsp;Pride</option>
          
            <option value="1107371" >&nbsp;&nbsp;Special Events</option>
          
            <option value="2506800" >&nbsp;&nbsp;Spirituality</option>
          
            <option value="1130857" >&nbsp;&nbsp;Sports</option>
          
            <option value="2456766" >&nbsp;&nbsp;Spring Arts Preview</option>
          
            <option value="2751116" >&nbsp;&nbsp;Summer Survival Guide</option>
          
            <option value="4000687" >&nbsp;&nbsp;Support Groups</option>
          
            <option value="3904784" >&nbsp;&nbsp;Transgender Awareness Week</option>
          
            <option value="3862947" >&nbsp;&nbsp;Volunteer</option>
          
            <option value="1107321" >&nbsp;&nbsp;Well-Being</option>
          
            <option value="1107942" >&nbsp;&nbsp;Comedy & Storytellers</option>
          
            <option value="3656923" >&nbsp;&nbsp;Dancing, DJ, Karaoke and Open Mic</option>
          
            <option value="3707286" >&nbsp;&nbsp;Trivia Games</option>
          
        </select>

        <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        
          <option value="7424285" >TUCSON</option>
        
        <option value="3552209" >&nbsp;&nbsp;Downtown / 4th Ave / University</option>
      
        
        <option value="1094781" >&nbsp;&nbsp;Central</option>
      
        
        <option value="1094814" >&nbsp;&nbsp;South Tucson</option>
      
        
        <option value="3287529" >&nbsp;&nbsp;North/Foothills</option>
      
        
        <option value="1094791" >&nbsp;&nbsp;East side</option>
      
        
        <option value="1094969" >&nbsp;&nbsp;West side</option>
      
        
        <option value="3266147" >&nbsp;&nbsp;Southeast</option>
      
        
        <option value="3138323" >&nbsp;&nbsp;Southwest</option>
      
        
        <option value="1094793" >&nbsp;&nbsp;Northeast</option>
      
        
        <option value="1094785" >&nbsp;&nbsp;Northwest</option>
      
        
        <option value="7424290" >&nbsp;&nbsp;Tucson (general)</option>
      
        
          <option value="7424291" >NORTH OF TUCSON</option>
        
        <option value="3287479" >&nbsp;&nbsp;Catalina</option>
      
        
        <option value="3904764" >&nbsp;&nbsp;Florence</option>
      
        
        <option value="3287527" >&nbsp;&nbsp;Marana</option>
      
        
        <option value="3287528" >&nbsp;&nbsp;Oracle</option>
      
        
        <option value="3287533" >&nbsp;&nbsp;Oro Valley</option>
      
        
        <option value="3339208" >&nbsp;&nbsp;San Manuel</option>
      
        
        <option value="3212371" >&nbsp;&nbsp;Superior</option>
      
        
        <option value="7426378" >&nbsp;&nbsp;Globe</option>
      
        
        <option value="7426357" >&nbsp;&nbsp;Phoenix / Chandler / Glendale</option>
      
        
        <option value="7426433" >&nbsp;&nbsp;Casa Grande</option>
      
        
        <option value="7426380" >&nbsp;&nbsp;Payson</option>
      
        
        <option value="7426379" >&nbsp;&nbsp;Sedona / Flagstaff</option>
      
        
        <option value="7426319" >&nbsp;&nbsp;Scottsdale</option>
      
        
          <option value="7424292" >SOUTH OF TUCSON</option>
        
        <option value="3223056" >&nbsp;&nbsp;Ajo</option>
      
        
        <option value="3235744" >&nbsp;&nbsp;Amado / Carmen</option>
      
        
        <option value="3212928" >&nbsp;&nbsp;Arivaca</option>
      
        
        <option value="3509182" >&nbsp;&nbsp;Elgin</option>
      
        
        <option value="3229508" >&nbsp;&nbsp;Green Valley</option>
      
        
        <option value="3259115" >&nbsp;&nbsp;Huachuca City</option>
      
        
        <option value="3303004" >&nbsp;&nbsp;Nogales</option>
      
        
        <option value="3287530" >&nbsp;&nbsp;Patagonia</option>
      
        
        <option value="3274620" >&nbsp;&nbsp;Sahuarita</option>
      
        
        <option value="2700860" >&nbsp;&nbsp;Sonoita</option>
      
        
        <option value="3187460" >&nbsp;&nbsp;Tumacácori</option>
      
        
        <option value="7426317" >&nbsp;&nbsp;Sasabe</option>
      
        
        <option value="7426318" >&nbsp;&nbsp;Douglas</option>
      
        
        <option value="2573339" >&nbsp;&nbsp;Sierra Vista / Hereford</option>
      
        
        <option value="7424289" >&nbsp;&nbsp;Tubac</option>
      
        
          <option value="7424287" >EAST OF TUCSON</option>
        
        <option value="3093054" >&nbsp;&nbsp;Benson / Dragoon</option>
      
        
        <option value="2673664" >&nbsp;&nbsp;Bisbee / Warren</option>
      
        
        <option value="3011257" >&nbsp;&nbsp;Safford</option>
      
        
        <option value="7424288" >&nbsp;&nbsp;Silver City / Pinos Altos</option>
      
        
        <option value="2826341" >&nbsp;&nbsp;Tombstone</option>
      
        
        <option value="3268503" >&nbsp;&nbsp;Vail</option>
      
        
        <option value="3243183" >&nbsp;&nbsp;Willcox</option>
      
        
        <option value="1094842" >&nbsp;&nbsp;Beyond AZ</option>
      
        
          <option value="7424302" >WEST OF TUCSON</option>
        
        <option value="3287537" >&nbsp;&nbsp;Three Points</option>
      
    
  </select>

        <input type="text" name="keywords" title="Enter keyword" class="text" value="" />
        <input type="submit" value="go" />
      </form>
      <div class="clear"></div>
      <p class="submitLink"><a href="https://posting.tucsonweekly.com/tucson/Events/AddEvent">Submit an Event</a></p>
    </div>

    

    <div class="eventSearchBody" style="display: none;">
      <form name="musicEventSearchForm" method="get" action="https://www.tucsonweekly.com/tucson/EventSearch">
        <input type="hidden" name="eventCategory" value="1107701" />

        <select name="narrowByDate">
    <option value="">-All Dates-</option>
    
    
      
      
        
        
          <option value="2018-05-03" selected="selected">Thursday, May  3</option>
        
      
        
        
          <option value="2018-05-04">Friday, May  4</option>
        
      
        
        
          <option value="2018-05-05">Saturday, May  5</option>
        
      
        
        
          <option value="2018-05-06">Sunday, May  6</option>
        
      
        
        
          <option value="2018-05-07">Monday, May  7</option>
        
      
        
        
          <option value="2018-05-08">Tuesday, May  8</option>
        
      
        
        
          <option value="2018-05-09">Wednesday, May  9</option>
        
      
        
        
          <option value="2018-05-10">Thursday, May 10</option>
        
      
        
        
          <option value="2018-05-11">Friday, May 11</option>
        
      
        
        
          <option value="2018-05-12">Saturday, May 12</option>
        
      
        
        
          <option value="2018-05-13">Sunday, May 13</option>
        
      
        
        
          <option value="2018-05-14">Monday, May 14</option>
        
      
        
        
          <option value="2018-05-15">Tuesday, May 15</option>
        
      
        
        
          <option value="2018-05-16">Wednesday, May 16</option>
        
      
        
        
          <option value="2018-05-17">Thursday, May 17</option>
        
      
        
        
          <option value="2018-05-18">Friday, May 18</option>
        
      
        
        
          <option value="2018-05-19">Saturday, May 19</option>
        
      
        
        
          <option value="2018-05-20">Sunday, May 20</option>
        
      
        
        
          <option value="2018-05-21">Monday, May 21</option>
        
      
        
        
          <option value="2018-05-22">Tuesday, May 22</option>
        
      
        
        
          <option value="2018-05-23">Wednesday, May 23</option>
        
      
        
        
          <option value="2018-05-24">Thursday, May 24</option>
        
      
        
        
          <option value="2018-05-25">Friday, May 25</option>
        
      
        
        
          <option value="2018-05-26">Saturday, May 26</option>
        
      
        
        
          <option value="2018-05-27">Sunday, May 27</option>
        
      
        
        
          <option value="2018-05-28">Monday, May 28</option>
        
      
        
        
          <option value="2018-05-29">Tuesday, May 29</option>
        
      
        
        
          <option value="2018-05-30">Wednesday, May 30</option>
        
      
        
        
          <option value="2018-05-31">Thursday, May 31</option>
        
      
        
        
          <option value="2018-06-01">Friday, June  1</option>
        
      
        
        
          <option value="2018-06-02">Saturday, June  2</option>
        
      
    
  </select>
        <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        
          <option value="7424285" >TUCSON</option>
        
        <option value="3552209" >&nbsp;&nbsp;Downtown / 4th Ave / University</option>
      
        
        <option value="1094781" >&nbsp;&nbsp;Central</option>
      
        
        <option value="1094814" >&nbsp;&nbsp;South Tucson</option>
      
        
        <option value="3287529" >&nbsp;&nbsp;North/Foothills</option>
      
        
        <option value="1094791" >&nbsp;&nbsp;East side</option>
      
        
        <option value="1094969" >&nbsp;&nbsp;West side</option>
      
        
        <option value="3266147" >&nbsp;&nbsp;Southeast</option>
      
        
        <option value="3138323" >&nbsp;&nbsp;Southwest</option>
      
        
        <option value="1094793" >&nbsp;&nbsp;Northeast</option>
      
        
        <option value="1094785" >&nbsp;&nbsp;Northwest</option>
      
        
        <option value="7424290" >&nbsp;&nbsp;Tucson (general)</option>
      
        
          <option value="7424291" >NORTH OF TUCSON</option>
        
        <option value="3287479" >&nbsp;&nbsp;Catalina</option>
      
        
        <option value="3904764" >&nbsp;&nbsp;Florence</option>
      
        
        <option value="3287527" >&nbsp;&nbsp;Marana</option>
      
        
        <option value="3287528" >&nbsp;&nbsp;Oracle</option>
      
        
        <option value="3287533" >&nbsp;&nbsp;Oro Valley</option>
      
        
        <option value="3339208" >&nbsp;&nbsp;San Manuel</option>
      
        
        <option value="3212371" >&nbsp;&nbsp;Superior</option>
      
        
        <option value="7426378" >&nbsp;&nbsp;Globe</option>
      
        
        <option value="7426357" >&nbsp;&nbsp;Phoenix / Chandler / Glendale</option>
      
        
        <option value="7426433" >&nbsp;&nbsp;Casa Grande</option>
      
        
        <option value="7426380" >&nbsp;&nbsp;Payson</option>
      
        
        <option value="7426379" >&nbsp;&nbsp;Sedona / Flagstaff</option>
      
        
        <option value="7426319" >&nbsp;&nbsp;Scottsdale</option>
      
        
          <option value="7424292" >SOUTH OF TUCSON</option>
        
        <option value="3223056" >&nbsp;&nbsp;Ajo</option>
      
        
        <option value="3235744" >&nbsp;&nbsp;Amado / Carmen</option>
      
        
        <option value="3212928" >&nbsp;&nbsp;Arivaca</option>
      
        
        <option value="3509182" >&nbsp;&nbsp;Elgin</option>
      
        
        <option value="3229508" >&nbsp;&nbsp;Green Valley</option>
      
        
        <option value="3259115" >&nbsp;&nbsp;Huachuca City</option>
      
        
        <option value="3303004" >&nbsp;&nbsp;Nogales</option>
      
        
        <option value="3287530" >&nbsp;&nbsp;Patagonia</option>
      
        
        <option value="3274620" >&nbsp;&nbsp;Sahuarita</option>
      
        
        <option value="2700860" >&nbsp;&nbsp;Sonoita</option>
      
        
        <option value="3187460" >&nbsp;&nbsp;Tumacácori</option>
      
        
        <option value="7426317" >&nbsp;&nbsp;Sasabe</option>
      
        
        <option value="7426318" >&nbsp;&nbsp;Douglas</option>
      
        
        <option value="2573339" >&nbsp;&nbsp;Sierra Vista / Hereford</option>
      
        
        <option value="7424289" >&nbsp;&nbsp;Tubac</option>
      
        
          <option value="7424287" >EAST OF TUCSON</option>
        
        <option value="3093054" >&nbsp;&nbsp;Benson / Dragoon</option>
      
        
        <option value="2673664" >&nbsp;&nbsp;Bisbee / Warren</option>
      
        
        <option value="3011257" >&nbsp;&nbsp;Safford</option>
      
        
        <option value="7424288" >&nbsp;&nbsp;Silver City / Pinos Altos</option>
      
        
        <option value="2826341" >&nbsp;&nbsp;Tombstone</option>
      
        
        <option value="3268503" >&nbsp;&nbsp;Vail</option>
      
        
        <option value="3243183" >&nbsp;&nbsp;Willcox</option>
      
        
        <option value="1094842" >&nbsp;&nbsp;Beyond AZ</option>
      
        
          <option value="7424302" >WEST OF TUCSON</option>
        
        <option value="3287537" >&nbsp;&nbsp;Three Points</option>
      
    
  </select>

        <input type="text" name="keywords" title="Enter keyword" class="text" value="" />
        <input type="submit" value="go" />
      </form>
      <div class="clear"></div>
      <p class="submitLink"><a href="https://posting.tucsonweekly.com/tucson/Events/AddEvent">Submit an Event</a></p>
    </div>

    

    <div class="eventSearchBody" style="display: none;">
      <form name="movietimesSearchForm" method="get" action="https://www.tucsonweekly.com/tucson/MovieTimes">
        <select name="film" onchange="submit();">
          <option value="">Select a movie</option>
          
        </select>
        <noscript>
          <br />
          <input type="submit" value="go" />
        </noscript>
      </form>

      <p>or</p>

      <form name="movietimesSearchForm" method="get" action="https://www.tucsonweekly.com/tucson/MovieTimes">
        <select name="location" onchange="submit();">
          <option value="">Select a location</option>
          
        </select>
        <noscript>
           <br />
           <input type="submit" value="go" />
        </noscript>
      </form>
    </div>

    

    <div class="eventSearchBody" style="display: none;">
      <form name="diningSearchForm" method="get" action="https://www.tucsonweekly.com/tucson/LocationSearch">
        <input type="hidden" name="locationSection" value="1113936" />

        <select name="locationCategory">
          <option value="">-All Categories-</option>
          
            <option value="1113954">Americana</option>
          
            <option value="3966316">Australian</option>
          
            <option value="1113955">Barbecue</option>
          
            <option value="1113956">Brew Pubs</option>
          
            <option value="3691897">Buffet</option>
          
            <option value="3966308">Burgers & Dogs</option>
          
            <option value="1113961">Cafes and Bistros</option>
          
            <option value="1113965">Cajun</option>
          
            <option value="3966320">Caribbean</option>
          
            <option value="1113959">Chinese</option>
          
            <option value="1113957">Coffee Houses</option>
          
            <option value="1113958">Cuban</option>
          
            <option value="2593488">Deli</option>
          
            <option value="1294952">Eastern European</option>
          
            <option value="1113953">Ethiopian</option>
          
            <option value="1113966">Filipino</option>
          
            <option value="1113937">French</option>
          
            <option value="1113945">Greek</option>
          
            <option value="3950579">Guatemalan</option>
          
            <option value="3179449">Hawaiian</option>
          
            <option value="1113947">Indian</option>
          
            <option value="1113950">Italian</option>
          
            <option value="2321964">Jamaican</option>
          
            <option value="1113962">Korean</option>
          
            <option value="1113951">Latin American</option>
          
            <option value="1113967">Malaysian</option>
          
            <option value="2593490">Market</option>
          
            <option value="1113952">Mexican</option>
          
            <option value="1113938">Middle Eastern</option>
          
            <option value="1113940">Pan-Asian</option>
          
            <option value="1113942">Pizza</option>
          
            <option value="3951464">Russian</option>
          
            <option value="1113943">Sandwiches</option>
          
            <option value="2583225">Seafood</option>
          
            <option value="1113944">Southwest</option>
          
            <option value="1113964">Spanish</option>
          
            <option value="2593489">Sports Bar</option>
          
            <option value="2583227">Steakhouse</option>
          
            <option value="1113946">Surf and Turf</option>
          
            <option value="1113948">Sushi and Japanese</option>
          
            <option value="1113941">Thai</option>
          
            <option value="1113949">Upper Crust</option>
          
            <option value="1113939">Vegetarian Friendly</option>
          
            <option value="1113963">Vietnamese</option>
          
            <option value="1113960">Wine Bars</option>
          
        </select>

        <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        
          <option value="7424285" >TUCSON</option>
        
        <option value="3552209" >&nbsp;&nbsp;Downtown / 4th Ave / University</option>
      
        
        <option value="1094781" >&nbsp;&nbsp;Central</option>
      
        
        <option value="1094814" >&nbsp;&nbsp;South Tucson</option>
      
        
        <option value="3287529" >&nbsp;&nbsp;North/Foothills</option>
      
        
        <option value="1094791" >&nbsp;&nbsp;East side</option>
      
        
        <option value="1094969" >&nbsp;&nbsp;West side</option>
      
        
        <option value="3266147" >&nbsp;&nbsp;Southeast</option>
      
        
        <option value="3138323" >&nbsp;&nbsp;Southwest</option>
      
        
        <option value="1094793" >&nbsp;&nbsp;Northeast</option>
      
        
        <option value="1094785" >&nbsp;&nbsp;Northwest</option>
      
        
        <option value="7424290" >&nbsp;&nbsp;Tucson (general)</option>
      
        
          <option value="7424291" >NORTH OF TUCSON</option>
        
        <option value="3287479" >&nbsp;&nbsp;Catalina</option>
      
        
        <option value="3904764" >&nbsp;&nbsp;Florence</option>
      
        
        <option value="3287527" >&nbsp;&nbsp;Marana</option>
      
        
        <option value="3287528" >&nbsp;&nbsp;Oracle</option>
      
        
        <option value="3287533" >&nbsp;&nbsp;Oro Valley</option>
      
        
        <option value="3339208" >&nbsp;&nbsp;San Manuel</option>
      
        
        <option value="3212371" >&nbsp;&nbsp;Superior</option>
      
        
        <option value="7426378" >&nbsp;&nbsp;Globe</option>
      
        
        <option value="7426357" >&nbsp;&nbsp;Phoenix / Chandler / Glendale</option>
      
        
        <option value="7426433" >&nbsp;&nbsp;Casa Grande</option>
      
        
        <option value="7426380" >&nbsp;&nbsp;Payson</option>
      
        
        <option value="7426379" >&nbsp;&nbsp;Sedona / Flagstaff</option>
      
        
        <option value="7426319" >&nbsp;&nbsp;Scottsdale</option>
      
        
          <option value="7424292" >SOUTH OF TUCSON</option>
        
        <option value="3223056" >&nbsp;&nbsp;Ajo</option>
      
        
        <option value="3235744" >&nbsp;&nbsp;Amado / Carmen</option>
      
        
        <option value="3212928" >&nbsp;&nbsp;Arivaca</option>
      
        
        <option value="3509182" >&nbsp;&nbsp;Elgin</option>
      
        
        <option value="3229508" >&nbsp;&nbsp;Green Valley</option>
      
        
        <option value="3259115" >&nbsp;&nbsp;Huachuca City</option>
      
        
        <option value="3303004" >&nbsp;&nbsp;Nogales</option>
      
        
        <option value="3287530" >&nbsp;&nbsp;Patagonia</option>
      
        
        <option value="3274620" >&nbsp;&nbsp;Sahuarita</option>
      
        
        <option value="2700860" >&nbsp;&nbsp;Sonoita</option>
      
        
        <option value="3187460" >&nbsp;&nbsp;Tumacácori</option>
      
        
        <option value="7426317" >&nbsp;&nbsp;Sasabe</option>
      
        
        <option value="7426318" >&nbsp;&nbsp;Douglas</option>
      
        
        <option value="2573339" >&nbsp;&nbsp;Sierra Vista / Hereford</option>
      
        
        <option value="7424289" >&nbsp;&nbsp;Tubac</option>
      
        
          <option value="7424287" >EAST OF TUCSON</option>
        
        <option value="3093054" >&nbsp;&nbsp;Benson / Dragoon</option>
      
        
        <option value="2673664" >&nbsp;&nbsp;Bisbee / Warren</option>
      
        
        <option value="3011257" >&nbsp;&nbsp;Safford</option>
      
        
        <option value="7424288" >&nbsp;&nbsp;Silver City / Pinos Altos</option>
      
        
        <option value="2826341" >&nbsp;&nbsp;Tombstone</option>
      
        
        <option value="3268503" >&nbsp;&nbsp;Vail</option>
      
        
        <option value="3243183" >&nbsp;&nbsp;Willcox</option>
      
        
        <option value="1094842" >&nbsp;&nbsp;Beyond AZ</option>
      
        
          <option value="7424302" >WEST OF TUCSON</option>
        
        <option value="3287537" >&nbsp;&nbsp;Three Points</option>
      
    
  </select>

        <input type="text" name="keywords" title="Enter keyword" class="text" value="" />
        <input type="submit" value="go" />
      </form>
    </div>

    

    <div class="eventSearchBody" style="display: none;">
      <form name="locationSearchForm" method="get" action="https://www.tucsonweekly.com/tucson/LocationSearch">
        <select name="locationCategory">
          <option value="">-All Categories-</option>
          
            
              <option value="2215006" >CULTURE & ENTERTAINMENT</option>
            
            <option value="1113914" >&nbsp;&nbsp;Bar</option>
          
            
            <option value="1113933" >&nbsp;&nbsp;Coffee House</option>
          
            
            <option value="1256739" >&nbsp;&nbsp;Concert Hall</option>
          
            
            <option value="1146952" >&nbsp;&nbsp;Dance Club</option>
          
            
            <option value="1113916" >&nbsp;&nbsp;Galleries</option>
          
            
            <option value="4002307" >&nbsp;&nbsp;Hookah Bar</option>
          
            
            <option value="1113923" >&nbsp;&nbsp;Museums</option>
          
            
            <option value="1113974" >&nbsp;&nbsp;Music Venues</option>
          
            
            <option value="1113928" >&nbsp;&nbsp;Theaters (film)</option>
          
            
            <option value="1113917" >&nbsp;&nbsp;Theaters (live)</option>
          
            
            <option value="1252196" >&nbsp;&nbsp;Winery</option>
          
            
              <option value="1113913" >COMMUNITY, SHOPS & SERVICES</option>
            
            <option value="1252195" >&nbsp;&nbsp;Banquet Hall</option>
          
            
            <option value="1113925" >&nbsp;&nbsp;Bookstore</option>
          
            
            <option value="1253417" >&nbsp;&nbsp;Business</option>
          
            
            <option value="1252187" >&nbsp;&nbsp;Caterer</option>
          
            
            <option value="1113919" >&nbsp;&nbsp;Community Center</option>
          
            
            <option value="1113926" >&nbsp;&nbsp;Country Club</option>
          
            
            <option value="1113934" >&nbsp;&nbsp;Dance Studios/Companies</option>
          
            
            <option value="1113922" >&nbsp;&nbsp;Education</option>
          
            
            <option value="1113935" >&nbsp;&nbsp;Government</option>
          
            
            <option value="1113929" >&nbsp;&nbsp;Health</option>
          
            
            <option value="1113932" >&nbsp;&nbsp;Hotel</option>
          
            
            <option value="1113924" >&nbsp;&nbsp;Library</option>
          
            
            <option value="1113921" >&nbsp;&nbsp;Outdoors</option>
          
            
            <option value="1113920" >&nbsp;&nbsp;Park</option>
          
            
            <option value="1113918" >&nbsp;&nbsp;Religious</option>
          
            
            <option value="1113931" >&nbsp;&nbsp;Residential</option>
          
            
            <option value="1113930" >&nbsp;&nbsp;Sports or Recreation</option>
          
            
            <option value="1113927" >&nbsp;&nbsp;Store or Market</option>
          
        </select>

        <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        
          <option value="7424285" >TUCSON</option>
        
        <option value="3552209" >&nbsp;&nbsp;Downtown / 4th Ave / University</option>
      
        
        <option value="1094781" >&nbsp;&nbsp;Central</option>
      
        
        <option value="1094814" >&nbsp;&nbsp;South Tucson</option>
      
        
        <option value="3287529" >&nbsp;&nbsp;North/Foothills</option>
      
        
        <option value="1094791" >&nbsp;&nbsp;East side</option>
      
        
        <option value="1094969" >&nbsp;&nbsp;West side</option>
      
        
        <option value="3266147" >&nbsp;&nbsp;Southeast</option>
      
        
        <option value="3138323" >&nbsp;&nbsp;Southwest</option>
      
        
        <option value="1094793" >&nbsp;&nbsp;Northeast</option>
      
        
        <option value="1094785" >&nbsp;&nbsp;Northwest</option>
      
        
        <option value="7424290" >&nbsp;&nbsp;Tucson (general)</option>
      
        
          <option value="7424291" >NORTH OF TUCSON</option>
        
        <option value="3287479" >&nbsp;&nbsp;Catalina</option>
      
        
        <option value="3904764" >&nbsp;&nbsp;Florence</option>
      
        
        <option value="3287527" >&nbsp;&nbsp;Marana</option>
      
        
        <option value="3287528" >&nbsp;&nbsp;Oracle</option>
      
        
        <option value="3287533" >&nbsp;&nbsp;Oro Valley</option>
      
        
        <option value="3339208" >&nbsp;&nbsp;San Manuel</option>
      
        
        <option value="3212371" >&nbsp;&nbsp;Superior</option>
      
        
        <option value="7426378" >&nbsp;&nbsp;Globe</option>
      
        
        <option value="7426357" >&nbsp;&nbsp;Phoenix / Chandler / Glendale</option>
      
        
        <option value="7426433" >&nbsp;&nbsp;Casa Grande</option>
      
        
        <option value="7426380" >&nbsp;&nbsp;Payson</option>
      
        
        <option value="7426379" >&nbsp;&nbsp;Sedona / Flagstaff</option>
      
        
        <option value="7426319" >&nbsp;&nbsp;Scottsdale</option>
      
        
          <option value="7424292" >SOUTH OF TUCSON</option>
        
        <option value="3223056" >&nbsp;&nbsp;Ajo</option>
      
        
        <option value="3235744" >&nbsp;&nbsp;Amado / Carmen</option>
      
        
        <option value="3212928" >&nbsp;&nbsp;Arivaca</option>
      
        
        <option value="3509182" >&nbsp;&nbsp;Elgin</option>
      
        
        <option value="3229508" >&nbsp;&nbsp;Green Valley</option>
      
        
        <option value="3259115" >&nbsp;&nbsp;Huachuca City</option>
      
        
        <option value="3303004" >&nbsp;&nbsp;Nogales</option>
      
        
        <option value="3287530" >&nbsp;&nbsp;Patagonia</option>
      
        
        <option value="3274620" >&nbsp;&nbsp;Sahuarita</option>
      
        
        <option value="2700860" >&nbsp;&nbsp;Sonoita</option>
      
        
        <option value="3187460" >&nbsp;&nbsp;Tumacácori</option>
      
        
        <option value="7426317" >&nbsp;&nbsp;Sasabe</option>
      
        
        <option value="7426318" >&nbsp;&nbsp;Douglas</option>
      
        
        <option value="2573339" >&nbsp;&nbsp;Sierra Vista / Hereford</option>
      
        
        <option value="7424289" >&nbsp;&nbsp;Tubac</option>
      
        
          <option value="7424287" >EAST OF TUCSON</option>
        
        <option value="3093054" >&nbsp;&nbsp;Benson / Dragoon</option>
      
        
        <option value="2673664" >&nbsp;&nbsp;Bisbee / Warren</option>
      
        
        <option value="3011257" >&nbsp;&nbsp;Safford</option>
      
        
        <option value="7424288" >&nbsp;&nbsp;Silver City / Pinos Altos</option>
      
        
        <option value="2826341" >&nbsp;&nbsp;Tombstone</option>
      
        
        <option value="3268503" >&nbsp;&nbsp;Vail</option>
      
        
        <option value="3243183" >&nbsp;&nbsp;Willcox</option>
      
        
        <option value="1094842" >&nbsp;&nbsp;Beyond AZ</option>
      
        
          <option value="7424302" >WEST OF TUCSON</option>
        
        <option value="3287537" >&nbsp;&nbsp;Three Points</option>
      
    
  </select>

        <input type="text" name="keywords" title="Enter keyword" class="text" value="" />
        <input type="submit" value="go" />
      </form>
    </div>
  </div><!-- End of Tabbed Box -->

</div>





<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function() {
  // Main tabs.
  dnSetupTabGroup(
      $$("#EventPicksChooser div.tabs>div"),
      $$("#EventPicksChooser div.eventSearchBody"),
      "tabCurrent", "tabBack", 0
  );

  // Remove default tab behavior.
  $$("#EventPicksChooser div.tabs>div a").each(function (a, index) {
      a.onclick = function() {
        return false;
      };
  });
});
//-->
</script>
<!-- End #EventPicksChooser -->
<div id="Rectangle1" class="SpanningIsland TheRangeBlogPost MediumRectangle Ad">
  
  <!-- /4961490/TW_ROS_right_300x250 -->
          <div id="div-gpt-ad-tw_ros_right_300x250" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_300x250" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_300x250');
                  });
              </script>
          </div>
  
</div><style>
.storyItem.EotD img {margin:0 0 10px;width:280px;}
</style>


  

  <div id="EventoftheDay" class="SpanningIsland TheRangeBlogPost PickOfTheDay ">
    <div class="headerBar">
      <h1 class="sectionHeader">Staff Pick</h1>
    </div>

    <div class="storyItem EotD">
      
        <a href="https://www.tucsonweekly.com/tucson/civic-orchestra-of-tucson-presents-pops-in-the-park/Event?oid=15942256"> 
          <img src="https://media1.fdncms.com/tucsonweekly/imager/u/eventoftheday/15942255/b9c7a118_cot-1975.png" alt="" class="storyImg" />
          
        </a>
      

      <h4 class="headline"><a href="https://www.tucsonweekly.com/tucson/civic-orchestra-of-tucson-presents-pops-in-the-park/Event?oid=15942256">Civic Orchestra of Tucson presents "Pops in the Park"</a></h4>
 
      
        <p>Music for dancing! Tango, country dance, big band swing, waltzes, a fire dance, plus marches and show&hellip;
        <a href="https://www.tucsonweekly.com/tucson/civic-orchestra-of-tucson-presents-pops-in-the-park/Event?oid=15942256">More</a></p>
      
    </div>

    <div class="storyItem eventInfo">
      
        @ Georges DeMeester Performance Center
      
      Sun., May 6, 7-9 p.m.
      
        900 South Randolph Way
      
    </div>

    <p class="submitListing"><a href="https://www.tucsonweekly.com/tucson/EventSearch?feature=Staff%20Pick">&raquo; More Picks</a></p>
    <p class="submitListing"><a href="https://posting.tucsonweekly.com/tucson/SubmitEvent/Page">Submit an Event Listing</a></p>
  </div>


<div id="Rectangle3" class="SpanningIsland TheRangeBlogPost MediumRectangle Ad">
  
  <!-- /4961490/TW_WeGotCactus_300x250_1 -->
          <div id="div-gpt-ad-tw_wegotcactus_300x250_1" style="" data-content-type="ad" data-slot="/4961490/TW_WeGotCactus_300x250_1" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_wegotcactus_300x250_1');
                  });
              </script>
          </div>
  
</div>

<div id="TabbedMost" class="SpanningIsland TheRangeBlogPost ">












  <!-- Cached: 2018-05-03 19:00 -->

  <h2>Popular Content</h2>

    <div class="tabs">
      <a href="#" class="mostread tabCurrent">Most Read</a>
      
      <a href="#" class="mostdiscussed tabBack">Most Discussed</a>
    </div>

    <div class="clear"><!-- clear --></div>

    
    <div class="commentsBody" style="">
      
          <ol>
        
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/03/its-best-of-tucson-time">It's Best of Tucson Time</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/03/the-weekly-list-23-things-to-do-in-tucson-this-week">The Weekly List: 23 Things To Do In Tucson This Week</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/02/some-schools-announce-reopening-as-lawmakers-debate-proposal-on-education-funding">Some Schools Announce Reopening as Lawmakers Debate Proposal on Education Funding</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2018/04/19/the-weekly-list-17-things-to-do-in-tucson-this-week">The Weekly List: 17 Things To Do In Tucson This Week</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2018/05/01/uas-freedom-school-isnt-free-of-costs-or-hiring-restrictions">UA's 'Freedom School' Isn't Free Of Costs Or Hiring Restrictions</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
          </ol>
        
      <div class="clear"><!-- clear --></div>
    </div>

  

    
    <div class="commentsBody" style="display:none">
      
          <ol>
        
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2018/04/20/the-strike-is-on-arizona-teachers-prepared-for-walkout-next-week">The Strike Is On: Arizona Teachers Prepared for Walkout Next Week</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2018/04/16/the-wrongheaded-decision-to-remove-auggie-romero-as-pueblo-high-principal">The Wrongheaded Decision To Remove Auggie Romero As Pueblo High Principal</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2018/04/24/conservatives-told-keep-criticizing-teachers-but-not-about-their-pay-or-perks">Conservatives Told: Keep Criticizing Teachers, But Not About Their Pay or Perks</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2018/04/06/a-partial-list-of-ua-freedom-centers-funders">A Partial List Of UA Freedom Center's Funders</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
        
        <li><a href="https://www.tucsonweekly.com/TheRange/archives/2018/04/30/school-closures-continue-into-a-second-week-of-walkouts">School Closures Continue Into a Second Week of Walkouts</a> (The Range: The Tucson Weekly's Daily Dispatch)</li>
        
      
          </ol>
        
      <div class="clear"><!-- clear --></div>
    </div>


  

    

    <script type="text/javascript">
    <!--
      Event.observe(document, "dom:loaded", function() {
        dnSetupTabGroup(
            $$("#TabbedMost div.tabs a"),
            $$("#TabbedMost div.commentsBody"),
            "tabCurrent", "tabBack", 0
        );
      });
    //-->
    </script>
  </div>
  


<div id="BigSkyscraper300x600" class="SpanningIsland TheRangeBlogPost HalfPage Ad">
  
  <!-- /4961490/TW_ROS_right_300x600 -->
          <div id="div-gpt-ad-tw_ros_right_300x600" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_300x600" data-output="asynchronous" data-width="300" data-height="600">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_300x600');
                  });
              </script>
          </div>
  
</div><div id="Rectangle2" class="SpanningIsland TheRangeBlogPost Ad MediumRectangle">
  <!-- /4961490/TW_ROS_right_300x250_2 -->
          <div id="div-gpt-ad-tw_ros_right_300x250_2" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_300x250_2" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_300x250_2');
                  });
              </script>
          </div>
</div><div id="Rectangle4" class="SpanningIsland TheRangeBlogPost Ad MediumRectangle">
  
  <!-- /4961490/TW_WeGotCactus_300x250_2 -->
          <div id="div-gpt-ad-tw_wegotcactus_300x250_2" style="" data-content-type="ad" data-slot="/4961490/TW_WeGotCactus_300x250_2" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_wegotcactus_300x250_2');
                  });
              </script>
          </div>
  
</div><div id="Rectangle5" class="SpanningIsland TheRangeBlogPost Ad MediumRectangle">
  
  <!-- /4961490/TW_WeGotCactus_300x250_3 -->
          <div id="div-gpt-ad-tw_wegotcactus_300x250_3" style="" data-content-type="ad" data-slot="/4961490/TW_WeGotCactus_300x250_3" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_wegotcactus_300x250_3');
                  });
              </script>
          </div>
  
</div>
      </div><!-- end gridSpanningIsland -->  
     
      <div id="gridMainSidebar">
        <div id="Skyscraper1" class="MainSidebar TheRangeBlogPost Ad Skyscraper">
  
  <!-- /4961490/TW_ROS_right_160x600 -->
          <div id="div-gpt-ad-tw_ros_right_160x600" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_160x600" data-output="asynchronous" data-width="160" data-height="600">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_160x600');
                  });
              </script>
          </div>
  
</div>
      </div><!-- end gridMainSidebar -->

      <div id="gridAdSidebar">
        <div id="Skyscraper2" class="AdSidebar TheRangeBlogPost Ad Skyscraper">
  
  <!-- /4961490/TW_ROS_right_160x600_2 -->
          <div id="div-gpt-ad-tw_ros_right_160x600_2" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_160x600_2" data-output="asynchronous" data-width="160" data-height="600">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_160x600_2');
                  });
              </script>
          </div>
  
</div>
      </div><!-- end gridAdSidebar -->
      
      <div id="gridBottomSidebar">
        <div id="BigSkyscraper300x600Ad2" class="MainSidebar TheRangeBlogPost Ad HalfPage">
  <!-- /4961490/TW_ROS_right_300x600_2 -->
          <div id="div-gpt-ad-tw_ros_right_300x600_2" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_300x600_2" data-output="asynchronous" data-width="300" data-height="600">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_300x600_2');
                  });
              </script>
          </div>
</div><div id="BigSkyscraper300x6003" class="MainSidebar TheRangeBlogPost Ad HalfPage">
  <!-- /4961490/TW_ROS_right_300x600_3 -->
          <div id="div-gpt-ad-tw_ros_right_300x600_3" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_300x600_3" data-output="asynchronous" data-width="300" data-height="600">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_300x600_3');
                  });
              </script>
          </div>
</div><div id="BigSkyscraper300x6004" class="MainSidebar TheRangeBlogPost Ad HalfPage">
  <!-- /4961490/TW_ROS_right_300x600_4 -->
          <div id="div-gpt-ad-tw_ros_right_300x600_4" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_300x600_4" data-output="asynchronous" data-width="300" data-height="600">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_300x600_4');
                  });
              </script>
          </div>
</div><div id="BigSkyscraper300x6005" class="MainSidebar TheRangeBlogPost Ad HalfPage">
  <!-- /4961490/TW_ROS_right_300x600_5 -->
          <div id="div-gpt-ad-tw_ros_right_300x600_5" style="" data-content-type="ad" data-slot="/4961490/TW_ROS_right_300x600_5" data-output="asynchronous" data-width="300" data-height="600">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-tw_ros_right_300x600_5');
                  });
              </script>
          </div>
</div>
      </div>
    </div><!-- end gridRightColumn -->
    
    <!-- Footer -->
    <div id="gridFooter">
      


    <div id="FooterNavigation" class="GlobalFooter TheRangeBlogPost ">
      <ul>
  
  
  <li class="">
    <a href="https://www.tucsonweekly.com/" target="_self">
      
        home
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/opinion/Section?oid=1063711" target="_self">
      
        opinion
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/currents/Section?oid=1063709" target="_self">
      
        currents
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/cityweek/Section?oid=1063710" target="_self">
      
        city week
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/cinema/Section?oid=1063716" target="_self">
      
        cinema
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/arts/Section?oid=1063713" target="_self">
      
        arts
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/books/Section?oid=1063715" target="_self">
      
        books
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/chow/Section?oid=1063714" target="_self">
      
        chow
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/BestOf" target="_self">
      
        best of tucson®
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.facebook.com/tucsonweekly" target="_blank">
      
        Facebook
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/ArticleArchives" target="_self">
      
        archives
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/Advertising/Page" target="_self">
      
        advertising
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/PrivacyPolicy/Page" target="_self">
      
        privacy policy
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/Staff/Page" target="_self">
      
        Staff / Contact Us
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="rss-icon">
    <a href="https://www.tucsonweekly.com/tucson/Syndication/Page" target="_self">
      
        rss
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.flickr.com/photos/tucsonweekly/" target="_blank">
      
        Flickr
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.twitter.com/TucsonWeekly" target="_blank">
      
        Twitter
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/TermsConditions/Page" target="_self">
      
        terms & conditions
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://displayads.tucsonweekly.com/" target="_self">
      
        print ads
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.tucsonweekly.com/tucson/CommentsPolicy/Page" target="_self">
      
        comments policy
      
    </a>
    
    
  </li> 
  

      </ul>
    </div>
  



<div id="footerCopyright">
  <p>
   &copy; 2018
   Tucson Weekly |
   7225 Mona Lisa Rd. Ste. 125, Tucson AZ 85741 |
   
  (520) 797-4384 |
   Powered by <a href="http://foundation.gyrobase.com/" target="_blank">Foundation</a>
  </p>
</div><!-- start compete.com tag -->
<script type="text/javascript">
    __compete_code = '312a684a250efb96916726877042f53b';
    (function () {
        var s = document.createElement('script'),
            d = document.getElementsByTagName('head')[0] ||
                document.getElementsByTagName('body')[0],
            t = 'https:' == document.location.protocol ? 
                'https://c.compete.com/bootstrap/' : 
                'http://c.compete.com/bootstrap/';
        s.src = t + __compete_code + '/bootstrap.js';
        s.type = 'text/javascript';
        s.async = 'async'; 
        if (d) { d.appendChild(s); }
    }());
</script>
<!-- end compete.com tag --> </div>


<!-- Start Google Analytics -->
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-3905397-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'stats.g.doubleclick.net/dc.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<!-- End Google Analytics -->


<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-6cJMtQ1dR3JBg"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-6cJMtQ1dR3JBg.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->


  <img src="/foundation/images/icons/pixel.gif?oid=16066002" alt="" />


    </div><!-- end gridFooter -->

  </div><!-- end gridMain -->

</div><!-- end gridClamp -->

<!-- Closer -->
<div id="gridCloser">
  <div id="FullBackgroundAd" class="Closer TheRangeBlogPost ">
  <!-- /4961490/BackgroundAd1950x930 -->
          <div id="div-gpt-ad-backgroundad1950x930" style="" data-content-type="ad" data-slot="/4961490/BackgroundAd1950x930" data-output="asynchronous" data-width="1950" data-height="930">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-backgroundad1950x930');
                  });
              </script>
          </div>
</div>
</div><!-- end gridCloser -->
    </body>
</html>
  


